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Preface

About This Manual The ERDAS IMAGINE Tour Guides™ manual is a compilation of 
tutorials designed to help you learn how to use ERDAS IMAGINE® 
software. This is a comprehensive manual, representing ERDAS 
IMAGINE and its add-on modules. Each guide takes you step-by-step 
through an entire process. The tour guides are not intended to tell 
you everything there is to know about any one topic, but to show you 
how to use some of the basic tools you need to get started. 

This manual serves as a handy reference that you can refer to while 
using ERDAS IMAGINE for your own projects. Included is a 
comprehensive index, so that you can reference particular 
information later. 

There are several sections to this manual. These sections are based 
upon the way in which ERDAS IMAGINE is packaged. The following 
sections are composed of the tour guides you go through in a step 
by step fashion to learn detailed information about the various 
ERDAS IMAGINE functions.

• Section I—IMAGINE Essentials™

• Section II—IMAGINE Advantage™

• Section III—IMAGINE Professional™

• Section IV—IMAGINE Radar Interpreter™

• Section V—IMAGINE Vector™

Example Data Data sets are provided with the software so that your results match 
those in the tour guides. The data used in the tour guides are in the 
<IMAGINE_HOME>/examples directory. <IMAGINE_HOME> is the 
variable name of the directory where ERDAS IMAGINE resides. When 
accessing data files, you must replace <IMAGINE_HOME> with the 
name of the directory where ERDAS IMAGINE is loaded on your 
system.

Time Required Each individual tour guide takes a different amount of time to 
complete, depending upon the options you choose and the length of 
the tour guide. The approximate completion time is stated in the 
introduction to each tour guide.
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Documentation This manual is part of a suite of on-line documentation that you 
receive with ERDAS IMAGINE software. There are two basic types of 
documents, digital hardcopy documents which are delivered as PDF 
files suitable for printing or on-line viewing, and On-Line Help 
Documentation, delivered as HTML files.

Digital Hardcopy 
Documentation

The ERDAS IMAGINE Digital Hardcopy Documentation is designed to 
provide comprehensive information about a particular concept or to 
walk you through complicated steps in a process like the Installation 
of IMAGINE or Advanced Classification. The Digital Hardcopy 
Documentation also contains programming reference material, such 
as the ERDAS Macro Language Reference Manual which helps you 
design your own IMAGINE dialogs. These documents may be found 
in the <IMAGINE_HOME>/help/hardcopy folder.

To read the IMAGINE Digital Hardcopy Documentation, you must 
install Adobe Acrobat Reader 4.0 or higher and follow all 
installation instructions provided by the software, especially 
those regarding internet browser and Acrobat integration.

Following is a list of Digital Hardcopy Documentation that is available 
with ERDAS IMAGINE software:

• ERDAS Field Guide™ (FieldGuide.pdf)

• ERDAS IMAGINE Configuration Guides (Unix_ConfigGuide.pdf, 
Win_ConfigGuide, and LPS_ConfigGuide)

• ERDAS IMAGINE Tour Guides™ (TourGuide.pdf)

• ERDAS Macro Language Reference Manual (EML.pdf)

• ERDAS Spatial Modeler Language Reference Manual (SML.pdf)

• ERDAS IMAGINE Read Me First document

• ERDAS IMAGINE Release Notes

• FLEXlm End Users Guide (enduser.pdf)

• What’s New in ERDAS IMAGINE 



ERDAS IMAGINE Tour Guides Documentation / xix

On-Line Help 
Documentation

The IMAGINE On-Line Help Documentation is set up as a network of 
HTML files that are displayed in your default internet browser and 
provide quick, informative chunks of information on all of the 
IMAGINE dialogs, as well as additional explanatory notes and 
diagrams. This HTML database includes JavaScript applets that 
provide an expanding and collapsing Table of Contents, Index, and 
Full Text Search utilities. To use these applets you must have 
installed a compliant browser (Netscape 4.7 or Internet Explorer 5.5 
or higher are greatly recommended) and that you enable Java 
scripting in your browser properties.

Following is a list of on-line manuals that can be found in the On-Line 
Help in ERDAS IMAGINE software. This list may change depending 
on your software package and add-on modules you have purchased:

• ERDAS IMAGINE

- Introduction
- Annotation
- AOI (Area of Interest)
- Classification
- DPPDB (Digital Point Positioning Database) Workstation
- Expert Classifier
- HyperSpectral
- Image Catalog
- Image Interpreter
- IMAGINE Interface
- Imagizer
- Import/Export
- Importing Native Formats
- Map Composer
- Mosaic Tool
- NITF

- Preferences
- Radar Mapping Suite
- Rectification
- Session
- Spatial Modeler
- Spectral Analysis
- Tools and Utilities
- Vector
- Viewer
- Viewer Raster Tools
- VirtualGIS
- Appendices

• Leica Photogrammetry Suite
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- LPS Project Manager
- LPS Automatic Terrain Extraction
- Stereo Analyst
- Terrain Editor
- Viewplex
- ImageEqualizer

Documentation Functions The following table depicts the different types of information you can 
extract from ERDAS IMAGINE documentation.

Conventions Used 
in This Book

In ERDAS IMAGINE, the names of menus, menu options, buttons, 
and other components of the interface are shown in bold type. For 
example:

“In the Select Layer To Add dialog, select the Fit to Frame option.”

When asked to use the mouse, you are directed to click, Shift-click, 
middle-click, right-click, hold, drag, etc.

• click—designates clicking with the left mouse button.

If you want to... Read...

Install ERDAS IMAGINE ERDAS IMAGINE Release Notes, 
then ERDAS IMAGINE 
Configuration Guides

Set up hardware for use with ERDAS 
IMAGINE

ERDAS IMAGINE Configuration 
Guides

Learn to use ERDAS IMAGINE ERDAS IMAGINE Tour Guides

Learn about GIS and image 
processing theory

ERDAS Field Guide

See what a particular dialog does On-Line Help

Get quick information for a button or 
function

On-Line Help or Status Bar Help

Learn how to most effectively use the 
On-Line Help system

Introduction to On-Line Help in the 
On-Line Help

Learn more about the Image 
Interpreter functions

ERDAS IMAGINE Tour Guides

Use the Spatial Modeler Language to 
write models

ERDAS Spatial Modeler Language 
Reference Manual

Customize the ERDAS IMAGINE 
graphical user interface (GUI)

ERDAS Macro Language Reference 
Manual

Write custom application programs 
within ERDAS IMAGINE

ERDAS Developers’ Toolkit On-Line 
Manual
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• Shift-click—designates holding the Shift key down on your 
keyboard and simultaneously clicking with the left mouse button.

• middle-click—designates clicking with the middle mouse button.

• right-click—designates clicking with the right mouse button.

• hold—designates holding down the left (or right, as noted) 
mouse button.

• drag—designates dragging the mouse while holding down the left 
mouse button.

The following paragraphs are used throughout the ERDAS IMAGINE 
documentation:

These paragraphs contain strong warnings.

These paragraphs provide software-specific information.

These paragraphs contain important tips.

These paragraphs lead you to other areas of this book or other 
ERDAS® manuals for additional information.

NOTE: Notes give additional instruction.

Getting Started To start ERDAS IMAGINE, type the following in a UNIX command 
window: imagine, or select ERDAS IMAGINE from the Start 
menu.

ERDAS IMAGINE begins running; the icon panel automatically opens.

ERDAS IMAGINE Icon 
Panel

The ERDAS IMAGINE icon panel contains icons and menus for 
accessing ERDAS IMAGINE functions. You have the option (through 
the Session -> Preferences menu) to display the icon panel 
horizontally across the top of the screen or vertically down the left 
side of the screen. The default is a horizontal display. 

Shaded Boxes
Shaded boxes contain supplemental information that is not 
required to execute the steps of a tour guide, but is noteworthy. 
Generally, this is technical information.
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The icon panel that displays on your screen looks similar to the 
following:

The various icons that are present on your icon panel depend on the 
components and add-on modules you have purchased with your 
system.

ERDAS IMAGINE Menu 
Bar

The menus on the ERDAS IMAGINE menu bar are: Session, Main, 
Tools, Utilities, and Help. These menus are described in this 
section.

NOTE: Any items which are unavailable in these menus are shaded 
and inactive.

Session Menu

1. Click the word Session in the upper left corner of the ERDAS 
IMAGINE menu bar. The Session menu opens:

The following table contains the Session menu selections and their 
functionalities: 

Click here to end 
the ERDAS IMAGINE You can also place the 

cursor anywhere in the 
icon panel and press 
Ctrl-Q to exit ERDAS 

These menus are 
identical to the ones 
on the icon panel. 

session 

IMAGINE 
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Table 1: Session Menu Options

Selection Functionality

Preferences

Set individual or global default options 
for many ERDAS IMAGINE functions 
(Viewer, Map Composer, Spatial 
Modeler, etc.).

Configuration Configure peripheral devices for ERDAS 
IMAGINE.

Session Log
View a real-time record of ERDAS 
IMAGINE messages and commands, 
and to issue commands.

Active Process List View and cancel currently active 
processes running in ERDAS IMAGINE.

Commands
Open a command shell, in which you 
can enter commands to activate or 
cancel processes.

Enter Log Message Insert text into the Session Log.

Start Recording Batch 
Commands

Open the Batch Wizard. Collect 
commands as they are generated by 
clicking the Batch button that is 
available on many ERDAS IMAGINE 
dialogs.

Open Batch Command File Open a Batch Command File (*.bcf) you 
have saved previously.

View Offline Batch Queue
Open the Scheduled Batch Job list 
dialog, which gives information about 
pending batch jobs.

Flip Icons Specify horizontal or vertical icon panel 
display.

Tile Viewers Rearrange two or more Viewers on the 
screen so that they do not overlap.

Close All Viewers Close all Viewers that are currently 
open.

Main
Access a menu of tools that corresponds 
to the icons along the ERDAS IMAGINE 
icon bar.

Tools
Access a menu of tools that allow you to 
view and edit various text and image 
files.

Utilities
Access a menu of utility items that allow 
you to perform general tasks in ERDAS 
IMAGINE.

Help Access the ERDAS IMAGINE On-Line 
Help.
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Main Menu

2. Click the word Main in the ERDAS IMAGINE menu bar. The Main 
menu opens

The following table contains the Main menu selections and their 
functionalities:

.

Properties
Display the ERDAS IMAGINE Properties 
dialog where system, environment and 
licensing information is available.

Generate System Information Report
Provides a mechanism for printing 
essential IMAGINE operating system 
parameters.

Exit IMAGINE Exit the ERDAS IMAGINE session 
(keyboard shortcut: Ctrl-Q).

Table 1: Session Menu Options (Continued)

Selection Functionality

Table 2: Main Menu Options

Selection Functionality

Start IMAGINE Viewer Start an empty Viewer.

Import/Export Open the Import/Export dialog.

Data Preparation Open the Data Preparation menu.

Map Composer Open the Map Composer menu.

Image Interpreter Open the Image Interpreter menu.

Image Catalog Open the Image Catalog dialog.

Image Classification Open the Classification menu.

Spatial Modeler Open the Spatial Modeler menu.

Vector Open the Vector Utilities menu.
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Tools Menu

3. Click the word Tools in the ERDAS IMAGINE menu bar. The Tools 
menu opens:

The following table contains the Tools menu selections and their 
functionalities: 

Radar Open the Radar menu.

VirtualGIS Open the VirtualGIS menu.

LPS Project Manager Open the LPS Project Manager Startup 
dialog.

Stereo Analyst Open the Stereo Analyst Workspace.

Table 2: Main Menu Options (Continued)

Selection Functionality

Table 3: Tools Menu Options

Selection Functionality

Edit Text Files Create and edit ASCII text files.

Edit Raster Attributes Edit raster attribute data.

View Binary Data View the contents of binary files in a 
number of different ways.

View IMAGINE HFA File 
Structure

View the contents of the ERDAS 
IMAGINE hierarchical files.

Annotation Information
View information for annotation files, 
including number of elements and 
projection information.

Image Information Obtain full image information for a 
selected ERDAS IMAGINE raster image.

Vector Information
Obtain full image information for a 
selected ERDAS IMAGINE vector 
coverage.

Image Command Tool Open the Image Command dialog. 
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Utilities Menu

4. Click Utilities on the ERDAS IMAGINE menu bar. The Utilities menu 
opens:

The following table contains the Utilities menu selections and their 
functionalities: 

Coordinate Calculator Transform coordinates from one 
spheroid or datum to another.

Create/Display Movie 
Sequences

View a series of images in rapid 
succession.

Create/Display Viewer 
Sequences

View a series of images saved from the 
Viewer.

Image Drape Create a perspective view by draping 
imagery over a terrain DEM.

DPPDB Workstation Start the Digital Point Positioning 
DataBase Workstation (if installed).

View EML ScriptFilesa
Open the EML View dialog, which 
enables you to view, edit, and print 
ERDAS IMAGINE dialogs.

a. UNIX only.

Table 3: Tools Menu Options (Continued)

Selection Functionality
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Help Menu

5. Select Help from the ERDAS IMAGINE menu bar. The Help menu 
opens.

Table 4: Utility Menu Options

Selection Functionality

JPEG Compress Images
Compress raster images using the JPEG 
compression technique and save them 
in an ERDAS IMAGINE format.

Decompress JPEG Images Decompress images compressed using 
the JPEG Compress Images utility.

Convert Pixels to ASCII Output raster data file values to an 
ASCII file.

Convert ASCII to Pixels Create an image from an ASCII file.

Convert Images to Annotation
Convert a raster image to polygons 
saved as ERDAS IMAGINE annotation 
(.ovr).

Convert Annotation to Raster Convert an annotation file containing 
vector graphics to a raster image file.

Create/Update Image Chips Provide a direct means of creating chips 
for one or more images.

Mount/Unmount CD-ROMa Mount and unmount a CD-ROM drive.

Create Lowercase Parallel 
Linksa

Make a set of links to items on CD for 
systems that convert CD paths to 
uppercase.

Create Font Tables Create a map of characters in a 
particular font.

Font to Symbol
Create a symbol library to use as 
annotation characters from an existing 
font.

Compare Images Open Image Compare dialog. Compare 
layers, raster, map info, etc.

Reconfigure Raster Formats Start a DLL to reconfigure raster 
formats.

Reconfigure Vector Formats Start a DLL to reconfigure vector 
formats.

Reconfigure Resample Methods Start a DLL to reconfigure resampling 
methods.

Reconfigure Geometric Models Start a DLL to reconfigure the geometric 
models.

a. UNIX only.
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NOTE: The Help menu is also available from the Session menu.

The following table contains the Help menu selections and their 
functionalities: 

6. From the Help menu, select Help for Icon Panel. The following 
Help page displays in your default internet browser:

Table 5: Help Menu Options

Selection Functionality

Help for Icon Panel View the On-Line Help for the ERDAS 
IMAGINE icon panel.

IMAGINE Online 
Documentation

Access the root of the On-Line Help 
tree.

IMAGINE Version View which version of ERDAS IMAGINE 
you are running.

IMAGINE DLL Information Display and edit DLL class information 
and DLL instance information.

About ERDAS IMAGINE Open ERDAS IMAGINE Credits.
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The ERDAS IMAGINE On-Line Help (OLH) system is a collection of 
on-line manuals that functions just like an internet website. The OLH 
system includes help for all of the dialogs in ERDAS IMAGINE, as well 
as in-depth Help files that provide more details about a process. Each 
manual covers a specific topic. These manuals can be printed for 
convenience. The individual html files may also be bookmarked for 
quick reference.

* blue is the default link color; your system may be different

Back button
Click to return 
to the last topic 
viewed

Location bar
Displays the 
location of the 
current help 
file

Hyperlinks
Click the 
blue* 
underlined 
words to link 
to other help 
topics

Show/Hide button
Displays or hides the 
navigation pane

Browse buttons
Click to move to the 
next or previous 
topic in the browse 
sequence

Slider bar
Use the slider bar 
to scroll through 
long help topics
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7. Click the  button at the upper right corner of the help topic. 

The Navigation Pane displays in the left portion of your browser.

8. Click the + beside the Viewer On-Line Manual in the Contents tab 
to view all of the topics in the Viewer manual. 

9. Double-click the Viewer topic.

Contents
Click this tab to 
view the Table 
of Contents

Use the slider 
bars to scroll 
through the 
navigation 
pane

Index
Click this tab to look 
up help topics by 
keyword

Search
Click this tab to 
perform a Full Text 
Search for a word or 
phrase

Show/Hide button
Displays or hides the 
navigation pane

Click the + to 
open a book and 
browse its topics

Click the - to 
close a book and 
hide its topics

Click to select a 
topic. Double-click 
to open a topic. The 
currently displayed 
topic is highlighted 
in the Table of 
Contents.
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10. The first page of the Viewer Manual displays. Use the  and 

 browse buttons to jump from topic to topic and the scroll bars 

to page through a topic. Click any hyperlinked text to jump to that 
topic. Click the Back button to return to the point from which you 
jumped.

11. Use the Contents, Index, and Search tabs when looking for a 
specific title, subject, or word or phrase. 

12. Select File ->ERDAS IMAGINE Tour Guides Exit from the On-Line 
Help file menu bar when you are finished reading On-Line Help. The 
Help window is closed.

Dialogs A dialog is a window in which you enter file names, set parameters, 
and execute processes. In most dialogs, there is very little typing 
required—simply use the mouse to click the options you want to use. 

Most of the dialogs used throughout the tour guides are reproduced 
from the software, with arrows showing you where to click. These 
instructions are for reference only. Follow the numbered steps to 
actually select dialog options.

For On-Line Help with a particular dialog, click the Help button in 
that dialog.

All of the dialogs that accompany the raster and vector editing tools, 
as well as the Select Layer To Add dialog, contain a Preview window, 
which enables you to view the changes you make to the Viewer 
image before you click Apply.

Most of the functions in ERDAS IMAGINE are accessible through 
dialogs similar to the one below:

More 
Information/Help

As you go through the tour guides, or as you work with ERDAS 
IMAGINE on your own, there are several ways to obtain more 
information regarding dialogs, tools, or menus, as described below.
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On-Line Help

There are two main ways you can access On-Line Help in ERDAS 
IMAGINE:

• select the Help option from a menu bar

• click the Help button on any dialog.

Status Bar Help

The status bar at the bottom of the Viewer displays a quick 
explanation for buttons when the mouse cursor is placed over the 
button. It is a good idea to keep an eye on this status bar, since 
helpful information displays here, even for other dialogs. 

Bubble Help

The User Interface and Session category of the Preference Editor 
enables you to turn on Bubble Help, so that the single-line Help 
displays directly below your cursor when your cursor rests on a 
button or frame part. This is helpful if the status bar is obscured by 
other windows.
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Viewer & Geospatial Light Table

Introduction In this tour guide, you can learn how to:

• set Preferences

• display an image

• query for pixel information

• arrange layers

• adjust image contrast

• link Viewers

• use the Area of Interest (AOI) function 

• use the Raster menu functions (Raster Attribute Editor, 
Measurement tools, and so on)

• use the geospatial light table

Approximate completion time for this tour guide is 45 minutes.

Display 
Preferences

ERDAS IMAGINE allows you to set up default band-to-color gun 
assignments for Landsat MSS, Landsat TM, SPOT, and AVHRR data 
in the Preference Editor. 

Check Band-to-Color Gun 
Assignments

ERDAS IMAGINE should be running and a Viewer should be open.

1. Click the word Session in the upper left corner of the ERDAS 
IMAGINE menu bar.

2. From the Session menu, click Preferences.

The Preference Editor opens.
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3. Drag the scroll bar on the right side of the dialog down to see all of 
the User Interface & Session preferences (User Interface & 
Session is the default under Category). 

You may change these or any other preferences at any time by 
selecting the preference category (click the list below Category) and 
then editing the text in the text entry fields. 

4. Under the User Interface & Session category in the Preference 
Editor, locate the preferences for the 3-Band Image Red Channel 
default, 3-Band Image Green Channel default, 3-Band Image 
BlueChannel default, 4-Band Image Red Channel default, 4-
Band Image Green Channel default, 4-Band Image Blue 
Channel Default, 5-Band Image Red Channel default, 5-Band 
Image Green Channel default, 5-Band Image Blue Channel 
Default, 6-or-greater-Band Image Red Channel default, 6-or-
greater-Band Image Green Channel default, and 6-or-
greater-Band Image Blue Channel Defaults.

The number that is entered for these defaults shows the band that is 
used for the Red, Green, and Blue color guns in your display. You 
may change these defaults. These are the band assignments that 
display in the Layers to Colors section of the Select Layer To Add 
dialog when it opens. These assignments can also be changed in the 
Select Layer To Add dialog for specific files.

Check Viewer 
Preferences

1. With the Preference Editor still open, click the Category list and 
select Viewer. 

The Viewer preferences display.

2. Drag the scroll bar on the right of the dialog down to see all of the 
Viewer preferences. 

These preferences control the way the Viewer automatically displays 
and responds each time it opens.

Click here
to see on-line
help for this
dialog

Click here 
to select the
preference

Click here
to see on-line
help for this
category

categories 
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Check Preference Editor 
Help

1. Click Help in the lower right corner of the dialog. 

The On-Line Help for the Preference Editor opens.

2. When you are through studying the Preference Editor help file, select 
File -> Exit from the On-Line Help file menu bar. 

The On-Line Help file closes.

View Category Help

1. Click the Category Help button on the Preference Editor.

The On-Line Help for this category, Viewer, opens.
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2. When you are through studying the Viewer preferences help file, 
select File -> Exit from the On-line Help file menu bar. 

3. Click the Close button on the Preference Editor. 

NOTE: If you have changed any preferences, you can save them at 
this time by clicking the User Save or Global Save buttons on the 
Preference Editor dialog.

Display an Image Next, you display a Landsat Thematic Mapper (TM) image of 
Gainesville, Georgia in a Viewer. 

Since the data files in the <IMAGINE_HOME>/examples directory 
are read-only, you may want to copy them to a new directory and 
change the file permissions. Remember, <IMAGINE_HOME> is the 
variable name for the directory where ERDAS IMAGINE resides.
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1. In the Viewer menu bar, select File -> Open -> Raster Layer.

You can also open this dialog using either of these two methods:

— use the keyboard shortcut, Ctrl-r

— click this icon  in the Viewer toolbar.

The Select Layer To Add dialog opens.

2. In the Select Layer To Add dialog, click the Recent button.

A dialog with a listing of the most recent files you have opened 
displays. You can individually select these files and then click OK to 
display them quickly in the Select Layer To Add dialog.

3. Click Cancel in the List of Recent Filenames dialog.

4. In the Select Layer To Add dialog, click the Goto button.

A dialog with a listing of the most recent directories you have opened 
displays. You can individually select these directories, or enter the 
name of a new directory, and then click OK to display that directory 
quickly in the Select Layer To Add dialog.

5. Click Cancel in the Select a Directory dialog.

NOTE: The Recent and Goto buttons in the Select Layer To Add 
dialog are helpful for quickly locating and displaying a file or directory 
you work with often.

A preview of the 
image displays 
here 

Click this 

change file types 
dropdown list to 

Click here 
to select file 

file name 
part
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6. In the file name part of the Select Layer To Add dialog, click the file 
lanier.img. 

This is a Landsat TM image of the Gainesville, Georgia area, including 
Lake Lanier. Information about this file is reported in the bottom, left 
corner of the Select Layer To Add dialog. This true color image has 
seven bands, 512 columns, and 512 rows.

7. Click the Raster Options tab at the top of the Select Layer To Add 
dialog. 

The Raster Options display. 

8. Under Layers to Colors, display band 4 in the Red color gun, band 
5 in the Green color gun, and band 3 in the Blue color gun.

Display Options

1. Note the display options in the Select Layer To Add dialog.

File Name Part
The framepart under Filename is called a file name part. A file 
name part is a tool used to select specific files for use in an 
ERDAS IMAGINE function. A file name part consists of:

• a text field—for entering the file name by typing it in, or 
clicking on, the file from the scroll list.

• a scrolling list—shows the name of all files with the default 
extension in the selected directory. Files can be selected by 
clicking on the name in the list.

Click this file tab 
to display the 
raster options 

Click here to 

image in the 
display the 

Viewer 

Change the layer 
to color band 
assignment here 
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Display Options Defaults
The default settings of the Raster Options tab are briefly described 
below: 

• Orient Image to Map System—This checkbox is enabled if 
calibration is saved to the image file. If there is no calibration, 
this option is disabled. When enabled, the image displays using 
calibration. Otherwise, the calibration is ignored.

• Clear Display—When this checkbox is enabled, and a new 
image is loaded, the image currently displayed in the Viewer is 
removed. Disable this checkbox to overlay images.

• Fit to Frame—If this checkbox is enabled, the image is 
magnified or reduced to fit the Viewer window at its current 
size.

• Data Scaling—The Viewer performs a two standard deviation 
stretch by default. Click this checkbox to select an alternate 
data range to stretch.

If you want to save the contrast stretched values with the 
image, you can use the Radiometric Enhance -> LUT 
Stretch option of Image Interpreter. 

• Zoom by—If Fit to Frame is disabled, then you can enter the 
zoom ratio for the data in this data field.

• Set View Extent—Allows you to specify the upper left and 
lower right coordinates of the portion of the image to display.

The coordinates in this dialog set the area of the image to 
display in the Viewer. This is useful if you have an image that 
is larger than the Viewer window, or if you want only a specific 
portion of a large image to display in the Viewer. You can also 
select View -> Scale -> Extent from the Viewer menu bar. 

• No Stretch—Click to display data without applying the normal 
two standard deviation stretch.
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2. Click OK in the Select Layer To Add dialog to display the file.

The file lanier.img displays in the Viewer. The name of the file and 
the layers selected are written in the Viewer title bar.

Utility Menu 
Options

The Utility menu on the Viewer enables you to access four separate 
groups of functions:

• inquiry functions 

• measurement tool

Display Options Defaults, Continued

• Background Transparent—Click to make the background of 
grayscale, pseudocolor, and true color areas transparent—the 
layer underneath shows through. Background areas are 
automatically transparent in thematic layers.

• Using—Resampling is appropriate if the image is magnified (a 
magnification factor greater than one). Use one of the 
following resampling methods: Nearest Neighbor, Bilinear 
Interpolation, Cubic Convolution, and Bicubic Spline.

Click here to minimize the window

The title bar shows
the Viewer number
and name of image
displayed 

Drag on any
of the corners
to resize the Viewer

In the title bar,

move the Viewer
hold and drag to

Use the scroll bars
to roam in an image

Single-line help and coordinates 
display in this Status Bar
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• layer viewing

• information

Each function group is separated by a line in the dropdown menu.

Use Inquiry Functions You can query a displayed image for information about each pixel 
using the inquiry functions.

The file lanier.img must be displayed in a Viewer.

1. Select Utility -> Inquire Cursor from the Viewer menu bar. 

A white crosshair displays in the Viewer and the Inquire Cursor dialog 
opens.

You can move the Inquire Cursor in the Viewer using any of these 
methods:

• Drag the white crosshair over the image.

• Enter new coordinates into the CellArray™ of the Inquire Cursor 
dialog. The Inquire Cursor moves when you move the mouse 
cursor back into the Viewer.

• Click the black arrows at the bottom of the Inquire Cursor dialog.

As the crosshair is moved, the information in the Inquire Cursor 
dialog automatically updates. 

2. The CellArray in the Inquire Cursor dialog reports a variety of pixel 
information. Drag on the horizontal scroll bar (or enlarge the Inquire 
Cursor dialog by dragging any corner) to show all of the pixel 
information available in the CellArray. 

Change Inquire Cursor 
Style

You can change the color and shape of the Inquire Cursor to make it 
more visible in the Viewer. 

Drag the crosshair 
over the image in the Viewer 
or click here to move it 

Drag the scroll bars 

Map projection/spheroid 
listed here 

Drag any corner to enlarge 
the CellArray for more information for more details

Pixel information
reported in this
CellArray

Click arrows to move
 

the Inquire cursor

Click the circle to move the Inquire 
cursor to the center of the image 
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1. To change the color of the Inquire Cursor, select Utility -> Inquire 
Color from the Viewer menu bar.

The Inquire Color dialog opens. 

2. Select a new color for the Inquire Cursor by holding on the Inquire 
Color dropdown list and dragging to select the desired color. 

3. Click OK in the Inquire Color dialog.

The Inquire Cursor changes color.

4. To change the shape of the Inquire Cursor, select Utility -> Inquire 
Shape from the Viewer menu bar.

The Inquire Shape dialog opens.

5. Click circle.cursor in the scroll list that displays, then click Apply. 

The Inquire Cursor becomes a circle.

6. In the Inquire Shape dialog, click the Use Cursor button, then 
Apply to return the Inquire Cursor to the original crosshair shape. 

7. Click Close in the Inquire Shape and the Inquire Cursor dialogs.

The Inquire Cursor is cleared from the Viewer.

Take Measurements The Measurement tool enables you to measure points, lines, 
polygons, rectangles and ellipses in the displayed layer. Both 
distance and area are reported in the units you select.

1. Click the Measurement icon  in the Viewer toolbar or select 
Utility -> Measure from the Viewer menu bar. 

The Measurement Tool viewer opens.

Hold on the dropdown 
list to select a new 
color 

Click to make the 
Inquire Cursor an 
icon or a cursor 

Click here to 
apply the new shape
to the Inquire Cursor

Click to select
a new shape
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2. Click the Measure Positions icon  in the Measurement toolbar. 
This tool gives the individual point coordinates (x, y) in the image.

3. Move the cursor into the Viewer and click anywhere. 

In the Measurement Tool viewer, the location of the point displays in 
the type of units in which the file is saved. You may select different 
display units from the dropdown lists in the top toolbar.

4. Next, click the Polyline icon  in the Measurement Tool viewer 
toolbar.

5. Move the cursor into the Viewer and click once at the beginning of a 
line feature then drag the mouse to extend the line along the feature. 
Click to add a vertex at each point. Middle-click (or double-click, 
depending on how your Preferences are set) to end the 
measurement. 

The length displays in the Measurement Tool CellArray. 

6. Click the Print icon  to print and a Print dialog opens, which allows 
you to enter or select the printer to be used. 

Click to print 

Click to 
locate point 
coordinates 

The Measurement Tool

The Measurement Tool can create a new annotation layer on top 
of your image. Simply click the Annotation tool and a new layer is 
automatically created. While this tool is enabled, the measurement 
features (points, polylines, polygons, rectangles, ellipses, etc.) are 
added to the annotation layer as well as a text box containing the 
measured values. Click the tool again to turn this feature off.

The annotation layer may be saved and used with other images 
with the same geographic area.

NOTE: These annotation objects may be moved and resized, but 
the measured values in the text boxes are not updated.
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7. Select the Printer and click Print (or OK) in the Print dialog. If you 
do not wish to print, click Cancel.

8. Experiment with the other measurement tools if you like, and when 
you are done, click the Close button in the top toolbar. 

You are asked if you want to save the measurements. Save them if 

you like. You can click the Save icon  at any time to save your 
measurements.

Click the Help button to view the On-Line Help for the 
measurement tools.

View Menu 
Options

Arrange Layers ERDAS IMAGINE should be running, and lanier.img should be 
displayed in a Viewer.

1. In the Viewer toolbar, click the Open icon  to open another layer 
on top of lanier.img. 

The Select Layer To Add dialog opens.

2. In the Select Layer To Add dialog under File name, click 
lnsoils.img. This is a thematic soils file of the Gainesville, Georgia 
area. 

3. Click the Raster Options tab at the top of the Select Layer To Add 
dialog.

4. Check to be sure that the Clear Display checkbox is disabled (not 
selected), so that lanier.img is not cleared from the Viewer when 
lnsoils.img displays.

5. Click OK in the Select Layer To Add dialog to display the file.

Now, both lanier.img and lnsoils.img are displayed in the same 
Viewer, with lnsoils.img on top. 

6. To bring lanier.img to the top of the Viewer, select View -> 
Arrange Layers from the Viewer menu bar.

The Arrange Layers dialog opens.
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7. In the Arrange Layers dialog, drag the lanier.img box above the 
lnsoils.img box, as illustrated above.

When you release the mouse button, the layers are rearranged in the 
Arrange Layers dialog so that the lanier.img box is first.

8. Click Apply in the Arrange Layers dialog to redisplay the layers in 
their new order in the Viewer. 

The layers are now reversed. 

9. Click Close in the Arrange Layers dialog.

Zoom In this section, you zoom in by a factor of 2 and create a magnifier 
window. Once the image enlarges, you can roam through it.

lanier.img should be displayed on top of lnsoils.img in a Viewer at 
a magnification of 1 (this is the case if you have been following 
through this tour guide from the beginning).

1. Select View -> Zoom -> In by 2 from the Viewer menu bar.

The images are redisplayed at a magnification factor of 2.

The Zoom options are also available from:

— the Quick View menu (right-hold on the Viewer image) 
under Zoom -> Zoom In by 2

— the Viewer toolbar by clicking this icon  .

2. Move the scroll bars on the bottom and side of the Viewer window to 
view other parts of the image. 

To move by small increments, you can click the small triangles at 
either end of the scroll bars. To move by larger increments, drag the 
scroll bars. 

Click and drag 
this box to the top
to change the
order of the 
displayed layers

Click here to
redisplay layers
in the new order
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You can also enlarge the Viewer window by dragging any corner.

3. Select View -> Create Magnifier from the Viewer menu bar.

A white cursor box opens in the center of the image. This area 
displays in a small magnifier window that opens over the top corner 
of the Viewer.

4. With your pointer inside the white cursor box, hold and drag the box 
around the image.

The data in the magnifier window changes as the cursor box is 
moved over the image. This technique is called chip extraction, 
which is used in the Rectification tools to help you precisely identify 
ground control points (GCPs).

5. In the Viewer menu bar, select File -> Close Other Viewers to 
close the magnifier window.

Image in this new Viewer
is a magnified view of
the image area under
this cursor box
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Other methods of zooming in and out of imagery are Animated 
Zoom, Box Zoom, and Real-time Zoom. 

Animated Zoom Animated Zoom enables you to zoom in and out of the Viewer’s 
image in a series of steps that are similar to animation. The image is 
resampled after it is magnified or reduced.

Display lanier.img in the Viewer. 

1. Select Session -> Preferences.

2. In the Preference Editor dialog, select Viewer from the Category 
list. 

3. Click the checkbox for Enable Animated Zoom.

4. Click User Save then Close in dialog, and go back to the Viewer.

5. Click the Zoom In By Two icon  .

The Viewer zooms into the image in a simulated animation by a 
factor of 2. The Viewer center is maintained.

6. Click the Zoom Out By Two icon  . 

The Viewer zooms out of the image in a simulated animation by a 
factor of 2. The Viewer center is maintained. 

Magnifying Areas
There are four ways to change the size of the area magnified:

• With the cursor on any corner (or side) of the cursor box, drag 
the box until it is the desired size.

• Place the cursor on the lower right corner of the magnifier 
window and drag the magnifier window until it is the desired 
size.

• Press the space bar to enter precise positioning coordinates in 
the inquire box dialog.

• Use the Quick View menu (from the right mouse button) or 
the View menu (from the Viewer menu bar) to zoom in either 
Viewer.

As you try these methods, you notice that each change in size is 
reflected in the other window. As the cursor box is adjusted, the 
magnification in the magnifier window is adjusted to accommodate 
the new area. Likewise, as the magnifier window is adjusted, the 
cursor box changes to reflect the new size and proportion.
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7. Click either the Interactive Zoom In  or the Interactive Zoom Out 

icon  .

8. Click a location on the image. 

The Viewer recenters the image to that location and zooms in or out 
in a simulated animation by a factor of 2.

Animated zoom also works with View -> Zoom -> In by X and 
Out by X.

Box Zoom Box Zoom is used to select a boxed area in the image. When zooming 
in or out by using the zoom recentering icons, the boxed image 
enlarges or reduces within the Viewer.

Display lanier.img in the Viewer. 

1. Select Session ->Preferences.

2. In the Preference Editor dialog, select Viewer from the Category 
list. 

3. Click to select Enable Box Zoom.

4. Click User Save then Close in dialog, and go back to the Viewer.

5. Click the Interactive Zoom In icon. 

6. Click and drag a box in the image. 

The selected area of the image is magnified to fit the Viewer. 

7. Select the Interactive Zoom Out icon. 

8. Click and drag a box in the image. 

The area displayed in the Viewer is reduced to fit in the box. Space 
surrounding the reduced image is populated with available imagery.

Real-time Zoom When you select either of the Interactive Zoom tools, you can to 
zoom into and out of images in real time by holding the middle 
mouse button and moving the mouse upward and downward over 
the image.

NOTE: You can also hold down the Control key and press on the left 
mouse button to zoom in real time.

Display lanier.img in the Viewer. There is no need to set up a 
preference for this feature.

1. Select either of the Interactive Zoom icons. 

2. Position the cursor in the Viewer, and hold the middle mouse button. 

3. Move the mouse forward to zoom in on the image. 
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The image magnifies at a constant rate, depending on how far 
forward you move the mouse.

4. Hold the middle mouse button and move the mouse backward. 

The image reduces at a constant rate, depending on how far 
downward on the image you move the mouse.

Display Two Images Two or more Viewers can be geographically or spectrally linked so 
that when you roam in one image, that area is simultaneously 
displayed in the linked Viewer(s). 

The file lanier.img should be displayed on top of lnsoils.img in a 
Viewer window, at a magnification of 2.

1. Drag on a lower corner of the Viewer so that it occupies the entire 
left half of the screen.

2. In the Viewer menu bar, select View -> Split -> Split Horizontal.

The Viewer is divided in half, horizontally, to form two Viewers.

3. In the toolbar of the new Viewer, click the Open icon  . 

The Select Layer To Add dialog opens.

4. In the Select Layer To Add dialog under File name, click the file 
lnsoils.img.

5. Click the Raster Options tab at the top of the dialog.

6. Confirm that Zoom by is set to 1.00.

7. Click OK in the Select Layer To Add dialog.

The file lnsoils.img displays in the second Viewer.

Link Viewers

1. In the first Viewer, select View -> Link/Unlink Viewers -> 
Geographical.

The Link/Unlink Instructions display.

2. Move your pointer to the second Viewer.

The pointer becomes a Link symbol  .

Types of Linking

• Geographically linked—the same image area displays in all 
linked Viewers.

• Spectrally linked—enhancements made to an image are also 
made in other Viewers if that same image, or portions of it, are 
displayed in other Viewers.
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3. Move the pointer to the first Viewer. 

The No Link symbol  displays as the cursor in the first Viewer. 
Clicking in this Viewer discontinues the link operation.

4. To link the Viewers, click anywhere in the second Viewer.

The two Viewers are now linked. A white cursor box opens over the 
image in the second Viewer, indicating the image area displayed in 
the first Viewer.

You can move and resize this cursor box as desired, and the image 
area in the first Viewer reflects each change. This is similar to the 
magnification box you used earlier.

Compare Images

1. Drag the cursor box in the second Viewer to a new location. The 
image area selected in the second Viewer displays in the first Viewer.

2. Drag the scroll bars in the first Viewer to roam in the image. 

The white cursor box in the second Viewer moves as the image area 
in the first Viewer changes.

You could also use the Roam icon  in the Viewer toolbar to 
roam over the image. Just move the hand across the Viewer 
image to change the view.

Unlink Viewers

1. In either Viewer, select View -> Link/Unlink Viewers -> 
Geographical to unlink the Viewers.

The Link/Unlink Instructions display.

2. Move the pointer to the other Viewer.

The unlink cursor  displays.

3. Click anywhere inside the Viewer to unlink the Viewers.

4. In the menu bar of the second Viewer, select File -> Close. 

The second Viewer closes.

5. In the first Viewer, select File -> Clear to clear the Viewer.
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Raster Menu 
Options

Create an AOI Layer These options allow you to define an AOI in the image, excluding 
other parts of the image. Specific processes can be applied to this 
AOI only, which can save considerable time and disk space. The 
option to use a specified AOI for processing is available from many 
dialogs throughout ERDAS IMAGINE. 

This exercise tells you how to create an AOI layer that can be saved 
as a file and recalled for later use. 

NOTE: Each Viewer can display only one AOI layer at a time.

Display lanier.img in a Viewer. You must have an image displayed 
in the Viewer to create an AOI layer.

1. Select File -> New -> AOI Layer from the Viewer menu bar. 

ERDAS IMAGINE creates an AOI layer. 

2. Select View -> Arrange Layers from the Viewer menu bar to verify 
that the AOI layer has been created. 

The Arrange Layers dialog opens, and should look similar to the 
following example: 

3. After verifying the creation of the AOI layer, click Close in the 
Arrange Layers dialog.

Later, you are asked to name the layer and save it to a file.

Open AOI Tools 

1. Select AOI -> Tools from the Viewer menu bar (or click the Tools 
icon on the toolbar). 

The AOI tool palette displays.

This signifies that an 
AOI layer was created 

Click here
when you have
verified the
creation of the
AOI layer 
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2. Click the Rectangle icon in the AOI tool palette  .

3. Move the cursor into the Viewer window. Drag and then release to 
draw a rectangle over the AOI. Include a portion of the water when 
designating the AOI.

A rectangular AOI displays in the Viewer. 

Click to draw
a rectangular AOI Click to plant

a seed to grow a
regional AOI

Click to select
an AOI

Rectangular AOI 
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Select Styles

1. Select AOI -> Styles from the Viewer menu bar. 

The AOI Styles dialog opens.

This dialog enables you to change the style of the AOI display. 

2. Experiment in the AOI Styles dialog with the line widths and colors 
to find a style that looks best on the displayed image.

3. When you are finished, click Close in the AOI Styles dialog.

Set Seed Properties

1. Next, select AOI -> Seed Properties from the Viewer menu bar.

The Region Growing Properties dialog opens.

Selecting AOIs
Following are some tips regarding the selection of the AOI:

• You can move the AOI by dragging the AOI to a new location. 

• You can resize the AOI by dragging any of the handles at the 
corners and sides of the bounding box, or by pressing the 
space bar to enter precise coordinates.

•  The x in the center of the bounding box marks the center 
coordinate of the AOI.

Click to apply the new 
style to the AOI 

Click to see 
On-Line Help 
for this dialog 

Click to fill the AOI 
polygon with a color 

Right-hold to 
select a new color 
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This dialog enables you to define the region that grows from the 
seed.

2. In the Region Growing Properties dialog, change the Spectral 
Euclidean Distance to 5.00.

3. Click Set Constraint AOI in the Region Growing Properties dialog.

The Choose AOI dialog opens.

4. In the Choose AOI dialog, select Viewer under AOI Source and 
then click OK.

5. Click the Region Grow AOI icon  in the AOI tool palette. 

Click this tool to plant seeds, or points in the Viewer, from which to 
grow a regional AOI. The region grows in the Viewer as an AOI that 
can be selected.

6. Move the cursor into the Viewer window and click the water inside 
the rectangular AOI to indicate where you want the region growing 
to take place.

A status meter displays in the status bar of the Viewer. You may click 
Cancel to terminate the region grow process. The meter dismisses 
when the region growing process is complete. The area you selected 
in the Viewer is surrounded by a second bounding box and chaser 
lights.

7. Click Close in the Region Growing Properties dialog.

Save AOI

1. Select File -> Save -> AOI Layer As from the Viewer menu bar. 

The Save AOI As dialog opens. This dialog allows you to save the 
selected AOIs as a layer (.aoi extension) that can be used again for 
other functions. 

2. Enter a name for the AOI layer under Save AOI as (the .aoi 
extension is added automatically). Pay special attention to the 
directory where the file is saved, so you can find the layer later. 

Click to select 
an AOI to constrain 
the region growing 

Adjust the Spectral 
Euclidean Distance 
here 
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If you wanted to save specific AOIs only, you could turn on the 
Selected Only checkbox in the Save AOI As dialog, and only 
selected AOIs would be saved to a file.

3. Click OK in the Save AOI As dialog. 

This layer can now be used in any dialog where a function can be 
applied to a specific AOI layer. You can also edit this layer at any 
time, adding or deleting areas. 

Arrange Layers

1. Select View -> Arrange Layers from the Viewer menu bar. 

The Arrange Layers dialog opens.

2. In the Arrange Layers dialog, right-hold over the AOI Layer and 
select Delete Layer from the AOI Options menu.

3. Click Apply and then Close in the Arrange Layers dialog.

The file lanier.img is redisplayed in the Viewer without the AOI 
layer.

Adjust Image Contrast When images are displayed in ERDAS IMAGINE, a linear contrast 
stretch is applied to the data file values, but you can further enhance 
the image using a variety of techniques.

The file lanier.img should be displayed in a Viewer.

1. In the Viewer menu bar, select Raster -> Contrast -> 
Brightness/Contrast.

The Contrast Tool dialog opens.

2. In the Contrast Tool dialog, change the numbers and/or use the 
slider bars to adjust the image brightness and contrast.

3. Click Apply.

The image in the Viewer is redisplayed with new brightness values.

4. Click Reset and Apply in the Contrast Tool dialog to undo any 
changes made to the Viewer image.

Adjust 
brightness 
here 

Adjust 
contrast 
here 

Click here to 
reset to original 
contrast 

Click here or here 
to apply changes 
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5. Click Close in the Contrast Tool dialog.

Use Piecewise Linear 
Stretches

1. In the Viewer menu bar, select Raster -> Contrast -> Piecewise 
Contrast.

The Contrast Tool dialog for piecewise contrast opens.

2. With your pointer over the image in the Viewer, right-hold Quick 
View -> Inquire Cursor.

The Inquire Cursor dialog opens and an Inquire Cursor is placed in 
the Viewer.

Adjust contrast 
and brightness 
here 

Specify range 
of lookup table 
to modify here 

Set lookup 
table ranges 
here 

Select color 
gun to affect 

Click here to reset 
to the original 
lookup table 

contrast 

The Contrast Tool
This tool enables you to enhance a particular portion of an image 
by dividing the lookup table into three sections: low, middle, and 
high. You can enhance the contrast or brightness of any section 
using a single color gun at a time. This technique is very useful for 
enhancing image areas in shadow, or other areas of low contrast. 

The brightness value for each range represents the midpoint of the 
total range of brightness values occupied by that range.

The contrast value for each range represents the percent of the 
available output range that particular range occupies.

As one slider bar is moved, the other is automatically adjusted, so 
that there is no gap in the lookup table. This tool is set up so that 
there are always pixels in each data file value from 0 to 255. You 
can manipulate the percentage of pixels in a particular range, but 
you cannot eliminate a range of data file values.
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3. In the Viewer, drag the intersection of the Inquire Cursor to the lake. 
Move the Inquire Cursor over the water while keeping an eye on the 
lookup table values in the blue color gun, as reported in the Inquire 
Cursor dialog. 

This gives you an idea of the range of data file values in the water. 
You can stretch this range to bring out more detail in the water. 

4. In the Contrast Tool dialog, click Blue under Select Color.

5. Under Range Specifications, set the Low range From 34 To 55 
and press Enter on your keyboard.

6. Drag the Brightness slider bar (the top slider bar) to 50.

7. Click Apply in the Contrast Tool dialog. 

The water now has more contrast and shows more detail.

If your image is at a magnification of 1, this new detail may be 
difficult to see. You can zoom in to a magnification of 2 using the 
Quick View menu in the Viewer.

8. In the Contrast Tool dialog, click Reset and then Apply to return the 
image to the original lookup table values.

9. Click Close in the Contrast Tool dialog.

10. Click Close in the Inquire Cursor dialog.

Manipulate Histogram

1. In the Viewer menu bar, select Raster -> Contrast -> 
Breakpoints.

The Breakpoint Editor opens. 
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2. Click the dropdown list at the top of the Breakpoint Editor and select 
Red.

Each of the three histogram graphics in the Breakpoint Editor can be 
expanded up to full size by selecting the appropriate histogram from 
the dropdown list at the top of the Break Point Editor. The parts of 
the histogram graphic are described in the following illustration.

Indicate which 
histograms 
to view 

Click to 
apply changes 
made to all 
histograms 

Allows you to set 
histogram display 
options 

Click to 
apply changes 
to the red 
histogram only 

Enlarge the

by dragging on 
any corner 

histograms 
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3. Click the dropdown list at the top of the Breakpoint Editor and select 
RGB.

All three histograms redisplay in the Breakpoint Editor.

4. Experiment by dragging the breakpoints of the lookup table graphs 
in the different color guns (Red, Green, and Blue).

5. Click Apply All in the Breakpoint Editor to view the results of your 
changes in the image.

6. To undo the edits you just made, select Raster -> Undo from the 
Viewer menu bar.

Adjust Shift/Bias

1. In the Breakpoint Editor, click the Shift/Bias icon  on the toolbar.

The Shift/Bias Adjustment dialog opens.

The Y axis 
represents both 
the frequencies 
of the histogram 
and the range 
of output values 
for the lookup table 

The X axis The histogram of the 
input values (white) 
does not change 

The histogram of 

represented 
frequency 
The highest 

The lookup table 

you manipulate the 
(red) changes as 
the output values 

lookup table graph 

range of values 

range is 0 to 255)

represents the 

(for 8-bit data, the 

breakpoints 
graph with 

(small squares) 

Histogram Edit Tools 
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The lookup table graph and the output histogram are updated in the 
Histogram Tool dialog as you manipulate the information in the 
Shift/Bias Adjustment dialog.

2. In the Shift/Bias Adjustment dialog, drag the Shift slider bar to the 
right.

Notice that the value in the number field to the left increases as you 
move the slider bar. This is the number of pixels that the lookup table 
graph is moved.

3. In the Shift/Bias Adjustment dialog, double-click the number in the 
Shift number field and change the number field to 20. Press Enter 
on your keyboard.

4. In the Breakpoint Editor, click Apply All.

The image is redisplayed using the new lookup table. It is very dark.

5. In the Shift/Bias Adjustment dialog, return the Shift value to 0.

6. In the Breakpoint Editor, click Apply All to return the image to its 
original contrast.

7. Repeat step 2 through step 6 using the Bias option.

8. When you are finished, click Close in the Shift/Bias Adjustment 
dialog.

Use Mouse Linear 
Mapping

1. In the Breakpoint Editor, click the Red Mouse Linear Mapping icon 

 , which is located on the left border of the Red histogram.

The Red Mouse Linear Mapping dialog opens.

Shift moves the 
lookup table graph
left and right 
(X direction)

Bias moves the
lookup table graph
up and down
(Y direction)
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2. In the Red Mouse Linear Mapping dialog, click the Rotate button to 
disable the rotate option.

3. Drag the dot in the center of the grid left or right to shift the red 
lookup table graph.

4. In the Breakpoint Editor, click the Run icon  for the red histogram 
to update the image in the Viewer. 

5. In the Red Mouse Linear Mapping dialog, click the Rotate button to 
turn it on and the Shift button to turn it off.

6. Drag the dot in the grid up or down to change the slope of the lookup 
table graph.

7. Click the Run icon for the red histogram to update the Viewer image.

8. Click Close in the Red Mouse Linear Mapping dialog.

9. With your cursor over the red histogram graph, right-hold Graph 
Options -> Undo All Edits.

10. Click Apply All in the Breakpoint Editor to return the Viewer image 
to its original contrast.

11. Click Close in the Breakpoint Editor.

12. Select File -> Clear from the Viewer menu bar.

Move this dot left and right 
to shift the lookup table graph. 
Move the dot up and down 
to rotate the lookup table graph. 

Click here to 
disable this 
option 

Linear Mapping
Moving the dot in the center of the grid left and right shifts the 
lookup table graph in the histogram graphic left or right. Moving 
the dot up and down rotates the lookup table graph, changing the 
slope. Up rotates the graph counterclockwise and down rotates the 
graph clockwise. 

As the dot is moved, the numbers on the right side of the dialog 
are automatically updated. The Rotate number reports the angle 
of the rotation ramp, with 180 being a straight horizontal line and 
90 being a straight vertical line. The Shift number reports the 
pixel value at the center of the lookup table graph.
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Raster Editor The Raster Editor enables you to edit portions of the displayed image 
using various tools in the Viewer Raster menu. When a specific 
raster editing tool is in use, that tool locks the Viewer, therefore, 
work with one tool must be completed before opening another one.

All of the dialogs that accompany the raster editing tools contain a 
preview window, which enables you to view the changes you make 
to the Viewer image before you click Apply.

Prepare (UNIX)

You must have a writable file displayed to use this function. Follow 
the steps below to create a writable file to work with.

1. In a command window, copy lndem.img to testdem.img by typing 
the following (without a carriage return):

cp   $IMAGINE_HOME/examples/lndem.img <your directory 
path>/testdem.img

Press Enter on your keyboard.

2. Change read/write permissions by typing the following in the 
command window: 

chmod   644   testdem.img 

Press Enter on your keyboard and close the command window.

Prepare (PC)

1. Open the Explorer.

2. Copy lndem.img from the <IMAGINE_HOME>/examples directory 
to the directory of your choice.

3. Right-click and select Rename to rename the file testdem.img.

4. Right-click the file, and select Properties.

5. In the Attributes section of the General tab, make sure Read-only 
is not checked.

6. Click OK in the Properties dialog.

Open the Image

1. Open testdem.img in the Viewer. 

This is a DEM file of the Gainesville, Georgia area, corresponding to 
the lanier.img data you have been using.

2. If it is not already displayed, select AOI -> Tools from the Viewer 
menu bar to open the AOI tool palette.

The AOI tool palette displays. The AOI tools are used to define the 
area(s) to be edited.
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3. Click the Ellipse icon  in the AOI tool palette and then drag near 
the center of the Viewer image to draw an elliptical AOI, measuring 
about 1” to 2” in diameter.

When the mouse button is released, the AOI is surrounded by chaser 
lights and a bounding box.

Interpolate

1. In the Viewer menu bar, select Raster -> Interpolate.

The Interpolate dialog opens.

Digitize Points

Digitizing points helps you to control the overall surface generated 
by the raster editing function. However, you should digitize points 
only when you know the general areas in the AOI that are bad. The 
Interpolation function uses the data values of the digitized points and 
the boundary of the AOI to generate a new surface.

1. Click the Digitize Points icon  in the Interpolate dialog, then click 

the Lock icon  ,which changes to  .

2. Click at least 12 times in the AOI in the Viewer to digitize 12 points.

The point coordinates display in the CellArray in the Interpolate 
dialog.

3. When you are finished digitizing points, click the Lock icon in the 
Interpolate dialog again to disable it.

Click this icon 
to lock the 
designated tool 

Click this icon 
to digitize points 
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4. In the Interpolate dialog under Buffer Points, enter 25 to allow up 
to 25 points in the computation.

5. In the Interpolate dialog under Polynomial Order, enter 3 to 
increase the polynomial order of interpolation.

6. Click Apply in the Interpolate dialog.

7. An Attention box displays, asking if you want to remove the data 
stretch lookup table. Click Yes. 

8. A Warning box displays, suggesting that you recalculate the 
statistics. Click OK.

The new surface displays inside the AOI. 

9. Observe the changes in the AOI and then select Raster -> Undo 
from the Viewer menu bar.

The data values return to the original values. This lets you undo the 
edit without changing the original data values.

NOTE: Undo works only for the last edit applied. 

10. Click Close in the Interpolate dialog.

Fill with Constant Value If the area to be edited is a flat surface, you may use a constant 
value to replace the bad data values. 

1. Select Raster -> Fill from the Viewer menu bar.

The Area Fill dialog opens.

2. In the Area Fill dialog, click Apply to accept the Constant function 
and its defaults. 

The AOI is replaced with a Constant value of zero—the area is black.

3. Select Raster -> Undo from the Viewer menu bar. 

The image returns to the original values.

4. In the Area Fill dialog, enter 1500 in the Fill With number field and 
click Apply. 

The preview 
window displays 
what the AOI 
fill looks like 

Click here 
to apply 
the specified 
area fill 
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Now the AOI fill area is white.

5. Select Raster -> Undo from the Viewer menu bar. 

The image returns to the original values.

Set Global Value

1. In the Area Fill dialog, click the Function dropdown list and select 
Majority. 

This option uses the majority of the pixel values in the AOI to replace 
all values in the AOI.

2. Click Apply in the Area Fill dialog. 

The AOI displays the newly generated surface.

3. After observing the changes, select Raster -> Undo from the 
Viewer menu bar. 

4. Click Close in the Area Fill dialog. 

5. Select File -> Clear from the Viewer menu bar.

Save the AOI layer in the Viewer if you like.

Raster Attribute 
Editor

You can easily change the class colors in a thematic file. Here, you 
change the colors in lnsoils.img.

Change Color Attribute Display lnsoils.img in a Viewer.

1. In the Viewer menu bar, select Raster -> Attributes.

The Raster Attribute Editor opens.

The CellArray in the Raster Attribute Editor is for manipulating the 
raster attributes and selecting classes to edit. To change the color of 
a class, you can select that class in two ways:

• with your cursor in the Viewer, click the class you want to edit, or

Expand the 

Column titles

Right-hold
here for a
list of colors

CellArray by 
dragging on 
any corner 

Select class to
edit here or by
clicking in the
Viewer
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• with your cursor in the Row column of the Raster Attribute Editor 
CellArray, click the class to edit.

You use both methods in the following examples.

2. Move your cursor inside the Viewer and click an area.

That class is highlighted in yellow in the Raster Attribute Editor 
CellArray, and the current color assigned to that class is shown in the 
bar underneath the Color column. 

3. In the CellArray, right-hold with your cursor over the Color patch for 
the selected class and select Other.

The Color Chooser dialog opens.

A dot is present on the colorwheel itself, indicating the current color 
of the selected class. This color is also shown in the preview window 
in the lower, right corner of the dialog.

4. In the Color Chooser dialog, change the color of the selected class by 
dragging the dot on the colorwheel to another spot on the 
colorwheel. Then, click the Apply button. 

The selected class changes color in both the Viewer image and the 
Raster Attribute Editor CellArray.

You can also change the class color using any of these methods:

a) enter RGB (red, green, blue) or IHS (intensity, hue, 
saturation) values in the Color Selector number fields in the 
Color Chooser dialog, or

b) click the Standard tab in the Color Chooser dialog to select 
from a list of predefined colors, or

c) move the slider bars in the Color Chooser dialog

5. In the Raster Attribute Editor, select Edit -> Undo Last Edit.

The change you made in step 4 is undone.

6. Click Close in the Color Chooser dialog.

Select colors 
here 

Enable 
transparent A preview of 

color display in 

color displays 

Click here to 
make the new 

the Viewer 

the selected 

here 

Colorwheel 

layers here 
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7. Select File -> Close from the Raster Attribute Editor.

Make Layers Transparent If you have more than one file displayed in a Viewer, you can make 
specific classes or entire files transparent. In this example, you make 
the overlaid soils partially transparent so that the Landsat TM 
information shows through.

1. Display lanier.img over lnsoils.img in a Viewer. Be sure that the 
Clear Display checkbox is disabled under Raster Options when 
you are in the Select Layer To Add dialog.

2. In the Viewer menu bar, select View -> Arrange Layers.

The Arrange Layers dialog opens.

3. In the Arrange Layers dialog, drag the lnsoils.img box on top of the 
lanier.img box.

4. Click Apply, then Close in the Arrange Layers dialog.

Edit Raster Attributes

1. Select Raster -> Attributes from the Viewer menu bar. 

The Raster Attribute Editor displays.

The objective is to select a class that covers a section of lanier.img 
that you would like to see through lnsoil.img. Then, you can make 
that class transparent. 

2. Select the class to become transparent, either by clicking in the 
Viewer or in the Row column of the CellArray. 

3. In the Raster Attribute Editor CellArray, right-hold on the color 
button in the Color column of the selected class and drag to select 
Other from the popup list. 

The Color Chooser dialog opens.

4. In the Color Chooser dialog, click the Use Opacity checkbox. 

Click here and enter .40, or 
use the slider bar at right to set 
the number field to .40

Click checkbox 
to use opacity
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5. At O (which stands for Opacity), change the number to .40 (opacity 
percentage of 40) using either the number field or the slider bar.

6. Click Apply in the Color Chooser dialog. 

The selected color becomes partially transparent, allowing you to see 
lanier.img underneath.

7. Experiment with different ways to change class color and opacity.

8. When you are finished, click Close in the Color Chooser dialog.

Manipulate CellArray 
Information

1. With your cursor in the title bar of the Raster Attribute Editor, drag 
it to the top of your screen.

2. Drag one of the bottom corners of the Raster Attribute Editor down 
until all rows of the
CellArray are visible.

3. Drag the corners of the Raster Attribute Editor horizontally until all 
columns are visible.

NOTE: The CellArray probably occupies most of your screen. 

Select Rows
To select one row, simply click in the Row column of the desired 
row. That row is highlighted in yellow. You can select sequential 
rows by middle-clicking in additional rows. Shift-click in a selected 
row to deselect a row. You can also select rows using the Row 
Selection menu that opens when you right-hold in the Row 
column.

Select Columns
To select one column, click in the title box of the desired column. 
That column is highlighted in blue. You can select multiple columns 
by middle-clicking in the title bar of additional columns. Shift-click 
in a selected column to deselect it.

Choose Column Options
Many column options are available from the Column Options 
menu, which opens when you right-hold in a column title bar. You 
can have multiple columns and rows selected at the same time. 

You use many of these features in the following steps. 

Resize Columns
You can make each column in the CellArray narrower and then 
reduce the width of the entire dialog, so that it takes up less room.
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Edit Column Properties

1. Click the Column icon  in the Raster Attribute Editor.

The Column Properties dialog opens.

2. In the Column Properties dialog, select Color under Columns and 
activate the Show RGB checkbox.

3. Click OK in the Column Properties dialog.

4. In the Raster Attribute Editor, place your cursor on the column 
separator in the header row between the Color and Red columns. 

The cursor changes from the regular arrow to a double-headed 
arrow. You can now change the size of the Color column. 

5. Drag the double-headed arrow to the right to make the Color 
column wider.

6. Repeat this procedure, dragging the double-headed arrow to the left, 
to narrow the other columns.

Generate Statistics

1. In the Raster Attribute Editor CellArray, select the entire Red column 
by clicking in the Red title box.

The entire column is highlighted in blue.

2. With your cursor in the Red title box, right-hold Column Options -
> Compute Stats.

The Statistics dialog opens.

Click here to 
activate this 
function 

Click here to 
select the 
Color column 
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The Statistics for the column selected are reported. 

3. Click Close in the Statistics dialog.

Select Criteria

1. In the Raster Attribute Editor CellArray, select the Class_Names 
column by shift-clicking in the Class_Names title box.

Now the Class_Names and Red columns are both selected; both 
columns are highlighted in blue.

Next, you generate a report that lists all of the classes and the area 
covered by each. You do not include classes with an area of 0 (zero).

2. With your cursor in the Row column (not the header row of the Row 
column), right-hold Row Selection -> Criteria.

The Selection Criteria dialog opens.

Column
selected

Column
statistics

Column Statistics
These statistics include:

• Count—number of classes selected

• Total—sum of column figures (in this example, total area)

• Min—minimum value represented in the column

• Max—maximum value represented in the column

• Mean—average value represented (Total/Count)

• Stddev—standard deviation



ERDAS IMAGINE Tour Guides Raster Attribute Editor / 41

3. In the Selection Criteria dialog under Columns, click Red.

$ìRedî is written in the Criteria definition box at the bottom of the 
dialog.

4. Under Compares, click >.

5. In the calculator, click 0.

The Criteria should now read:

$ ìRedî > 0

This criteria selects all classes in the CellArray with an area that is 
greater than 0.

6. Click Select in the Selection Criteria dialog to select these rows in 
the CellArray.

All rows except 0, 12, and 34 are selected (that is, highlighted in 
yellow). These rows are not selected because the opacity for each of 
these categories is 0.

7. Click Close in the Selection Criteria dialog.

Generate Report

1. With your cursor in a Class_Names title box, right-hold Column 
Options -> Report.

The Report Format Definition dialog opens.

Click here, then here, then here
to define the criteria (automatically written
to the Criteria definition box)

All columns
in the CellArray
are listed here

Click here
and it displays
here
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2. In the Report Format Definition dialog under Title, add for 
lnsoils.img to the default text string.

3. Under Header, add for lnsoils.img to the default text string.

4. Under Statistics, click each checkbox to include all available 
statistics in the report.

5. Click OK in the Report Format Definition dialog to generate the 
report.

A Job Status dialog opens, indicating the progress of the function.

When the function is complete, the report displays in an IMAGINE 
Text Editor. 

Click here to 
generate a report 

Enter text to 
precede the page 
number on the bottom 
of the report 

Enter report title 
and header here 

Specify statistics 
to include here 
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6. To save the report, in the Text Editor menu bar, select File -> Save 
As.

The Save As dialog opens.

7. Enter a name for the report, such as soilsreport.txt.

8. Click OK in the Save As dialog.

The file name is written in the title bar of the Text Editor window.

9. In the Text Editor menu bar, select File -> Close.

10. Select File -> Close from the Raster Attribute Editor.

Save your changes to the Raster Attribute Editor if you like.

11. In the Viewer toolbar, click the Clear Viewer icon  to clear the 
window.

Use these menu
bar and toolbar

edit report
items to save and
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Profile Tools The spectral profile display is fundamental to the analysis of 
hyperspectral data sets. As the number of bands increases and the 
band widths decrease, the remote sensor is evolving toward the 
visible/infrared spectrometer. The reflectance (DN) of each band 
within one (spatial) pixel can be plotted to provide a curve 
approximating the profile generated by a laboratory scanning 
spectrometer. This allows estimates of the chemical composition of 
the material in the pixel. To use this tool, follow the steps below.

Prepare ERDAS IMAGINE should be running and a Viewer should be open.

Display Spectral Profile

1. In the Viewer menu bar, select File -> Open -> Raster Layer.

The Select Layer To Add dialog opens.

2. In the Select Layer To Add dialog, select hyperspectral.img under 
Filename.

3. Click the Raster Options tab at the top of the dialog.

4. In the Raster Options, click the Fit to Frame checkbox to activate 
it and then click OK.

The file hyperspectral.img displays in the Viewer.

5. In the Viewer menu bar, select Raster -> Profile Tools.

The Select Profile Tool dialog opens.

6. Accept the Spectral default and click OK in the Select Profile Tool 
dialog.

The Spectral Profile viewer opens.
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7. In the Spectral Profile viewer, click the Create icon  and then 
select a pixel of interest by clicking it in the Viewer image.

The data for the selected pixel are displayed in the Spectral Profile 
viewer.

NOTE: The pixel can be moved around the displayed image by 
dragging it.

Analyze Data

1. In the Spectral Profile viewer menu bar, select Edit -> Chart 
Options.

The Chart Options dialog opens.

2. In the Chart Options dialog, click the Y Axis tab at the top of the 
dialog.

3. Set Min to 20 and Max to 180 to control the numerical range.

Click here to 
create a new 
profile point in 
the Viewer 

Click this tab to 
view the options 
for the Y axis 
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4. Click Apply and then Close in the Chart Options dialog.

The selected range is shown in detail in the Spectral Profile viewer.

5. In the Spectral Profile viewer menu bar, select Edit -> Plot Stats.

The Spectral Statistics dialog opens.

6. In the Spectral Statistics dialog, change the Window Size to 7.

7. Select Mean and click Apply. 

The mean (within the selected window) of Profile 1 is depicted on the 
graph.

8. Click Cancel in the Spectral Statistics dialog.

9. Select File -> Close from the Spectral Profile viewer.

Display Spatial Profile The Spatial Profile display function allows the analyst to view the 
reflectance(s) of the pixels along a user-defined polyline. The display 
can be viewed in either two-dimensional (one band) or perspective 
three-dimensional (multiple bands) mode. To use this tool, follow the 
steps below.

The file hyperspectral.img should be displayed in a Viewer, with 
the Fit to Frame checkbox activated. 

1. In the Viewer menu bar, select Raster -> Profile Tools.

The Select Profile Tool dialog opens.

Adjust the 
window size here 

Click to 
select Mean 

Wavelength Axis
Data tapes containing hyperspectral imagery commonly designate 
the bands as a simple numerical sequence. When plotted using the 
profile tools, this yields an x-axis labeled as 1, 2, 3, 4, etc. 
Elsewhere on the tape or in the accompanying documentation is a 
file which lists the center frequency and width of each band. This 
information should be linked to the image intensity values for 
accurate analysis or comparison to other spectra, such as the 
Spectra Libraries. 

To do this, the band position information must be entered into a 
linkable format, which is an .saf file. An example of this format can 
be seen by using a texteditor or vi command to view one of the 
.saf files in <IMAGINE_HOME>/etc. Once this file is created, it can 
be linked with the Spectral Profile by using the Edit -> Use 
Sensor Attributes option.
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2. Click the Spatial button in the Select Profile Tool dialog and then 
click OK.

The Spatial Profile viewer opens.

3. Click the Polyline icon  in the Spatial Profile viewer toolbar and 
then draw a polyline on the image in the Viewer. Click to set vertices 
and middle-click to set an endpoint.

The spatial profile 

in the Spatial Profile viewer.

Analyze Data

1. Select Edit -> Plot Layers from the Spatial Profile viewer menu bar.

The Band Combinations dialog opens.

2. Add Layers 2 and 3 to the Layers to Plot column by individually 
selecting them under Layer and clicking the Add Selected Layer icon 

. 

3. Click Apply and then Close in the Band Combinations dialog.

Layers 1, 2, and 3 are plotted in the Spatial Profile viewer.

NOTE: Moving the cursor around in the Spatial Profile viewer gives 
you the pixel values for the x and y coordinates of the layers.

Click here and 
then here 
to add the layer 
to the plot 
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4. In the Plot Layer box to the right of the toolbar in the Spatial Profile 
viewer, click the up arrow to view layers 4 and 5. 

5. Select Edit -> Plot Layers from the Spatial Profile viewer to again 
bring up the Band Combinations dialog.

6. In the Band Combinations dialog, click the Add All icon  .

7. Click Apply and Close.

As in the Spectral Profile viewer, you can select Edit -> Chart 
Options to optimize the display.

8. Select File -> Close from the Spatial Profile viewer menu bar.

View Surface Profile The Surface Profile can be used to view any layer (band) or subset 
in the data cube as a relief surface. To use this tool, follow the steps 
below.

The file hyperspectral.img should be displayed in a Viewer with the 
Fit to Frame checkbox activated. 

1. In the Viewer menu bar, select Raster -> Profile Tools.

The Select Profile Tool dialog opens.

2. In the Select Profile Tool dialog, click the Surface button and then 
click OK.

The Surface Profile viewer opens.

3. Click the Rectangle icon  in the Surface Profile viewer and then 
select an AOI in the Viewer by dragging to create a box around it.

When the mouse button is released, the surface profile for the 
selected area displays in the Surface Profile viewer. As with all of the 
profile tools, selecting Edit -> Chart Options allows you to optimize 
the display.
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Analyze Data

It may be desirable to overlay a thematic layer onto this surface. For 
example, a vegetation map could be overlaid onto a DEM surface, or 
an iron oxide map (Landsat TM3/TM1) onto a kaolinite peak (1.40 
µm) layer. In this example, you overlay a true color image.

1. In the Surface Profile viewer, select Edit -> Overlay True Color.

The Overlay TrueColor on Surface dialog opens.

2. In the Overlay TrueColor on Surface dialog, select 
hyperspectral.img under Overlay File.

3. Under Band Combination, enter 55 for Red, 34 for Green, and 2 
for Blue.

4. Click OK in the Overlay TrueColor on Surface dialog.

5. When you are finished analyzing the data, select File -> Close from 
the Spatial Profile viewer menu bar.

For more information on Hyperspectral Image Processing or the 
Hyperspectral Profile Tools, see the chapter Enhancement in the 
ERDAS Field Guide.

Image Drape It is possible to access the Image Drape utility either through the 
Tools menu in the ERDAS IMAGINE menu bar or through the Viewer. 
Here, you access the Image Drape utility via the Viewer.

ERDAS IMAGINE should be running and a Viewer should be open.

1. Click the Open icon  in the Viewer toolbar.

The Select Layer To Add dialog opens.

2. In the Select Layer To Add dialog under File name, select the file 
eldodem.img.

Click to select 
the file Change the 

RGB band 
combinations 
here 
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3. Click OK in the Select Layer To Add dialog.

The file eldodem.img displays in the Viewer.

4. Click the Open icon again in the Viewer toolbar.

The Select Layer To Add dialog reopens.

5. In the Select Layer To Add dialog under File name, select the file 
eldoatm.img.

6. Click the Raster Options tab at the top of the dialog.

7. In the Raster Options, click the Clear Display checkbox to turn it off. 
This allows eldoatm.img to display on top of eldodem.img.

8. Click OK in the Select Layer To Add dialog.

Now, both eldodem.img and eldoatm.img are displayed in the 
same Viewer, with the eldoatm.img layer on top.

9. Select Utility -> Image Drape from the Viewer menu bar.

An Image Drape viewer displays, with the overlapping images in it. 

Change Options

1. Select Utility -> Options from the Image Drape viewer menu bar.

The Options dialog opens. 

Click this icon to 
open a file in the 
Image Drape viewer 

Click this icon to 
open the Observer 
Positioning tool 

Click this icon to 
open the Sun 
Positioning tool 
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2. Click the Background tab in the Options dialog.

3. In the Background options, hold on the dropdown list next to 
Background Color and select Gold.

4. Click Apply in the Options dialog.

The background of the image in the Image Drape viewer is now gold.

5. Click Close in the Options dialog.

Change Sun Position

1. Select View -> Sun Positioning from the Image Drape viewer 
menu bar.

The Sun Positioning dialog opens. 

2. In the Sun Positioning dialog, drag the dot to another position on the 
target. The center of the target indicates the sun position at high 
noon.

3. Click Apply and then Close in the Sun Positioning dialog.

Note how the shadows across the image change to reflect the 
different sun position you have selected.

Dump Contents to Viewer

1. Select Utility -> Dump Contents to Viewer from the Image Drape 
viewer menu bar.

A second Viewer opens, displaying another view of the image in the 
Image Drape viewer.

Click this tab to edit
background options

Click to apply your 
changes and close this
dialog

Click to apply no changes
and close this dialog

Drag this dot to
change the position
of the sun

Click here to apply
your changes
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2. Select File -> Close in the first Viewer to clear it from the screen.

3. Select View -> Link/Unlink with Viewer from the Image Drape 
viewer menu bar.

An instructions box opens, directing you to click in the Viewer to 
which you want the Image Drape viewer to be linked.

4. Click in the Viewer you just created.

The viewers are now linked and a Positioning tool displays in the 
Viewer. 

NOTE: The bounding box in the Viewer image pictured above is for 
visual purposes only, and does not actually appear in the Viewer 
window.

Start Eye/Target

1. To make the Positioning tool easier to see in the Viewer, select 
Utility -> Selector Properties from the Viewer menu bar.

The Eye/Target Edit dialog opens. 

2. In the Eye/Target Edit dialog, hold on the Selector Color dropdown 
list and select a color that displays well in the Viewer image (for 
example, Yellow).

The point of 
observation (“target”) 

Positioning tool 

The observer’s point- 
of-view (“eye”) 

Hold on this dropdown 
list to change the 
selector color 
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3. Click OK in the Eye/Target Edit dialog.

The dialog closes and the color of the Positioning tool is updated to 
the designated color.

Manipulate the Observer 
and Field of View

You can manipulate the observer and the observer’s field of view in 
several ways. See step 1 through step 3 below to learn how to obtain 
different views using the Positioning tool and the Position Parameters 
dialog.

Use the Positioning Tool

1. Click the Observer Positioning icon  in the Image Drape viewer 
toolbar. 

The Position Parameters dialog opens. 

2. Drag on the Eye marker of the Positioning tool to change the 
observer’s point of view in the Image Drape viewer.

The data in the Position Parameters dialog updates to reflect the 
changes in the observer’s position. The view in the Image Drape 
viewer is also updated.

If the image in the Image Drape viewer does not completely 
refresh when the mouse button is released, click the Update icon 

 .

3. Next, drag on the Target marker of the Positioning tool to change 
the point of observation in the Image Drape viewer.

The data in the Position Parameters dialog updates to reflect the 
changes in the point of observation. The view in the Image Drape 
viewer is also updated.

4. Change the position of both the observer and the target at once by 
dragging on the line that connects them in the Viewer.

The data in the Position Parameters dialog and the Image Drape 
viewer is updated.

5. In the Image Drape viewer, click the Goto icon  to return to the 
original position of the observer and the target. 

Control ground 
level positioning 
here 

Control sea 
level positioning 
here

Manipulate the 
Field of View here 
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The image and the Positioning tool in the Viewer are updated to their 
original position. The Position Parameters dialog is also updated.

Use the Position Parameters Dialog

1. In the Position Parameters dialog, change the FOV to 90 and the 
Roll to 45, then click Apply.

The image in the Image Drape viewer is updated to reflect this 
change.

2. In the Position Parameters dialog under Observer Position, enter 
3000 in the AGL (Above Ground Level) number field.

3. Click Apply and then Close in the Position Parameters dialog.

GLT Viewer The Geospatial Light Table is the optional Viewer available with 
IMAGINE. The GLT Viewer has a Geospatial Tools palette that can be 
displayed and hidden as needed. The Geospatial Tools palette aids 
the visual analyst by providing multiple viewing windows and placing 
at the fingertips many of the most frequently used geospatial tools. 
The Geospatial Tools palette also provides enhanced functionality in 
the status bar below the view panes.
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Geospatial Tools Palette

Display Function This group sets the number of viewing panes in the Viewer. 

Display the file XS_truecolor_sub.img in a Viewer.

1. Click the Two Viewer icon  under the Display option to bring up 
a second Viewer.

2. Hold the left mouse button to drag and drop the top layer in the 
second pane.

3. Hold the right mouse button and select Fit Image to Window.

The two Viewers display the image.

Geospatial Tools Palette
The Geospatial Tools Palette consists of six Functional groups:

• Display—The four Layout Control icons in this functional group allow 
you to set the number of viewing panes in the viewer.

• Enhance—This functional group provides access to brightness, 
contrast, and sharpness adjustments.

• Zoom/Rotate—This functional group consists of a zoom control, a 
rotation control, and a scale tool.

• Roam—This group consists of a roaming speed control, autoroaming 
controls, and the snail trail recorder.

• General—This palette of tools provides fast access to many tools that 
are also available through the menus. In addition, there are several 
tools that are specific to geospatial light table use.

• Spectral—The Spectral Selector allows you to select from a list of 
named band combinations that are applicable to a specific sensor. The 
Sensor List is built dynamically from installed sensor attribute files 
(.saf) based upon the number of data bands in the input image.
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Dynamic Range 
Adjustment

This feature ensures the brightness and contrast is automatically 
adjusted to optimum as you roam the image. During autoroaming, 
however, the adjustment is not made until roaming is paused.

1. In the first Viewer, navigate to the urban area of the image.

2. Click the Dynamic Range Adjustment icon  to enhance and 
brighten features in the image. 

The image displayed with the dynamic range adjustment turned on.
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The dynamic range adjustment function is most useful with 
larger images to enhance features that might appear dark or 
washed out. This feature adjusts your range as you move 
around the image and locate details you might otherwise miss. 
The dynamic range adjustment freeze gives the added 
advantage of freezing a particular section and allowing you to 
continue roaming as you adjust new areas to the dynamic range 
adjustment option. This feature overrides any other contrast or 
brightness settings.

3. Click the Horizontal Path icon  to roam using the left to right scan 
pattern.

4. Click the Start icon  to begin the roam pattern. 

Turning on the Dynamic Range Adjustment function slows down 
the roaming pattern. To resume the speed, turn off the feature.

While roaming, if you observe an area you want to freeze with a 
particular contrast and brightness setting, use the Dynamic Range 
Adjustment Freeze. This allows you to lock in the settings used at 
that moment. 

5. Click the Dynamic Range Adjustment Freeze button to freeze any 
areas of interest, then continue roaming. Once you are satisfied with 
the results you may turn off the Dynamic Range Adjustment buttons.
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Digitizing a Roam Path Digitizing a roam path on the image that the GLT automatically 
roams can be used to follow features like roads and rivers.

1. In the first viewer, click the Resize Image to Viewer Size icon  on 
the GLT toolbar. 

2. Click the Follow User-Defined Path icon  in the Roam section of 
the GLT toolbar, the AOI Tools palette opens. 

3. Click the polyline tool  on the AOI Tools palette. 

4. Digitize each vertex of the custom roam path in the active view pane. 
Double-click to place the last vertex (the end point).

The digitized image displays.

Roaming Technique

1. Click the Start  / Pause  Roam icon. Roaming begins at the 
first digitized point of the first polyline or where it left off when you 
clicked the pause icon. 

2. Click the Stop Roam icon  .

3. Click the Roaming Preferences icon  , the Roaming Properties 
dialog opens. 

4. Change the Roam Speed to 2.
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5. Click OK to Close the Roaming Properties dialog.

6. Click the Go to Start icon  and click Start again to roam. 

Use the AOI Tool palette for other roaming techniques that can 
be defined. Build a Multiple Point Auto Roam with the point tool, 
Confine Auto roam to a User-Defined Rectangle/Square with the 
rectangle tool, or Confine Auto roam to a User-Defined 
ellipse/circle with the ellipse tool. Once these options are 
chosen, start roaming using the roaming techniques above.

Create a Snail Trail The Snail Trail is an annotation layer indicating areas of the image 
over which you have roamed. Only one snail trail may be open at any 
time. When roaming, the area displayed in the main view pane is 
represented as a trail of contrasting color over a color block that 
represents the full extent of the image. The snail trail view pane may 
also contain any data that includes the extents of the image in the 
main view pane and that has the same projection (including the 
same image). To use the snail trail recorder, Viewer #1 must be 
populated with imagery.

The two Viewers should display the file XS_truecolor_sub.img.

1. Select the second Viewer to record the snail trail.

2. Click the Record Snail Trail icon  in the Roam section of the 
Geospatial Tool Palette to create a new snail trail. 

The Snail Trail Menu is added to the GLT Viewer.



GLT Viewer / 60ERDAS IMAGINE Tour Guides

3. Select Snail Trail -> Properties from the GLT Viewer menu.

The Snail Trail Properties menu opens.

4. Click the dropdown list and change the Seen Color to Red.

The current screen to file pixel ratio must be below the threshold 
set in the Snail Trail Properties dialog.

5. Click OK to close the Snail Trail Properties dialog.

6. Select the main view pane.

7. Click the Horizontal Path roaming technique.

8. Click Play to observe the path left in the snail trail pane (second 
Viewer).

9. Pause the path of the snail trail by clicking the Pause button. To start 
again, click the Play button.

The snail trail pauses in the second Viewer.
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10. Click the snail trail view pane to activate it.

11. Click the Save icon  to save the snail trail path.
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Image Catalog

Introduction In this tour guide, you can learn how to:

• set catalog preferences

• create an Image Catalog

• add information to a catalog

• perform queries

• view the information in a catalog

• modify the views/information

• save and restore a specific area of coverage

• archive data

• add custom maps

Approximate completion time for this tour guide is 15 minutes.

Set Catalog 
Preferences

ERDAS IMAGINE should be running. It is not necessary to have a 
Viewer open.

1. In the ERDAS IMAGINE menu bar, select Session -> Preferences.

The Preference Editor opens.

2. In the Preference Editor under the Category list, select Image 
Catalog.

The default preferences for the Image Catalog display.
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The following table lists and describes the various catalog 
preferences.

Click this
category

Table 6: Image Catalog Preferences

Preference Function

Catalog Directory The default directory that the catalog uses to save and open 
catalogs.

Default Catalog The name of the catalog that opens by default when the 
Image Catalog starts.

Canvas Backdrop The backdrop file (ArcInfo coverage) that displays when the 
Graphical Query viewer initially displays. This must be one of 
the files named in catalog.cov.

Archive Media The name of the default media used by the archive function of 
the catalog. 

Water Color The default color used for all of the area outside of the 
polygons in a coverage, which is assumed to be water. 

Land Color The default color used to fill the polygons in an area coverage.

Border Color The default color used to draw the border around each of the 
polygons in an area coverage.

Line Style The default style used for lines in a line coverage.

Point Symbol The default symbol used for points in a point coverage.

Symbol Color The default color used for point symbols in a point coverage.

Symbol Size The default size of point symbols (in points) in a point 
coverage.

Footprint Color The default color used for image footprints.

Footprint Selected 
Color

The default color used for selected image footprints.

Footprint Fill Style The default style used to fill image footprints.

Show Map Grid Used to control the display of the map grid at startup.

Grid Color The default color used for the Lat/Lon grid.
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3. Make any changes you wish to the catalog preferences by entering 
the new information in the fields and pressing Enter on your 
keyboard.

4. To save your changes and accept them as the new defaults, click 
User Save.

5. Click Close on the Preference Editor dialog to close the Preference 
Editor.

Create an Image 
Catalog

ERDAS IMAGINE should be running.

1. Click the Catalog icon  on the ERDAS IMAGINE icon panel.

The default Image Catalog opens.

Show Grid Labels Used to control the display of the text grid labels.

Grid Label Color The default color used for the map grid text labels.

Level of Detail Maximum level of detail to use when displaying maps (for 
example, local, global).

Show Map 
Outlines

Enable to display the map outlines at startup.

Map Outline Color The default color used to display the map outlines.

Map Outline Style The default line style used for the map outlines (for example, 
solid, dashed).

Restore Directory The default destination directory for restoring an image.

Table 6: Image Catalog Preferences (Continued)
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NOTE: You can specify a default catalog via Session -> 
Preferences. More information on how to do this is located in “Set 
Catalog Preferences”.

For the following example, you use the default catalog which is 
distributed with ERDAS IMAGINE.

Add Information

1. In the Image Catalog dialog, select Edit -> Catalog Image, or click 

the Add Image icon  on the Image Catalog toolbar.

The Catalog Image dialog opens.

2. In the Catalog Image dialog file list, scroll down the list and select 
30meter.img.

3. Click Add, and then Close in the Catalog Image dialog.

The file 30meter.img is the last file recorded in the Image Catalog.

Click here to 
add the selected 
file to the Image 
Catalog Click here to select 

this file to add to the 
Image Catalog 

Scroll down to
30meter.img
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NOTE: If you were to select 30meter.img and then select Add All, 
all files with an .img extension would be added to the Image Catalog.

Perform Graphical 
Queries

First, select an area of the map in which you want to query the 
images, and then run the query.

The Image Catalog should be open and it should contain the images 
in the <IMAGINE_HOME>/examples directory.

Select Area

1. Select View -> Graphical Query Viewer, or click the Visual Query 

icon  on the Image Catalog toolbar.

The Graphical Query dialog opens.

The file is added
to the bottom of
the list of files
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2. Click the Select Area for Zooming icon  on the Graphical Query 
toolbar.

The pointer becomes a crosshair.

3. With the crosshair, draw a bounding box that covers the entire 
continental United States.

When the mouse button is released, the United States is magnified 
in the Graphical Query viewer. Note that more detail is presented as 
the backdrop is zoomed.

Run Query

1. Click the Query icon  on the Graphical Query toolbar.

The files of images located within the designated query area (the 
continental US) are highlighted in yellow in the Image Catalog. Tiny 
rectangles on the map in the Graphical Query viewer mark the 
location of these images.
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2. Click the Zoom In icon  on the Graphical Query toolbar.

3. Place the Zoom In tool over one of the black dots in the map in the 
Graphical Query view and click until the dot is magnified to a yellow 
box. The image in the view shifts depending on where you click.

4. Click the Select icon  on the Graphical Query toolbar.

5. With the Select tool, click the yellow box you just magnified. Note 
that all of the other images located in the Graphical Query viewer are 
characterized by red boxes.

The file name corresponding to the point you selected in the 
Graphical Query view highlights in the Image Catalog.

Highlighted
records are
within the 
continental
US, which you
zoomed to in
the Graphical
Query view

Yellow means
the area is
selected

Red means that
an area is not
selected
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6. Click the Display Single Viewer icon  on the Image Catalog 
toolbar.

The selected image, in this example lanier.img, displays in a 
Viewer.

7. Repeat step 2 through step 6, but select a red box on the map to 
display another image. Note that when the box is selected, it turns 
yellow.

This file
corresponds
to the point 
you clicked in
the Graphical
Query view

This is the file
you selected
in the Graphical
Query view,
which was also
highlighted in
the Image 
Catalog
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If necessary, click the Roam icon  on the Graphical Query toolbar, 
and then drag the image in the Graphical Query view to change the 
position of the image in the view. (If you reset the display, be 
prepared to start back at step 2.)

NOTE: Magnified boxes that are deselected are red in color; selected 
boxes are yellow.

8. In the Image Catalog toolbar, click the Display Another Viewer icon 

 to display the image you selected in step 7 in a second Viewer.

View Information

1. To view all of the information for the image in your first Viewer in one 
convenient form, highlight that file in the Image Catalog by clicking 
on the Record number of that file.

The file is highlighted in yellow.

2. In the Image Catalog dialog, select View -> Form View, or click the 

Catalog Default icon  .

The Form View dialog opens, listing the characteristics of the file you 
selected.

In this example,
the second point
selected 
corresponds to
the file named
panAtlanta.img



Perform Graphical Queries / 72ERDAS IMAGINE Tour Guides

3. In the bottom left corner of the Form View dialog, there is an Up 

Arrow icon and a Down Arrow icon  . Click twice on the Down 
Arrow icon, noting that the information in the Form View dialog 
corresponds with the highlighted file in the Image Catalog.

4. Click Close to close the Form View dialog.

5. Another way to view information about individual files is to use the 
ImageInfo dialog. Select View -> Image Info from the Image 

Catalog, or click the ImageInfo icon  .

The ImageInfo dialog opens.

The image is
identified here

You can scroll
through all of
the images in 
the catalog
using these
arrows
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6. Select File -> Close on the ImageInfo dialog.

Modify Views

1. In the Graphical Query viewer, select File -> Area Definition.

The Area Definition dialog opens.

The Area Definition dialog lets you store the extent of particular 
areas of interest for quick retrieval. For example, if your study area 
covers the states of North and South Dakota, you could save a view 
of just that area. You can either enter the coordinates manually into 
the Area Definition dialog, or you can select an area by drawing a box 
in the Graphical Query view.

The upper-left and lower-right coordinates are the coordinates of the 
area currently viewed in the Graphical Query view. You can save 
these coordinates to a bounding box file (.bbox).

2. Click Save in the Area Definition dialog.

The Defined Areas file selector dialog opens.

All of this 
information
corresponds to
the image that
is highlighted
in the Image
Catalog dialog

Enter the coordinates
manually here 

or 

Follow these 
instructions here 
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3. In the Defined Areas dialog under File name, enter the name usa 
in the directory of your choice, then press Enter on your keyboard. 
Then click OK. 

4. Click Cancel in the Area Definition dialog to close it.

5. In the Graphical Query view, click the Roam icon  and then drag 
on the image to view a different area.

6. In order to recall the area you saved as usa.bbox, select File -> 
Area Definition in the Graphical Query view, and then click Open 
in the Area Definition dialog.

The Defined Areas dialog opens.

7. Navigate to the location where you saved the file in the Defined 
Areas file selector dialog and select usa.bbox.

8. Click OK in the Defined Areas file selector dialog.

The Defined Areas dialog closes and the coordinates in the Area 
Definition dialog change.

9. Click Apply and then Cancel in the Area Definition dialog.

The Graphical Query view redisplays the view you saved as 
usa.bbox.

Enter the
directory here
and file 
name here
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Archive Data The following steps detail how data are archived.

You must have a non-rewinding tape device already configured 
in order to archive data. 

1. Select the image in the Viewer by clicking on its Record number in 
the Image Catalog CellArray.

The file is highlighted in yellow.

2. In the Image Catalog, select File -> Archive, or click the Archive 

icon  in the toolbar.

The Archive dialog opens.
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Follow step 3 through step 6 for initial setup only.

3. In the Archive dialog, click Log New Tape in Database to set up 
the tape to be used.

4. Click the Media Type dropdown list and select one of the options 
such as tape_8mm or tape_exabyte.

5. Enter the Location of the tape. This is simply a note to yourself, 
indicating where you store the tape or which tape you are using (for 
example, tape #16).

6. Click Log Tape in Database to add this tape to the list of available 
tapes. A message displays with the identification number that should 
be placed on the tape for later retrieval. The new tape number 
displays in the scrolling list of available tapes.

7. Click to select the tape from the list.

8. Click Device to select the actual tape device to which you archive. A 
list of configured tape devices displays.

9. In the Select Configured Devices dialog, click the device to which you 
archive. It must be configured as a non-rewinding device.

10. Click Select to select the device.

Click here to
set up the tape

Click here to
select the
media type

Enter the
location of 
the tape here
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11. In the Archive dialog, click Archive to archive the selected image.

12. You are instructed to place the selected tape in the selected device. 
Click Continue when the tape is loaded. You are informed when the 
process is complete.

NOTE: For subsequent images, omit step 3 through step 6.
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Map Composer

Introduction The ERDAS IMAGINE Map Composer is an editor for creating 
cartographic-quality maps and presentation graphics. Maps can 
include single or multiple continuous raster layers, thematic (GIS) 
layers, vector layers, and annotation layers. 

Map Composer’s extensive annotation capabilities allow you to 
automatically generate text, legends, scale bars, grid lines, tick 
marks, borders, symbols, and more. You can select from over 16 
million colors, multiple line styles, and over 60 text fonts.

Approximate completion time for this tour guide is 40 minutes.

Create a Map In this tutorial, you create a map using the file 
modeler_output.img in the <IMAGINE_HOME>/examples 
directory. This file contains SPOT panchromatic data overlaid with an 
environmental sensitivity analysis file.

In creating this map, you use these basic steps:

• plan the map

• start Map Composer

• prepare the data layers

• draw the map frame

• add a neatline and tick marks

• make scale bars

• create a legend

• add a map title

• place a north arrow

• write descriptive text

• print the map

This tour guide also contains information about editing map frames, 
deleting map frames, and editing map compositions.
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Start Map Composer You must have ERDAS IMAGINE running.

1. Start Map Composer by clicking the Composer icon  on the ERDAS 
IMAGINE icon panel.

The Map Composer menu displays.

2. In the Map Composer menu, select New Map Composition to 
create a new map composition.

You can also create a new composition by selecting File -> New 
-> Composition from the Viewer menu bar.

The New Map Composition dialog opens.

3. In the New Map Composition dialog under New Name, type a unique 
name for your map (such as tour.map). Be sure that you have write 
permission in the directory where you are creating the new map.

4. Drag across the value in Map Width to select it.

Click here to
create a new map

Specify map 

Click here

Type a name

size here
in meters
or in inches

for your map
here

 to make
a new map
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5. Type 7.5 and then press the Enter key on your keyboard.

6. Drag across the value in Map Height to select it.

7. Type 10.0 and then press the Enter key on your keyboard.

Most printers have a small margin on all sides of a sheet that are 
unprintable. Therefore, even though you output your map to 8.5” × 
11.0” paper, you must specify a smaller size here for the actual live 
area of the map. This ensures that no part of the map occupies that 
unprintable area, and it leaves a margin around the edge of the 
composition.

8. Accept the Display Scale 1 of 1.00 and inches for the Units.

9. Click OK in the New Map Composition dialog.

A blank Map Composer viewer displays along with the Annotation 
tool palette. 

NOTE: The tool palette that displays on your screen may look 
different from the following one, depending upon your ERDAS 
IMAGINE preferences. 

10. With your cursor in the Map Composer viewer, right-hold Fit Map To 
Window from the Quick View menu so that you can see the entire 
map composition page.

Menu bar 

Toolbar 

Compose 
map here 

Annotation tool palette

Title bar 

Status bar 
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Prepare the Data 
Layers

You must determine what data layer(s) you are going to use in your 
composition and then display the layer(s) in a Viewer window. In this 
exercise, you use modeler_output.img from the 
<IMAGINE_HOME>/examples directory. 

ERDAS IMAGINE must be running, and you must have a Viewer and 
a Map Composer viewer open.

1. In the Viewer, click the Open icon  on the toolbar or select File -
> Open -> Raster Layer from the menu bar. 

The Select Layer To Add dialog opens.

2. In the Select Layer To Add dialog under Filename, click 
modeler_output.img. Be sure that the source directory is 
<IMAGINE_HOME/examples> (the default).

3. Click the Raster Options tab and then select the Fit to Frame 
option so that you can see the entire file and can more easily select 
the area to include in the map. 

4. Click OK in the Select Layer To Add dialog.

Draw the Map 
Frame

You can now begin creating your map composition. The first step in 
creating your map is to define the map frame. 

Second, click here to
display the Raster Options

A preview
of the image
displays
here

The file type
should be
.img

First, click 
here to 
select the file
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A Viewer must be open, with the data layer you want to use in your 
composition displayed in it. You must also have an open Map 
Composer viewer.

1. From the Annotation tool palette, click the Map Frame icon  to 
draw the boundary of the map frame.

2. Near the top of the Map Composer viewer, Shift-drag your cursor 
downward at an angle to draw the map frame. You position and size 
the map frame later. 

NOTE: Pressing the Shift key while drawing the map frame allows 
you to draw a perfect square.

When the mouse is released, the Map Frame Data Source dialog 
opens.

What is a Map Frame?
A map frame is drawn, resized, and selected like other annotation 
elements, but a map frame works like a Viewer. Map frames can 
contain raster, vector, and annotation layers that you want to 
include in your composition. 

Although map frames display the layer(s) you want to include in a 
map composition, the data in a map frame are not copied, but are 
referenced. When you create a map frame, simply click in the 
Viewer where the layers you want to use in the map are displayed.

Map Frame Dimensions
There are three ways to select the dimensions of a map frame. You 
use different options depending on the image area you want in the 
final map composition. The dimensions of a map frame are 
expressed in the following ways:

• The map area is the area in the Viewer that displays in the map 
frame in the map composition. It corresponds to the 
dimensions of the area on the ground in map units.

• The frame area is the area used by the map frame in the map 
composition. It is the area on the page occupied by a particular 
image. It is defined in page units.

• The scale (like the scale used in geometric correction) is the 
ratio of distance in the map frame to the distance that is 
represented on the ground. For example, you can define an 
area showing a scale of 1:24,000.
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3. In the Map Frame Data Source dialog, click the Viewer button to 
select the source image from the Viewer.

The Create Frame Instructions dialog displays.

4. Click anywhere in the image in the Viewer to reference the displayed 
image to the new map frame.

The Map Frame dialog opens, giving you options for sizing, scaling, 
and positioning the map frame. 

A cursor box also displays in the Viewer. This cursor box allows you 
to select the area you want to use in the map composition.

Click here to enter
map frame height
and width in inches

Click here to enter
map frame X
and Y coordinates

Click here to adjust
the position of the 

Click here to enter
the scale of the data 
in the map frame

map frame

Click here to adjust
the size of the map
frame
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Adjust the Size of the Map 
Frame

1. In the Map Frame dialog, click the Change Map and Frame Area 
(Maintain Scale) option so that you can accurately size the map 
frame in the Map Composer viewer window.

2. In the Map Frame dialog, double-click the value in Frame Width to 
select it.

3. Type 5.5 for the width of the map frame and then press the Enter 
key on your keyboard.

Moving and Adjusting the Map Frame
You can move the map frame in the Map Composer viewer window 
and the cursor box in the Viewer by dragging and resizing them 
with the mouse, or you can move one or both boxes by 
manipulating the information in the Map Frame dialog. You can 
also rotate the box in the Viewer if you want to change the 
orientation. 

Next, you move the map frame by setting parameters in the Map 
Frame dialog. Then you can select the image area you like by using 
the mouse to move the cursor box in the Viewer.

The three buttons at the top of the Map Frame dialog allow you to 
adjust two parameters while keeping the other frozen. Start by 
selecting the size of the map frame (Change Scale and Frame 
Area), and then freeze that option to select the scale and position 
of the map frame (Change Scale and Map Area).

Your map frame is positioned according to the following 
illustration:

NOTE: The origin of the Map Composer viewer is the lower left 
corner.

5.5” x 5.5”

10”9.0” (Y) 

1.0” (X)

3.5”

1
.0

”
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4. Double-click the value in the frame Height (to the right of Frame 
Width) to select it.

5. Type 5.5 for the height of the map frame and then press the Enter 
key on your keyboard.

Adjust the Position of the 
Map Frame

1. In the Map Frame dialog, click the Change Scale and Map Area 
(Maintain Frame Area) option so that you can select a map area 
in the Viewer without losing the dimensions of the map frame in the 
Map Composer viewer.

2. In the Map Frame dialog, under Upper Left Frame Coordinates, 
change the Y value to 9.0. Press Enter on your keyboard.

3. Double-click the value in Scale 1 to select it. Type 50000. Press 
Enter on your keyboard.

4. With your cursor inside the cursor box in the Viewer, drag the cursor 
box to the area you want to display in the map composition.

5. When the cursor box is positioned to your satisfaction, click OK in 
the Map Frame dialog to reference that portion of the image to the 
map composition.

The image area that you selected in the Viewer is now displayed in 
the map frame in the Map Composer viewer. 

6. To enlarge the image in the Map Composer viewer, drag on the 
corners of the Map Composer viewer to enlarge it, and the right-hold 
to select Fit Map To Window from the Quick View menu.
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7. You are now finished with the Viewer, so select File -> Close from 
the Viewer menu bar to close it.

Choose Your Path

• If you are satisfied with your map frame and the image area you 
have selected, proceed to “Add a Neatline and Tick Marks”.

• If you want to edit your map frame or change the image area you 
selected, proceed to “Edit the Map Frame”.

Edit the Map 
Frame

The Map Composer is very flexible in allowing you to place a map 
frame in a composition based on scale, image area, etc. Once you 
have placed a map frame in a composition, you can move it, change 
the size of it, and change the image area within it. 

If you want to change the image you are using, you must delete 
the map frame and redraw it or edit the .map file.

Choose Your Path • To edit the map frame, proceed with this section.

• To delete the map frame, proceed to “Delete the Map Frame”.
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• To edit the .map file, proceed to “Edit Composition Paths”.

1. To edit a map frame, click the Select Map Frame icon  in the 
Annotation tool palette.

2. Click in the map frame you want to edit to select it.

3. In the Map Composer viewer, select Annotation -> Element 
Properties or double-click in the map frame.

A new Viewer opens, with the image you are using displayed. A white 
cursor box indicates the area currently in the map frame. The Map 
Frame dialog also opens, displaying the settings you originally 
entered to position and size the map frame. 

4. Change the information in the Map Frame dialog and/or move the 
cursor box in the Viewer.

5. Click OK in the Map Frame dialog when you are satisfied with the 
map frame.

6. Select File -> Close from the Viewer menu bar.

Delete the Map 
Frame

If you want to delete the map frame altogether, follow the next 
series of steps.

Deleting a map frame cannot be undone.

You must have your map composition open.

1. In the Map Composer viewer menu bar, select View -> Arrange 
Layers.

The Arrange Layers dialog opens. 

Press the third mouse
button to delete
this map frame

Click here to delete
the map frame
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2. In the Arrange Layers dialog, move your pointer to the box titled 
MapFrame__modeler_output.img and right-hold to select 
Delete Layer from the Frame Options dropdown list. 

3. In the Arrange Layers dialog, click Apply to delete the map frame. 

4. Click Close in the Arrange Layers dialog.

You are now ready to redraw the map frame. Return to “Draw the 
Map Frame”.

Add a Neatline 
and Tick Marks

Now, add a neatline and labeled tick marks around the image in the 
map composition.

You must have a Map Composer viewer open containing a map frame 
referenced to a georeferenced image in order to generate 
georeferenced tick marks. The Annotation tool palette must also be 
open.

1. If you have not already done so, right-hold Fit Map To Window in 
the Map Composer viewer so that you can see the entire map 
composition page.

2. Click the Grid/Tick icon  on the Annotation tool palette.

3. Click the image inside the map frame on which you want to place the 
neatline and tick marks.

The Set Grid/Tick Info dialog opens.

Neatlines and Tick Marks

• A neatline is a rectangular border around a map frame.

• Tick marks are small lines along the edge of the map frame or 
neatline that indicate regular intervals of distance. Tick marks 
are usually labeled in meters, feet, or other units.

The Map Composer allows you to generate a neatline and labeled 
tick marks at the same time. A set of these elements for a map 
frame is actually a group of line and text elements that is 
automatically generated to your specifications. (You can also 
generate grid lines in the same step, but grid lines are not included 
in this map.)
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4. Accept the default of Neat line to put a neatline around the map and 
leave the Margin at 0 so that the neatline fits to the edge of the map 
frame.

5. In the Horizontal Axis options, drag across the Length Outside 
field to select it.

6. Type a tick length of 0.06. Press Enter on your keyboard.

Tick marks extend 0.06” outside of the map frame.

7. Drag across the Spacing field to select it.

8. Type 5000. Press Enter on your keyboard.

The Number of lines is about 4, indicating that there are 4 
horizontal tick marks (depending on the actual image area you 
selected).

9. Click the Copy to Vertical option to apply these settings to the 
vertical axis.

The same settings are applied to the vertical axis. 

10. Click the Vertical Axis tab to verify neatline and label information 
for the vertical axis.

11. Click Apply in the Set Grid/Tick Info dialog to place the neatline and 
tick marks on the map. 

12. If you are satisfied with the appearance of the neatline, click Close 
in the Set Grid/Tick Info dialog. Otherwise, you may make 
adjustments in the Set Grid/Tick Info dialog and click Redo to apply 
them. Your map should look similar to the following: 

Specify neatline 

Enter tick mark
information here
for the horizontal

Click here to 
copy horizontal 
tick information to
the vertical axis

axis

here
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Change Text/Line Styles The text and line styles used for neatlines, tick marks, and grid lines 
depend on the default settings in the Styles dialog. You can either 
set the styles before adding this annotation to your map, or you can 
change the styles once they are placed in the map. 

Next, set the line style to 1 point for the neatline and tick marks, and 
the text size to 10 points for the tick labels.

1. Select the group of ticks, tick labels, and the neatline by clicking on 
any of the number labels outside of the map frame. 

A selection box displays around the entire group.

2. From the Map Composer viewer menu bar, select Annotation -> 
Styles.

The Styles dialog opens.

Hold on this dropdown
list to select Other
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3. In the Styles dialog, hold on the dropdown list next to Line Style and 
select Other.

The Line Style Chooser dialog opens.

4. In the Line Style Chooser dialog next to Width, enter 1.00 to change 
the width in points.

5. Click Apply and then Close in the Line Style Chooser dialog.

The group redraws with the new line width.

6. In the Styles dialog, hold on the dropdown list next to Text Style 
and select Other.

The Text Style Chooser dialog opens.

7. In the Text Style Chooser dialog, verify that the Size is 10.00.

8. Click Apply and then Close in the Text Style Chooser dialog.

9. Deselect this annotation group by clicking anywhere in the map 
composition window outside of the selection box.

10. Click Close in the Styles dialog.

Change the 
line width 
here

Verify that the
text size is 10
points
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Make Scale Bars A scale bar indicates the scale of the image on the map. You can 
create one scale bar, or several, showing the scale in different units. 
A scale bar is actually a group of elements that is automatically 
generated to your specifications. 

In this section, place two scale bars in your map composition, 
showing scale in kilometers and miles. Then center them under the 
map frame. 

You can create scale bars only for map frames containing 
georeferenced data.

You must have a map composition open and it must contain 
georeferenced data. The Annotation tool palette must also be open.

1. To place scale bars, select the Scale Bar tool  from the Annotation 
tool palette.

2. Move the cursor into the Map Composer viewer and the cursor 
changes to the scale bar positioning cursor. 

3. Drag the mouse to draw a box under the right corner of the map 
frame in the Map Composer viewer, outlining the length and location 
of the scale bar(s).

You can change the size (length) and location later, if needed. 

When you release the mouse button, the Scale Bar Instructions 
dialog is activated. 

4. Follow the instructions in the Scale Bar Instructions dialog by clicking 
in the map frame to indicate that this is the image’s scale you are 
showing. 

The Scale Bar Properties dialog opens.
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5. In the Scale Bar Properties dialog under Units, select Kilometers 
and Miles by clicking the appropriate checkboxes.

6. Set the Maximum Length to 2.0 inches. Press Enter on your 
keyboard.

7. Click Apply in the Scale Bar Properties dialog. 

The scale bars display where you drew the box in the Map Composer 
viewer.

8. If you are satisfied with the appearance of the scale bar, click Close 
in the Scale Bar Properties dialog. Otherwise, you may make 
adjustments in the Scale Bar Properties dialog and click Redo to 
apply them.

Reposition Scale Bars

1. If you need to move the scale bars, first select them by clicking on 
one of the scale bars. To move, simply drag the selection box to the 
desired position. Remember to click outside the selection box to 
deselect the scale bars.

Create a Legend A legend is a key to the colors that are used in a map. Legends 
created in the Map Composer are actually groups of elements that 
are generated automatically to your specifications. 

Next, you create a legend explaining the four colors used in the 
overlaid environmental sensitivity analysis.

You must have a map composition open that contains thematic data. 
The Annotation tool palette should also be open.

1. Click the Legend icon  in the Annotation tool palette.

Click here to
center scale bars
on each other

Click here
and here
to select units

Select length of
scale bars here
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2. Move the cursor into the Map Composer viewer and the cursor 
changes to the legend positioning cursor. 

3. Click in the Map Composer viewer under the left side of the map 
frame to indicate the position of the upper left corner of the legend.

4. Click in the map frame to indicate that this is the image you want to 
use to create the legend. You are reminded to do this with the 
following dialog: 

The Legend Properties dialog opens, with the Basic properties 
displayed. The class names are listed under Legend Layout.

5. Under Legend Layout, click in the Class_Names field (entitled 
Class_5) of Row number 6.

6. Type SPOT Panchromatic. Press Enter on your keyboard.

7. Under Legend Layout, move your cursor to the Row column and 
click Row 2, then middle-click Row 6 to select the classes to display 
in the legend. 

Rows 2 and 6, and the rows in between them are highlighted in 
yellow. These are the only entries that are used in the legend.

8. In the Legend Properties dialog, click the Title tab at the top of the 
dialog.

Middle-click here
to select multiple
rows

Click here to 
change the class 
name to SPOT 

Click here for 
title properties 

Panchromatic
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9. Click the Title Alignment dropdown list and select Left-Justified.

10. In the Legend Properties dialog, click Apply.

The legend is drawn in the Map Composer viewer.

11. If you are not satisfied with the appearance of your legend, you may 
make adjustments in the Legend Properties dialog and click Apply 
or Redo to apply them. 

12. Click Close in the Legend Properties dialog when finished.

Reposition Legend

1. If you wish to reposition the legend, click any of the color patches or 
text strings in the legend to select it. To move, hold and drag the 
selection box to the desired position. Remember to click outside the 
selection box to deselect the legend.

Add a Map Title You must have a map composition and the Annotation tool palette 
open.

1. Click the Text icon  in the Annotation tool palette.

2. Move your cursor to the top of the map in the Map Composer viewer. 

The cursor becomes an I-beam , indicating that you are placing 
text.

3. Click where you want to place the text. The spot where you click is 
the bottom left corner of your text string.

The Annotation Text dialog opens.

Click this tab 
to view title 
properties 

Click this 
dropdown list to 
specify alignment 
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4. Move your pointer into the Enter Text String area in the Annotation 
Text dialog.

5. Type Environmental Sensitivity Analysis in the text field. 

6. Click OK in the Annotation Text dialog to place the text in the map 
composition.

The text string is now displayed in the map composition.

Change Text Style

1. Click the text string in the Map Composer viewer to select it.

2. From the Map Composer menu bar, select Annotation -> Styles.

The Styles dialog opens.

3. In the Styles dialog, hold on the dropdown list next to Text Style 
and select Other.

The Text Style Chooser dialog opens.

4. In the Text Style Chooser dialog, change the text Size to 20 points.

The preview window at the bottom right corner of the Text Style 
Chooser dialog illustrates the change in point size.

5. In the Text Style Chooser dialog, click the Custom tab.

6. In the scrolling list of font names, scroll to the top of the list and 
select Antique-Olive. The preview window at the bottom right 
corner of the dialog illustrates the selected font.

7. Click Apply in the Text Style Chooser dialog to change the selected 
text in the map composition.

8. Click Close in the Text Style Chooser dialog if you are satisfied with 
your changes.

Position Text

1. Double-click the text string you just edited. The Text Properties 
dialog opens, which allows you to edit, position, and align the text.

Type text 
string here
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2. In the Text Properties dialog, under Position, drag across the X 
value to select it.

3. Type 7.5/2 to calculate the center of the map. Press Enter. The 
value 3.75 is returned.

4. Change the Y value to 9.5 and press Enter on the keyboard.

5. Under Alignment, the Vertical default should be Bottom. Click the 
Center radio button under Horizontal. This indicates that position 
3.75 × 9.5 (that you just entered) is to be the bottom center of the 
text string.

6. Click Apply in the Text Properties dialog to center the text.

7. Click Close in the Text Properties dialog.

8. Deselect the text by clicking elsewhere in the background of the Map 
Composer viewer.

Place a North 
Arrow

Map Composer contains many symbols, including north arrows. 
These symbols are predrawn groups of elements that are stored in a 
library. Other symbols include school, church, marsh, landmark, and 
many others.

You must have a map composition and the Annotation tool palette 
open.

1. If the Styles dialog is not currently open, select Annotation -> 
Styles from the Map Composer menu bar.

The Styles dialog opens.

Enter text 
string X,Y 

Edit text 
string here

position here

Specify 
horizontal
and vertical
alignment
here
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2. In the Styles dialog, hold the dropdown list next to Symbol Style 
and select Other.

The Symbol Chooser dialog opens.

3. In the Symbol Chooser dialog, click the dropdown list and select 
North Arrows.

4. Select north arrow 4 from the North Arrows list.

The preview window at the bottom right corner of the Symbol 
Chooser dialog displays north arrow 4.

5. In the Symbol Chooser dialog, change the Size to 36 points (a size 
of 72 points is equal to one inch), and press Enter on the keyboard.

The preview window at the bottom right corner of the Symbol 
Chooser dialog displays the north arrow as it looks in the map 
composition. 

6. Click Apply and then Close in the Symbol Chooser dialog to make 
this the default symbol.

Note that the North Arrow is now the default symbol for Symbol 
Style in the Styles dialog.

7. Select the Symbol tool  from the Annotation tool palette.

8. In the Map Composer viewer, click under the map image, between 
the legend and the scale bars.

The north arrow is placed on your composition. You can reposition it 
by clicking on it to select it, then dragging it to the new position.

Hold on this
dropdown list to 
select Other 

Click here to 
select from a 
list of north
arrows

Select this 
north arrow 

Change the 
size here 
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You can also double-click a selected symbol to bring up the Symbol 
Properties dialog. Here, you can enter size and positioning 
measurements.

Write Descriptive 
Text

You can add descriptive text to your map to provide more 
information. The steps below include the instructions for adding two 
lines of text. However, you may add more if you like.

You must have a map composition and the Annotation tool palette 
open. 

1. If the Styles dialog is not currently open, select Annotation -> 
Styles from the Map Composer menu bar.

The Styles dialog opens.

2. In the Styles dialog, hold on the Text Style dropdown list and select 
Other.

The Text Style Chooser dialog opens.

3. In the Text Style Chooser dialog, change the text Size to 10 points. 

4. Click the Custom tab at the top of the Text Style Chooser dialog.

5. Check to be sure that Fill Style is set to solid black.

6. Click Apply to change the defaults.

7. Click Close in the Text Style Chooser dialog and in the Styles dialog.

Place Text

1. Click the Text icon  in the Annotation tool palette to use the text 
option to write descriptive text.

2. Click in the bottom right side of the map composition to indicate 
where you want to place the text.

The Annotation Text dialog opens.

3. Move your pointer into the Annotation Text dialog and type the 
following lines under Enter Text String. At the end of the first line, 
press Enter to left-align the text.

San Diego, California<return>
Environmental Sensitivity Analysis

You may click the ASCII File button to import the text from an 
existing ASCII text file.

4. Click OK in the Annotation Text dialog to place the text.

The Annotation Text dialog automatically closes.
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Save the Map 
Composition

1. Save your map composition by clicking the Save icon  in the Map 
Composer toolbar.

You can also save a composition by selecting File -> Save -> 
Map Composition from the Map Composer menu bar.

Print the Map 
Composition

ERDAS IMAGINE supports many output devices, including 
electrostatic plotters, continuous tone color printers, and PostScript 
devices. The printers you can use vary depending on your system 
configuration. These steps illustrate how to print to a PostScript 
printer.

1. Click the Composer icon from the ERDAS IMAGINE icon panel. 

The Map Composer menu displays.

2. Select Print Map Composition from the Map Composer menu, or 
select File -> Print from the Map Composer viewer menu bar.

The Compositions dialog opens.

3. Under Filename, click the name of the map you previously created.

4. Click OK in the Compositions dialog.

The Print Map Composition dialog opens.

Click the 
map name 

Click here to 
print the map 

here 
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5. Click the Print Destination dropdown list to select the printer you 
want to use.

If you do not have any output devices configured, you can output 
your map to an ERDAS IMAGINE image file (.img extension), and 
display it in a Viewer. When displaying maps converted to image 
format, assign bands 1, 2, 3 to R, G, B, respectively, in the Select 
Layer To Add dialog. This gives you an idea of what the map looks 
like if it is printed.

6. For this exercise, select EPS File in the Print Destination 
dropdown list to create an encapsulated PostScript file. This file can 
be sent to a PostScript printer using the standard file print command 
for your platform.

7. Click OK to print the map composition.

Edit Composition 
Paths

This section describes how to edit a map composition when you want 
to use another image in an existing map frame, or if the original 
image you used has been moved to another directory.

Select printer
destination here 

Click here to
print the map 
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You must have a saved map composition (.map file).

1. Click the Composer icon on the ERDAS IMAGINE icon panel.

The Map Composer menu displays.

2. In the Map Composer menu, select Edit Composition Paths.

The Map Path Editor displays.

3. In the Map Path Editor, select File -> Open or click the Open icon 

 . 

The Compositions dialog opens.

.map File
When you create a map or a graphic using Map Composer, a file is 
created with the .map extension. This file contains all of the 
specifications for your composition, such as size, position of the 
image, name of the image, annotation, etc. When you display or 
print a map composition, the software reads this .map file and 
recreates the map you originally composed. 

So, although you place an image in a composition, you are actually 
only referencing it. The name of the image you are using is listed 
in the .map file. Therefore, when that image is enhanced or 
changed in any way, the image in the map composition also 
changes because it is the same image.

It is necessary to edit a .map file if you wish to move an image that 
has been used in a map composition to a new directory. 

Editing Annotation
The annotation in a map composition can be edited interactively 
with the Annotation tools in the Annotation tool palette, using the 
same methods you used to place the annotation when you 
originally created the map. 

Click here to
edit the composition
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4. In the Compositions dialog under Filename, select the map file you 
wish to edit (for example, tour.map).

5. Click OK in the Compositions dialog.

The information for the selected map file displays in the Map Path 
Editor.

6. In the Map Path Editor under Frame, click 
MapFrame_modeler_output.img.

The type of Layer and Layer Information displays for the image. 
Note the path name for this image (located under Layer 
Information in the Name section).

7. Under Frame, click Composition.

8. Under Layer Information, type the new file name or directory 
name in the Name text entry field.

9. Click Apply in the Map Path Editor.

The changes you made are applied to the map composition.

After you make each individual edit to each frame or layer, you 
must click Apply.

10. If you do not want the changes you have just made, click the Reset 
button.

11. When you are satisfied with your changes, save the file by selecting 
File -> Save from the Map Path Editor menu bar.

For more information about cartography, see the chapter 
“Cartography” in the ERDAS Field Guide.
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Vector Querying and Editing

Introduction The IMAGINE Vector capabilities are designed to provide you with an 
integrated GIS package for raster and vector processing. The Vector 
tools in ERDAS IMAGINE are based on the ESRI data models, 
therefore ArcInfo vector coverages, ESRI shapefiles, and ESRI SDE 
vectors can be used in ERDAS IMAGINE with no conversion. 

This tour guide explains how to edit vector layers

The data used in this tour guide are in the 
<IMAGINE_HOME>/examples directory. Replace 
<IMAGINE_HOME> with the directory where ERDAS IMAGINE is 
installed on your system (for example, /usr/imagine/880).

A Digitizing Template is supplied in the information packet for 
ERDAS IMAGINE.

For more information about IMAGINE Vector, see  “IMAGINE 
Vector™” on page 697.

This tour guide covers the following topics:

• creating new vector layers

• changing vector properties

• creating attributes

Approximate completion time for this tour guide is 55 minutes.

Query Vector Data NOTE: The following section covers only the native Vector 
functionalities in ERDAS IMAGINE. If you have the IMAGINE Vector 
module, please see  “IMAGINE Vector™”.

Copy Vector Data Move to the directory where you want to create your workspace. 
Start ERDAS IMAGINE from this directory. Make sure this is a 
directory in which you have read/write permission.

1. Click the Vector icon on the ERDAS IMAGINE icon panel.
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The Vector Utilities menu opens.

The vector utilities in this menu should NOT be run on open 
vector layers. Close the layer you are using before running the 
utility, and do NOT attempt to open the layer until the process 
is complete.

2. In the Vector Utilities menu, select Copy Vector Layer.

The Copy Vector Layer dialog opens.

3. In the Copy Vector Layer dialog under Vector Layer to Copy, select 
the file named zone88.

Click here to
copy sample 
vector layer

Enter vector layer
to copy here

Enter new vector
layer name here

Click here to
start copy
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4. Under Output Vector Layer, enter zone88 in the directory of your 
choice. This should be the directory from which you started ERDAS 
IMAGINE.

5. Click OK in the Copy Vector Layer dialog.

A Job Status dialog displays to track the progress of the function. 
When the Copy ArcInfo coverage process is complete, the files are 
copied and you are ready to proceed with this tour guide.

6. Click Close in the Vector Utilities menu to dismiss it.

Display Vector Layers ERDAS IMAGINE should be running and a Viewer should be open. 
You must have completed the section, “Copy Vector Data”.

1. In the Viewer menu bar select File -> Open -> Vector Layer.

The Select Layer To Add dialog opens.

2. Under Filename select zone88 from the directory in which you 
saved it in the last section.

3. Click OK to display the layer in the Viewer.

The zone88 polygon layer displays in the Viewer, similar to the 
following example:

Click here to 
display the 
vector layer

Confirm that the 
directory listed 
here is the 
directory in 
which you 
copied zone88 

Enter vector 
layer to display
here.
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Change Vector Properties

1. Select Vector -> Viewing Properties from the Viewer menu bar.

The Properties dialog opens.

This dialog allows you to determine how and which vector features 
(lines, points, attributes, polygons, tics, and nodes) are displayed. 
You can also select the color to use for selected features.

In this example, the lines are currently displayed in the Viewer using 
the default styles shown in the Properties dialog.

Click the check
boxes to select
the features to
display. Use the
dropdown lists to 
modify properties.

Right-hold this
color patch to
select another
highlight color
for selected
features.

Click to use
attribute-based 
symbology.

Click to apply
new styles to 
the displayed 
vectors.
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2. In the Properties dialog, click to turn off the Arcs checkbox, then 
click to turn on Points.

3. Click Apply in the Properties dialog.

Now, points are displayed in the Viewer and lines are not. These are 
the polygon label points.

4. In the Properties dialog, click Points, Arcs, Polygon, and then 
Apply, so that lines and polygons are displayed and points are not.

5. Left-hold (for UNIX) or left-click (for PC) on the dropdown list next 
to Arcs and select Other to change the line style used.

The Line Style Chooser dialog opens.

6. In the Line Style Chooser dialog, change the Width to 2.00 points.

7. Left-hold (UNIX) or left-click (PC) on the Outer Color dropdown list 
and select Red.

8. Click Apply and then Close in the Line Style Chooser dialog.

The Line Style Chooser dialog closes. The new line style is reflected 
in the Properties dialog.

9. Click Apply in the Properties dialog to change the displayed vectors 
in the Viewer.

The vectors are redrawn in the Viewer as thick, red lines.

10. In the Properties dialog, right-hold on the popup list next to Arcs and 
select Other again. The Line Style Chooser dialog opens.

11. Change the Outer Color back to Black and the Width back to 
0.500 points, then click Apply.

12. Click Close in the Line Style Chooser dialog and then click Apply in 
the Properties dialog. The lines are redisplayed in black.

Change line
width here

Change line
color here

Current line
style is
shown here
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Display Attributes in the 
Viewer

1. In the Properties dialog, click the Points and Attribute checkboxes, 
then click the dropdown list under Attribute and select ZONING.

2. Click Apply in the Properties dialog.

The polygon label points and zone numbers display in the Viewer.

3. In the Properties dialog, click the Attribute checkbox to deselect it, 
and then click Apply.

4. Click Close in the Properties dialog.

5. An Attention dialog displays, asking if you want to save these styles 
in a symbology file. Click No.

The Properties dialog closes.

View Attributes

1. In the Viewer toolbar, click the Tools icon  (or select Vector -> 
Tools from the Viewer menu bar).

The Vector tool palette displays

NOTE: Depending on the package you have, your tool palette may 
include more icons than the one pictured above. If you have the 
IMAGINE Vector module, please see  “IMAGINE Vector™” for a 
description of the entire Vector tool palette.

2. With your cursor in the Viewer, click a polygon to select it (the Select 
tool is enabled by default in the Vector tool palette).

The selected polygon is highlighted in yellow.

3. Shift-click another polygon to add to the selection.

Now two polygons are highlighted in yellow.

Use the Select 
tool to select 
features 
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4. Click outside of the polygons (within the Viewer) to deselect 
everything.

5. In the Viewer menu bar, select Vector -> Attributes.

The Attributes dialog displays, as in the following example:

Polygon attributes are displayed in a CellArray. Therefore, you have 
access to the same tools that you use in other CellArrays.

6. In the Viewer, click another polygon to select it.

The polygon is highlighted in yellow in the Viewer, and the 
corresponding record in the Attributes CellArray is also highlighted.

7. Click a record number under Record in the Attributes CellArray to 
select it.

That record is highlighted in the CellArray and the corresponding 
polygon is highlighted in the Viewer.

8. With your cursor in the Record column of the Attributes CellArray, 
right-hold Row Selection -> Select All.

All features in both the CellArray and the Viewer are selected.

9. With your cursor in the Record column of the Attributes CellArray, 
right-hold Row Selection -> Select None to deselect all features.

Use the Marquee Tools to 
Select Features 

The marquee tool allows you to select a group of objects by dragging 
a box to contain them.

1. In the Viewer menu bar, select Vector -> Options.

The Options dialog opens.

Attributes for
the displayed
layer are
shown here

Use the menu
bar items to
create and
edit attributes
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2. In the Options dialog under Select By, click the Contained In 
checkbox.

3. Click Apply in the Options dialog.

When you use the marquee tools in the Vector tool palette now, only 
the features completely contained within the boundary of the 
marquee are selected.

4. Click the Marquee icon  on the Vector tool palette.

5. Drag to draw a rectangle in the Viewer.

When you release the mouse button, the polygons and lines 
contained within the rectangle are selected (outlined in yellow). The 
corresponding attributes are selected in the Attribute CellArray.

6. In the Viewer, click outside of the polygons to deselect all features.

7. Click the Line Selection icon  on the Vector tool palette. 

8. In the Viewer, click to start drawing a line over the vectors and either 
double-click or middle-click once (depending on how your 
Preferences are set) to terminate the line.

The features that intersect the line are selected in the Viewer and in 
the Attribute CellArray.

9. In the Viewer, click outside of the polygons to deselect everything.

10. Click Close in the Options dialog.

Use the Criteria Function This function allows you to specify the criteria upon which the 
automatic selection of CellArray rows is based.

1. With your cursor in the Record column of the Attributes CellArray, 
right-hold Row Selection -> Criteria.

The Selection Criteria dialog opens.

Click here to
restrict selection
to only those
features within
the marquee
boundary
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Next, you create a criteria statement to select only those polygons 
that have an area greater than 5,000,000 square feet. 

2. In the Selection Criteria dialog, click AREA under Columns.

$”AREA” is now written in the Criteria statement box at the bottom 
of the Selection Criteria dialog.

3. Under Compares, click >.

The greater than symbol displays in the Criteria statement.

4. Use the numeric keypad to enter the number 5000000.

The Criteria statement now reads:

$îAREAî > 5000000

5. Click Select to compare the attributes in the Attributes CellArray 
against this criteria statement.

Only those records that meet the criteria are selected and 
highlighted in the Viewer and Attributes CellArray.

Now, you further refine the criteria by limiting the selection to only 
those polygons that are both greater than 5,000,000 square feet and 
in zone 4.

6. In the Selection Criteria dialog, click the and button.

7. Under Columns, click ZONING.

8. Under Compares, click ==.

9. In the numeric keypad, click 4.

The Criteria statement now reads:

$îAREAî > 5000000 and $îZONINGî == 4

10. Click Select in the Selection Criteria dialog.

All polygons greater the 5,000,000 square feet and in zone 4 are 
selected in the Viewer and in the Attribute CellArray.

11. Click Close in the Selection Criteria dialog.

Select items here
to create criteria
statement here
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12. In the Viewer, click outside of the polygons (within the Viewer) to 
deselect everything.

13. Click Close in the Vector tool palette.

14. Select File -> Close from the Attributes dialog.

15. Select File -> Clear from the Viewer.

Edit Vector Layers For this section, display a Landsat TM raster layer, then overlay the 
vector layer you have been using. 

ERDAS IMAGINE should be running and you should have a Viewer 
open. 

1. Select File -> Open -> Raster Layer from the Viewer menu bar or 

click the Open icon  on the toolbar.

The Select Layer To Add dialog opens.

2. In the Select Layer To Add dialog under Filename, select 
germtm.img from the file list.

3. Click the Raster Options tab at the top of the dialog, and then click 
the Fit to Frame option so that the entire layer is visible in the 
Viewer.

4. Click OK in the Select Layer To Add dialog.

The file germtm.img displays in the Viewer.

5. In the Viewer menu bar, select File -> Open -> Vector Layer.

The Select Layer To Add dialog opens.

6. In the Select Layer To Add dialog under Filename, select zone88.

NOTE: If zone88 does not appear in the file list, click the dropdown 
list next to File Type and select Arc Coverage.

7. Click the Vector Options tab at the top of the dialog, and then 
confirm that the Use Symbology checkbox is turned off. Also, make 
sure that the Clear Display checkbox is turned off, so that the raster 
layer remains in the Viewer.

8. Click OK in the Select Layer To Add dialog.

The vector layer displays over the raster layer. Since the vectors are 
black, they may not be easily visible.

9. With your cursor in the Viewer, right-hold Quick View -> Zoom -> 
Rotate and Magnify Area.

A white rotation box displays in the Viewer and a Rotate/Magnify 
Instructions box also displays.
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10. Drag the white rotation box so that it is positioned over the vector 
layer in the Viewer. Make it just big enough to cover the vectors, 
then double-click within the rotation box to magnify that area.

The Rotate/Magnify Instructions box dismisses and both the raster 
and vector layers are magnified in the Viewer. 

For other methods of zooming into an area of interest, see 
“Animated Zoom”, “Box Zoom”, and “Real-time Zoom”.

Change Viewing 
Properties

1. In the Viewer menu bar, select Vector -> Viewing Properties.

The Properties dialog opens.

2. In the Properties dialog, hold on the dropdown list next to Arcs and 
select Other.

The Line Style Chooser dialog opens.

3. In the Line Style Chooser dialog, change the Width to 2.00 points, 
and hold on the Outer Color dropdown list to select White. 

4. Click Apply and then Close in the Line Style Chooser dialog.

5. Click Points in the Properties dialog to display points.

6. Hold on the dropdown list next to Points and select Other to change 
the style of the points so that they are more visible.

The Symbol Chooser dialog opens.

Hold on this dropdown 
list to select Other 

Click here to display 
points in the vector 
layer, then hold here 
to edit the point style 

Click here 

here to edit the 
nodes 

and then hold 
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7. In the Symbol Chooser dialog under Menu, click Black Filled 
Circle.

8. Hold on the Use Color dropdown list and select White.

9. Change the Size to 4.00 points.

10. Click Apply and then Close in the Symbol Chooser dialog.

The new style is reflected in the Properties dialog (although you 
cannot see it because it is a white symbol against a white 
background).

11. In the Properties dialog, click Nodes, then hold on the dropdown list 
next to All and select Other to change the style of nodes.

The Symbol Chooser dialog opens.

12. Change the Size of the symbol to 6.00 points.

13. Hold on the Use Color dropdown list and change the color of the 
symbol to something that is visible over germtm.img, such as 
Magenta. 

14. When you have selected a color, click Apply and then Close in the 
Symbol Chooser dialog. 

15. Click Apply in the Properties dialog.

The vectors and points are drawn in white, and the nodes appear in 
the color you selected in step 13.

16. Click Close in the Properties dialog.

17. An Attention dialog displays, asking if you want to save your changes 
to a symbology file. Click No.

Use Editing Tools and 
Commands

1. In the Viewer menu bar, select Vector -> Tools.

The Vector tool palette displays. 

Select symbol 
to use here 

Select symbol 
color here 

A preview of 
the selected 
symbol 
displays here 
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2. In the Vector tool palette, move the selector over each of the icons 
to view the single-line help that describes them in the lower portion 
of the Viewer.

3. In the Viewer menu bar, select Vector -> Enable Editing.

4. In the Viewer, click a line that you want to edit.

The selected line is highlighted in yellow and it is enclosed in a 
rotation box. You can simply hold and drag the entire box to move 
the line. You can hold and drag any of the handles on the box to 
enlarge or reduce the size of the line, or you can rotate the box.

5. In the Vector tool palette, click the Split icon  .

Your pointer is now a white crosshair when you move it back into the 
Viewer.

6. Click somewhere on the selected line to split it into two lines.

A node is placed where you clicked.

7. Click again on the line you split.

Only that part of the line is selected, since it is now two lines.

8. Shift-click the other part of the split line.

Now both parts of the line are selected.

9. In the Viewer menu bar, select Vector -> Join.

The node is removed, and the two lines form a single line again.

10. With the line still selected, select Vector -> Reshape from the 
Viewer menu bar.

The vertices of the line display, similar to the following example.



Edit Vector Layers / 118ERDAS IMAGINE Tour Guides

Each vertex is marked by a black dot in the example above.

11. Drag one of the vertices to a new location to reshape the line.

12. Select Vector -> Undo from the Viewer menu bar to undo this edit.

The line is restored to its original shape and it is deselected.

NOTE: To delete a vertex, you can Shift-middle click. To add a 
vertex, middle-click.

Create New Vector Layer

1. Click the Viewer icon on the ERDAS IMAGINE icon panel.

A new Viewer opens.

2. In the new Viewer (Viewer #2) select File -> Open -> Raster 
Layer.

The Select Layer To Add dialog opens.

3. In the Select Layer To Add dialog, select IMAGINE Image from the 
File Type dropdown list.

4. Under Filename, click the file germtm.img. 

5. Click the Raster Options tab at the top of the dialog and confirm 
that the Fit to Frame option is enabled.

6. Click OK in the Select Layer To Add dialog.

The file germtm.img displays in the Viewer.

7. In the Viewer #2 menu bar, select File -> New -> Vector Layer.

The New Vector Layer dialog opens.

8. In the New Vector Layer dialog under Vector Layer, enter a name 
for the new layer, such as zone88subset, in the directory of your 
choice.

Vector coverages include Arc Coverage, SDE Vector Layer, and 
Shapefile.

Vertices
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9. Click OK in the New Vector Layer dialog.

The New Arc Coverage Layer Option dialog opens.

10. Confirm that Single Precision is selected.

11. Click OK in the New Arc Coverage Layer Option dialog.

The title bar in Viewer #2 reflects the name of the new vector layer 
you are creating.

12. In the menu bar of Viewer #1, select Vector -> Options.

The Options dialog opens.

13. In the Options dialog under Select By, click Contained In.

14. Click Apply and then Close in the Options dialog.

15. In the menu bar of Viewer #1, select Vector -> Attributes.

The Attributes dialog opens.

Click here to select 
Contained In
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16. In the Attributes dialog menu bar, click View and make sure that 
Point Attributes is selected.

17. In Viewer #1, click the Zoom Out by 2 icon  .

Export Zoning Attributes

1. Click the Ellipse Marquee icon  on the Vector tool palette.

2. Shift-drag to draw a circle over the vector layer in Viewer #1.

The lines and points completely contained within the circle are 
selected in the Viewer and in the Attributes CellArray. You are going 
to export the ZONING attributes for the selected rows and import 
them into the new vector layer you are creating in Viewer #2.

3. Click the ZONING column header in the Attributes CellArray to 
select that column (use the bottom scroll bar to view the ZONING 
column).

The ZONING column is highlighted in green.

4. With your cursor in a column header of the Attributes CellArray, 
right-hold Column Options -> Export.

The Export Column Data dialog opens.

Click here to be 
sure that Point 
Attributes is 
selected 



ERDAS IMAGINE Tour Guides Edit Vector Layers / 121

5. In the Export Column Data dialog, enter a name for the ASCII file 
you are creating, such as zoning. The .dat extension is added 
automatically.

6. Click OK in the Export Column Data dialog.

7. Select Vector -> Copy from the Viewer #1 menu bar.

The selected lines and points are copied into the paste buffer.

8. Click anywhere in Viewer #2, then select Vector -> Paste from the 
Viewer #2 menu bar.

The selected vectors are displayed in Viewer #2.

9. In Viewer #2, click outside of all lines and points of the vector layer 
to deselect everything.

10. In the Attributes dialog, select File -> Close.

11. In the menu bar of Viewer #2, select File -> Save -> Top Layer.

12. In the menu bar of Viewer #2, select Vector -> Attributes.

The Attributes dialog displays, but it is empty because this new layer 
has no attribute data. It must be cleaned or built. You can also create 
attributes using the Edit -> Create Attributes option of the 
Attributes dialog. Use this method now, then run Build later.

Create Attributes

1. In the Attributes dialog, select View -> Point Attributes to select 
point attributes for display.

2. In the Attributes dialog, select Edit -> Create Attributes.

The Attributes CellArray fills with the basic point attributes.

Next, you create a new column in the Attributes CellArray for the 
ZONING attribute that you exported from the original Attributes 
CellArray.

3. In the Attributes dialog, select Edit -> Column Attributes.

The Column Attributes dialog opens.

Enter a name
for the ASCII
file here

Click here to
export data
to an ASCII
file
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4. In the Column Attributes dialog, click New to add a new column to 
the CellArray.

The options on the right side of the dialog are now enabled, so that 
you can define the parameters of the new column.

5. For the column Title, enter ZONING. Press Enter on your keyboard.

6. For Type, click the dropdown list and select Integer.

7. For Precision, click the dropdown list and select Single.

8. For Display Width, accept the default of 12.

9. Click OK in the Column Attributes dialog to create the new column.

The Attributes CellArray now has a new column called ZONING. This 
new column is placed to the right of the last column.

10. Click in the header of this new column (ZONING) to select it.

The column is highlighted in blue.

11. With your cursor in the Record column, right-hold Row Selection 
-> Select All.

12. With your cursor in a column header, right-hold Column Options -
> Import.

The Import Column Data dialog opens.

Click here to 
create a new 
column 

Specify column 
parameters here 

Enter ASCII
file name
here
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13. In the Import Column Data dialog, enter the name of the ASCII file 
that you created in the Export Column Data dialog in step 5 (that is, 
zoning.dat).

14. Click OK.

The Attributes CellArray now has the same ZONING column and 
attributes as the original Attributes CellArray.

15. Select File -> Close from the menu bar of Viewer #2. When asked 
if you would like to save changes, click Yes.

The Attributes dialog automatically closes.

Create a Simple Shapefile 
Layer

1. Click the Viewer icon on the ERDAS IMAGINE icon panel.

A new Viewer opens.

2. In the new Viewer (Viewer #2) select File -> Open -> Raster 
Layer.

The Select Layer To Add dialog opens.

3. In the Select Layer To Add dialog, select IMAGINE Image from the 
File Type dropdown list.

4. Under Filename, click the file germtm.img. 

5. Click the Raster Options tab at the top of the dialog and confirm 
that the Fit to Frame option is enabled.

6. Click OK in the Select Layer To Add dialog.

The file germtm.img displays in the Viewer.

7. With your cursor in the Viewer, right-hold Quick View -> Zoom -> 
Rotate and Magnify Area.

A white rotation box displays in the Viewer and a Rotate/Magnify 
Instructions box also displays.

8. Drag the white rotation box so that it is positioned over the same 
area that was covered by the zone88 vector coverage. Double-click 
within the rotation box to magnify that area.

The Rotate/Magnify Instructions box dismisses and the raster layer 
is magnified in the Viewer. 

For other methods of zooming into an area of interest, see 
“Animated Zoom”, “Box Zoom”, and “Real-time Zoom”.
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9. In the Viewer #2 menu bar, select File -> New -> Vector Layer.

The New Vector Layer dialog opens.

10. Under File of Type, select Shapefile (*.shp) from the dropdown 
list.

11. In the New Vector Layer dialog under Vector Layer, enter a name 
for the new layer, such as zone88shapefile, in the directory of your 
choice. 

Vector coverages include Arc Coverage, SDE Vector Layer, and 
Shapefile.

12. Click OK in the New Vector Layer dialog.

The New Shapefile Layer Option dialog opens.

13. Select Polygon Shape from the dropdown list.

14. Click OK in the New Shapefile Layer Options dialog.

Create a Shapefile 
Coverage

1. In the Viewer toolbar, click the Tools icon  (or select Vector -> 
Tools from the Viewer menu bar).

The Vector tool palette displays.
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2. In the Vector tool palette, click the Polygon icon  .

For more information on using the Shapefile editing tools, see 
the Vector Tools Diagram page in the Vector On-Line Manual.

3. Using the Inquire Cursor, find the triangular field at X: 
726102.951800, Y: 497901.936911.

4. Left-click at the north end of the field and begin digitizing a shapefile 
coverage of the field. 

Your polygon should look something like this:

NOTE: The raster layer of these images has been washed out for the 
purposes of illustration.

5. Open the Vector Attributes table by selecting Vector -> Attributes 
from the Viewer menu bar, or by clicking on the Vector Attributes 

icon  on the Vector Tool palette.

The Vector Attributes table displays.

Left-click to begin
digitizing the field

Left-click to add
vertices to the field

Middle-click
to close the polygon

The polygon tool 
automatically draws
the closing line
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Editing the Shapefile 
Layer

1. To divide this polygon into two polygons, select the Polygon Split icon 

 on the Vector Tools palette.

2. Left-click once just outside the left side of the polygon. Move your 
cursor across the middle and outside of the right side of the polygon 
so that the split line divide the polygon into no more than two parts. 
It should look similar to this:

3. Middle-click to end the split line. The polygon has split into two 
polygons and should look like this:

4. Notice that the Area and Perimeter columns were automatically 
updated in the Vector Attributes table:
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5. Next you create a new polygon that shares a common border with 

an existing polygon. To do this, select the Append Polygon icon  
on the Vector tools palette.

6. To begin digitizing the field below the original polygon, left-click 
inside of the existing polygon. Continue to left-click to add vertices 
until you have digitized the entire field. Your line should end up 
within the same polygon in which you started and look like this:

7. Double-click to close the polygon. The new polygon should look like 
this:

8. Again note that the columns in the Vector Attributes Table update to 
show the area and perimeter of the new polygon.
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9. Next you reshape this polygon so that it contains more of the field. 

To do this, you need to select the Replace Polygon icon  on the 
Vector tools palette.

10. Again, start your digitizing by left-clicking inside of the polygon you 
want to reshape. Continue left-clicking to add vertices to the 
polygon. Your line should end up within the same polygon in which 
you started and look similar to this:

11. Double-click inside of the starting polygon to reshape the existing 
polygon to include the newly digitized area. Your new polygon should 
look like this:

12. The Area and Perimeter values in the Vector Attributes table reflect 
the dimensions of the polygon:
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13. Click File -> Close from the Viewer menu bar. When asked if you 
would like to save your changes, click Yes.

The Attributes dialog automatically closes.

Open a Personal 
Geodatabase

1. In a new viewer, click the Open Layer button and select ArcGIS 
Geodatabase (*.gdb) from the pull down menu in Files of Type.

2. Click the Connect button that appears in the Select Layer To Add 
dialog to connect to the geodatabase.

The Select GeoDatabase Feature Class to Add dialog opens.
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3. Select the directory where your personal geodatabase is stored. 
Select the .mdb file you wish to use and click Add.

4. The list of feature data sets appears in the dialog. Select the data set 
you wish to use and click Add.

5. Next, a list of feature classes displays. Choose the one you want to 
add and click Add.
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6. This connection is mapped for you to the proxy file, and you are 
brought back to the Select Layer To Add dialog where it is listed in a 
directory with any other mapped connections.

7. Select the .gdb file you want to view. From this point on you can treat 
this like any other vector layer. You can access it and edit it just like 
any other vector data. You may also rename the file by right-clicking 
on the file name and selecting rename. Click OK in the dialog to 
display the information in a Viewer.

You can also choose several mapped layers at once to display in a 
Viewer by using your Ctrl (control) key to select more than one 
feature class.
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After selecting two or more layers and clicking OK, all selected layers 
display in the Viewer:

Open An Enterprise 
Geodatabase

1. Click the Open Layer icon in a new Viewer. In the Files of Type 
dropdown menu, choose ArcGIS Geodatabase .gdb as your file 
type. 

2. Notice that this adds a Connect button to the dialog. Click Connect, 
and in the Look in dropdown menu, select Database Connections.
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3. Choose Add Spatial Database Connection and click Add.

4. The Spatial Database Connection dialog opens.
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You should ask your System Administrator to find out exactly 
what you should use as your server, service, database, and 
account information. The information used here is for 
instructional purposes only.

5. Click OK in the Spatial Database Connection dialog.

6. You are brought back to the Select Geodatabase Feature Class to 
Add dialog, and a connection to the server displays. Select this 
connection and click Add.

You are connected to the database where you can select a feature to 
create a proxy file that serves as a connection to the server and 
feature classes. This proxy file resides in the directory where your file 
chooser is located. If you wish to rename the file, right-click and 
select rename. To access the feature classes in the database, simply 
double-click the proxy file name.
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Classification

Introduction Classification is the process of sorting pixels into a finite number of 
individual classes, or categories of data based on their data file 
values. If a pixel satisfies a certain set of criteria, then the pixel is 
assigned to the class that corresponds to that criteria. 

In this tour guide, you perform a basic unsupervised classification of 
an image file (.img). 

All of the data used in this tour guide are in the 
<IMAGINE_HOME>/examples directory. You should copy the 
germtm.img file to a different directory so that you can have 
write permission to this file. 

For more detailed information on Classification techniques, 
please see  “Advanced Classification”.

Approximate completion time for this tour guide is 20 minutes.

Use Unsupervised 
Classification

This section shows you how to create a thematic raster layer by 
letting the software identify statistical patterns in the data without 
using any ground truth data. 

ISODATA Classifier
ERDAS IMAGINE uses the ISODATA algorithm to perform an 
unsupervised classification. The ISODATA clustering method uses 
the minimum spectral distance formula to form clusters. It begins 
with either arbitrary cluster means or means of an existing 
signature set. Each time the clustering repeats, the means of these 
clusters are shifted. The new cluster means are used for the next 
iteration. 

The ISODATA utility repeats the clustering of the image until either 
a maximum number of iterations has been performed, or a 
maximum percentage of unchanged pixel assignments has been 
reached between two iterations.

Performing an unsupervised classification is simpler than a 
supervised classification because the signatures are automatically 
generated by the ISODATA algorithm. 
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In this example, you generate a thematic raster layer using the 
ISODATA algorithm. 

You must have ERDAS IMAGINE running.

1. Click the DataPrep icon on the ERDAS IMAGINE icon panel. 

The Data Preparation menu opens.

Generate Thematic 
Raster Layer

1. Select Unsupervised Classification from the Data Preparation 
menu to perform an unsupervised classification using the ISODATA 
algorithm. 

The Unsupervised Classification (Isodata) dialog opens.

Click here to start 
the Unsupervised 
Classification utility
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2. Click Close in the Data Preparation menu to clear it from the 
screen.

3. In the Unsupervised Classification dialog under Input Raster File, 
enter germtm.img. This is the image file that is classified. 

4. Under Output File, enter germtm_isodata.img in the directory of 
your choice. 

This is the name for the output thematic raster layer. 

Set Initial Cluster Options

The Clustering Options allow you to define how the initial clusters are 
generated. 

5. Under Clustering Options, enter 10 in the Number of Classes 
field. 

Choose Processing 
Options

The Processing Options allow you to specify how the process is 
performed. 

1. Enter 24 in the Maximum Iterations number field under 
Processing Options. 

This is the maximum number of times that the ISODATA utility 
reclusters the data. It prevents this utility from running too long, or 
from potentially getting stuck in a cycle without reaching the 
convergence threshold.

2. Confirm that the Convergence Threshold number field is set to 
.950. 

Enter 

Enter 10 here to

germtm_isodata.img 
here

generate 10
classes 
(that is, signatures)

Enter germtm.img

Enter 24 for the

This should 

Click here to 

maximum number
of times the process
runs

be set to .950

start the process

here
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3. Click OK in the Unsupervised Classification dialog to start the 
classification process. The Unsupervised Classification dialog closes 
automatically.

A Job Status dialog displays, indicating the progress of the function.

NOTE: This process could take up to 15 minutes, depending upon 
your hardware capabilities.

4. In the Job Status dialog, click OK when the process is 100% 
complete.

5. Proceed to the “Evaluate Classification” section to analyze the 
classes, so that you can identify and assign class names and colors.

Evaluate 
Classification

After a classification is performed, you can use a classification 
overlay or recode the classes to evaluate and test the accuracy of the 
classification.

Create Classification 
Overlay 

In this example, you use the Raster Attribute Editor to compare the 
original image data with the individual classes of the thematic raster 
layer that was created from the unsupervised classification 
(germtm_isodata.img). This process helps identify the classes in 
the thematic raster layer. You may also use this process to evaluate 
the classes of a thematic layer that was generated from a supervised 
classification. 

ERDAS IMAGINE should be running and you should have a Viewer 
open.

Display Files

1. Select File -> Open -> Raster Layer from the Viewer menu bar to 
display the germtm.img continuous raster layer.

The Select Layer To Add dialog opens.

Convergence Threshold
The convergence threshold is the maximum percentage of pixels 
whose cluster assignments can go unchanged between iterations. 
This threshold prevents the ISODATA utility from running 
indefinitely. 

By specifying a convergence threshold of .95, you are specifying 
that as soon as 95% or more of the pixels stay in the same cluster 
between one iteration and the next, the utility should stop 
processing. In other words, as soon as 5% or fewer of the pixels 
change clusters between iterations, the utility stops processing.
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2. In the Select Layer To Add dialog under Filename, select 
germtm.img.

3. Click the Raster Options tab at the top of the Select Layer To Add 
dialog.

4. Set Layers to Colors at 4, 5, and 3, respectively.

5. Click OK in the Select Layer To Add dialog to display the image file. 

6. Select File -> Open -> Raster Layer from the Viewer menu bar to 
display the thematic raster layer, germtm_isodata.img, over the 
germtm.img file. 

The Select Layer To Add dialog opens.

7. Under Filename, open the directory in which you previously saved 
germtm_isodata.img by entering the directory path name in the 
text entry field and pressing the Enter key on your keyboard. 

8. Select the file germtm_isodata.img from the list of files in the 
directory.

You are going to evaluate/identify the classes in this file.

9. Click the Raster Options tab at the top of the Select Layer To Add 
dialog.

10. Click Clear Display to turn off this checkbox. 

11. Click OK in the Select Layer To Add dialog to display the image file. 

Open Raster Attribute 
Editor

1. Select Raster -> Attributes from the Viewer menu bar. 

The Raster Attribute Editor displays.

Click to set 
Layers to
Colors

Select 
germtm.img
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2. In the Raster Attribute Editor, select Edit -> Column Properties to 
rearrange the columns in the CellArray so that they are easier to 
view. 

The Column Properties dialog opens. 

3. In the Column Properties dialog under Columns, select Opacity, 
then click Up to move Opacity so that it is under Histogram.

4. Select Class_Names, then click Up to move Class_Names so that 
it is under Color. 

5. Click OK in the Column Properties dialog to rearrange the columns 
in the Raster Attribute Editor. 

The Column Properties dialog closes.

The data in the Raster Attribute Editor CellArray should appear 
similar to the following example: 

Analyze Individual 
Classes

Before you can begin to analyze the classes individually, you need to 
set the opacity for all of the classes to zero.

Click here to move
this column

Click here to move
the selected
column up

Click here to 
rearrange the 
columns
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1. In the Raster Attribute Editor, click the word Opacity at the top of 
the Opacity column to select all of the classes. 

2. In the Raster Attribute Editor, right-hold on the word Opacity at the 
top of the Opacity column and select Formula from the Column 
Options menu. 

The Formula dialog opens.

3. In the Formula dialog, click 0 in the number pad. 

A 0 is placed in the Formula field.

4. In the Formula dialog, click Apply to change all of the values in the 
Opacity column to 0, and then click Close.

5. In the Raster Attribute Editor, click and hold on the color patch under 
Color for Class 1 in the CellArray and change the color to Yellow. 
This provides better visibility in the Viewer. 

6. Verify the Opacity for Class 1 in the CellArray is set to 1. 

This class is shown in the Viewer.

7. In the Viewer menu bar, select Utility -> Flicker to analyze which 
pixels are assigned to this class. 

The Viewer Flicker dialog opens. 

8. Turn on the Auto Mode in the Viewer Flicker dialog by clicking on 
the checkbox.

The flashing black pixels in the germtm.img file are the pixels of 
this class. These areas are water.

9. In the Raster Attribute Editor, click inside the Class_Names column 
for Class 1. (You may need to double-click in the column.) Change 
this name to Water and then press Enter on the keyboard.

Click here to enter a 0
in the Formula

Click here to apply a 0
value to the Opacity column

Click here to close
this dialog 
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10. In the Raster Attribute Editor, click and hold on the Color patch for 
Water and select Blue from the dropdown list. (You may need to 
select the entire row for this class first.)

11. After you are finished analyzing this class, click Cancel in the Viewer 
Flicker dialog and set the Opacity for Water back to 0 in the Raster 
Attribute Editor. Press Enter on the keyboard.

12. Change the Color for Class 2 in the CellArray to Yellow for better 
visibility in the Viewer. 

13. Change the Opacity for Class 2 to 1 and press Enter on the 
keyboard. 

This class is shown in the Viewer.

14. In the Viewer menu bar, select Utility -> Flicker to analyze which 
pixels are assigned to this class.

The Viewer Flicker dialog opens.

15. Turn on the Auto Mode in the Viewer Flicker dialog.

The flashing yellow pixels in the germtm.img file should be the 
pixels of this class. These are forest areas.

16. In the Raster Attribute Editor, click inside the Class_Names column 
for Class 2. (You may need to double-click in the column.) Change 
this name to Forest, then press Enter on the keyboard.

17. In the Raster Attribute Editor, click and hold on the Color patch for 
Forest and select Pink from the dropdown list. (You may need to 
select the entire row for this class first.)

18. After you are finished analyzing this class, click Cancel in the Viewer 
Flicker dialog and set the Opacity for Forest back to 0. Press Enter 
on the keyboard.

19. Repeat these steps with each class so that you can see how the 
pixels are assigned to each class. You may also try selecting more 
than one class at a time.

20. Continue assigning names and colors for the remaining classes in the 
Raster Attribute Editor CellArray.

21. In the Raster Attribute Editor, select File -> Save to save the data 
in the CellArray. 

22. Select File -> Close from the Raster Attribute Editor menu bar. 

23. Select File -> Clear from the Viewer menu bar.
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Image Commands

Introduction ERDAS IMAGINE gives you access to a tool called the Image 
Commands tool. With it, you can take any file supported by ERDAS 
IMAGINE and perform many types of operations. One such operation 
is using the Image Commands tool to create a world file. You can 
then use the world file with other software packages, such as ESRI’s 
ArcView.

In this tour guide, you can learn how to:

• access the Image Commands tool

• create a world file from a .tif file

Approximate completion time for this tour guide is 15 minutes.

Image Commands With the Image Commands tool, you can make many changes to 
your files.

Use Image Interpreter Utilities

ERDAS IMAGINE must be running.

1. Click the Interpreter icon on the ERDAS IMAGINE icon panel.

The Image Interpreter menu opens.

2. Click Utilities in the Image Interpreter menu.

Click the Utilities option
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The Utilities menu opens.

Use the Subset Function

1. In the Utilities menu, select Subset.

The Subset dialog opens.

Select the Subset option 
to create a .tif file

Type the input file 
here, then select the 
.tif file type for the 
output file
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2. In the Subset dialog, click the Open icon  below Input File.

3. In the Input File dialog, navigate to the 
<IMAGINE_HOME>/examples directory, and select the file 
germtm.img.

4. Click OK in the Input File dialog to transfer germtm.img to the 
Subset dialog.

5. Click the Open icon under Output File.

6. In the Output File dialog, navigate to a directory where you have 
write permission.

7. Click the File Type dropdown list and choose TIFF.

8. Type the name germtm in the Filename window, then press Enter 
on your keyboard.

The .tif extension is automatically added. By using the Subset utility 
in this fashion, you can quickly create a TIFF image from an image 
file.

9. Click OK in the Output File dialog.

The Subset file updates accordingly.

10. Click OK in the Subset dialog to generate germtm.tif.

A Job Status dialog opens, tracking the progress of the function. 

11. When the Job is complete, click OK in the Job Status dialog. 

You can set a preference in the User Interface & Session 
category to automatically dismiss the Job Status dialog once a 
job is complete.

Check the TIFF file

1. Click the Viewer icon on the ERDAS IMAGINE icon panel.

2. Click the Open icon, and click the Recent button in the Select Layer 
To Add dialog.

3. Select the file you just created, germtm.tif.

4. Click the Raster Options tab, and select Fit to Frame.

5. Click OK in the Select Layer to Add dialog.
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The TIFF image displays in the Viewer. Notice that it is in the State 
Plane projection, indicated in the status area of the Viewer.

Now, you can take the file germtm.tif and create a world file using 
the Image Command Tool.

Start the Image Command Tool

1. From the Tools menu of ERDAS IMAGINE, select Image Command 
Tool.

2. In the Image Commands dialog, click the Open icon  .

The Image File dialog opens.

You can create a world file 
from this .tif file
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3. Navigate to the directory in which you saved the file, and select the 
file germtm.tif.

4. Click OK in the Image File dialog to transfer the information to the 
Image Commands dialog. 

The Image Commands dialog updates accordingly, and the Map 
Model to World option is activated.

5. Click the checkbox next to Map Model to World.

By default, the Image Commands tool assigns the same name to the 
output file, but with the .tfw extension. In this case, the file name is 
germtm.tfw. The world file is saved in the same directory as the 
image you create it from.

6. If you wish, click the Open icon , and navigate to a different 
directory in which you want to save the world file. If not, proceed to 
step 9.

The File Selector dialog opens.

Select the file 
germtm.tif

The Image File displays in 
this window

Once you click Map Model 
to World, the field updates 
automatically
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7. Type the name germtm.tfw in the Filename window, then press 
Enter on your keyboard.

8. Click OK in the File Selector dialog.

9. Click OK in the Image Commands dialog to start the process.

A Job Status dialog opens, which tracks the progress of the function.

10. When the job is complete, click OK in the Job Status dialog.

You can set a preference in the User Interface & Session 
Category of the Preference Editor, Keep Job Status Box, 
which allows the Job Status box to close automatically upon 
completion of a job.

Check for .tfw file

1. Using a UNIX shell or the Microsoft Explorer, navigate to the 
directory in which you created germtm.tif, and generated 
germtm.tfw.

2. Note the presence of the file in that directory.

Now, you can use the .tfw file to supply georeferencing information 
to other software packages, such as ArcView. Georeferencing 
information includes coordinate information.

The .tfw file 
resides in the 
same directory
as the .tif file
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Polynomial Rectification

Introduction Rectification is the process of projecting the data onto a plane and 
making it conform to a map projection system. Assigning map 
coordinates to the image data is called georeferencing. Since all map 
projection systems are associated with map coordinates, 
rectification involves georeferencing.

Approximate completion time for this tour guide is 1 hour.

Rectify a Landsat 
Image

Perform Image to Image 
Rectification

In this tour guide, you rectify a Landsat TM image of Atlanta, 
Georgia, using a georeferenced SPOT panchromatic image of the 
same area. The SPOT image is rectified to the State Plane map 
projection. 

In rectifying the Landsat image, you use these basic steps:

• display files

• start Geometric Correction Tool

• record GCPs

• compute a transformation matrix

• resample the image

• verify the rectification process

Display Files

First, you display the image to be rectified and an image that is 
already georeferenced.

ERDAS IMAGINE must be running and a Viewer open. 

1. Click the Viewer icon on the ERDAS IMAGINE icon panel to open a 
second Viewer. 

The second Viewer displays on top of the first Viewer.
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2. In the ERDAS IMAGINE menu bar, select Session -> Tile Viewers 
to position the Viewers side by side.

3. In the first Viewer’s toolbar, click the Open icon  (or select File -
> Open -> Raster Layer).

The Select Layer To Add dialog opens.

4. In the Select Layer To Add dialog under Filename, click the file 
tmAtlanta.img.

This file is a Landsat TM image of Atlanta. This image has not been 
rectified.

5. Click the Raster Options tab at the top of the Select Layer To Add 
dialog.

The Raster Options display in the Select Layer To Add dialog.

6. Click the Display as dropdown list and select Gray Scale.

7. Under Display Layer, enter 2. 

A preview of 
the image 
displays here 

Click here to 
select Raster 
Options

Select the
tmAtlanta file

The preview
image is 
displayed in 
grayscale 

Click OK when 
finished

Click this dropdown 
list to select Gray 
Scale

Display layer 2

Click 
Fit to Frame
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Depending upon your application, it may be easier to select GCPs 
from a single band of imagery. The image tmAtlanta.img displays 
in True Color by default.

8. Click Fit to Frame, so that the entire image is visible in the Viewer. 

9. Click OK in the Select Layer To Add dialog.

The file tmAtlanta.img displays in the first Viewer.

10. In the second Viewer toolbar, click the Open icon (or select File -> 
Open -> Raster Layer).

The Select Layer To Add dialog opens.

11. In the Select Layer To Add dialog, click the file panAtlanta.img.

This file is a SPOT panchromatic image of Atlanta. This image has 
been georeferenced to the State Plane map projection.

12. Click OK in the Select Layer To Add dialog.

The file panAtlanta.img displays in the second Viewer.

Start GCP Tool You start the Geometric Correction Tool from the first Viewer—the 
Viewer displaying the file to be rectified (tmAtlanta.img).

1. Select Raster -> Geometric Correction from the first Viewer’s 
menu bar.

The Set Geometric Model dialog opens.

2. In the Set Geometric Model dialog, select Polynomial and then click 
OK.

The Geo Correction Tools open, along with the Polynomial Model 
Properties dialog.

Select Polynomial



Rectify a Landsat Image / 152ERDAS IMAGINE Tour Guides

3. Click Close in the Polynomial Model Properties dialog to close it for 
now. You select these parameters later.

The GCP Tool Reference Setup dialog opens. 

4. Accept the default of Existing Viewer in the GCP Tool Reference 
Setup dialog by clicking OK.

The GCP Tool Reference Setup dialog closes and a Viewer Selection 
Instructions box opens, directing you to click in a Viewer to select for 
reference coordinates.

5. Click in the second Viewer, which displays panAtlanta.img.

The Reference Map Information dialog opens showing the map 
information for the georeferenced image. The information in this 
dialog is not editable. 

Click Close

Click OK to 
accept the default 
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6. Click OK in the Reference Map Information dialog.

The Chip Extraction Viewers (Viewers #3 and #4), link boxes, and 
the GCP Tool open. The link boxes and GCP Tool are automatically 
arranged on the screen (you can turn off this option in the ERDAS 
IMAGINE Preferences). You may want to resize and move the link 
boxes so that they are easier to see. 

In this tour guide, you are going to rectify tmAtlanta.img in the first 
Viewer to panAtlanta.img in the second Viewer.

Chip Extraction 
Viewer 

Link box 
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Select GCPs When the GCP Tool is started, the tool is set in Automatic GCP Editing 
mode by default. 

The following icon  is active, indicating that this is the case. 

1. In the first Viewer, select one of the areas shown in the following 
picture by clicking on that area. The circled areas are locations for 
GCPs. You should choose points that are easily identifiable in both 
images, such as road intersections and landmarks. 

The point you have selected is marked as GCP #1 in the Viewer and 
its X and Y inputs are listed in the GCP Tool CellArray. 

2. In order to make GCP #1 easier to see, right-hold in the Color 
column to the right of GCP #1 in the GCP Tool CellArray and select 
the color Yellow.

3. In Viewer #3 (the Chip Extraction Viewer associated with the first 
Viewer), drag the GCP to the exact location you would like it to be.
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NOTE: (UNIX only) To view the GCP while you are dragging it, turn 
off the Use Fast Selectors checkbox in the Viewer category under 
Session -> Preferences (this change does not take effect until the 
Viewer is restarted).

4. In the GCP Tool, click the Create GCP icon  .

5. In the second Viewer, click in the same area that is covered in the 
source Chip Extraction Viewer (Viewer #3). 

The point you have selected is marked as GCP #1 in the Viewer, and 
its X and Y coordinates are listed in the GCP Tool CellArray.

6. In order to make GCP #1 easier to see in the second Viewer, right-
hold in the Color column to the left of the X reference for GCP #1 in 
the GCP Tool CellArray and select the color Black.

The GCP Tool should now look similar to the following: 

7. In Viewer #4 (the Chip Extraction Viewer associated with the second 
Viewer), drag the GCP to the same location you moved it to in Viewer 
#3.

Select the color 
for the source 
GCP here 

These are the X and Y file 
coordinates for GCPs in the 
input image (tmAtlanta.img)

These are the X and Y map 
coordinates for GCPs in the 
reference image (panAtlanta.img)
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8. Click the Create GCP icon in the GCP toolbar. 

9. Return to the source Viewer (the first Viewer) and click to digitize 
another GCP.

10. In order to make GCP #2 easier to see, right-hold in the Color 
column to the right of GCP #2 in the GCP Tool CellArray and select 
the color Magenta.

11. In Viewer #3, drag the new GCP (GCP #2) to the exact location you 
would like it to be.

12. Repeat step 4 and step 5 to digitize the same point in the second 
Viewer.

13. As in step 10, you can change the color of the GCP marker to make 
it easier to see.

14. Digitize at least two more GCPs in each Viewer (on tmAtlanta.img 
in the first Viewer and panAtlanta.img in the second Viewer) by 
repeating the above steps. The GCPs you digitize should be spread 
out across the image to form a large triangle (that is, they should not 
form a line).

15. Choose colors that enable you to see the GCPs in the Viewers.

After you digitize the fourth GCP in the first Viewer, note that the 
GCP is automatically matched in the second Viewer. This occurs with 
all subsequent GCPs that you digitize.

After you digitize GCPs in the Viewers, the GCP Tool CellArray should 
look similar to the following example: 
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Selecting GCPs
Selecting GCPs is useful for moving GCPs graphically or deleting 
them. You can select GCPs graphically (in the Viewer) or in the 
GCP CellArray. 

• To select a GCP graphically in the Viewer, use the Select icon 

 .

Select it as you would an annotation element. When a GCP is 
selected, you can drag it to move it to the desired location.

You can also click any GCP coordinate in the CellArray to enter 
new coordinates.

• To select GCPs in the CellArray, click in the Point # column, or 
use any of the CellArray selection options in the right mouse 
button menu (right-hold in the Point # column).

Deleting a GCP
To delete a GCP, select the GCP in the CellArray in the GCP Tool 
and then right-hold in the Point # column to select Delete 
Selection.
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Calculate Transformation 
Matrix from GCPs

The Auto Calculation function is enabled by default in the GCP Tool. 
The Auto Calculation function computes the transformation in real 
time as you edit the GCPs or change the selection in the CellArray. 

With the Automatic Transform Calculation tool activated, you can 
move a GCP in the Viewer while watching the transformation 
coefficients and errors change at the top of the GCP Tool.

Compute Transformation Matrix
A transformation matrix is a set of numbers that can be plugged 
into polynomial equations. These numbers are called the 
transformation coefficients. The polynomial equations are used to 
transform the coordinates from one system to another.

The Transformation tab in the Polynomial Model Properties 
dialog shows you a scrolling list of the transformation coefficients 
arranged in the transformation matrix. To access the Polynomial 
Model Properties dialog and the Transformation tab, click the 

Display Model Properties icon  in the Geo Correction Tools.

The coefficients are placed in the transform editor in two ways:

• The Transformation tab CellArray is automatically populated 
when the model is solved in the GCP Tool. 

• Using the CellArray located in the GCP tool to enter them 
directly from the keyboard.

In this tour guide, the transformation coefficients are calculated 
from the GCP Tool, and are automatically recorded in the 
Transformation tab.

Preparation
A minimum number of GCPs is necessary to calculate the 
transformation, depending on the order of the transformation. This 
number of points is:

Where t is the order of the transformation.

If the minimum number of points is not satisfied, then a message 
displays notifying you of that condition, and the RMS errors and 
residuals are blank. At this point, you are not allowed to resample 
the data.

Change Order of Transformation
To change the order of the transformation, use the Polynomial 
Model Properties dialog (available from the Geo Correction Tools). 
Using this dialog, select the Parameters tab at the top of the 
dialog. This tab allows the polynomial order to be altered.

t 1+( ) t 2+( )
2

--------------------------------
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You may want to turn off the Auto Calculation function if your system 
or computation is taking too long.

NOTE: Some models do not support Auto Calculation. If this is the 
case, the function is disabled.

1. If your model does not support Auto Calculation, click the Calculate 

icon  on the GCP Tool toolbar. 

NOTE: The transformation matrix contains the coefficients for 
transforming the reference coordinate system to the input 
coordinate system. Therefore, the units of the residuals and RMS 
errors are the units of the input coordinate system. In this tour 
guide, the input coordinate system is pixels.

Digitize Check Points Check points are useful in independently checking the accuracy of 
your transformation. 

2. In the GCP Tool, turn all of the GCPs to yellow by right-holding 
Select All in the Point # column and then right-holding Yellow in 
each of the two Color columns.

3. Right-hold Select None in the Point # column of the GCP Tool 
CellArray to deselect the GCPs.

4. In the last row of the CellArray, right-hold in each of the two Color 
columns and select Magenta.

All of the check points you add in the next steps are Magenta, which 
distinguishes them from the GCPs.

5. Select the last row of the CellArray by clicking in the Point # column 
next to that row.

6. Select Edit -> Set Point Type -> Check from the GCP Tool menu 
bar.

All of the points you add in the next steps are classified as check 
points.

7. Select Edit -> Point Matching from the GCP Tool menu bar.

The GCP Matching dialog opens.
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8. In the GCP Matching dialog under Threshold Parameters, change 
the Correlation Threshold to .8, and then press the Enter key on 
your keyboard.

9. Click the Discard Unmatched Point checkbox to activate it.

10. Click Close in the GCP Matching dialog.

11. In the GCP Tool, click the Create GCP icon and then the Lock icon.

12. Create five check points in each of the two Viewers, just as you did 
for the GCPs. 

NOTE: If the previously input points were not accurate, then the 
check points you designate may go unmatched and be automatically 
discarded.

13. When the five check points have been created, click the Lock icon in 
the GCP Tool to unlock the Create GCP function.

14. Click the Compute Error icon  on the GCP Tool to compute the 
error for the check points.

The Check Point Error displays at the top of the GCP Tool. A total 
error of less than 1 pixel error would make it a reasonable 
resampling.

15. To view the polynomial coefficients, click the Model Properties icon 

 in the Geo Correction Tools.

Set the Correlation 
Threshold here 

Click here to activate 
this checkbox 



ERDAS IMAGINE Tour Guides Rectify a Landsat Image / 161

The Polynomial Model Properties dialog opens.

16. Once you have checked the tabs of the Polynomial Model Properties 
dialog, click Close in the Polynomial Properties dialog. 

Resample the Image Resampling is the process of calculating the file values for the 
rectified image and creating the new file. All of the raster data layers 
in the source file are resampled. The output image has as many 
layers as the input image.

ERDAS IMAGINE provides these widely-known resampling 
algorithms: Nearest Neighbor, Bilinear Interpolation, Cubic 
Convolution, and Bicubic Spline.

Resampling requires an input file and a transformation matrix by 
which to create the new pixel grid.

1. Click the Resample icon  in the Geo Correction Tools. 

The Resample dialog opens.

2. In the Resample dialog under Output File, enter the name 
tmAtlanta_georef.img for the new resampled data file. This is the 
output file from rectifying the tmAtlanta.img file to the coordinate 
system of the panAtlanta.img file. 

NOTE: Be sure to enter the output file in a directory where you have 
write permission and at least 25 Mb of free disk space.

3. Under Resample Method, click the dropdown list and select 
Bilinear Interpolation. 

4. Click Ignore Zero in Stats., so that pixels with zero file values are 
excluded when statistics are calculated for the output file.

5. Click OK in the Resample dialog to start the resampling process.

Click here to select the 
Bilinear Interpolation 
resampling method

Click here to exclude 
zero file values in statistics 
for output file

Enter file name 
for the new 
georeferenced 
image file

Output map 
projection should 
be State Plane
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A Job Status dialog opens to let you know when the processes 
complete.

6. Click OK in the Job Status dialog when the job is 100% complete.

Verify the Rectification 
Process

One way to verify that the input image (tmAtlanta.img) has been 
correctly rectified to the reference image (panAtlanta.img) is to 
display the resampled image (tmAtlanta_georef.img) and the 
reference image and then visually check that they conform to each 
other. 

1. Display the resampled image (tmAtlanta_georef.img) in the first 
Viewer. Use the Clear Display option in the Select Layer To Add 
dialog to remove tmAtlanta.img from the Viewer before the 
resampled image opens. 

2. When tmAtlanta.img closes in the first Viewer, you are asked if you 
want to save your changes. Click No in all of the Save Changes 
dialogs. 

The Geometric Correction Tool exits.

3. Right-hold Geo. Link/Unlink under the Quick View menu in the 
first Viewer.

4. Click in the second Viewer to link the Viewers together.

5. Right-hold Inquire Cursor under the Quick View menu in the first 
Viewer.

The inquire cursor (a crosshair) is placed in both Viewers. An Inquire 
Cursor dialog also opens.

6. Drag the inquire cursor around to verify that it is in approximately 
the same place in both Viewers. Notice that, as the inquire cursor is 
moved, the data in the Inquire Cursor dialog are updated.
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7. When you are finished, click Close in the Inquire Cursor dialog.

Rotate, Flip, or 
Stretch Images

It is often necessary to perform a first-order rectification to a layer 
displayed in the Viewer. You may need to rotate, flip, or stretch the 
image so that North is up. 

Choose Model Properties

1. Display the file tmAtlanta.img in a Viewer.

2. In the Viewer, select Raster -> Geometric Correction.

The Set Geometric Model dialog opens.

3. In the Set Geometric Model dialog, click Affine and then OK.

The Geo Correction Tools open, along with the Affine Model 
Properties dialog.

4. Change the Rotate Angle to 25.

5. Select the desired Reflect Option in the Affine Model Properties 
dialog, then click Apply and Close.

6. Click the Resample icon  in the Geo Correction Tools. 

The Resample dialog opens.

Enter scaling
options here

Click here
to choose 

Select one of 
these options the direction 

to rotate to flip images 
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7. In the Resample dialog under Output File, enter the name 
tmAtlanta_rotate.img. 

8. Under Resample Method, click the dropdown list and select 
Bilinear Interpolation. 

9. Click Ignore Zero in Stats., so that pixels with zero file values are 
excluded when statistics are calculated for the output file.

10. Click OK in the Resample dialog to start the resampling process.

A Job Status dialog opens to let you know when the processes 
complete.

11. Click OK in the Job Status dialog when the job is 100% complete.

Check Results

1. Open a new Viewer.

2. Click the Open icon, then select tmAtlanta_rotate.img from the 
directory in which you saved it.

3. Click the Raster Options tab, and click the Display as dropdown 
list to select Gray Scale.

4. In the Display Layer section, select Layer 2.

5. Click Orient Image to Map System to make sure it is not selected. 
If this option is selected, the rotation will not appear.

6. Click OK in the Select Layer To Add dialog. 

7. Compare tmAtlanta_georef.img and tmAtlanta_rotate.img 
side-by-side. 

Click here to exclude 
zero file values in statistics 
for output file

Click here to select the 
Bilinear Interpolation 
resampling method

Output map 
projection is
Unknown

Enter file name 
for the new 
georeferenced 
image file
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Subpixel 
Coregistration

Coregistration is sometimes inherent in the data set, for example 
Landsat 7 TM data. If the data is not coregistered, a greatly over-
defined second order polynomial transform should be used to 
resample one image to the other.

When doing a coregistration, you should register the lower resolution 
image to the higher resolution image so that the high resolution 
image is used as the reference image.

For this tour you use the tmatlanta.img and panatlanta.img files.

1. Open a new viewer by clicking the Viewer icon on the IMAGINE 
toolbar.

2. In the Viewer, click the Open icon and select tmatlanta.img from 
the example data.
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3. Before clicking OK in the Select Layer To Add dialog, click the Raster 
Options tab, and select Gray Scale to display the image and Layer 
2. Also check Fit to Frame, and click OK.

The image tmatlanta.img displays as grayscale in the Viewer.

Examples
directory

Choose the
Raster Options
tab for 
different 
options 
regarding your

Specific 
file to add

image

Click the 
dropdown
arrow to see
display 
options

Check Fit
to Frame so
the image 
fits entirely in
the Viewer
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4. In the Viewer, click Raster -> Geometric Correction.

The IMAGINE Application Setup bar displays saying Starting 
warptool. The Set Geometric Model dialog opens.

5. Choose Polynomial as the Geometric Model in the Set Geometric 
Model dialog, and click OK.

The Geo Correction Tools and the Polynomial Model Properties 
dialogs open.
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6. Type or click the arrows to input 2 as the Polynomial Order.

7. Click the Projection tab in the Polynomial Model Properties dialog, 
and click Set Projection from GCP Tool near the bottom of the 
dialog.

8. The GCP Tool Reference Setup dialog opens. Choose Image Layer 
(New Viewer) and click OK.

9. In the Reference Image Layer dialog, navigate to your example data, 
and choose panAtlanta.img. Click OK.

10. Click OK in the Reference Map Information dialog after looking over 
the Reference Map Projection.

The GCP Tool and three new viewers open automatically. Viewers 3 
and 4 are small in order to highlight certain GCPs that you choose.

Use these 
arrows to 
enter your
Polynomial
Order

Click here to
set the 
projection

Choose
panAtlanta
as your 
Reference
Image
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Select GCPs After the GCP Tool opens, it is set in Automatic GCP Editing mode by 

default. Check the following icon  to make sure it is active.

1. In the first Viewer, start selecting your GCPs by clicking the Create 

GCP icon  and clicking on locations in the Viewer. 

2. The GCPs need to be very precise so that the images match properly. 
Place the GCPs in specific locations such as intersections, large 
buildings, and distinct shapes. Make sure you scatter your GCPs 
around the image so they are not all concentrated in one place. Look 
at the image below for guidance in selecting the points.

3. After placing six GCPs, turn on the Toggle Fully Automatic GCP 

Editing Mode icon  so you can see the points and where they fall 
in panAtlanta.img in the second Viewer.

4. Select your seventh point. Notice how it falls very close to where it 
should in the panAtlanta.img image. This is the sign of a good 
registration transform. You can move the point slightly to give it the 
exact location between the two images.

5. Keep adding points until you have at least twelve. In the second 
image, panAtlanta.img, your points should be falling exactly where 
you are placing them in tmAtlanta.img. When this accuracy is 
achieved, you can resample the image.
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Resample and Evaluate 
the Coregistered Image

1. Click the Resample icon  on the Geo Correction Tools dialog that 
opened with the Polynomial Model Properties dialog.

The Resample dialog opens.

Browse to the 
directory where 
you want to store
the output file, and
type the name

Choose the 
Resample Method
you want to use
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2. Browse to the directory where you want to store your new Output 
File. Type the name of the file in the Output File dialog and click OK.

In some cases you may want to change the Resample Method, but 
for this tutorial leave it set to Nearest Neighbor.

3. In the Resample dialog, click OK to perform the resampling. A job 
status box displays stating that you are resampling tmAtlanta.img 
to whatever you have named your new Output File. When it is 100% 
done, click OK.

4. Open a Viewer and display panAtlanta.img. Make sure you go to 
Raster Options and click Fit to Frame. Also click Clear Display if 
it is checked to turn it off.

5. In the same Viewer, display your resampled image. Make sure you 
go to Raster Options and choose Gray Scale as the Display 
Option as well as Fit to Frame and turn off Clear Display.

Both images appear in the Viewer.

6. Click Utility and choose Swipe. The Viewer Swipe dialog opens.

Use the slide
to swipe over
the images

Choose either
horizontal
or vertical

Use Auto Mode 
and Speed to 
watch the images
being swiped at
a rate you choose
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7. Check Auto Mode in the Viewer Swipe dialog, and type 500 for the 
Speed. You can watch as the swipe tool slowly works its way over 
the images allowing you to evaluate the quality of the coregistration. 
Experiment with both Vertical and Horizontal direction and 
different speeds.
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Easytrace

Introduction MAGINE Easytrace adds assisted feature extraction capabilities to 
the existing vector, AOI and annotation editing tools of ERDAS 
IMAGINE. Assisted Feature Extraction is a means of reducing the 
number of mouse button clicks that you must perform, in order to 
capture vector information from a digital source such as satellite 
imagery or aerial photography, through automation of the extraction 
of features in the vicinity of the mouse clicks. The most prevalent 
example is the capture of roads from imagery. The traditional 
“heads-up” digitizing requires you to place vertices frequently along 
a winding road in order to adequately capture the detail represented 
in the imagery, whereas assisted feature extraction minimizes the 
number of manually measured vertices by automatically tracing the 
path of the feature between the positions you digitize. By minimizing 
the number of mouse clicks the linear feature capture process 
becomes more efficient, therefore faster.
In this tour guide, we will demonstrate the IMAGINE Easytrace tool 
by digitizing roads and boundaries (land areas) with a minimum 
number of measured vertices.

IMAGINE Easytrace tool requires a license to run. If you don't 
have a license you will receive this warning message. 

IMAGINE Easytrace security checking failed. Please make 
sure you have the license to run it.

IMAGINE 
Easytrace 
Features

• Fast response - extraction results can be displayed in real time;

• Capable of processing any raster image displayed in the viewer;

• In most cases, it is not necessary to do data pre-processing;

• Integrated with manual digitizing minimizes learning curve and 
makes it easy-to use;

• Different tracing modes deliver high flexibility to different data 
type and image scene complexities;

• Hot keys enable you to quickly switch between various digitizing 
modes
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Hot Keys

Hot Keys, except Undo (Z or Backspace) are not available when 
Easy Tracing is unchecked.

IMAGINE Easytrace 
Matrix

Checking the Reuse Template box saves you time, you won't 
have to specify the template each time when digitizing 
centerline or ribbon on multiple features with similar width and 
texture.

Starting IMAGINE 
Easytrace from 
Vector Tools

In this section, you will open a raster image, 
waldkirch_ads40_sub.img in the Viewer, then open the IMAGINE 
Easytrace tool from the Vector tool palette.

The IMAGINE Easytrace tool can be started from the Vector, 
Annotation, or AOI tools menu.

1. In an IMAGINE Viewer select File | Open | Raster Layer..., the 
Select Layer to Add dialog is opened. From the examples folder, 
select waldkirch_ads40_sub.img.

Shift Manual mode (switch back to manual mode)

A Rubber band mode

S Streaming mode (only effective for boundary extraction)

D Discrete mode

Z or Back-
space

Undo current segment of extraction

C Hold this key to close a polygon (feature between the 
current cursor and start point will be traced)

Tracing Mode Feature Type

Boundary Centerline Ribbon

Rubber Band

Streaming

Discrete

Manual
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2. In the Viewer, select File | New | Vector Layer..., the Create a 
New Vector Layer dialog is opened. Type tour_trace in the file 
name box. 

3. Click OK to create the new vector layer. 

The New Arc Coverage Layer Option dialog is opened.
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4. Click OK to create a single precision layer.

The Vector tools dialog is opened.

5. Click the Easytrace Tool icon  to access the tool and its feature 
extracting options for digitizing.

6. Check the Easy Tracing box to enable Feature Type and Tracing 
Mode options.
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Digitizing using 
IMAGINE 
Easytrace

In this section, we will use the IMAGINE Easytrace tool to digitize 
different feature types using different tracing modes. 

Centerline with Rubber 
Band Mode

1. Click the Centerline radio button to select it as the feature type.

2. Click the Rubber Band radio button to select it as the tracing mode.

3. Click the Advan. Settings, the Advanced Easytrace Settings dialog 
is opened. Change the Smoothness to 86, Straightness to 66 and 
the Image Feature to 30.

The default is 50, but we’re adding more smoothness and 
straightness, and decreasing the Image Feature. Since the curve of 
the road is fairly smooth, this will produce a smoother result.

4. Make sure the Color Band for Easy Tracing is set for All.

5. Click OK to apply the weighting factors changes and close the 
Advanced Easytrace Settings dialog.

6. Zoom in  to an area in the image with a winding road.

7. Click the polyline icon  to trace a line feature, the pointer 
becomes a cross in the image.

8. Using the left mouse button, make two clicks (using the center of 
the cross as guide), one on each side of the road to get a 
measurement for the template of the road cross-section.
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The template is specified by two mouse clicks on the boundary of the 
ribbon (for example, roads) you are going to digitize. These clicks 
should be as close to the edge as possible and the line segment of 
the two points should be perpendicular to the ribbon. The purpose of 
specifying the template is to specify width of the linear feature and 
get the texture of the linear feature.

NOTE: When using the centerline or ribbon modes on narrow linear 
features and having difficulty in specifying the template at the zoom 
level you want to digitize;zoom in to your desired zoom level, specify 
the template, using the context menu (click the right mouse button), 
then zoom out and start digitizing.

9. Then start tracing, the IMAGINE Easytrace tool will follow the road 
and automatically generate points as needed.

10. When you feel that the results are OK, click the left mouse button to 
confirm the segment and go on.

You can switch tracing modes while digitizing by using the Hot 
Keys. Switching modes may be helpful when moving through a 
particular area, for example switching to manual to continue to 
digitize the feature when IMAGINE Easytrace does not work well.

11. Double-click to end the digitization of the line..

If you make a mistake or see undesired vertices while digitizing, 
press Z to erase the last set of vertices.
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To correct specific vertices, select that line and click the reshape 
icon  on the Vector tool palette and click outside the selected 
line when done.

Centerline
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Changing the Appearance 
of the Tracing Results

You may want to change the color and or width of the tracing results. 
If this is necessary, use the following steps.

1. Select the Properties icon  on the Vector Tools palette.

The properties for tour_trace is displayed.

2. Click the button to the right of Arcs.

3. Select Other, the Line Style Chooser dialog is displayed.

4. Type 2 in the width window.

5. Change the Outer Color to red.

6. Click Apply and Close in the Line Style Chooser dialog.

7. Click Close in the Properties dialog. 

NOTE: An Attention dialog will display and ask if you want to save 
changes to a symbology file.

8. Click No in the Attention dialog.
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Boundary with Rubber 
Band Mode

1. Click the Boundary radio button to select it as the feature type.

2. Click the Rubber Band radio button to select it as the tracing mode.

3. Click the Advan. Settings buttton, the Advanced Easytrace Settings 
dialog is opened. Click the Reset button to return to the default 
settings.

4. Change the Image Feature to 90.

5. Click OK to apply the weighting factors changes and close the 
Advanced Easytrace Settings dialog.

6. Select the polygon icon  to digitize the cluster of trees surronding 
a stream of water.

7. Double-click to end the digitization of the line.
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8. Save the single precision coverage file and close the Viewer.
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Import/Export

Introduction The ERDAS IMAGINE Import function allows you to import a wide 
variety of data types for use in ERDAS IMAGINE. The Export function 
lets you convert image (ERDAS IMAGINE .img file format) files into 
one of several data formats.

In this tour guide, you can learn how to:

• import SPOT data from CD

• import ERDAS 7.x GIS and Generic Binary Data files

• export an image file in the ERDAS 7.x LAN format

• create a TIFF file 

• view raw data values using the Data View option

• view image data information using the ImageInfo utility

Approximate completion time for this tour guide varies 
depending upon the data you are importing or exporting.

Import a SPOT 
Scene

Before you can import data from a peripheral device, such as a tape 
drive or a CD-ROM drive, you must configure the device in ERDAS 
IMAGINE. 

Refer to the current ERDAS IMAGINE Installation Guide for 
configuration instructions.

This section takes you through the steps to import SPOT data. 
Since each individual has different types of SPOT data, these 
steps are only an example. 

1. If your Session Log is not already open, select Session -> Session 
Log from the ERDAS IMAGINE menu bar. 

The Session Log displays real-time messages about what is 
happening throughout the import process. Following these messages 
closely helps you understand what is happening.

2. Click the Import icon  on the ERDAS IMAGINE icon panel.
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The Import/Export dialog opens:

The Import button is enabled when the dialog first opens, so that all 
of the prompts that display in the dialog are for importing data. 
When you click the Export button, the prompts change to options 
for exporting data. 

3. Click the Type dropdown list to select SPOT from the list of available 
importers. 

4. Confirm that the Media defaults to CD ROM. 

Displayed under Input CDROM is a list of configured CD-ROM 
drives. 

5. Click to select the device from which you want to import data. 

If it is necessary to configure a new device, see the current 
ERDAS IMAGINE Installation Guide.

6. Under Output File, enter a name for the output file in the directory 
of your choice. You can click the directory bar dropdown list or enter 
the directory name in the file name part to select a different 
directory.

7. Click OK in the Import/Export dialog. 

8. Watch the Session Log to see a report of the activities of the import 
process. 

The Import SPOT dialog opens:

Select Import
or Export here

Click here to
see a list of data
types

Click here
to select media

Click here to
file name part: 

Default file 
extension is 
shown in

Click to see
the raw data values
of the input file

parentheses

select configured
Enter the outputinput device

Directory bar: 
Click this
dropdown list to
change directories 

 
directory and file
name here
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Check Preview Options

1. Click Preview Options and the following dialog opens:

Shows information about 
the selected image 

Shows map projection 
information, if available 

Click to go to the previous 

multi-image CD 

Click to go to the next 

multi-image CD
image on CD, if a 

image on CD, if a 

Click here to see 
a preview image before 
importing the data 

Click here to define 
options for the preview 
image 
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2. Click OK in the Preview Options dialog. 

3. Click Preview in the Import SPOT dialog. 

A Job Status dialog displays, indicating the progress of the function.

When the Job Status bar shows 100 (indicating that the job is 100% 
done), the dialog automatically closes. A Viewer window similar to 
the following opens and displays the preview image:

Preview Options Dialog
The Preview Options allow you to import a decimated (that is, 
reduced) version of the image file. You can view the image before 
importing to be sure that this is the image you want, or to define 
a subset area of the image to import.

The Preview Options dialog is the same for all importers. For 
example, if you were importing a Landsat TM scene and you 
wanted to preview the image, the Preview Options dialog would be 
identical to the one in “Check Preview Options”. 

In the Preview Options dialog, you can set:

• Size of the displayed image—up to 512 × 512 or 1024 × 1024.

• Decimation—Nearest Neighbor (provides a faster preview 
image, although it may appear blocky) or Average Pixel 
(averages groups of pixels, which provides a smooth image but 
may take longer, especially with large images).

• Preview Bands—the bands that are assigned the red, green, 
and blue colors in the previewed image (this option may not be 
applicable to some data).

• Coordinate Type—the type of coordinates used to define the 
subset. If there is no map information in the source image, 
only File coordinates are available.

• Subset Definition—define a subset area for previewing or 
importing. 
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Preview images have a .preview.img file extension. Because 
the preview image is decimated, it is not suitable for image 
processing.

Check Import Options

1. In the Import SPOT dialog, click Import Options.

The Import Options dialog opens. This dialog is similar to the Preview 
Options dialog.

NOTE: Like the Preview Options dialog, the Import Options dialog is 
the same for every type of importer.

2. Select Utility -> Inquire Box from the SPOT_test.preview.img 
Viewer menu bar. 
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The Inquire Box Coordinates dialog opens and a rectangular box (the 
Inquire Box) displays in the center of the Viewer. 

3. When you have selected the subset area to import, click From 
Inquire Box in the Import Options dialog. 

The coordinates for the subset area display in the Import Options 
dialog. 

Sometimes, when map coordinate information is not available in 
the source image, there are apparent differences between the 
Inquire Box coordinates and those transferred to the Import 
Options dialog. However, the imported image subset matches 
the area bounded by the inquire box.

4. Click OK in the Import Options dialog.

5. Click OK in the Import SPOT dialog.

A Job Status dialog displays, indicating the progress of the import 
process:

Depending on your eml Preferences, when the Job Status bar 
shows 100 (indicating that the job is 100% done), you must either 
click OK to close the dialog or the dialog closes automatically.

6. Open a Viewer window and display the output file.

Subset an Area
You can select a subset area to be imported by moving and 
resizing the Inquire Box in the Viewer:

• to resize the Inquire Box, hold and drag on the sides or corners 
of the box

• to move the Inquire Box, hold and drag in the center of the box

The coordinates update in the Inquire Box dialog as you move 
and/or resize the Inquire Box.
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See the chapter "Raster and Vector Data Sources" in the ERDAS 
Field Guide for more information on importing data.

Export LAN Data In this section, you export one of the image example files to an 
ERDAS Version 7.x LAN file. 

Choose Export Options ERDAS IMAGINE should be running and the Import/Export dialog 
should be open.

1. In the Import/Export dialog, click Export. 

2. Click the Type dropdown list to see a list of available exporters.

3. Click to select LAN (Erdas 7.x) from the Type dropdown list.

4. Confirm that the Media lists File. 

5. Enter lanier.img under Input File. 

6. In the Import/Export dialog, ERDAS IMAGINE automatically enters 
lanier.lan as the output file. You may change this name if you want.
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7. Click OK in the Import/Export dialog.

The Export ERDAS 7.5 LAN Data dialog opens:

8. Click OK in the Export ERDAS 7.5 LAN Data dialog. 

A Job Status dialog displays. 

The file lanier.lan now resides in the selected directory. 

Creating LAN Data
ERDAS IMAGINE also creates two other files when it exports the 
LAN data:

• lanier.pro—contains map projection information

• lanier.sta—contains file statistics

These file formats are used in ERDAS 7.5 software. In ERDAS 
IMAGINE, map projection and file statistics are included in the 
image file format. You may delete the files lanier.pro and 
lanier.sta if desired, since they are not used in this exercise. 
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Create .tif Files In this section, run an ERDAS IMAGINE process, producing a .tif file 
instead of an image file. 

NOTE: Since the input image is georeferenced, the output TIFF 
image has geotiff tags. If you wish to produce a TIFF World file, 
select the Write option in the TIFF image file category of the 
Preference Editor.

1. Click the Classifier icon on the ERDAS IMAGINE icon panel. 

The Classification menu opens.

2. Click Unsupervised Classification from the Classification menu. 

The Unsupervised Classification (Isodata) dialog opens.

Click here to start the
Unsupervised Classification
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3. Click the Open icon  by Input Raster File.

The Input Raster File dialog opens.

4. In the Input Raster File dialog, click dmtm.img, then click OK.

The raster file, dmtm.img, is located in the 
<IMAGINE_HOME>/examples directory.

5. Click the Open icon next to Output Cluster Layer Filename.

The Filename dialog opens.

6. Navigate to a directory where you have write permission.

7. Click the File Type dropdown list, and select TIFF (*.tif). 

8. Type in dmtm1.tif in the Filename field, and then click OK.

9. Change the Number of Classes to 30. This tells the classifier how 
many classes to create. 

10. Deselect the Output Signature Set Filename checkbox. 

11. Click OK at the bottom of the Unsupervised Classification dialog. 

A job status dialog displays the progress of the classification of the 
file.

Select the input file here

Name the output file here

Uncheck the Output Signature 
Set Filename checkbox

Change the number of 
classes to 30



ERDAS IMAGINE Tour Guides Create .tif Files / 193

The resulting classification is created in the .tif format.

Check the Classification

1. Click the Viewer icon to open a Viewer.

2. From the Viewer toolbar, click the Open icon  .

3. In the Select Layer To Add dialog, click the Recent button.

4. Select the file dmtm1.tif from the top of the list.

5. Click OK in the List of Recent Files dialog.

6. Click the Raster Options tab of the Select Layer to Add dialog.

Select dmtm1.tif from the top 
of the Recent Files list

Select Gray 

Select Fit to 

Scale

Frame
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7. Click the Display as dropdown list and select Gray Scale.

8. Click the Fit to Frame checkbox.

9. Click OK in the Select Layer To Add dialog.

The file dmtm1.tif displays in the Viewer. The various shades of 
gray denote different classes of land cover.

Check Map Information

1. Click the ImageInfo icon  on the Viewer toolbar.

The ImageInfo dialog for dmtm1.tif opens.
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Note the information in the Map Info section and that the 
Projection Info section shows that the map is georeferenced to 
State Plane.

2. When you are finished, click File -> Close in the ImageInfo dialog.

3. Click File -> Close in the Viewer containing dmtm1.tif.

Import Generic 
Binary Data

In this section, you import the lanier.lan file that you just exported. 
This file could be imported using the ERDAS 7.x LAN import function. 
However, you are using this file to learn how the Generic Binary Data 
dialog works. 

This function is designed for importing data types for which there are 
currently no specific ERDAS IMAGINE importers. 

1. In the Import/Export dialog, click Import.

2. Click the Type dropdown list and select Generic Binary.

3. Select File from the Media dropdown list.

4. Under Input File, select lanier.lan. Change directories if needed by 
clicking on the directory bar. 

Note map and 
projection 
information
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5. Under Output File, ERDAS IMAGINE automatically enters 
lanier.img as the file name. If you try to save the file in the 
<IMAGINE_HOME>/examples directory, an Attention message 
warns you that lanier.img already exists.

6. If the Attention dialog displays, click No. 

This prevents the original lanier.img file from being overwritten. 

7. In the Import/Export dialog, enter lanier2.img as the Output File 
in the directory of your choice. 

8. In the Import/Export dialog, click OK. 

The Import Generic Binary Data dialog opens.

This dialog requires you make many inputs that define the data 
structure for ERDAS IMAGINE. In some cases, you can get the 
information for these inputs from the header data of the file (using 
the Data View option from the Import/Export dialog), but you may 
have to rely on prior knowledge or assumption for the information. 

You must enter the correct inputs for the data you are importing. 
The defaults for this dialog are not acceptable for importing. 

Data View

1. Click the Data View button in the Import/Export dialog. 

The DataView dialog opens. The data, as initially displayed, may not 
appear to be very useful. The following steps result in a display from 
which you can extract the information needed to complete the 
generic import.

Data View is also available from the Utility menu on the ERDAS 
IMAGINE menu bar.

Click here to
select input file

Directory bar:
Click this
dropdown list to
change directories

Click here to see
raw data values and
header information

ERDAS IMAGINE
automatically
enters this
output file
name with 
.img extension
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2. In the DataView dialog, click Data Type and select Unsigned 16 
bit.

3. In the DataView dialog, click Byte Order and select Intel.

4. Set the Offset to 8 and check that the Format is Decimal.

The DataView dialog is updated to look like the following:

5. In the DataView dialog, click Data Type and select Unsigned 32 
bit.

6. In the DataView dialog, click Byte Order and select Intel.

LAN File Format
The LAN format has the following characteristics:

• the first 128 bytes of the file are header data

• the number of bands is stored as a 16-bit integer in bytes 9 and 
10

• the number of columns is stored as a 32-bit integer in bytes 
17-20

• the number of rows is stored as a 32-bit integer in rows 21-24

With this knowledge, you can look at the data values in these bytes 
to obtain the information needed to import the file as generic 
binary data.

Data field
displays
actual data
values

Number
of bands

Offset equals 8 because
number of bands begins
in byte 9

Unsigned 16 bit data 
selected because
number of bands 
is two bytes
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7. Set the Offset to 16 and check that the Format is Decimal.

The DataView dialog updates. 

Enter Image Dimensions

1. In the Import Generic Binary Data dialog, next to File Header 
Bytes, enter 128.

This is the number of bytes in the header, before the actual data 
values begin.

2. Under Image Dimensions, for # Rows, enter 512.

3. Under Image Dimensions, for # Cols, enter 512.

4. Under Image Dimensions, for # Bands, enter 7.

The Import Generic Binary Data dialog updates.

Number
of columns

Offset equals 16 because
number of columns begins
in byte 17

Unsigned 32-bit 

Number
of rows

data is selected 

number of 
because the

columns and 

four bytes each
rows are
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Save Options

1. Click Save Options.

The Save Options File dialog opens.

This dialog allows you to save the inputs you have entered to a .gen 
file. It can be recalled and loaded into the Import Generic Data dialog 
whenever you are importing data with this structure. This keeps you 
from having to find and enter the necessary inputs again. 

2. Under File name, enter LAN and move the cursor out of the text 
field. 

ERDAS IMAGINE automatically appends the default .gen file 
extension. Use a descriptive name that helps you to recognize the 
type of inputs saved in the file. 

3. Click OK in the Save Options File dialog. 

These inputs are now saved and can be used again, when 
appropriate. 

Click here to 

Enter number 
of header 
 

Enter image 
dimensions 
and number 
of bands here 

bytes here 

see a preview 
of the image 

Enter name for 
the options file 

Click here 
to save file 
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To load the .gen file at a later time, click the Load Options 
button in the Import Generic Binary Data dialog. 

Preview the Image

1. In the Import Generic Binary Data dialog, click Preview. 

A Job Status dialog displays. When the Job Status bar shows 100 
(indicating that the job is 100% done), the dialog closes 
automatically.

A Viewer automatically opens and displays the file 
lanier2.preview.img. The .preview file extension is added to 
indicate that this is a decimated preview file (not suitable for 
processing).

2. Open another Viewer window and display the file lanier.img. 

You see that the two files are similar in appearance. The difference 
in these files is that lanier.img has map projection information and 
lanier2.preview.img does not. This is because when lanier.img 
was exported to a .lan file, the map information was exported to 
lanier.pro, which is a format used in ERDAS 7.5. The map projection 
data in lanier.pro was not imported with the Generic Binary Data 
importer.

However, the imported image does contain statistics (similar to the 
statistics exported to lanier.sta), because statistics are recalculated 
after a raster file is imported.

3. In the ERDAS IMAGINE menu bar, select Session -> Close All 
Viewers. 

Get Image 
Information

The ImageInfo utility is a function that gives you information about 
ERDAS IMAGINE image files. With this function you can access any 
image file and see the:

• date of last modification

• number of Layers

• layer information: Width, Height, Type, Block Width, Block 
Height, Data Type, Compression, and Pyramid Layer status for 
each layer in the file 

• calculated statistics

• map coordinates, when available

• map projection information, when available

NOTE: ImageInfo can only be used for image files. Use Vector 
Info for vector coverages.
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Edit Image Information In image files that have write permission, you can edit file 
information or perform the following operations using the ImageInfo 
dialog:

• change layer name

• compute statistics

• add, change, or delete map information

• add, change, or delete map projection

• delete calibration

• access the Raster Attribute Editor to change file attributes, such 
as color, histogram values, etc.

View Image Information In this section, you use the ImageInfo utility to learn more about the 
lanier.img file. 

1. Select Tools -> Image Information from the ERDAS IMAGINE 
menu bar. 

The ImageInfo dialog opens.

This option is also accessible from Session -> Tools -> Image 
Information on the ERDAS IMAGINE menu bar.

2. Select File -> Open from the ImageInfo menu bar, or click the Open 

icon  on the toolbar. 

The Image Files dialog opens. This dialog allows you to select a file 
for which information displays in the ImageInfo dialog. 

3. Under Filename, select lanier.img.

Select 
lanier.img
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4. Click OK in the Image Files dialog. 

The information for lanier.img displays in the ImageInfo dialog.

5. Look over the information listed in the dialog. 

The functions in the ImageInfo menu bar in the toolbar are 
described in the On-Line Help.

Since this is a write-protected file, none of these values can be 
changed. If you want to practice editing image information with this 
dialog, you can copy lanier.img to the directory of your choice and 
change the write protections. Then open the writable file in the 
ImageInfo dialog and click Edit to use the editing functions. 

6. Select File -> Close from the ImageInfo menu bar when you have 
read the information in the dialog. 

Menu bar 

Toolbar 

Status bar displays 
single-line help 

Click this dropdown 
list to select the 
layer for which to 
display info 

Map and Projection
Info display only for
georeferenced data.
Using ImageInfo is a
good way to find out
if an image is
georeferenced. 
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Batch Processing

Introduction The ERDAS IMAGINE Batch Wizard allows you to process one or 
more files with one or more commands at any time, from 
immediately to many years in the future.1 This is useful if you have 
a process that requires a long time to run and you want to run it 
when your system is at minimum utilization (for example, during the 
night). It is also useful if you wish to run a repetitive task many 
times, such as executing the reprojection command to reproject 
hundreds of images.

Some of the ERDAS IMAGINE functions that can be included in a 
Batch job are: classification, rectification, radar processing, Image 
Interpreter, import/export, and reproject.

Most of the processing dialogs in ERDAS IMAGINE, such as 
Importers, Exporters, Image Interpreter functions, Data Preparation 
functions, and others have a Batch button. This button is used to 
place the command in the Batch queue instead of actually 
performing the operation. Off-line processing allows unattended 
operation, enabling you to log off if you wish. 

The Batch wizard is distributed as part of the IMAGINE Essentials 
module, but can be used with functions from other modules. 
Consequently, some portions of this chapter may not compute 
successfully unless you also have an IMAGINE Advantage 
license, because functions from that module are used in the 
examples. 

On systems where off-line processing is not available, the 
options for processing at a later time are not available. 

On Microsoft Windows NT, your account must have 
administrator privilege to schedule jobs at a later time.

Approximate completion time for this tour guide varies, 
depending upon the data you select for Batch processing.

1. Under Windows NT, a job cannot be scheduled beyond the end of the current 
month.
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Set up/Start the 
Task Scheduler on 
NT and 2000

Before you can use the Batch Wizard to schedule jobs to run at a 
later time on Windows NT systems, you must set up and run the 
Scheduler. This requirement means that the account that starts 
Scheduler must remain logged-in for the scheduled job to run. You 
must log in as an administrator or as a person with administrator 
privileges to set up and start the Task Scheduler. Once started, you 
no longer need to have administrator privileges to submit jobs.

There are two ways to determine if Task Scheduler is installed on 
your system. If the Explorer shows a folder called “Scheduled Tasks” 
under “My Computer”, then Task Scheduler is installed. If there is an 
entry called Task Scheduler under the “Services” control panel, then 
Task Scheduler is installed. 

If Task Scheduler is installed, there is an additional panel at the end 
of the Batch Wizard which collects username and password 
information required by the Task Scheduler. The Finish button is 
disabled and the Next button is enabled. Once the information has 
been entered, it is remembered for the session and does not have to 
be entered again. The information is not saved, so when you exit 
ERDAS IMAGINE, it is forgotten and will have to be reentered during 
the next session. Saving username and password information in a 
file might pose a security problem.

1. From the Start menu, select Settings -> Control Panel.

2. On the Control Panel, select Administrative Tools, then choose 
Services.

3. Scroll through the Services dialog and select Task Scheduler, then 
click the Properties button on the Services menu to startup and 
open the Task Scheduler Properties dialog.

Read the help for the services control panel when using it for the 
first time. The help button is located on the Services menu bar.

Select 
Properties 
from the
Services 
dialog 

Select Task 
Scheduler from 
the Services 
dialog
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4. In the Task Scheduler Properties dialog, select Automatic as the 
Startup Type in the General menu, then click the This Account 
checkbox in the Log On menu. Enter your account name and 
password, confirm your password, and then click OK. 

5. Click the Start button in the Services dialog.

NOTE: The ability to run Batch at a later time is built using the 
Windows scheduler, which is part of the at command. Refer to the 
Windows help to learn more about the use of the at command.

(Microsoft Windows NT) If you are submitting jobs for processing 
later and you are using mapped network drives, then you need 
to ensure that these maps are in place when the Batch job runs. 
Typically, a mapped drive is only available to the current user 
unless the Reconnect at Logon option was checked on the Map 
Network Drive dialog when the drive was mapped. 

Select Automatic

Click the Start 
icon to start the 
Scheduler
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If this option is not checked, then when the Batch process is run 
by the Scheduler, it is not able to find the drive. This is one of 
the reasons to make sure that the Schedule service runs as your 
account name. This ensures that remembered network drive 
maps are reestablished when the Batch process runs.

Use Batch with a 
UNIX System

Unlike the Scheduler on NT, you do not have to be an administrator 
or a person with administrator privileges to set up Batch to run on a 
UNIX system.

On UNIX, the ability to run Batch at a later time is built using the 
UNIX cron system. See the man pages for more information about 
cron and the at command on UNIX.

Execute a Single 
File/Single 
Command

This operation is very useful for performing lengthy processes on 
large files.

1. From the ERDAS IMAGINE icon bar, click the Interpreter icon and 
then select GIS Analysis -> Clump to open the Clump dialog. 

2.  In the Clump dialog, select 
<IMAGINE_HOME>/examples/lnsoils.img for the Input File name 
and <your_workspace>/lnsoils_clump.img for the Output File 
name.

Where <your_workspace> is the Default Output Directory 
specified in the User Interface & Session category in the 
Preference Editor, and <IMAGINE_HOME> is the directory where 
ERDAS IMAGINE is installed.

3. In the Clump dialog, click the Batch button. The Batch Wizard opens 
with the Select Type of Command Processing panel displayed. The 
Use commands as they are radio button is already selected. 
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4. Click the Next > button. The Select When to Process Commands 
panel displays. The Start Processing Now button is already 
selected. If you wish to process the file immediately, go to step 6.

5. If you wish to process the file at a later time, click the Start 
Processing Later At... option, and set the time you wish it to begin 
processing.

6. Click the Finish button in the Select When to Process Commands 
panel to begin processing. A Job Status dialog opens showing the 
progress of each individual file along with progress of the overall job. 
When the job is complete, the OK button is enabled. 

7. Click OK to close the status meter.

The clump operation is complete. If you wish, you can open a Viewer 
and check the file.

Use commands 
as they are is 
already selected 
for you

The Batch job is 
scheduled to begin 
now

This meter tracks the 
progress of an individual file

This meter tracks the 
progress of all the files in the 
Batch job
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Execute Multiple 
Files/Single 
Command—Run 
Now

The ability to execute a command on multiple files is very useful. In 
the following example, the Batch Wizard is used to compute statistics 
for several TIFF images. 

NOTE: You must provide your own TIFF files for this exercise.

See  “Image Commands” on page 143 for instructions on how to 
use Image Interpreter utilities to create TIFF images from image 
files.

It is important to note that some processes depend upon the 
physical extents of the imagery, or the number of bands, or data 
types, or the projection parameters, and so on. You must be 
aware of both the requirements of the processes (commands) as 
well as the differences between the file types to be processed. 
In many cases, the data sets provided to multifile processing 
jobs must share common physical and ephemeral aspects.

Set TIFF Image File 
Preferences

1. Select Session -> Preferences from the ERDAS IMAGINE menu 
bar to open the Preference Editor dialog, and select the TIFF Image 
Files category.

2. Ensure that the Edits Allowed option is enabled (checkbox 
checked). If you want this to be the default, click User Save. Click 
Close.

Now you are ready to start the Image Command Tool, which 
interactively provides Batch access to many of the functions that the 
Image Information tool provides.

Make sure that edits are allowed
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Start the Image 
Command Tool

1. Select Tools -> Image Command Tool from the ERDAS IMAGINE 
menu bar to open the Image Commands dialog.

2. Click the File Open icon on the Image Commands dialog. In the file 
selector, click the Files of Type dropdown list and select TIFF. 
Select a TIFF file and click OK. The options on the Image Commands 
dialog are now enabled.

3. Check the Compute Statistics checkbox on the Image Commands 
dialog.

Start the Batch Wizard

1. Click the Batch button in the Image Commands dialog.

The Batch Wizard starts, and the Batch Commands panel displays. If 
you click the Finish button now, the job runs on the selected file. 
However, it is more useful to automate the process to run on several 
files.

2. Select the Modify commands manually option in the Batch 
Commands panel.

3. Click the Next > button to display the Commands and Variables 
tabs. 

Notice that the command, visible in the window, contains the full 
path of the selected file. In order for the software to be able to make 
file name substitutions from a list, there must be a variable into 
which the substitution is made. This is done in the following step.

Select the Compute 
Statistics option
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4. Click the Create and Insert Variables icon  to create variables. 

This tool examines the command for file names and replaces them 
with variables. In this case, one variable called Input is created and 
replaces a specific file and path. 

For more information about variables, see “Work with 
Variables”. 

The Batch commands can be saved for future use. See 
“Save/Load Options”.

5. Click the Next > button to display the Select Files to Process panel.

Insert variable icon

Replace 
argument icon

Create and insert 
variables icon

Undo

Load

SaveNotice this
name

The variable displays in 
the command line as well 
as the variable dropdown 
list
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6. Select the Add Files icon  . This opens a file selector. Click the 
File Type dropdown list and select TIFF.

NOTE: If you are working on the Windows platform, files can be 
added to the input list by dragging and dropping them from Explorer 
to the input list.

7. Select another TIFF file, and then click the Multiple Files Selection 
tab. 

8. Click the Use the following Selection Pattern checkbox. The 
default wild card displayed in the Selection Pattern field selects all 
TIFF files in the specified directory. You may modify the wild card as 
needed.

9. Click the OK button on in the Multiple File Selection tab. The 
specified TIFF files are added to the list in the Select Files to Process 
panel in the Input column. 

NOTE: You can repeat step 6 through step 8 to choose TIFF files from 
other directories.

Add files to the Input 
list by clicking this 
icon

Click the Use the 
following Selection 
Pattern checkbox

The Selection Pattern 
is based on the file you 
choose for input
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NOTE: Entries in the list may be selected by clicking in the number 
column as shown above, and then removed from the list by clicking 
the Delete icon  .

10. Click Finish to start computing statistics on the listed images 
immediately. A Job Status dialog displays showing the progress of 
each individual file along with progress of the total job. When the job 
is complete, the OK button is enabled. Click OK to close the Job 
Status dialog.

Execute Multiple 
Files/Single 
Command—Run 
Later

In the following example, you are going to perform reprojection on 
all of the Lake Lanier-related files in the ERDAS IMAGINE examples 
directory.

NOTE: For Windows NT users, you must be an administrator or a 
person with administrator privileges to run a Batch process at a later 
time.

1. From the ERDAS IMAGINE icon bar, click the DataPrep icon, and 
then select Reproject Images to open the Reproject Images dialog. 

2. Select lanier.img as the Input File and lanier_reproj.img as the 
Output File. Select UTM WGS 84 South from the Categories 
dropdown list. Select UTM Zone 25 from the Projection dropdown 
list.

NOTE: If you are creating projections of your own, do not include a 
slash (/ or \) in the name. The Batch processor uses the presence of 
a slash in a name to decide if it is an argument to be converted to a 
variable.

This row is selected, 
indicated by the 
yellow highlight
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3. Click the Batch button. The Batch Commands dialog opens with the 
options for selecting different commands. Select the Modify 
commands automatically option.

4. In the Batch Commands dialog, click the Next > button to open the 
Commands/Variables panel. Ensure the Commands tab is selected. 
Using the horizontal scroll bar, scroll about 2/3 to the left and 
observe that Input and Output variables have already been created 
in the command line.

For more information about variables, see “Work with 
Variables”.

5. Click the Next > button. The Select Files to Process panel opens with 
the selected input file displayed.

The dropdown list in the Select Files to Process panel determines 
which variable is populated when you click the Add Files button. In 
this example, there is only an Input variable.

Save the Output File in 
the directory of your 
choice

Set the projection 

Click the Batch 

here

button
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By default, there is always an Input column in the list, which 
corresponds to the default Input variable.

Add Multiple Files

1. Click the Add Files icon  . The Select Batch Files dialog opens. 

2. Select lnaspect.img from the Select Batch Files dialog. Click the 
Multiple File Selection tab and click the Use the following 
Selection Pattern checkbox. Edit the Selection Pattern field to 
insert ln before the asterisk. It should look like this:

<IMAGINE_HOME>/examples/ln*.img

Where <IMAGINE_HOME> represents the installation directory of 
ERDAS IMAGINE on your system.

3. Click the OK button in the Select Batch Files dialog.

Select 
list

Add files Delete files

dropdown 

The Selection Pattern has 
been changed to include all 
files that start with ln
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The input files display under the Input column. Select and delete 
any duplicate or unwanted files by clicking in the numbered column 
next to the file name and then clicking the Delete Files icon. This list 
of input files may be saved for future use. 

See “Save/Load Options” for information about saving files.

4. Click the Next > button to open the Select When to Process 
Commands panel. Click the Start Processing Later At checkbox. 
Use the default time of the next available minute.

.

The following characters are converted to a - (dash) when 
present in the Name field of the Select When to Process 
Commands panel: \, /, *, ?, ->, <, and >. Spaces and tabs are 
converted to an _ (underscore). 

5. Click the Finish button to begin processing. The Scheduled Batch 
Job List dialog opens, displaying all current Batch jobs. This is the 
place where the Task Scheduler may appear as discussed in the 
introduction to this Tour Guide chapter.

These are all the 
files that begin with 
ln located in the 
directory identified 
in the Selection 
Pattern window

This Batch file begins 
on 15 December 2003 
at 11:59 AM.

When you schedule 
Batch jobs later, a 
Name is assigned. 
Names cannot contain 
certain characters or 
spaces. Batch 
renames the job 
accordingly.
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The Scheduled Batch Job List dialog may be opened any time by 
selecting Session -> View Off-line Batch Queue from the ERDAS 
IMAGINE menu bar.

When the job begins, the Status changes from WAITING to 
ACTIVE. When the job has finished, the Status changes from 
ACTIVE to DONE. 

When the job is done, the log file can be viewed by first selecting the 
job in the Scheduled Batch Job list dialog, and then clicking the Log 
button. This is useful for checking to see if your Batch command ran 
successfully on all of the input files.

 

Status starts as 
WAITING

You can use the scroll 
bar to see the complete 
path of the Job File

The log displays in a 
text editor
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Execute Multiple 
Files/Multiple 
Commands

This procedure is most useful for very complex operations on 
multiple files involving many commands where the output from one 
command becomes the input to a succeeding command. In the 
following example, you are going to perform three operations on 
each of the Lake Lanier-related files in the ERDAS IMAGINE 
examples directory.

Some processes depend upon the physical extents of the 
imagery, or the number of bands, or data types, and so on. You 
must be aware of both the requirements of the processes 
(commands) as well as the differences between the file types to 
be processed. In many cases, the data sets provided to multifile 
processing jobs must share common physical and ephemeral 
aspects.

Set Up

1. Select Session -> Preferences from the ERDAS IMAGINE menu 
bar to open the Preference Editor dialog, and select the Batch 
Processing category.

2. Ensure that the Run Batch Commands in Record Mode option is 
enabled (checkbox checked). 

This preference tells ERDAS IMAGINE to run the commands and 
record them simultaneously. When running in Record Mode, you are 
typically collecting a series of commands to automate. Since the first 
command typically produces input for the next command, it is best 
to have the command run as soon as it is placed into the current list 
of commands. 

Batch commands should run in record mode
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Once the command has completed, the resulting file is available to 
be selected as input to the next command. In this case, the Create 
and Insert Variables button can be used to identify and replace 
intermediary files with temporary file variables, so that only the final 
output file is left on disk—not all of the intermediate steps.

Optionally, you can select the Run commands as they are 
recorded checkbox on the Record Commands for Automation panel. 
This sets the preference for the current session without changing 
your general preferences.

3. In the Preference Editor, click the Image Files (General) category, 
then click to deselect the Compute Pyramid Layers option. You do 
not want pyramid layers to be generated for the temporary files. 
Instead, you can run the Image Command Tool as a Batch process 
to create pyramid layers for the output files only.

4. Click User Save in the Preference Editor, then click Close.

5. Select Session -> Start Recording Batch Commands from the 
ERDAS IMAGINE menu bar to open the Batch Commands dialog. The 
Batch Commands dialog with the recording panel displays.

Note that the flashing record light, located in the lower-left corner of 
the Batch Commands dialog, has been activated.

Run First Command

1. From the ERDAS IMAGINE icon bar, click the Interpreter icon and 
then select Radiometric Enhancement -> Histogram 
Equalization to open the Histogram Equalization dialog.

2.  Select <IMAGINE_HOME>/examples/lanier.img for the Input File 
name and <your_workspace>/image1.img for the Output File 
name.

Where <your_workspace> is the Default Output Directory 
specified in the User Interface & Session category in the 
Preference Editor and <IMAGINE_HOME> is the directory where 
ERDAS IMAGINE is installed.

Batch commands 
display in this window

This is the flashing 
record unit
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3. Click the Batch button in the Histogram Equalization dialog. The 
command to perform histogram equalization is added to the Record 
Commands for Automation panel. The histogram equalization 
process starts, and a Job Status dialog displays. When the process is 
done, click OK.

Run Next Command

1. To open the Brightness Inversion dialog, select Brightness 
Inversion from the Radiometric Enhancement menu you opened 
in the first command.

2.  Select <your_workspace>/image1.img for the Input File name 
and <your_workspace>/image2.img for the Output File name. 
The Batch option is now enabled.

3. Click the Batch button. The command to perform Brightness 
Inversion is added to the Record Commands for Automation panel. 
The histogram Brightness Inversion starts, and a Job Status dialog 
displays. When the process is done, click OK.

Save the Output File 
in the directory of your 
choice

Click the Batch 
button to add the 
command to the 
Batch Commands

This is the 
output file from
the first Batch 
command

The output from the 
first Batch command 
is used to create the 
output for the 
second Batch 
command

Click the Batch 
button to add the 
second Batch 
command to the list
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Run Another Command You can also use Batch to create pyramid layers of your data. Next, 
you instruct the Image Command Tool to create pyramid layers for 
the output files only.

1. From the Tools menu of the ERDAS IMAGINE menu bar, select 
Image Command Tool. In the Image File window of the Image 
Commands dialog, select the file you generated in the last example, 
image2.img.

2. Click the Compute Pyramid Layers checkbox, then click the 
Options button next to Compute Pyramid Layers to open the 
Pyramid Layers Options dialog. 

3. Notice the Kernel Size, and whether or not the External File box is 
checked. You want the output file to contain internal pyramid layers 
rather than having the pyramid layers stored in an external .rrd file. 
Make sure the External File box is not checked. Click OK in the 
Pyramid Layers Options dialog.

These are the Batch 
commands you 
created. Note the 
exact files involved 
are specified

Select the image 
output from the last 
Batch request

Select the Compute 
Pyramid layers option
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4. Click the Batch button in the Image Commands dialog. The 
command to create pyramid layers is added to the Batch 
Commands dialog. The pyramid layer generation starts and a Job 
Status dialog displays. When the process is done, click OK.

If you examine the contents of the Batch Commands dialog recording 
panel at this time, you notice that the commands explicitly name the 
input and output files. The next procedure converts the input and 
output file names into variables so that these commands may be 
applied to a larger set of input files.

Create Variables

1. On the recording panel of the Batch Commands dialog, click the 
Next > button. The panel for selecting the type of command you 
want to use displays in the Batch Commands dialog. Select the 
Modify commands automatically option.

2. On the command selection panel, click the Next > button. The 
Commands/Variables panel displays.

Modify Variables This procedure creates an intermediate file that is used to pass the 
output of the first process to the input of the second. There is no 
need to keep this file and use disk space. Also, you might want the 
output file name to be a little more meaningful than image2. The 
following steps tell you how to modify variables.

1. Click the Variables tab to view the variable editing tools.

Click OK

Now, the files have 
been replaced by 
variables: Input, 
Temp1, and Output
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The Input variable has the type User. This means that you provide 
the names of the input files. 

2. Select the Temp1 variable. This represents the intermediate files 
that are not needed after processing. The Delete Before 
Processing checkbox is automatically selected to remove these files 
before processing begins. This prevents problems arising from the 
existence of an old file. The Delete After Processing checkbox is 
also automatically selected to remove these temporary files when 
processing finishes.

3. Select the Output variable. This represents the name of the final 
output file. The Delete Before Processing checkbox is checked 
automatically to remove these files before processing begins. This 
prevents problems arising from the existence of an old file. 

The Input variable 
is defined by you

The Temp1 variable is 
automatically 
generated

Temp1 is deleted both 
before and after 
processing
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Notice that the Output variable as well as the Temp1 variable are 
set to the Type called Auto. This means the software creates the file 
names that are substituted for the variables at run time. 

By default, the software uses the output directory that you specified 
in step 2 under “Run Next Command”. For the file name, it uses a 
combination of the root name of the input file and the last specified 
output file (in this example, image2).

4. Click the Set button. Click in the Pattern window and edit the text 
string to change image2 to inverse, and then click OK.

NOTE: If your input files have the same root name (for example, 
03807701.nec, 03807701.nwc) change Input.root to 
Input.name in the Pattern window. This includes the extension 
and thus preserves the uniqueness of the file name.

Select Input Files

1. Click the Next > button to open the Select Files to Process panel. 
The original input file is listed in the Input column.

2. Click the Add Files icon  . The Select Batch Files dialog opens. 

The Output file is 
also automatically 
generated

Use the Set button to 
edit the replacement 
pattern, and give the 
Output a different 
name

Change this portion of the 
Pattern to the new name: inverse
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3. Select lnaspect.img from the Select Batch Files dialog. Click the 
Multiple File Selection tab and click the Use the following 
Selection Pattern checkbox. Edit the Selection Pattern field to 
insert ln before the asterisk. It should look like this:

<IMAGINE_HOME>/examples/ln*.img

Where <IMAGINE_HOME> represents the ERDAS IMAGINE 
installation directory.

4. Click the OK button on the Select Batch Files dialog.

The input files display under the Input column. Select and delete 
any duplicate or unwanted files by clicking in the numbered column 
next to the file name and then clicking the Delete Files icon. This list 
of input files may be saved for future use. 

See “Save/Load Options” for details on how to save lists of input 
files.

Set Start Time

1. Click the Next > button to open the Select When to Process 
Commands panel. Click the Start Processing Later At checkbox. 
Use the default time of the next minute.

2. Click the Finish button to begin processing. The Scheduled Batch 
Job List dialog opens, displaying all current Batch jobs.

Insert ln in the Selection 
Pattern window to select 
all files in the directory 
starting with the letters ln
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When the job begins, the Status changes from WAITING to 
ACTIVE. When the job has finished, the Status changes from 
ACTIVE to DONE.

When the job is done, the log file can be viewed by first selecting the 
job and then clicking the Log button in the Scheduled Batch Job List 
dialog. 

The Scheduled Batch Job List dialog may be opened any time by 
selecting Session -> View Off-line Batch Queue from the ERDAS 
IMAGINE menu bar.

3. When the Batch jobs are finished, indicated by DONE in the Status 
column, click Close in the Scheduled Batch Job List dialog.

If you like, you can check the files you just generated in a Viewer.

NOTE: You may also want to change your preferences back to the 
default of Compute Pyramid Layers in the Image Files 
(General) category of the Preference Editor.

Work with 
Variables

This section deals with modification of automatically created 
variables for the purpose of generalizing a command file.

Create a New Variable A new variable is helpful in the case of an application requiring 
multiple inputs. The automatically created variables always consist 
of a single Input, a single Output, and as many Temp variables as 
necessary. If you are creating a Batch command file that can be used 
by others, it is much more readable if the Temp variables are 
replaced by variable names that are meaningful.

When creating variables, it is important to know the distinction 
between User variables and Auto variables. The value of a User 
variable is derived from the Select Files to Process panel. You must 
provide the appropriate value for each User variable in the 
CellArray.

The Status of the 
Batch job is still 
WAITING
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The value of an Auto variable is generated by the software from 
parameters specified in the pattern window of the Set dialog. If you 
recall, you worked with the dialog generated by pressing the Set 
button, the Edit Replacement Pattern dialog in “Modify Variables”.

In the following example, you are going to create a variable, 
OutputDir, which enables another person to enter an output 
directory of his or her choice for files processed by Batch. For this 
exercise, you select a number of files that you want to reproject.

Prepare First, you have to start the application from which you launch the 
Batch Wizard.

ERDAS IMAGINE must be running.

1. Click the Interpreter icon. From the Image Interpreter menu, 
select Utilities. From the Utilities menu, select Subset.

The Subset dialog opens.

2. In the Subset dialog, click the Open icon underneath Input File. In 
the Input File dialog, navigate to the <IMAGINE_HOME>/examples 
directory. Choose the file lnaspect.img from the /examples 
directory. Click OK in the Input File dialog to transfer the file to the 
Subset dialog.

3. Click the Open icon underneath Output File. In the Output File 
dialog, navigate to the directory of your choice. Click the File Type 
dropdown list and select TIFF. In the Filename window, type 
lnaspect, then press Enter on your keyboard. The .tif extension is 
appended automatically. Click OK in the Output File dialog.

Select 
lnaspect.img as 
the Input File

You can use the 
Subset dialog to 
generate TIFF 
files
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Start Batch Commands

1. Click the Batch button in the Subset dialog.

2. In the command types panel of the Batch Commands dialog, click the 
Modify commands automatically checkbox. Then, click Next >.

The Commands/Variables panel of the Batch Commands dialog 
displays.

3. Click the Variables tab on the Commands/Variables panel. Click the 
Output variable to view its properties.

Notice in the Pattern window of the Variables tab that the path to 
the Output file is very long. This directory can be replaced with a 
new variable called OutputDir. You can set the Pattern of the 
OutputDir variable to any directory you choose. This makes your 
command line shorter.

Create a New Variable Since you know that you want your new variable to be named 
OutputDir, and you know you want it to replace the current path in 
the Pattern of the Output variable with it, you can begin editing 
there.

1. Make sure that the Variables tab displays the details of the Output 
variable.

The Input and 
Output variables are 
automatically 
assigned

Click the Output 
variable to observe 
its properties
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2. Click in the Pattern window and remove the entire directory 
structure you want to replace. Once you have eliminated it, type in 
the following:

$(OutputDir)

The contents of the Pattern window then look like the following:

You have to create the new variable, OutputDir, so that the variable 
Output does not generate errors in your Batch script, and output 
files are placed in the correct location.

3. In the Variables tab of the Commands/Variables panel, click the 
New button. 

The Variables tab changes to accommodate a new variable.

4. In the Name section of the Variables tab, type the name 
OutputDir.

5. Click the Type dropdown list and choose Auto.

6. In the Pattern window, type the path to the directory and folder 
where you want generated files to be saved.

Your Variables tab looks like the following:

Replace the original 
path with the new 
variable OutputDir

The new variable 
is added to the list; 
now you supply 
properties
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Add Additional Files to 
the Batch Job

1. Click Next > in the Commands/Variables panel.

2. In the Select Files to Process panel of the Batch Commands dialog, 
click the Select Files to Add icon, and add all files within the 
<IMAGINE_HOME>/examples directory that start with the letters ln 
using the Multiple File Selection tab.

If you need to review how to add multiple files, see “Add Multiple 
Files”.

Start Processing

1. Click the Next > button to open the Select When to Process 
Commands panel.

2. Make sure the Start Processing Now option is selected, then click 
Finish to start the Batch job with the new variable.

The Job Status dialog opens.

All output files are 
going to be stored in 
the output directory 
you designate

These are all the 
files that begin with 
ln and are located in 
the directory 
identified in the 
Selection Pattern 
window
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3. When the process completes, click OK in the Job Status dialog.

Check the Output 
Directory

Now, you can check the output directory to see the files that have 
been stored there. In this example, the directory holds TIFF files you 
created from image files using the Subset utility of Image 
Interpreter.

1. Using a UNIX shell or Microsoft Explorer, navigate to the directory 
you specified as the Output Directory.

2. Check for the new TIFF files created from all files starting with ln in 
the <IMAGINE_HOME>/examples directory.

Additional 
Information

Save/Load Options The Commands/Variables and the Select Files to Process panels of 
the Batch Commands dialog provide methods for saving and loading 
the Batch Commands and input file lists, respectively.

Save

Click the Save icon  to save the commands in the 
Commands/Variables panel to a text (.bcf) file, and the input file list 
in the Select Files to Process panel to a text (.bls) file for later use. 
The Save Batch Commands dialog opens, where you may enter a 
new file name. 

Load

Click the Load icon  to load a previously saved command (.bcf) 
file or input file list (.bls) file. A Load Batch Commands dialog opens, 
allowing you to select from a previously saved list of files. These files 
are text files that may be created outside of ERDAS IMAGINE. 

Batch Job Files Several files are created for each Batch job that runs at a later time. 
The default file name root is batch_job. The file name can be seen 
in the Name field of the Select When to Process Commands panel. 
File names for each Batch job are listed in the Scheduled Batch Job 
List dialog.
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PC Version

The following are PC versions of Batch job files that are located in the 
Batch job directory. The default Batch job directory is 
$PERSONAL/batch, and you can go to Session -> Preferences -
> Batch Processing to change the Batch Job Directory.

• batch_job.bat—This is an MS-DOS Batch file. This file sets up 
the environment for the ERDAS IMAGINE applications and runs 
“batchprocess,” which runs the commands found in the 
batch_job.bcf file.

• batch_job.bcf—These are ERDAS IMAGINE Batch command 
files. These files hold the variable definitions and issue the 
ERDAS IMAGINE commands to perform the step, or steps, 
required to complete a job.

• batch_job.bls—These files contain lists of input files.

• batch_job.id—This file contains a job number assigned by the 
system. This file is deleted automatically to indicate completion 
of the job.

• batch_job.lck—This is an empty file that is created when the 
job actually starts running. This indicates the job is ACTIVE. 
When the job is done, it is deleted.

• batch_job.log—This file contains the results of the Batch job.

UNIX Version

These are UNIX versions of Batch job files:

• batch_job.bcf—These are ERDAS IMAGINE Batch command 
files. These files hold the variable definitions and issue the 
ERDAS IMAGINE commands to perform the step, or steps, 
required to complete a job.

• batch_job.bls—These files contain lists of input files.

• batch_job.id—This file contains a job number assigned by the 
system. This file is deleted automatically to indicate completion 
of the job.

• batch_job.job—This is a UNIX shell script. This file sets up the 
environment for the ERDAS IMAGINE applications and runs 
“batchprocess,” which runs the commands found in the 
batch_job.bcf file.

• batch_job.lck—This is an empty file that is created when the 
job actually starts running. This indicates the job is ACTIVE. 
When the job is done, it is deleted.

• batch_job.log—This file contains the results of the Batch job.
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Fourier Transform Editor

Introduction In this tour guide, you enhance and destripe a 512 × 512 subset of 
a Landsat Thematic Mapper image using both interactive and 
automatic methods available in the ERDAS IMAGINE Fourier Analysis 
tools. 

Not all of the edits in this tour guide necessarily enhance the image. 
Many exercises are performed simply to show you how they affect 
the image. When you use these techniques on other data sets, you 
may want to experiment with different methods, or combinations of 
methods, to find the techniques that work best.

We highly recommend that you read the section Fourier Analysis 
section, in the "Enhancement" chapter in the ERDAS Field Guide, 
before going through this tour guide.

If you are new to ERDAS IMAGINE, we recommend that you go 
through the tour guide  “Viewer & Geospatial Light Table” before 
using the Fourier Transform Editor.

Approximate completion time for this tour guide is 45 minutes.

Create an .fft 
Layer

In order to use the Fourier Transform Editor, you must first create a 
Fourier Transform (.fft) layer from the input image. 

Display Source File ERDAS IMAGINE must be running and you must have a Viewer open.

1. Select File -> Open -> Raster Layer from the Viewer menu bar.

The Select Layer To Add dialog opens. 
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2. In the Select Layer To Add dialog under Filename, click TM_1.img. 

3. Click the Raster Options tab at the top of the dialog and then select 
Gray Scale from the Display as dropdown list.

4. The Display Layer section updates so that you can select which 
layer of the file to display. Accept the default of Layer 1.

5. Click OK to display the image file in the Viewer.

NOTE: You do not have to display a file before computing the .fft 
layer. This step is included to show you the image before any Fourier 
editing is performed.

Click here to
view the raster
options

Click here to 
select the file
TM_1.img

Click here
to display
the file
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Create FFT Output File

1. Click the Image Interpreter icon on the ERDAS IMAGINE icon panel. 

The Image Interpreter menu displays.

2. Select Fourier Analysis from the Image Interpreter menu.

The Fourier Analysis menu opens.

3. Select Fourier Transform from the Fourier Analysis menu.

The Fourier Transform dialog opens.

4. In the Fourier Transform dialog under Input File, type TM_1.img. 

Click here to
 use the Fourier
 Analysis tools

Click here to
create an FFT
layer

Click here to
start the
Fourier Editor

Enter input
image file
name here

Enter output
.fft file name
 here

Select layers
to use here
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Layer 1 of this file is badly striped. In this example, you work with 
only one layer to make the processing go faster. However, the 
techniques you use are applicable to multiple layers.

5. The name for the Output File, TM_1.fft, is automatically 
generated. Make sure it is in a directory in which you have write 
permission. The default is your default data directory set by Session 
-> Preferences.

6. Enter 1:1 in the Select Layers field.

7. Click OK in the Fourier Transform dialog to create the new file.

A Job Status dialog displays, showing the progress of the function. 
When the process is 100 percent complete, click OK.

Start the Fourier 
Transform Editor

With the .fft file created, you are ready to begin using the Fourier 
Transform Editor.

1. In the Fourier Analysis menu, select Fourier Transform Editor.

The Fourier Editor opens.

2. In the Fourier Editor, click the Open icon  on the toolbar, or select 
File -> Open from the menu bar.

The Open FFT Layer dialog opens.

Menu bar

Toolbar

FFT layer
displayed
here
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3. In the Open FFT Layer dialog under FFT Layer, enter the path and 
name of the .fft layer you created in step 4 through step 5 (for 
example, TM_1.fft).

Since this file contains only one layer, the Layer Number defaults 
to 1. However, if the file contained more than one layer, you could 
choose the layer to edit here. Edits performed on one layer can be 
applied to all layers of the .fft file using the File -> Save All option 
on the Fourier Editor menu bar.

4. Click OK to display the selected file in the Fourier Editor.

A status meter opens as the layer is read. Then the layer displays. 

You can resize the Fourier Editor window to see the entire file.

5. Click any point inside the Fourier Editor and the coordinates of that 
point are shown in the status bar. Hold and drag to dynamically 
update the coordinates. 

Enter FFT
layer to open
here
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Edit Using Menu 
Options

As previously stated, the menu bar and mouse-driven tools offer the 
same techniques and kinds of edits, only the method is different. In 
the menu bar options, you enter all parameters into dialogs. In many 
cases you want to use the mouse to view the coordinates of the .fft 
layer, so that you know what information to enter into the dialogs. 
In the next series of steps, you use some of the menu bar editing 
options. Then, in the next section, you perform many of those same 
edits using the mouse-driven tools. 

Use Low-Pass Filtering Low-pass filtering allows you to attenuate the high-frequency 
components of the image, but allows the low-frequency components 
to pass through.

1. Select Mask -> Filters from the Fourier Editor menu bar.

The Low/High Pass Filter dialog opens.

Fourier Editor Coordinates
The coordinates are referred to as (u,v) with the origin (u,v = 0,0) 
at the center of the image. See the illustration below.

Since Fourier images are symmetrical, a point in one quadrant is 
exactly the same as the corresponding point in the opposite 
quadrant. For example, point (64,170) is the same as point 
(-64,-170). For this reason, all edits are automatically performed 
on both halves of the image at the same time.

u,v

u,-v-u,-v

-u,v

0,0

Select filter
to use here

Select window
function here

Set window
radius here
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2. In the Low/High Pass Filter dialog, click the Window Function 
dropdown list and select Ideal.

An ideal window function produces a sharp transition at the edge of 
the filter.

3. Change the Radius to 10.00.

4. Leave all other parameters as they are and click OK.

A low-pass filter is applied to all values outside of the radius of 10.00. 
Therefore, the image is black, except for a small white circle in the 
center. 

Removing this much of the layer removes much of the content of the 
image, so you may want to undo this edit and try again.

5. Select Edit -> Undo from the Fourier Editor menu bar.

The image is restored to its original state.

Select a Different Filter

1. Select Mask -> Filters.

Filter Types
When the Filter Type is set to Low Pass, its function is the same 

as the Low Pass Filter icon  on the toolbar.

When the Filter Type is set to High Pass, its function is the same 

as the High Pass Filter icon  on the toolbar.

You use these mouse-driven tools later in this tour guide.



Edit Using Menu Options / 242ERDAS IMAGINE Tour Guides

2. In the Low/High Pass Filter dialog, click the Window Function 
dropdown list and select Ideal.

3. Enter a Radius of 80.00.

4. Click OK in the Low/High Pass Filter dialog.

All frequencies outside the radius of 80 are attenuated and 
frequencies inside the radius are unaffected. The .fft layer looks 
similar to the following example:

Save the File

1. Select File -> Save As from the Fourier Editor menu bar.

The Save Layer As dialog opens.

2. In the directory of your choice, enter a name for the new .fft layer, 
such as TM1lowpass.fft.

3. Click OK to save the file.

Enter a new
name for the
FFT layer here
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Apply an Inverse Fourier 
Transformation

Now, perform an inverse Fourier transformation so that you can view 
the original image and see what effect this edit had on it.

You must save your edits before performing an Inverse 
Transform Operation.

1. In the Fourier Editor, click the Run icon  on the toolbar or select 
File -> Inverse Transform from the menu bar.

The Inverse Fourier Transform dialog opens.

2. In the Inverse Fourier Transform dialog under Output File, enter a 
name for the new output file, such as inverse_TM1.img. This file 
has an .img extension by default. Be sure to use a directory in which 
you have write permission.

3. Click OK to create the new file.

A Job Status dialog displays, indicating the progress of the function.

4. When the Job Status dialog indicates that the file is created, click OK 
and then display the file in a Viewer. 

Your file should look similar to the following example:

Be sure to use a
directory in which 
you have write
permission

Enter a new
name for the
.img layer here
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For the other edits performed in this Tour Guide, you can save the 
.fft layer and perform an inverse Fourier transform at any time. The 
steps for doing so are not repeated here. However, the result is 
shown so that you can see how each edit affects the image.

Apply Other Filters

1. In the Fourier Editor, click the Open icon  on the toolbar, or select 
File -> Open from the menu bar.

2. In the Open FFT Layer dialog under FFT Layer, enter the name of 
the first .fft layer you displayed (for example, TM_1.fft).

3. Click OK to display the selected file in the Fourier Editor.

4. When the file displays, select Mask -> Filters from the Fourier 
Editor menu bar.

5. In the Low/High Pass Filter dialog, click the Window Function 
dropdown list and select Butterworth.

This is a smoother function than the Ideal. Use a radius of 80.00, just 
as with the Ideal. 

6. Change the Radius to 80.00.

7. Click OK in the Low/High Pass Filter dialog.

The .fft layer and the resulting image are shown in the following 
picture:
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This filter eliminated much of the image content because the radius 
was too small.

8. Try this same exercise using a Radius of 300.00, rather than 80.00

The resulting image looks like the following example:

The image is visibly smoothed (perhaps too much). However, the 
striping remains. You remove the stripes using the wedge filter later 
in this tour guide. You could try using the Butterworth filter with an 
even larger radius or the other windows. 

The following graphics illustrate some of these other scenarios.
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9. Redisplay the original .fft layer in the Fourier Editor.

Use a Circular Mask There are several bright spots in the .fft layer, such as those in the 
upper left quadrant. These can be eliminated using the circular mask 
option.

1. With your cursor in the Fourier Editor, click in the center of one of 
these bright areas. There is one at (u,v) = (-59,-200). You use this 
coordinate here, but you can use another if you like.

Type: Low Pass
Window: Hanning
Radius: 100.00

Type: High Pass
Window: Hanning
Radius: 20.00

Type: Low Pass
Window: Bartlett
Radius: 150.00

Type: Low Pass
Window: Gaussian
Radius: 200.00
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2. When you have selected a coordinate, select Mask -> Circular 
Mask from the Fourier Editor menu bar.

The Circular Mask dialog opens.

This option is the same as if you were to click the Circular Mask icon 

 on the toolbar.

3. In the Circular Mask dialog, click the Window Function dropdown 
list and select Butterworth.

4. Enter -59 for the Circle Center, U and -200 for the Circle Center, 
V.

5. Enter a Circle Radius of 20.

6. Click OK in the Circular Mask dialog to edit the .fft layer.

The bright spot disappears. This edit does not affect the appearance 
of this particular image very much, since it is such a small area and 
because the edited area is quite far from the center of the image 
where most of the image content is contained. However, this 
technique can be used to remove spikes caused by errant detectors 
and other types of periodic noise that are manifested by 
concentrated areas of high or low frequency in the .fft layer.

As an experiment, you create two circles of low frequency to see how 
they affect the image.

7. In the Fourier Editor, select Mask -> Circular Mask.

8. In the Circular Mask dialog, enter a Circle Center, U of 44 and a 
Circle Center, V of 57.

9. Enter a Circle Radius of 20.00 and a Central Gain of 10.00.

10. Click OK in the Circular Mask dialog.

The .fft layer and resulting image look like the following example:

Select window
function here

Enter center
coordinate here

Enter radius here
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The resulting image has a pronounced diagonal striping, in addition 
to the original striping.

NOTE: Remember to select another circle center coordinate before 
trying each new window.

Use a Rectangular Mask The rectangular mask allows you to mask a rectangular area of the 
.fft layer. This is similar to the circular mask in that it allows you to 
edit non-central regions of the Fourier image.

1. Make sure the .fft file you created in the previous section, “Use a 
Circular Mask”, displays in the Fourier Editor.

2. In the Fourier Editor menu bar, select Mask -> Rectangular Mask.

The Rectangular Mask dialog opens.

3. In the Rectangular Mask dialog, click the Window Function 
dropdown list and select Ideal.

4. Enter an upper left u (UL U) of 80 and an upper left v (UL V) of 80. 

5. Enter a lower right u (LR U) of 255 and a lower right v (LR V) of 
255.

6. Click OK in the Rectangular Mask dialog.

Select window
function here

Enter coordinates
of rectangle here
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The top left and bottom right corners of the .fft layer are black. To 
mask the other two corners, you must repeat this procedure.

7. Select Mask -> Rectangular Mask.

8. In the Rectangular Mask dialog, click the Window Function 
dropdown list and select Ideal.

9. Enter an upper left u (UL U) of 80 and an upper left v (UL V) of 
-255. 

10. Enter a lower right u (LR U) of 255 and a lower right v (LR V) of -80.

11. Click OK in the Rectangular Mask dialog.

The top, right and bottom, left corners of the .fft layer are now black 
also, making the .fft layer look like a cross. 

The resulting image is visibly smoother than the original.

Use a Wedge Mask The wedge mask option is often used to remove striping in imagery 
that appears in the .fft layer as radial lines. Most of the striping in 
the Landsat image you are using is manifested in the .fft layer as the 
bright, nearly vertical line that passes through the origin. 

1. If it is not already displayed, open the original .fft layer in the Fourier 
Editor (that is, TM_1.fft).

2. With your cursor in the Fourier Editor, click in the center of one of 
the bright areas that make up the line. You need to enter this 
information in the dialog. For this example, you use (35, -187).

3. Select Mask -> Wedge Mask.

The Wedge Mask dialog opens.



Edit Using Menu Options / 250ERDAS IMAGINE Tour Guides

4. In the Wedge Mask dialog for the Center Angle, enter the following 
expression to calculate the center of the wedge, based on the 
coordinate that you selected.

-atan(-185/36)

5. Press Enter on your keyboard. The value returned is 78.99.

6. Enter a Wedge Angle of 10.00.

This is the total angle of the wedge, in this case, 5.00 degrees on 
either side of the center.

7. Click OK to edit the layer.

The resulting .fft layer looks similar to the following example:

Select window
function here

Wedge Mask Angles
The angles are measured as shown in the illustration below.

0,0
0°

90°

180°

270° (-90°)

45°

315° (-45°)
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After performing an inverse Fourier transform, the resulting image is 
destriped.

Edit Using 
Mouse-Driven 
Tools

The mouse-driven tools allow you to perform the same types of edits 
as in the menu options, but they are a bit easier to use since they 
are more interactive than the dialogs. You can extend a filter radius 
or indicate where to place a mask simply by dragging the mouse. 

1. If it is not already displayed, open the original .fft layer in the Fourier 
Editor (for example, TM_1.fft).

2. From the Fourier Editor menu bar, select Edit -> Filter Options.

The Filter Options dialog opens.

This is where you set the window that is used for all subsequent 
mouse-driven editing options. However, you can change this window 
at any time. The Minimum Affected Frequency option allows you 
to enter the minimum frequency value that is affected by the filter. 
Setting this value to a number less than 10.00 might eliminate very 
low frequency data that are crucial to the content of the image.

3. In the Filter Options dialog, click the Window Function dropdown 
list and select Ideal.

Select window 
function here 
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4. Click OK.

Use Low-Pass Filtering The first tool you use is the Low-Pass Filter tool.

1. Click the Low-Pass Filter icon  on the Fourier Editor toolbar.

2. With your cursor in the center of the Fourier Editor, drag toward the 
right until the u coordinate in the status bar reads 80. Then release 
the mouse.

The image is filtered as soon as the mouse is released. This is 
equivalent to the second filtering operation you performed using the 
menu bar tools. 

You can select Edit -> Undo at any time to undo an edit. Select File 
-> Revert to undo a series of edits. The Low-Pass Filter tool remains 
active until you either select another tool or click the Select tool.

Use High-Pass Filtering Next, you use the High-Pass Filter tool.

1. Select Edit -> Filter Options from the Fourier Editor menu bar.

2. In the Filter Options dialog, click the Window Function dropdown 
list and select Hanning.

3. Click OK in the Filter Options dialog.

4. Click the High-Pass Filter icon  on the toolbar.

5. With your cursor in the center of the Fourier Editor, drag toward the 
right until the u coordinate in the status bar reads 20. Release the 
mouse button.

The image is filtered as soon as the mouse is released. The 
combination of filters (both Low-Pass and High-Pass) is shown in the 
following example:
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6. Select File -> Save As from the menu bar.

The Save Layer As dialog opens.

7. In the Save Layer As dialog, enter a new name for the .fft layer, such 
as TMhighpass.fft. Be sure to use a directory in which you have 
write permission.

8. Click OK to save the layer.

9. Click the Run icon  on the toolbar, or select File -> Inverse 
Transform from the menu bar to create an inverse Fourier layer for 
display.

10. In the Inverse Fourier Transform dialog, enter a name for the new 
.img layer in the directory of your choice, such as 
TM1highpass.img.

11. Click OK.

A Job Status dialog displays, indicating the progress of the function.

12. When the Job Status dialog indicates that the new .img layer is 
created, click OK and then display the layer in a Viewer.

Your new image should look similar to the following example:

Apply a Wedge Mask In the next exercise, you remove the nearly vertical radial line in the 
image, thereby removing the striping in the original image.

1. Redisplay the original .fft layer in the Fourier Editor if you have not 
already done so.

2. The Hanning window is still selected from the previous section, so 
you do not change it. 
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3. Click the Wedge Mask icon  on the toolbar.

4. Using the following example as a guide, with your cursor over the 
center of the line, drag to the right until the lines of the wedge are 
about 20 degrees apart. Release the mouse button.

The image is filtered as soon as you release the mouse, and similar 
to the following example. The resulting image is also shown.

Combine Edits You may combine as many edits as you like during an editing 
session. Since the Fourier Transform and Inverse Fourier Transform 
are linear operations, the effect of each edit on the resulting image 
is independent of the others. Here, you perform a low-pass filter over 
the wedged .fft layer that you just created.

Position your cursor 
in this area
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1. With the .fft layer that you just created displayed in the Fourier 

Editor, click the Low-Pass Filter tool  .

2. With your cursor in the center of the Fourier Editor, drag toward the 
right until the u coordinate in the status bar is about 200.

The .fft layer and resulting image look similar to the following:
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Image Interpreter

Introduction Image Interpreter is a group of over 50 functions that can be applied 
at the touch of a button to images with parameters you input. Most 
of the Image Interpreter functions are algorithms constructed as 
graphical models with Model Maker. These algorithms are common 
enhancements and utilities that have been made easily accessible 
through the Image Interpreter. 

NOTE: Some of these functions are found in other parts of ERDAS 
IMAGINE, but are also listed in Image Interpreter for convenience.

The models used in Image Interpreter functions can be edited and 
adapted as needed with Model Maker (from Spatial Modeler) or the 
Spatial Modeler Language.

See the Spatial Modeler section of this manual for a description 
of the relationship between Spatial Modeler Language, Model 
Maker, and Image Interpreter. See the chapter "Geographic 
Information Systems" in the ERDAS Field Guide for more 
information on modeling.

Approximate completion time for this tour guide is 50 minutes.

Subsetting an 
Image

Many images used in IMAGINE cover a large area, while the actual 
area being studied can only cover a small portion of the image. To 
save on disk space and processing time, IMAGINE lets you make new 
images out of a subset of the entire data set. 

In this exercise, you use the Subset Utility to take a subset of a small 
urbanized Area of Interest (AOI) from a much larger Landsat scene 
of San Diego.

ERDAS IMAGINE should be running with a Viewer open.

1. Select File -> Open Raster Layer from the Viewer menu bar.

The Select Layer to add dialog opens.
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2. Select dmtm.img from the list of examples.

3. Click OK to have the image display in the Viewer.

Selecting an AOI to 
Subset

In this section, you use the Subset utility to take a small Subset from 
a large image without using the Snap to Raster option.

1. With the cursor in the Viewer, right-click to access the Quick View 
menu.

2. Select Inquire Box... from the Quick View menu. The Inquire Box 
dialog displays. The title of this dialog is Viewer #1: dmtm.img.

3. Click the Snap to Raster checkbox to uncheck this option. This tells 
the Subset function to use the exact coordinates you enter for the 
Inquire Box.

4. Enter the following coordinates into the Inquire Box dialog:

ULX: 1698385.570
ULY: 288632.691217
LRX: 1702282.557434
LRY: 284900.708704

5. Click Apply on the Inquire Box dialog. The Inquire Box moves to the 
new coordinates.

6. Click the Zoom In icon  to zoom in on the Area of Interest.

The image in your Viewer should look something like this:

Click OK 
Select 
dmtm.img

Uncheck the
Snap to Raster
checkbox

Enter these
coordinates
in the Inquire
Box dialog.
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Subsetting an Image 
Without Snapping

1. Click the Interpreter icon on the ERDAS IMAGINE icon panel.

The Image Interpreter menu opens. Each of the buttons in the 
Image Interpreter menu displays a submenu of Image Interpreter 
functions

2. Select Utilities from the Image Interpreter menu and the 
Utilities menu opens.

Note that the corners
of the Inquire Box
are not snapped
to the pixel centers.

Ellipses indicate
that these buttons
display another dialog
with additional 
options

Click here to see
an On-Line Help
file describing this
dialog
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3. Select Subset from the Utilities menu and the Subset dialog opens.

4. Under Input File in the Subset dialog, enter dmtm.img.

This is a Landsat TM image of San Diego, California.

Click here to see
an On-Line Help
file describing this
dialog

Enter input file here
Enter output
file here

Click here to import
coordinates
from the Inquire Box
in the Viewer

Click here to start
the Subsetting process
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5. Under Output File, enter subset_no_snap.img in a directory 
where you have write permission.

6. Click OK to begin the Subsetting process.

A Job Status bar displays, indicating the progress of the subsetting 
operation.

7. Depending on your eml Preferences (under Session -> 
Preferences -> User Interface & Session -> Keep Job Status 
Box), when the Job Status bar shows 100, indicating that the job is 
100% done, you must either click OK to close the dialog or the dialog 
closes automatically.

Displaying the Subset 
with the Original Data

1. The original image should still be displayed in the Viewer.

2. Select File -> Open -> Raster Layer from the menu bar on the 
Viewer. 

The Select Layer to Add dialog displays.

3. Click the Recent button to open a list of recently accessed files.

4. Select subset_no_snap.img from the List of Recent Files.

5. Click OK to dismiss the List of Recent Files.

6. Click the Raster Options tab.

Status
updates here 

Title bar tells 
which function 
is running 

Click here to
open a list 
of recently
accessed files

Click here
to access the
Raster Options
tab
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7. Uncheck the Clear Display option so the new subset of the original 
image appears superimposed on the original image.

8. Click OK.

The subset displays in the Viewer over the original image.

When a subset of an image is taken from an Inquire Box that is not 
snapped to the pixel grid of the original image, the subset is drawn 
using the exact coordinates of the of the Inquire Box. Because the 
subset pixel grid differs slightly from the original image’s pixel grid, 
the subset image appears “shifted” from the original image.

9. Click the Clear Top Layer icon  to remove subset_no_snap.img 
from the Viewer.

Click here
to uncheck
the Clear Display
option

Note the original
Inquire Box

The darker pixels
belong to the subset

The pixels appear to “shift.”
Actually, the pixels are redrawn
to match the exact coordinates
of the Inquire Box. Note how 
the corner of the Inquire box
is centered in the Subset pixel.
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The original image and the Inquire Box should still be displayed in 
the Viewer.

Subsetting an Image 
With Snap to Raster

1. In the Inquire Box dialog, click the Snap to Raster checkbox to 
make sure it is active (checked). Click Apply. 

The Inquire Box snaps to the pixels centers and looks like this:

The coordinates in the Inquire Box dialog update to reflect the new 
corner coordinates.

2. In the Utilities dialog, click the Subset button. The Subset dialog 
displays.

3. Under Input File, enter dmtm.img.

4. In the Output File, enter subset_snap.img in a directory where 
you have write permission.

5. Click the From Inquire Box button. 

The coordinates in the Subset Definition area update to reflect the 
corner coordinates of the Inquire Box.

6. Click OK to start the Subsetting Process.

The Subsetting Progress meter opens, displaying the progress of the 
subsetting.

The Inquire Box
snaps to the center

These guides appear
to show the edges

of the included pixels.

of the included pixels.
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Viewing the Snapped 
Subset

1. Select File -> Open -> Raster Layer from the menu bar in the 
Viewer.

The Select Layer to Add dialog opens.

2. Click the Recent button.

The List of Recent Files dialog displays.

3. Select subset_snap.img from the list. 

4. Click OK on the List of Recent Files to close the dialog.

5. Click the Raster Options tab in the Select Layer to Add dialog.

6. Deselect the Clear Display option.

7. Click OK to open subset_snap.img in the Viewer on top of 
dmtm.img.

The subsetted image displays in the Viewer.

Because the Inquire Box was snapped to the centers of the pixels 
before the image was processed, the pixels in the output file lines up 
exactly with the pixels in the original image.

8. Click Close on the Viewer.

9. Click Close on the Utilities menu.

The pixels line up
with the pixels
in the original image.
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Apply Spatial 
Enhancement

ERDAS IMAGINE should be running with a Viewer open.

In this section, you use the convolution and crisp Spatial 
Enhancement functions to enhance images.

1. Click the Interpreter icon on the ERDAS IMAGINE icon panel. 

The Image Interpreter menu opens.

2. Select Spatial Enhancement from the Image Interpreter menu 
and the Spatial Enhancement menu opens.

Apply Convolution

1. Select Convolution from the Spatial Enhancement menu and the 
Convolution dialog opens.

Click here to see
an On-Line Help
file describing this
dialog
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This interactive Convolution tool lets you perform convolution 
filtering on images. It provides a scrolling list of standard filters and 
lets you create new kernels. The new kernels can be saved to a 
library and used again at a later time.

NOTE: Do not close the Image Interpreter menu, as you continue 
using it in the next section.

Select Input/Output Files

1. In the Convolution dialog, under Input File, enter lanier.img. 

2. Under Output File, enter convolve.img in the directory of your 
choice. It is not necessary to add the .img extension when typing the 
file name—ERDAS IMAGINE automatically appends the correct 
extension. 

NOTE: Make sure you remember in which directory the output file is 
saved. This is important when you try to display the output file in a 
Viewer.

Select Kernel Next, you must select the kernel to use for the convolution. A default 
kernel library containing some of the most common convolution 
filters is supplied with ERDAS IMAGINE. This library opens in the 
Kernel Selection part of this dialog.

1. From the scrolling list under Kernel, click 3x3 Edge Detect.

2. Click the Edit button in the Kernel Selection box. 

Click here to
add this function
to a batch file

Click here to
apply this function
to an area of interest

Enter input file here

Edit selected
kernel or
create new one

Enter kernel to use Enter output file hereSelect kernel
from this
scroll list
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The 3 × 3 Edge Detect dialog opens. 

For this exercise, you use the Kernel Editor to simply view the kernel 
used for the 3 × 3 Edge Detect filter. However, if desired, you could 
make changes to the kernel at this time by editing the CellArray.

3. Select File -> Close from the 3 × 3 Edge Detect dialog. 

4. Click OK in the Convolution dialog. 

A Job Status dialog displays, indicating the progress of the function.

5. When the Job Status dialog shows that the process is 100% 
complete, click OK.

Check the File

1. Select File -> Open -> Raster Layer from the Viewer menu bar.

The Select Layer To Add dialog opens.

2. In the Select Layer To Add dialog under Filename, click lanier.img. 

3. Click OK to display the file in the Viewer.

4. Open a second Viewer window by clicking on the Viewer icon on the 
ERDAS IMAGINE icon panel. 

5. Select File -> Open -> Raster Layer from the menu bar of the 
Viewer you just opened.

The Select Layer To Add dialog opens.
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6. In the Select Layer To Add dialog under Filename, enter the name 
of the directory in which you saved convolve.img, and press the 
Enter key on your keyboard.

7. In the list of files, click convolve.img and then click OK.

The output file generated by the Convolve function, convolve.img, 
displays in the second Viewer.

8. In the ERDAS IMAGINE menu bar, select Session -> Tile Viewers 
to compare the two files side by side.

9. When you are finished comparing the two files, select File -> Clear 
from the menu bar of each Viewer.

Apply Crisp

1. Select Crisp from the Spatial Enhancement menu. 

The Crisp dialog opens.
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The Crisp dialog is a good example of the basic Image Interpreter 
dialog. Other dialogs may have more prompts for inputs, depending 
on the function. Each dialog opens with default entries that are 
acceptable for use. These entries can be changed, if necessary, to 
achieve specific results. 

2. Under Input File in the Crisp dialog, enter panAtlanta.img. 

This is a SPOT panchromatic scene of downtown Atlanta, Georgia.

3. Under Output File, enter crisp.img in the directory of your choice 
as the output file. 

4. Under Output Options in the Crisp dialog, turn on the Stretch to 
Unsigned 8 bit checkbox by clicking on it.

This option produces the output file in unsigned 8-bit format, which 
saves disk space.

Use the View Option

1. Click the View button at the bottom of the Crisp dialog. 

The Model Maker viewer window opens and displays the graphical 
model used for the Crisp function.

Click here to 
view or edit the 
graphical model 
for this function 

Click here to 
add this function 
to a batch file Click here to 

apply this function 
to an area of interest 

Enter input file here Enter output 
file here 
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The View button in each Image Interpreter dialog lets you view the 
graphical model behind each function. If you want to change the 
model for a specific purpose, you can edit it through the Model Maker 
and apply the edited function to the image by running the model in 
Model Maker.

See  “Spatial Modeler” for information on editing and running a 
model in Model Maker.

2. Exit the Model Maker by selecting File -> Close All. 

3. Click OK in the Crisp dialog to start the process. 

A Job Status dialog opens, indicating the progress of the function.

4. When the Job Status dialog shows that the process is 100% 
complete, click OK.

View Results

1. Display panAtlanta.img in a Viewer.

2. Display crisp.img, the output file generated by the Crisp function, 
in the other Viewer. 
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3. Note the differences between the two images; crisp.img appears to 
be sharper. 

4. Use the Zoom In icon in the Viewer toolbar to zoom in for a closer 
look at the crispening of the image in crisp.img. 

5. When you are through, close all the Viewers at once by selecting 
Session -> Close All Viewers from the ERDAS IMAGINE menu bar. 

6. Click Close in the Spatial Enhancement menu.

NOTE: Do not close the Image Interpreter menu, as you continue 
using it in the next section.

Apply Radiometric 
Enhancement

1. In the Image Interpreter menu, select Radiometric 
Enhancement.

The Radiometric Enhancement menu opens.
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In this section, you use both the Inverse and Reverse options of 
the Image Inversion function to enhance images. Inverse 
emphasizes detail in the dark portions of an image. Reverse simply 
reverses the DN values.

Apply Brightness 
Inversion

1. In the Radiometric Enhancement menu, select Brightness 
Inversion.

The Brightness Inversion dialog opens.

2. In the Brightness Inversion dialog under Input File, enter 
loplakebedsig357.img.

3. Under Output File, enter inverse.img in the directory of your 
choice.

4. Under Output Options, turn on the Stretch to Unsigned 8 bit 
checkbox by clicking on it.

5. Under Output Options, click Inverse.

6. Click OK in the Brightness Inversion dialog to start the process. 

Click here to access
the Brightness Inversion
function

Select option
here

Enter output
file name here

Select this option
to reduce file size

Click here
to see model
in Model Maker
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A Job Status dialog displays, indicating the progress of the function.

Reverse

1. Select Brightness Inversion from the Radiometric 
Enhancement menu.

The Brightness Inversion dialog opens.

2. In the Brightness Inversion dialog, enter loplakebedsig357.img as 
the input file.

3. Enter reverse.img in the directory of your choice as the Output 
File.

4. Turn on the Stretch to Unsigned 8 bit checkbox under Output 
Options.

5. Click OK in the Brightness Inversion dialog to start the process. 

A Job Status dialog displays, indicating the progress of the function.

View Changes

1. Open a Viewer and display inverse.img. 

2. Right-hold within the Viewer and select Fit Window to Image from 
the Quick View menu. 

The Viewer changes size to bound the image data.

3. Select View -> Split -> Split Vertical from the Viewer menu bar. 

A second Viewer opens.

4. In the second Viewer, click the Open icon  (this is the same as 
selecting File -> Open -> Raster Layer from the Viewer menu 
bar).

The Select Layer To Add dialog opens.

5. From the Select Layer To Add dialog, open the file reverse.img.

6. In the second Viewer, select View -> Split -> Split Vertical from 
the Viewer menu bar.

A third Viewer opens.

7. With your cursor in Viewer #3, press Ctrl-r on your keyboard (this 
is just another way to open a raster layer). 

The Select Layer To Add dialog opens.

8. From the Select Layer To Add dialog, open the file 
loplakebedsig357.img. 

9. Resize the Viewers on screen so that you can see all three Viewers. 
Note the differences between reverse.img and inverse.img 
compared to the original file. 
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10. When you are through, close all three Viewers by selecting Session 
-> Close All Viewers from the ERDAS IMAGINE menu bar.

11. Click Close in the Radiometric Enhancement menu.

NOTE: Do not close the Image Interpreter menu, as you continue 
using it in the next section.

Apply Spectral 
Enhancement

1. In the Image Interpreter menu, click Spectral Enhancement.

Original image

Reverse image Inverse image
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The Spectral Enhancement menu opens.

In this section, you use the following Spectral Enhancement 
functions:

• Tasseled Cap

• RGB to IHS

• IHS to RGB

• Indices 

Use Tasseled Cap

1. In the Spectral Enhancement menu, select Tasseled Cap.

The Tasseled Cap dialog opens.

Click here to select
Tasseled Cap 
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2. Under Input File, enter lanier.img. That image is a Landsat TM 
image of Lake Lanier, Georgia, which was obtained by the Landsat 5 
sensor.

3. Enter tasseled.img in the directory of your choice as the Output 
File name. 

4. Under Output Options, turn on the Stretch to Unsigned 8 bit 
checkbox by clicking on it.

5. Click Set Coefficients.

The Tasseled Cap Coefficients dialog opens.

The coefficients that display are the standard default entries for 
Landsat 5 TM Tasseled Cap transformation. For this exercise, you 
use the default entries, although you may change these entries at 
any time.

Enter input 
file here

Enter output 
file here

Click to 
select this
option

Click to set
coefficients
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6. Click OK in the Tasseled Cap Coefficients dialog. 

7. Click OK in the Tasseled Cap dialog to start the function. 

A Job Status dialog opens to report the state of the job. 

8. When the Job Status dialog indicates that the job is Done, click OK.

Check Results

1. Open a Viewer and display lanier.img. 

2. Open a second Viewer and then open the Select Layer To Add dialog 
by clicking on the Open icon in the Viewer toolbar.

3. In the Select Layer To Add dialog, enter the name of the directory in 
which you saved tasseled.img, press Enter on your keyboard, and 
then click tasseled.img in the file list to select it. 

4. Click the Raster Options tab at the top of the Select Layer To Add 
dialog. Under Layers to Colors, use layer 1 as Red, layer 2 as 
Green, and layer 3 as Blue.

5. Click OK in the Select Layer To Add dialog.

The image, tasseled.img, shows a degree of brightness, greenness, 
and wetness, as calculated by the Tasseled Cap coefficients used.

• Layer 1 (red) = the brightness component (indicates areas of low 
vegetation and high reflectors)

• Layer 2 (green) = the greenness component (indicates 
vegetation)
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• Layer 3 (blue) = the wetness component (indicates water or 
moisture)

6. When you are through, close the Viewers by selecting Session -> 
Close All Viewers from the ERDAS IMAGINE menu bar. 

Use the Indices Function Next, you apply a mineral ratio from the Indices function to a 
Landsat TM image. Such ratios are commonly used by geologists 
searching for specific mineral deposits in the earth. 

For more information on this transformation, see the chapter 
"Enhancement" in the ERDAS Field Guide. 

1. In the Spectral Enhancement menu, select Indices.

The Indices dialog opens.

2. Under Input File, enter tmAtlanta.img.

3. Enter mineral.img in the directory of your choice as the Output 
File.

4. Under Select Function, click MINERAL COMPOSITE in the 
scrolling list. 

This index is a composite of three mineral ratios.

• Clay minerals = band 5 / band 7

• Ferrous minerals = band 5 / band 4

Enter input
file here

Enter output
file here

Click to 
select this
option

Click to select
sensor type

Function 
scroll list

Function definition
displays here for
selected function
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• Iron oxide = band 3 / band 1

NOTE: Notice how the selected function is defined beside the 
Function label, underneath the Select Function scroll list. 

5. Under Output Options, turn on the Stretch to Unsigned 8 bit 
checkbox by clicking on it.

6. Click OK in the Indices dialog to start the process. 

A Job Status dialog displays, indicating the progress of the function.

7. When the Job Status dialog indicates that the job is Done, click OK.

Choose RGB to IHS Next, you use the RGB to IHS function (red, green, blue to intensity, 
hue, saturation) and the reverse IHS to RGB function to enhance 
the image information obtained by this mineral ratio. 

The purpose of this function is to produce an input file for the IHS to 
RGB function.

1. Select RGB to IHS from the Spectral Enhancement menu. 

The RGB to IHS dialog opens.

2. Enter the mineral ratio output from the previous exercise 
(mineral.img) as the Input File. 

3. Enter RGBtoIHS.img (in the directory of your choice) as the 
Output File. 

4. Click OK in the RGB to IHS dialog. 

A Job Status dialog displays, reporting the progress of the function. 

5. When the Job Status dialog indicates that the job is Done, click OK.

Choose IHS to RGB Now, you convert the IHS image back into an RGB image. 

1. Select IHS to RGB from the Spectral Enhancement menu. 

The IHS to RGB dialog opens.
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2. In the IHS to RGB dialog, enter RGBtoIHS.img output from the 
previous exercise as the Input File. 

3. Enter IHStoRGB.img as the Output File in the directory of your 
choice.

4. On the IHS to RGB dialog, click Stretch I & S. 

This option applies a global Min-Max contrast stretch to the Intensity 
and Saturation values in the image before converting.

5. Click OK in the IHS to RGB dialog. 

A Job Status dialog displays, reporting the progress of the function. 

6. When the Job Status dialog indicates that the job is Done, click OK.

View the Results

1. Open three Viewers and then open the following files for comparison.

• mineral.img—mineral ratio index. Proper interpretation can 
reveal the presence or absence of iron, clay, or ferrous minerals.
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• RGBtoIHS.img—red, green, and blue values converted to 
intensity, hue, and saturation values. This image does not appear 
similar to the input file. It is not meant for interpretation; it is 
only meant to produce an input for the IHS to RGB function.

• IHStoRGB.img (see special instructions below)—intensity, hue, 
and saturation values converted to red, green, and blue values 
(appears similar to mineral.img). The intensity and saturation 
(red and blue) values have been contrast-stretched for better 
interpretation.
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In the Open Raster Layer dialog, when displaying 
IHStoRGB.img, be sure to load Layer 1 as Red, Layer 2 as 
Green, and Layer 3 as Blue. This is because the order of the 
layers was reversed in the transformation.

2. When you are through comparing the files, close the Viewers by 
selecting Session -> Close All Viewers in the ERDAS IMAGINE 
menu bar.

3. Click Close in the Image Interpreter menu. Click Close in the 
Spectral Enhancement menu.

The Image Interpreter and Spectral Enhancement menus close.

Wavelet 
Resolution Merge

Part of the Spatial Enhancement menu is the Wavelet Resolution 
Merge feature. This tour will cover the feature by using two images 
from the IMAGINE examples directory, 
Quickbird_Pyramids_Pan.img and 
Quickbird_Pyramids_MS.img. Both images are of the Egyptian 
pyramids and are courtesy of DigitalGlobe. Because both of these 
images have been captured by the same satellite, they are 
inherently coregistered. Before performing Wavelet Resolution 
Merge on your own images, you should precisely coregister them to 
the subpixel level. For more information on how to do this, see the 
tour for Subpixel Coregistration at the end of the chapter on 
Polynomial Rectification.
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In addition to being precisely coregistered, your images must 
also have the same footprint on the ground. Wavelet Resolution 
Merge will not produce the expected results if one image covers 
more ground than the other image. In that case the images are 
rewritten to fit one another by the geographic footprint rather 
than actual map coordinates causing pixel replication.

1. Open a Viewer, and click File -> Open -> Raster Layer or the open 
file icon to display the Select Layer to Add dialog.

2. Hold down the Ctrl key or the Shift key and select 
QuickBird_Pyramids_MS.img and 
Quickbird_Pyramids_Pan.img.

3. Click the Raster Options tab, and click Clear Display to deselect 
it. Click Fit to Frame, and OK.

You may want to rotate the image in the Viewer by clicking View -> 
Rotate. A dialog will appear giving you degree and rotation direction 
options. Whether or not to rotate the image is up to you.

4. In the Viewer menu, click Utility -> Swipe to open the Viewer 
Swipe dialog.

5. In the Viewer Swipe dialog, take a few minutes to manually move the 
swipe feature over the images both horizontally and vertically, so 
you can see how precisely they are matched. You can also use the 
Auto Mode and adjust its speed to your preference. When you are 
finished, click Cancel in the Viewer Swipe dialog.

6. Next, click the Zoom In icon, and zoom in on some features that 
interest you. This exercise also gives you a good idea of how well the 
two images are matched. You can use the Zoom In and Zoom Out 
icons to adjust your view. When you are finished, click the Reset 
Window Tools or arrow icon to return to the arrow cursor.

7. Click the Interpreter button in the IMAGINE toolbar.

The Image Interpreter dialog opens.

Choose Spatial
Enhancement

Click Close
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8. Select Spatial Enhancement, and click Close in the Image 
Interpreter dialog after the Spatial Enhancement dialog opens. 

9. Select Wavelet Resolution Merge. After the Wavelet Resolution 
Merge dialog opens, click Close in the Spatial Enhancement dialog.

10. Click the open file icon, and select Quickbird_Pyramids_Pan.img 
for the High Resolution Input File.

11. Click the open file icon, and select Quickbird_Pyramids_MS.img 
for the Multispectral Input File.

12. Click the open file icon, navigate to the directory where you want to 
store your merged image, and type the name of the new file.

13. Under Layer Selection, you can type in the range of bands to use 
in the Select Layers box. For this exercise, you will leave the range 
at 1:4.

Choose Wavelet
Resolution
Merge

Click Close
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14. Leave the Spectral Transform at Single Band.

NOTE: The IHS technique is limited to 3 bands, and there are 4 to be 
considered for this merge. If you chose IHS instead of Single Band, 
there would be distortions. Single band will use all 4 bands 
sequentially.

15. Leave the Resampling Technique, Data Type, and Output 
Options at their defaults.

16. Click OK.

The Wavelet Resolution Merge processing dialog appears.

17. Click OK when the button is highlighted and the Job State is Done.

18. Open a Viewer and display both Quickbird_Pyramids_MS.img and 
your new merged image. Make sure you click Clear Display in 
Raster Options to deselect it before adding each image.

19. Using the Swipe and Zoom tools, check the accuracy of the newly 
merged image.
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Orthorectification

Introduction Rectification is the process of projecting the data onto a plane and 
making it conform to a map projection system. Assigning map 
coordinates to the image data is called georeferencing. Since all map 
projection systems are associated with map coordinates, 
rectification involves georeferencing.

The orthorectification process removes the geometric distortion 
inherent in imagery caused by camera/sensor orientation, 
topographic relief displacement, and systematic errors associated 
with imagery. Orthorectified images are planimetrically true images 
that represent ground objects in their true “real-world” X and Y 
positions. For these reasons, orthorectified imagery has become 
accepted as the ideal reference image backdrop necessary for the 
creation and maintenance of vector data contained within a GIS.

By performing space resection, the effects of camera/sensor 
orientation have been considered and removed. By defining a DEM 
or constant elevation value (ideal for use in areas containing minimal 
relief variation), the effects of topographic relief displacement can be 
considered and removed.

For information on bundle block adjustment, see the Leica 
Photogrammetry Suite (LPS) Project Manager User’s Manual and 
LPS Automatic Terrain Extraction User’s Manual.

Approximate completion time for this tour guide is 30 minutes.

Rectify a Camera 
Image

In this tour guide, you orthorectify a camera image of Palm Springs, 
California, using a NAPP (National Aerial Photography Program) 
photo. 

Perform Image to Image 
Rectification

In rectifying the camera image, you use these basic steps:

• Display a camera image.

• Start the Geometric Correction Tool.

• Enter the Camera model properties.

• Record GCPs.

• Resample or calibrate the image.
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Prepare ERDAS IMAGINE should be running and a Viewer open. 

You must have write permission in a file if you wish to calibrate it. 

1. In a command shell or Windows Explorer, navigate to the 
<<IMAGINE_HOME>/examples directory.

2. Copy the file ps_napp.img to a directory in which you have write 
permission and at least 10 Mb of space. 

Resampling vs. Calibration

Resampling
Resampling is the process of calculating the file values for the 
rectified image and creating the new file. All of the raster data 
layers in the source file are resampled. The output image has as 
many layers as the input image.

ERDAS IMAGINE provides these widely-known resampling 
algorithms:

• Nearest Neighbor

• Bilinear Interpolation

• Cubic Convolution

• Bicubic Spline

Calibration
Instead of creating a new, rectified image by resampling the 
original image based on the mathematical model, calibrating an 
image only saves the mathematical model into the original image 
as a piece of auxiliary information. Calibration does not generate 
new images, so when the calibrated image is used, the math 
model comes into play as needed. 

For example, if you want to see the calibrated image in its rectified 
map space in a Viewer, the image can be resampled on the fly 
based on the math model, by selecting the Orient image to map 
system option in the Select Layer To Add dialog.

A major drawback to image calibration is that the processes 
involved with the calibrated image is slowed down significantly if 
the math model is complicated. One minor advantage to image 
calibration is that it uses less disk space and leaves the image’s 
spectral information undisturbed.

NOTE: We recommend that image calibration be used only when 
necessary, due to the drawbacks of the process.
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3. Set the permissions on ps_napp.img to read, write, execute on 
UNIX by using the command chmod 777 ps_napp.img, or on 
Windows by right-clicking on the file, selecting Properties and 
deselecting the Read-only option. 

Next, you should verify that ps_napp.img has no map or projection 
information.

4. Select Tools -> Image Information from the ERDAS IMAGINE 
menu bar.

5. Click the Open icon  , then navigate to the location where you 
saved ps_nappimg.

6. Select the file, then click OK in the Image Files dialog to open your 
copy of ps_napp.img.

7. Select Edit -> Delete Map Model.

8. Click Yes in the Attention dialog that opens. 

9. Select File -> Close to dismiss the ImageInfo dialog.

Click Yes—you will
apply a projection
system to the image
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Review Image 
Information

1. Select File -> Open -> Raster Layer from the Viewer menu bar, or 

click the Open icon  on the Viewer toolbar. 

The Select Layer To Add dialog opens.

2. In the Select Layer To Add dialog, select ps_napp.img from the 
directory into which you copied it.

3. Click OK in the Select Layer To Add dialog to display the camera 
image in the Viewer.

The file ps_napp.img opens in the Viewer. The Viewer image 
displays with a view of the upper-left corner of the photo, as shown 
in the following picture:

Check for Map Model Before you continue with geometric correction, you must first make 
sure that the image does not already have a map model.

1. On the Viewer toolbar, click the ImageInfo icon  .

The ImageInfo dialog opens.
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2. Look in the Map Info section by Geo. Model. If Geo. Model says 
Camera, you must delete the map model, therefore, proceed to step 
3. If there is no model, select File -> Close to dismiss the ImageInfo 
dialog, then proceed to “Perform Geometric Correction”.

3. Select Edit -> Delete Map Model from the ImageInfo menu bar.

4. Select File -> Close from the ImageInfo menu bar.

Redisplay the file

1. Click the Close icon  in the Viewer currently displaying 
ps_napp.img.

2. Click the Open icon  , and select ps_napp.img from the 
directory in which you saved it.

3. Move your cursor around the image and note the small coordinates 
in the status area.

The small coordinates are pixel coordinates, not map coordinates. 
You can now proceed with geometric correction.

Perform Geometric 
Correction 

1. Select Raster -> Geometric Correction from the Viewer menu 
bar.

The Set Geometric Model dialog opens. 

The model 
is listed here

Note the pixel
coordinates
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2. In the Set Geometric Model dialog, click Camera, and then click OK.

The Geo Correction Tools and Camera Model Properties dialogs open.

Set Camera Model 
Properties

1. In the Camera Model Properties dialog, enter the DEM file 
(ps_dem.img) under Elevation File.

The file ps_dem.img is located in the 
<<IMAGINE_HOME>/examples directory.

NOTE: Upon request, the data provider supplies the camera 
calibration certificate with the film at the time of purchase. This 
certificate provides the information needed for step 2 and step 3.

Click here to 
select Camera 

Enter the
DEM file
name 
here

Click here
to select
the
elevation
units

Make sure
this box
is not
checked

Enter X and Y point
coordinates here

Enter the 
Focal 
Length
here

Select the
units for
the points
and focal
length
here
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2. In the Camera Model Properties dialog under Principal Point, enter 
-0.004 for X and accept 0.000 as the default for Y. Then enter 
152.804 for the Focal Length.

NOTE: From the camera calibration certificate, there may be several 
possible types of the Principal Point coordinates. The Principal Point 
of Symmetry is preferable.

3. In Units under Principal Point, accept the default of Millimeters.

NOTE: The X and Y Principal Point coordinates, Focal Length, and 
Fiducial Film coordinates must all be entered in the same units.

4. For this example, make sure that the Account for Earth’s 
curvature checkbox not selected.

You should only account for the Earth’s curvature when using 
small-scale images or when it is necessary to take this factor 
into account. Alternately activating and deactivating this option 
(and then clicking Apply) allows you to observe changes to the 
RMS error. Accounting for the Earth’s curvature slows down the 
rectification process.

Edit Fiducials

1. Click the Fiducials tab at the top of the Camera Model Properties 
dialog. 

The Fiducial options display. 

2. Under Fiducial Type, click the Four Corners fiducial icon  . 

3. Under Viewer Fiducial Locator, click the Toggle icon  . 

Click here to view 
the Fiducials options 

Click here to select 
this Fiducial Type 

Click here to select 
the Viewer in which 
to locate fiducials 
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4. Follow the instructions by clicking in the Viewer that contains 
ps_napp.img.

A link box opens in the first Viewer, and the Chip Extraction Viewer 
also displays (the second Viewer).

5. In the first Viewer, drag the link box to the fiducial in the image you 
want to digitize (as illustrated in the following example). Place the 
center of the link box on the fiducial at the center of the area (where 
the crosshair intersects).

NOTE: Identifying the fiducial may sometimes require 
Breakpoint/LUT adjustments.

The second Viewer displays the point in the image that you have 
chosen with the link box.

6. In the Camera Model Properties dialog, click the Place Image Fiducial 

icon  .

7. Move your cursor into the Chip Extraction Viewer (the second 
Viewer), and click the center area where the crosshair intersects. 

Drag on this 
scroll bar to 
view the top 
or bottom of 
the image 

Drag on this scroll 
bar to view the 
left and right sides 
of the image 
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The point coordinates display under Image X and Image Y in the 
Fiducials CellArray of the Camera Model Properties dialog.

8. Create three more fiducials by repeating step 5 and step 6 in the 
three other corners of the image in the first Viewer. Move clockwise 
around the image in the Viewer, using the Viewer scroll bars, as 
shown in the following illustration: 

Enter Film Coordinates It is necessary to enter the Film coordinates into the Camera Model 
Properties dialog manually. The data provider can include this 
information in the camera calibration certificate.

1. Being sure to match the point numbers with the proper coordinates, 
enter the Film X and Film Y coordinates from the following table: 

Click here to place 
the image fiducial 

Begin digitizing here 

Drag the scroll bars 
to view the image in 
clockwise order

(Fiducial #1) 

(Fiducial #2) 

(Fiducial #3) 
(Fiducial #4) 

Table 7: Film X and Film Y Coordinates

Point 
# Film X Film Y

1 -106.000 106.000
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When the last Film coordinate has been entered in the Camera 
Model Properties dialog, the Status changes to Solved and the 
software calculates the Error. The presence of the Error value 
indicates that the interior orientation parameters have been solved.

An error of less than 1.0000 is acceptable. An error of greater than 
1.0000 indicates that the points were inaccurately measured or 
poorly identified. You can reposition the points using the Select 

Image Fiducial icon  to improve your results.

2. In the Camera Model Properties dialog under Viewer Fiducial 

Locator, click the Toggle icon  .

The Chip Extraction Viewer (the second Viewer) closes.

3. Click the Orientation tab in the Camera Model Properties dialog.

The Orientation options display. 

2 105.999 105.994

3 105.998 -105.999

4 -106.008 -105.999

Table 7: Film X and Film Y Coordinates (Continued)

Point 
# Film X Film Y

Enter the values
for the film 
fiducials here
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If you have known parameters for the Rotation Angle and 
Perspective Center Position derived from another triangulation 
package, Fixed, or if you have estimated values, Estimate, you can 
enter them in the Orientation tab.

In this example, the orientation parameters are Unknown.

If Account for Earth’s curvature is selected under the General 
tab, then the options on the Orientation tab are disabled (see step 
4).

Change Projection

1. Click the Projection tab in the Camera Model Properties dialog.

The Projection options display.

2. In the Projection options, click Add/Change Projection.

The Projection Chooser dialog opens. 

Click this button
to change the
projection
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3. In the Projection Chooser dialog, click the Custom tab.

4. Change the Projection Type to UTM using the dropdown list.

5. Change the Spheroid Name to Clarke 1866 using the dropdown 
list.

6. Change the Datum Name to NAD27 using the dropdown list.

7. Change the UTM Zone to 11 by typing in the value or using the 
increment nudgers.

8. Confirm that the NORTH or SOUTH window displays North.

9. Click OK in the Projection Chooser dialog.

The projection information you just entered displays under Current 
Reference Map Projection in the Camera Model Properties dialog.

10. In the Camera Model Properties dialog, click the dropdown list next 
to Map Units and select Meters (this activates the Apply button).

Click here once 
the projection 
has been chosen 

Click here to view 
the Custom options 

Click here to 
select UTM 
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11. Click Apply and then Save As in the Camera Model Properties 
dialog.

Name the Geometric 
Model

The Geometric Model Name dialog opens.

1. In the Geometric Model Name dialog next to File name, enter the 
name geomodel in the directory of your choice, then press Enter on 
your keyboard. 

The .gms file extension is added automatically.

2. Click OK in the Geometric Model Name dialog.

Start the GCP Tool and 
compute RMS Error

1. In the Geo Correction Tools dialog, click the GCP Tool icon  .

The GCP Tool Reference Setup dialog opens.

Select the GCP File
radio button
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2. In the GCP Tool Reference Setup dialog, select GCP File (.gcc) 
under Collect Reference Points From, and then click OK.

The Reference GCC File dialog opens.

3. In the Reference GCC File dialog, select ps_camera.gcc.

The reference points in this file were obtained from USGS 1:24,000 
scale topographical maps using a digitizer.

4. Click OK in the Reference GCC File dialog.

A Chip Extraction Viewer (the second Viewer), a link box, and the 
GCP Tool open. 

5. In the GCP Tool, click the Solve Geometric Model icon  .

NOTE: The orthorectification models do not have the option of 
Automatic Transform Calculation.

Clicking this icon solves the model and calculates the RMS error and 
residuals. The Control Point Error for the X and Y values displays 
beside the icons on the GCP Tool.

NOTE: The GCP Tool requires a minimum of three GCPs to run the 
model and at least six GCPs to make the model accurate and stable.

These file coordinates were 
previously measured and saved 
in the source file, ps_napp.img 

These reference coordinates 
are from the ps_camera.gcc file 

Error displays here
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6. Click Save in the Camera Model Properties dialog.

Choose Your Path • If you would like to resample the camera image, proceed to 
“Resample the Image”.

• If you would like to calibrate the camera image, proceed to 
“Calibrate the Image”.

Resample the Image Resampling requires an input file and a transformation matrix by 
which to create the new pixel grid.

1. In the Geo Correction Tools, click the Resample icon  .

The Resample dialog opens. 

2. In the Resample dialog under Output File, enter geomodel.img in 
the directory of your choice.

3. Under Resample Method, click the dropdown list and select Cubic 
Convolution.

4. Under Output Cell Sizes, enter 10 for X and 10 for Y.

NOTE: The default Output Cell Sizes are based on the 
triangulation. The smaller the pixel size, the larger the output file 
size.

5. Click the Ignore Zero in Stats. checkbox to activate it.

6. Click OK in the Resample dialog.

A Job Status dialog displays, indicating the progress of the function.

7. When the Job Status dialog indicates that the process is 100% 
complete, click OK.

Enter the output 
file name here Click this dropdown 

list to select 
Cubic Convolution 

Click to enable

Change the output 
cell sizes here 

the ignore
zeros option
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8. Display geomodel.img in a Viewer to view the resampled 
orthoimage.

Calibrate the Image To proceed with this portion of the tour guide, you must have 
completed the steps to rectify ps_napp.img in “Rectify a Camera 
Image”.

1. In the Geo Correction Tools dialog, click the Calibrate Image icon  
.

A Calibrate Image warning box displays.

2. Click OK in the Calibrate Image warning box.

The Geo Correction Tool and all its associated dialogs close. The file 
ps_napp.img closes and then reopens in the Viewer, with the 
Orient Image to Map System option turned off. To apply the 
calibration to the image in the Viewer, you must redisplay the output 
image with the Orient Image to Map System option turned on.

3. Click the Open icon  and navigate to the location where you 
saved ps_napp.img.

4. Select the file, then click the Raster Options tab.

Click OK to 
continue with
calibration
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5. In the Raster Options tab, click to select the option Orient Image 
to Map System, then click OK in the Select Layer To Add dialog.

NOTE: Once calibrated, this image cannot be reused in the 
orthorectification process using the information/coordinates files 
provided. Calibration must be deleted (Edit -> Delete Map Model 
in the ImageInfo dialog) for this file to be used again for this tour 
guide. 

6. In the Viewer, click the Info icon  to view the calibration 
information. 

The ImageInfo dialog opens, displaying the information for the 
calibrated image. 

Select the Orient
Image to Map
System checkbox
to apply the
calibration
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For a more in-depth discussion of the concepts behind 
rectification, see the chapter “Rectification” in the ERDAS Field 
Guide.
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Terrain Surface Interpolation

Introduction The Surfacing Tool enables you to create a three-dimensional 
surface from irregularly spaced points. Supported input data include:

• ASCII point files

• Arc point and line coverages

• ERDAS IMAGINE *.ovr layers

• existing raster images (IMG)

All input data sources must have X, Y, and Z values. Surface 
Interpolation calculates Z values at spatial locations where no Z 
samples exist in the input data source. The output is a continuous 
raster image that contains Z values calculated from the interpolation 
process. 

The ERDAS IMAGINE Surface Tool uses a TIN interpolation method. 
At each point where there is a known value, that known value 
remains unchanged in the output surface. Where the value is not 
known, it is interpolated from the surrounding known values.

Two TIN interpolation methods are available in the Surface Tool: 
Linear and Nonlinear. The Linear interpolation method, which makes 
use of a first-order polynomial equation, results in the TIN triangles 
being defined as angular planes. The Nonlinear interpolation 
method, which uses a fifth-order polynomial, results in a smooth 
surface. In this case, the TIN triangle areas are not considered to be 
planes, but areas that have rubber sheet characteristics. The Linear 
interpolation method is quicker and the results more predictable. 
However, the Nonlinear interpolation method produces more 
continuous results from irregularly distributed data sets where the 
observed phenomena has a rolling, nonangular surface 
characteristic.

Approximate completion time for this tour guide is 15 minutes.

Create a Surface ERDAS IMAGINE must be running and a Viewer open.

1. Click the DataPrep icon on the ERDAS IMAGINE icon panel. 
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The Data Preparation menu opens. 

2. In the Data Preparation menu, click Create Surface.

The 3D Surfacing dialog opens. 

3. Click Close in the Data Preparation menu to clear it from the 
screen.

Import an ASCII File

1. In the 3D Surfacing dialog, click the Read New Data icon  .

The Input Data dialog opens. 

Click here to start 
the Surface Tool 
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2. In the Read Points dialog, click the dropdown arrow next to Source 
File Type and select ASCII File. 

3. Under Source File Name, enter Inpts.dat.

This file is located in the <IMAGINE_HOME>/examples 
directory, where <IMAGINE_HOME> is the location of ERDAS 
IMAGINE on your system.

4. Click OK in the Read Points dialog.

The Read Points dialog closes, and the Import Options dialog opens. 

5. In the Import Options dialog, click the Input Preview tab to see 
how the ASCII file is imported and mapped under the present 
parameter settings.

Click this dropdown 
and select ASCII 
File 

Enter the name of 
the source file here 

Click this tab 
to preview the 
input data 
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From the Input Preview display, you can tell that the Separator 
Character is the comma and that Field 1 should be ignored.

6. Click the Field Definition tab.

7. Click the dropdown list next to Separator Character and select 
Comma.

8. In the Column Mapping CellArray, alter the Input Field Number 
column values vertically from 1, 2, 3 to 2, 3, 4 in order to ignore the 
ID column of the input file.

9. Click OK in the Import Options dialog.

A Job Status dialog opens, reporting the progress of the function.

10. When the Job Status dialog shows that the process is 100% 
complete, click OK (if necessary). 

The X, Y, and Z columns of the 3D Surfacing CellArray are now 
populated with 4,411 rows of X, Y, and Z coordinates.
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11. If you like, you can save these points as a Point Coverage (.arcinfo) 
or an Annotation Layer (.ovr) by selecting File -> Save As from 
the 3D Surfacing dialog menu bar.

Perform Surfacing

1. In the 3D Surfacing dialog, click the Perform Surfacing icon  .

The Surfacing dialog opens. The extent and cell size defaults are 
filled in automatically, based on the source ASCII file. 

The two options for a surfacing method are Linear Rubber 
Sheeting (1st Order Polynomial solution) and Non-linear Rubber 
Sheeting (5th Order Polynomial solution).

2. Under Output File, enter the name of the output file (for example, 
surface.img) in the directory of your choice.

3. Click the dropdown list next to Surfacing Method and select Non-
linear Rubber Sheeting.

4. Click the Ignore Zero In Output Stats checkbox to enable it.

5. Click OK in the Surfacing dialog.

A Job Status dialog displays, stating the progress of the function.

6. When the Job Status dialog reads that the function is 100% 
complete, click OK (if necessary).

Enter the path 
and name of the 
output file here 

Click here to 
select the 
surfacing 

Click to enable 
this checkbox 

The information 
in these fields is 
automatically 
generated 

Click OK to run 
the Surfacing 
program 

method 
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Display the Surface

1. Click the Open icon  in a Viewer. 

The Select Layer To Add dialog opens.

2. In the Select Layer To Add dialog under Filename, enter the name 
of the output file you created in step 2., beginning with the directory 
path in which you saved it.

3. Click OK in the Select Layer To Add dialog.

The output image displays in the Viewer for you to examine.

To edit portions of the resulting surface, use the raster editing 
techniques described in  “Viewer & Geospatial Light Table” on 
page 3, “Raster Editor”.
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Mosaic

Introduction This tour guide gives you the steps for mosaicking two or more 
image files to produce one image file. The mosaicking process works 
with rectified and/or calibrated images. Here, you are shown how to 
mosaic air photo images as well as LANDSAT images.

Approximate completion time for this tour guide is 45 minutes.

Mosaic Using Air 
Photo Images

In this section, you use a template to mosaic two air photo images. 

The two files to be mosaicked are air-photo-1.img and 
air-photo-2.img.

These data files are air photo images of the Oxford, Ohio area.

ERDAS IMAGINE should be running and a Viewer should be open.

1. In the Viewer, select File -> Open -> Raster Layer or click the 

Open icon  .

The Select Layer To Add dialog opens.

2. In the Select Layer To Add dialog under Filename, select 
air-photo-1.img from the file list.

3. Click the Raster Options tab at the top of the Select Layer To Add 
dialog.

4. Click the Fit to Frame option to enable it.

Click here
to select 
the file 

Click here 
to access 
the raster
options 

Click here 
to display 
the file 

Preview 
window 
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5. Click OK in the Select Layer To Add dialog.

The file air-photo-1.img displays in the Viewer.

6. Click the Viewer icon on the ERDAS IMAGINE icon panel to create a 
second Viewer. 

7. Repeat step 1 through step 5 for the second Viewer, selecting 
air-photo-2.img this time. 
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8. Position the Viewers side by side by selecting Session -> Tile 
Viewers from the ERDAS IMAGINE menu bar.

You can resize each Viewer so that they take up less screen space by 
dragging any corner of the Viewer.

9. In the ERDAS IMAGINE icon panel, click the DataPrep icon. 

The Data Preparation menu displays. 

10. In the Data Preparation menu, select Mosaic Images.

Click to open the
Mosaic Images menu
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The Mosaic Images menu opens.

11. Select Mosaic Tool from the Mosaic Images menu. The Mosaic Tool 
opens.

12. Click Close in the Data Preparation menu to clear it from the 
screen.

Set Input Images 

1. In the first Viewer containing air-photo-1.img, select AOI -> 
Tools.

The AOI tool palette displays. 

Select Mosaic
Tool

Menu bar

Toolbar

Files to be
mosaicked
are displayed
on the canvas

Status bar 
displays single
line help
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2. In the AOI tool palette, click the Polygon icon  .

3. In the first Viewer, draw a polygon around the border of the inside 
of the image, cutting out the fiducials, by moving your mouse around 
the interior border of the image and clicking to draw vertices (that 
is, on-screen digitize the outline of the image). Middle-click to close 
the polygon.

NOTE: If you do not have a three-button mouse, you can double-
click to close the polygon.

When you are finished, the AOI layer is highlighted with a dotted line 
and the image is surrounded by a bounding box. The image in the 
first Viewer should look like the following example: 
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Create a Template

1. When you have finished drawing the polygon, select File -> Save 
-> AOI Layer As in the first Viewer.

The Save AOI As dialog opens.

2. Under Save AOI as, enter template.aoi in the directory of your 
choice and click OK.

3. In the Mosaic Tool viewer, select Edit -> Add Images, or click the 

Add Images icon  .

The Add Images for Mosaic dialog opens.

4. Under File, select air-photo-1.img.

5. Under Image Area Options, click the Template AOI radio button, 
and then click the accompanying Set button.

Enter the directory and 
file name here 

Click here to save 
the AOI 

Click this tab to
choose options 
such as
Template AOI
and the 
accompanying 
Set button.

Select this 
file
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The Choose AOI dialog opens. 

6. In the Choose AOI dialog under AOI Source, select File.

7. Under AOI File, select template.aoi from the directory where you 
saved it.

8. Click OK in the Choose AOI dialog.

9. Click OK in the Add Images dialog to display air-photo-1.img in the 
Mosaic Viewer.

10. Click the Add Images icon to open the Add Images dialog.

11. In the Add Images for Mosaic dialog under File, select 
air-photo-2.img.

12. Under Image Area Options, click the Template AOI button and 
click Set.

13. In the Choose AOI dialog, select template.aoi from the directory 
where you saved it.

14. Click OK in the Choose AOI dialog.

Click this

Click
Template
AOI

Click Set

tab

Click this radio button 

Enter the appropriate 
path and file name here 

Click here when finished 
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15. Click OK in the Add Images dialog.

The data for air-photo-2.img displays in the Mosaic Image List 
CellArray, and a graphic of the image displays on top of the 
air-photo-2.img graphic in the canvas of the Mosaic Tool viewer.

16. If the Image List is not automatically displayed at the bottom of the 
Mosaic Tool viewer, go to Edit -> Show Image Lists, and select it.

The Mosaic Image List displays at the bottom of the Mosaic Tool 
viewer with the images listed in the CellArray. 

Click this for input
mode

Match histograms, color balance, or image dodge 
using this icon
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Identify Areas of 
Intersection

1. In the Mosaic Tool viewer, click the Intersection icon  to see the 
intersection lines between the two images. 

2. In the canvas of the Mosaic Tool viewer, click in the overlapping area 
of the two images.

The lines that overlap the two images are highlighted in yellow.

Draw a Cutline The Mosaic Tool enables you to draw one cutline through all the 
images or a single cutline in an individual image.

1. In the Mosaic Tool viewer, click the Cutline Selection icon  .

Viewer #3 opens, displaying the two images as they intersect. 

Click here
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2. Use the Zoom In icon  in the Viewer #3 toolbar to zoom in on the 
spot where you draw your cutline. (Do this by selecting the Zoom In 
icon and then clicking on the spot for which you want a closer view.) 

3. Select the Line icon  on the AOI tool palette.

Once in the Viewer, the cursor becomes a crosshair.

4. In Viewer #3, draw the cutline by digitizing the intersecting portion 
(the portion marked by the AOI box). Middle-click when finished.

NOTE: When drawing cutlines, it is best to trace linear landmarks, 
such as rivers or roads. This conceals any seams in the resulting 
mosaic.

NOTE: If you do not have a three-button mouse, you can double-
click to close the polygon.

Zoom in here
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5. In the Mosaic Tool viewer, click the AOI Cutline icon  .

The Choose Cutline Source dialog opens.

6. In the Choose Cutline Source dialog select AOI from Viewer and 
Apply cutlines to selected regions only (the default), and click 
OK.

7. An Attention dialog opens, warning you that cutlines can be lost if 
projection is changed. Click Yes in the dialog.

The cutline is highlighted in red in the Mosaic Tool viewer canvas.

Draw the 
cutline between
these two
points
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8. Click the Function icon  in the Mosaic Tool viewer.

The Set Overlap Function dialog opens.

Click Apply

Click these
options
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9. In the Set Overlap Function dialog under Intersection Type, select 
Cutline Exists.

10. Under Select Function, select Feathering.

11. In the Set Overlap Function dialog, click Apply and then Close.

NOTE: The cutline viewer automatically zooms to whatever is in the 
Mosaic Tool. In order to only show the overlapping area in the 
viewer, you need to click the Scale Canvas to Fit Selected Objects 
icon  .

Define Output Images

1. In the Mosaic Tool viewer, click the Output icon  to activate the 
output mode. 

2. In the Mosaic Tool viewer, click the Output Image icon  .

The Output Image Options dialog opens.

3. In the Output Image Options dialog under Define Output Map 
Area(s), make sure that Union of All Inputs is selected and click 
OK.

Run the Mosaic

1. In the Mosaic Tool viewer, select Process -> Run Mosaic.

The Output File Name dialog opens. 

Make sure Union 
is selected
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2. In the Run Mosaic dialog under Output File Name, enter AirMosaic 
in the directory of your choice, the press Enter on your keyboard.

3. Click the Output Options tab.

4. Click the Stats Ignore Value checkbox to activate it.

5. Click OK in the Run Mosaic dialog.

A Job Status dialog displays, showing the progress of the function.

6. Click OK when the Job Status dialog reads that the function is 100% 
complete.

NOTE: The Job Status dialog may close automatically, depending on 
your settings in Session -> Preferences -> User Interface & 
Session -> Keep Job Status Box.

Display the Mosaic

1. Click Viewer in the ERDAS IMAGINE icon panel.

A new Viewer displays.

Enter the name
of the output
file here

Click this 
checkbox to
activate it
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2. Click the Open icon  in the new Viewer.

The Select Layer To Add dialog opens.

3. In the Select Layer To Add dialog under Filename, select 
AirMosaic.img from the directory in which you saved it.

4. Click the Raster Options tab and click Fit To Frame.

5. Click OK.

AirMosaic.img displays in the Viewer.

6. Compare AirMosaic.img to the original images (air-photo-1.img 
and air-photo-2.img).

Automatically 
Generate Cutlines

In addition to drawing a cutline, you can use Mosaic Tool to 
automatically generate them. In this exercise you use the 2-2.img 
and 2-3.img data in the examples file to generate a cutline and 
discover how this feature works. You will be starting a new Mosaic 
Tool Viewer for this exercise.

1. Click the DataPrep icon in the IMAGINE toolbar.

2. Click Mosaic Images in the Data Preparation dialog.

The Mosaic Tool opens.

3. Click Close in the Data Preparation dialog to close it.
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4. In the Mosaic Tool viewer, add the images 2-2.img and 2-3.img by 

clicking the Add Images icon  .

5. Click the Set Mode for Intersections icon  to activate intersect 
mode.

6. Click the Automatically Generate Cutlines for Intersections icon  
on the toolbar.

The Cutline Generation Options dialog opens.

7. Choose the Weighted Cutline Generation option and click Set.

The Weighted Cutline Generation Options dialog opens.

8. Leave the default Segment Length, Bounding Width, and Cost 
Function Weighting Factors at their default settings, and click 
OK.

9. Click OK in the Cutline Generation Options dialog.

10. An Attention box opens telling you that cutlines will be lost if output 
map projection is changed. Click Yes to continue.

The Generating Weighted Cutline job status bar displays while the 
cutline is being generated. When it is finished a red cutline appears 
between the two images in the Mosaic Tool viewer.

Choose which
method you
want to use

Check to not
see this dialog
again

You can alter
the Segment
Length and
Bounding
Width or leave
the defaults If you want one

Cost Function to
count more than 
the others, increase
its number
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11. Move your cursor within the overlapping portion of the two images 
where the cutline is drawn and click it.

The area becomes highlighted as does the information below the 
images.

12. In the Mosaic Tool viewer, click the Cutline Selection Viewer Auto 

Mode icon .

A Viewer containing the two images opens with the cutline area 
outlined.

13. Use the Interactive Zoom In icon  to look at the cutline up close. 
You are able to see how the cutline that was automatically generated 
mainly follows the path of a road that separates the two images.
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Mosaic Using 
LANDSAT Images

In this section of the tour guide, you mosaic LANDSAT images of MSS 
and TM scenes.

The three files to be mosaicked are: wasia1_mss.img, 
wasia2_mss.img, and wasia3_tm.img.

These data files are LANDSAT images of Kazakhstan, in the former 
USSR.

Display Input Images ERDAS IMAGINE should be running and a Viewer should be open.

1. In the Viewer, select File -> Open -> Raster Layer or click the 

Open icon  .

The Select Layer To Add dialog opens.

Use the Zoom In
icon to view the 
cutline more 
closely

You are able
to see the 
cutline follow
the road
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2. In the Select Layer To Add dialog under Filename, click 
wasia1_mss.img. Hold down your Shift key after clicking 
wasia1_mss.img, and click wasia3_mss.img to select all three 
images at once.

3. Click the Raster Options tab at the top of the Select Layer To Add 
dialog.

4. Click the Clear Display option to disable it (this ensures that 
currently displayed files are not cleared in the Viewer).

5. Click the Background Transparent option to enable it.

6. Check to be sure that the Fit to Frame option is enabled.

7. Click OK in the Select Layer To Add dialog.

The three wasia files display in the Viewer.

8. When finished, you should be able to see all three files in the Viewer: 

Click this
file tab to 
view the raster
options 

Click here to 
select the file 

the image 
displays here 

A preview of 
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9. In the ERDAS IMAGINE icon panel, click the DataPrep icon.

The Data Preparation menu displays.

10. In the Data Preparation menu, select Mosaic Images.

The Mosaic Tool viewer opens. 

Select Mosaic Images
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11. Click Close in the Data Preparation menu to clear it from the 
screen.

Add Images for Mosaic

1. In the Mosaic Tool viewer, click the Add Images icon  .

The Add Images for Mosaic dialog opens. 

Files to be mosaicked are displayed here

Menu 
bar

Tool
bars

Image
list

Status bar displays single-line help



Mosaic Using LANDSAT Images / 332ERDAS IMAGINE Tour Guides

2. In the Add Images dialog under File, select wasia1_mss.img. Hold 
down the Shift key and click wasia3_mss.img. This should select 
all three wasia files at once.

3. In the Add Images dialog, click the Compute Active Area button 
under Image Area Options to enable it, and then click OK.

A Set button displays when you click Compute Active Area, and if 
you click it, the Compute Active Area dialog opens.

Use this dialog if you want to automatically compute the active areas 
in your images. For the purpose of this tour, you do not need to click 
set and change anything in Active Area Options.

The file wasia1_mss.img displays as image number 1 in the canvas 
of the Mosaic Tool viewer. Wasia2_mss.img and wasia3_mss.img 
display as numbers 2 and 3 respectively.

When you are finished adding the three images, the Mosaic Tool 
viewer should look like the following:

Click this tab
and the Compute
Active Area 
button
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Stack Images The images in the Mosaic Tool viewer are positioned as if they were 
regular photos that a person stacked by hand. One image intersects 
everything below it in the stack. 

1. Experiment with the stacking order in the Mosaic Tool viewer by 
clicking on any or all of the images in the canvas and then clicking 
on any of the icons pictured below:

2. When you are finished experimenting with the stacking icons, click 
outside of the images in the canvas of the Mosaic Tool viewer to 
deselect the image(s).

Correct Images

1. Click the Display Color Corrections icon  .

The Color Corrections dialog opens.
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2. Check the box for Use Histogram Matching and click Set.

The Histogram Matching dialog opens.

3. Select Overlap Areas from the Matching Method dropdown list 
and click OK.

4. Click OK in the Color Corrections dialog.

5. Click the Set Mode for Intersections icon  .

6. In the Mosaic Tool toolbar, click the Set Overlap Function icon  .

The Set Overlap Function dialog opens.

7. In the Set Overlap Function dialog under Intersection Type, make 
sure No Cutline Exists and Overlay under Select Function are 
chosen. These options are the default choices.

Choose the
correction
method 
you want to
use

Click OK

Click Set

Select the 
Matching Method Choose the

Histogram Type

Check if you
want to use an
external 
reference
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8. Click Close in the Set Overlap Function dialog. 

Run the Mosaic

1. In the Mosaic Tool viewer, select Process -> Run Mosaic.

The Output File Name dialog opens.

2. In the Output File Name dialog, enter a name for the output file in 
the directory of your choice (for example wasia_mosaic.img).

3. Click OK in the Output File name dialog.

A Job Status dialog displays, stating the progress of the mosaic 
operation. 

4. Click OK in the Job Status dialog when the mosaic operation is 
finished.

NOTE: The mosaic process time can vary based upon your hardware 
capabilities and the size of the files.

5. Select File -> Close from the Mosaic Tool viewer to clear it from the 
screen.

You are asked if you want to save the changes in the Mosaic Tool 
viewer. Save them if you like or click No to dismiss the dialog.

Display Output Image

1. Click the Viewer icon on the ERDAS IMAGINE icon panel to open a 
second Viewer.

2. In the Viewer you just opened, select File -> Open -> Raster or 

click the Open icon  .
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The Select Layer To Add dialog opens. 

3. In the Select Layer To Add dialog under Filename, click the file 
wasia_mosaic.img (or the output mosaic image you previously 
created). Remember to look in the directory in which you saved the 
file. You can also click the Recent button and choose the file from 
there.

4. Click the Raster Options tab at the top of the Select Layer To Add 
dialog.

5. Check to be sure that the Fit to Frame option is enabled.

6. Click OK in the Select Layer To Add dialog.

The output mosaic file displays in the Viewer.

7. In the ERDAS IMAGINE menu bar, select Session -> Tile Viewers 
to position the Viewers side by side.

8. Compare the input mosaic images in the first Viewer to the output 
mosaic image in the second Viewer. You can resize the Viewers by 
dragging on any of their corners.
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Mosaic Color 
Balancing Using 
Color Infrared 
Aerial Photos

In this section of the tour guide, you mosaic color-infrared aerial 
photograph images of eastern Illinois, USA. The color red in the 
photos represents vegetation with deep reds representing healthy 
vegetation.

The nine files to be mosaicked are: 2-2.img, 2-3.img, 2-4.img, 
3-2.img, 3-3.img, 3-4.img, 4-2.img, 4-3.img, and 4-4.img.

ERDAS IMAGINE should be running and a Viewer should be open.

1. In the Viewer, select File -> Open -> Raster Layer or click the 

Open icon  .

The Select Layer To Add dialog opens.

Click this
tab to view 
the raster 
options

Click here
to select the
file
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2. In the Select Layer To Add dialog under Filename, click 2-2.img. 
Hold down the Shift key and click 4-4.img. All of the images between 
the two, 2-3.img, 2-4.img, 3-2.img, 3-3.img, 3-4.img, 4-2.img, 
and 4-3.img (except for 30meter.img) should also be selected. If 
you want to deselect an image such as 30meter.img, press Ctrl and 
click to deselect it. You can also add the images one by one, but it is 
much faster to use the Shift key to add them all at once.

3. Click the Raster Options tab at the top of the Select Layer To Add 
dialog.

4. If you are adding the images separately, you will see the Layers to 
Colors box. Make sure Red is 1; Green is 2; and Blue is 3. 

5. If adding the images all at once, go to Session -> Preferences -> 
User Interface and Session and make sure the 3-Band Image 
Red, Green, and Blue are set to 1, 2, and 3 respectively. If you 
have had to change these, click User Save and then Close.

6. Click the Clear Display option on the Raster Options tab to disable 
it (this ensures that currently displayed files are not cleared in the 
Viewer).

7. Click the Fit to Frame option to enable it.

8. Click the Background Transparent option to enable it.

9. Click OK in the Select Layer To Add dialog.

You should be able to see all nine files in the Viewer.
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You can see patterned color differences in some of the images. Some 
spots in some of the photos appear brighter or darker than the rest 
of the image. In order to adjust these color differences, you use the 
Mosaic Color Balancing option in the Mosaic Tool.

10. In the ERDAS IMAGINE icon panel, click the DataPrep icon.

The Data Preparation menu displays.

11. In the Data Preparation menu, select Mosaic Images.

The Mosaic Tool viewer opens.

12. Click Close in the Data Preparation menu to clear it from the 
screen.

Add Images for Mosaic

1. In the Mosaic Tool viewer, click the Add Images icon  .

The Add Images dialog opens. 

2. In the Add Images dialog under Image Filename, select 2-2.img 
through 4-4.img using your Shift or Ctrl key to add them all at 
once. Do not forget to deselect 30meter.img.

3. Click the Image Area Options tab in the Add Images dialog, and 
make sure the Use Entire Image button is selected, and then click 
OK.

The files display according to number in the canvas of the Mosaic 
Tool Viewer.

When you are finished adding the nine images, the Mosaic Tool 
Viewer should look like the following:

Choose this
file

Click this tab
and click the
Use Entire 
Image button
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Set Exclude Areas

1. Click the Color Corrections icon  in the Mosaic Tool viewer.

The Color Corrections dialog opens.

2. Select Exclude Areas, and click Set.

The Set Exclude Areas dialog opens.

Click to 
use color
balancing

Click Set to
open the color 
balancing dialog

Click to
exclude 
areas
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The overview shows the full extent of the image, and the detail view 
allows you to zoom in on specific areas to create AOIs to be excluded 
from the Color Balancing process. Use the link cursor to isolate AOIs.

3. Image 2-2.img is the first image displayed in the viewers. Left-hold 
your mouse and drag the link cursor to the dark body of water in the 
upper left of the center of the image.

In the Detail View, the area is magnified so you can create specific 
AOIs to exclude from the Color Balancing process.

4. Click the Create Polygon AOI icon  .

5. Your cursor becomes a crosshair when inside a view. Use the Detail 
View to create polygons around the dark water bodies.

6. When you have finished, use the link cursor to identify any other 
areas in the image that need to be excluded such as other dark 
bodies of water, isolated bright urban areas, or bright areas of sun 
glint. 
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7. Create a polygon around each of the areas you wish to exclude from 
Color Balancing, and click Apply.

8. Use the arrow keys or the drop down box to select the next image, 
2-3.img

Continue identifying AOIs to exclude through all nine images. Click 
Apply after excluding areas in each image. Click Close in the Set 
Exclude Areas dialog when finished.

Find Like Areas After excluding a particular area, you can also use the Find Like 
Areas tool to find similar images in one or all of the images you want 
to mosaic. 

1. Click the Find Like Areas icon  in the Set Exclude Areas dialog.

The Find Like Areas dialog opens:

2. Look at the Layer 1 Statistics of the Selected Area. Notice the 
Std. Dev (standard deviation), the Mean, and the other statistics.

3. Under Searching Criteria in Layer 1 change the Max. Pixel Value 
to 75.

4. Choose the Exclude Area Color you want to use by clicking the color 
palette icon by the color box.

5. For Apply Searching To, click All Images.

Set Exclude Areas will calculate the like areas for all images, and the 
images in both the overview and the detail view will reflect the 
similar areas in what ever color you chose.

Use the arrows
to choose which
layer to useThe spectral distance

information is here

Use the arrows to 
select your minimum
and maximum pixel
values

Click this color
palette icon to 
choose a color
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6. Click the dropdown arrow and select another image. You can go 
through all the images to see where the like areas are in each image.

7. If you want to, click the Remove Like Areas icon  to erase the 
findings. You do not have to erase the findings, but you can use this 
icon to do so if you need to.

You can also go back and select an AOI of the lighter colored areas 
in the image and use Find Like Areas for that as well. Experiment 
with different types of areas, different spectral distances, and 
different layers. You can select a dark area and run Find Like Areas 
and then select a bright-light area and run the feature. Find Like 
Areas will retain the dark areas while locating and adding the bright 
areas.

8. When you have finished Find Like Areas and excluded the areas in 
every image you want to exclude for Color Balancing, click Apply To 
All in the Set Exclude Areas dialog, and click Close.

Mosaic Color Balancing

1. In the Color Corrections dialog, deselect Exclude Areas, and choose 
Color Balancing and click Set.

The Set Color Balancing Method dialog opens.

2. Choose Manual Color Manipulation and click Set.
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The Mosaic Color Balancing dialog opens.

3. The first image, 2-2.img, displays. If 2-2.img did not need color 
balancing, you could skip it, and use the Arrow Keys or the 
dropdown menu in the top left corner to choose another image.

4. Under Display Setting, make sure RGB is selected, and change Red 
to 1, Green to 2, and Blue to 3 in order to better compare the 
mosaicked images with the originals.

5. Choose the surface method you want to use in order to color balance 
the image. You may choose from Parabolic, Conic, Linear, or 
Exponential.

Unless you are using Linear as your surface method, you can click 
Common center for all layers in order to use the same center 
point in each layer of the image.

6. For image 2-2.img, select Conic, and enable Common center for 
all layers.

7. Click Compute Current and click Preview. The preview viewer 
displays the color balanced image.

8. Click Accept after previewing the color balanced image to accept it 
for mosaicking.
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The computed settings are based on the surface method chosen. The 
Image Profile box at the top right of the Mosaic Color Balancing 
dialog depicts the chosen surface method as a red line plotted 
against a profile of the pixel values shown as a green line between 
the center point and end point in the image. Results are best when 
the red line of the surface method matches the general trend of the 
green line of the image profile. 

9. Repeat steps 3. through 6. for images 2-3.img, 2-4.img, 3-2.img, 
3-3.img, 3-4.img, 4-2.img, 4-3.img, and 4-4.img. 

10. Click Close in the Mosaic Color Balancing dialog. 

11. Click OK in the Set Color Balancing dialog.

Match Images

1. If you have just completed the previous exercise, click Use Color 
Balancing to deselect it, and choose Use Histogram Matching. If 
you are starting this exercise anew, click the Color Corrections icon 

 in the Mosaic Tool Viewer after adding example images 2-2.img 
through 4-4.img.

The Color Corrections dialog opens.

2. In the Color Corrections dialog, check Use Histogram Matching 
and Set.

The Histogram Matching dialog opens.

3. Select For All Images as the Matching Method.

4. Select Band by Band as the Histogram Type.

5. Click OK in the Histogram Matching dialog and in the Color 
Corrections dialog.

6. Click the Intersection icon  on the Mosaic Tool toolbar. 

7. Click the Automatically Generate Cutlines for Intersections icon  .

The Cutline Generation Options dialog opens. 

8. Click Geometry-based Cutline Generation and OK.

9. Click Yes in answer to the question about cutlines being lost if the 
projection is changed.

10. In the Mosaic Tool toolbar, click the Function icon  .

The Set Overlap Function dialog opens.

11. In the Set Overlap Function dialog under Intersection Type, select 
Cutline Exists, No Smoothing, and Feathering then click Apply.

12. Click Close in the Set Overlap Function dialog. 
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Run The Mosaic

1. In the Mosaic Tool viewer, select Process -> Run Mosaic.

The Output File Name dialog opens.

2. In the Output File Name dialog under File Name, enter a name for 
the output file in the directory of your choice (for example 
color_infrared.img).

3. Click OK in the Output File Name dialog.

A Job Status dialog displays, stating the progress of the mosaic 
operation. 

4. Click OK in the Job Status dialog when the mosaic operation is 
finished.

NOTE: The mosaic process time varies based upon your hardware 
capabilities and the size of the files.

5. Select File -> Close from the Mosaic Tool viewer to clear it from the 
screen.

6. Click Yes to save changes in the Verify Save on Close dialog. You can 
also go directly to the Save Mosaic File As dialog by choosing File -
> Save in the Mosaic Tool menu.

7. Click the Look in dropdown arrow to choose the directory where you 
want to save your mosaic file.

8. Type the file name in the File name area, and click OK.

Your parameters and the mosaic set up will be saved.

Display Output Image

1. Click the Viewer icon in the ERDAS IMAGINE icon panel.

A new Viewer displays.

Enter the 
name of the
output file
here

Click here 
to run the
mosaic

Choose the 
appropriate
directory by
clicking here
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2. Click the Open icon  in the Viewer you just created.

The Select Layer To Add dialog opens.

3. In the Select Layer To Add dialog under Filename, select 
color_infrared.img from the directory in which you saved it, and 
then click OK.

4. Click the Raster Options tab at the top of the Select Layer To Add 
dialog.

5. Check to be sure the Fit to Frame option is enabled.

6. Click OK in the Select Layer To Add dialog.

The mosaicked output image displays in the viewer.

Mosaic Image 
Dodging

In this section of the tour guide, you use the Image Dodging option 
to correct light displacement in an image.

1. Click the Data Prep icon  on the IMAGINE toolbar.

2. Click Mosaic Images in the Data Preparation list.

The Mosaic Tool opens.
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3. Click the Add Images icon  , and select image-dodge-bright-
spot.img from the examples folder.

4. After the image is added to the Mosaic Tool, click the Color 

Corrections icon  .

The Color Corrections dialog opens.

5. Choose Use Image Dodging in the Color Corrections dialog, and 
click the Set button.

Choose Image
Dodging and 
click the Set 
button.

Click OK
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6. If a prompt about pyramid layers opens, click Yes to calculate them.

The Image Dodging dialog opens.

7. In the Image Dodging dialog, make sure under Display Setting, the 
band choices are Red-1, Green-2, and Blue-3.

It is obvious when looking at the image in the dodging viewer that 
there is a bright spot to correct.

8. Look under Statistics Collection at Grid Size, Skip Factor X, and 
Skip Factor Y. You can change these numbers to suit your 
purposes, but for this exercise leave them at the defaults of 10, 3, 
and 3.

9. Click Compute Current.

10. Click Preview to view the image after applying Image Dodging. 

The image appears in the Dodge Image Preview section of the dialog.
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11. Click Accept to accept the dodged image, and click Close.

12. Click OK in the Color Corrections dialog.

13. In Mosaic Tool, click Process and Run Mosaic. Even though you are 
only correcting one image and not technically mosaicking in this 
process, this option lets you output your dodged image to a file.

14. In the Output File Name dialog, browse to the directory where you 
want to store your output files.

15. Type the File name for your image, and click OK.

16. The Mosaic Job State dialog opens. When it is 100% done, click OK.

Go to the IMAGINE toolbar, and click Viewer.

17. In the Viewer, browse to the directory where your output images are 
stored, and open the dodged image.
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MosaicPro

Introduction This tour guide gives you the steps for mosaicking two or more 
image files to produce one image file. The mosaicking process works 
with rectified and/or calibrated images. MosaicPro allows you the 
capability of drawing and editing a new seam polygon in an 
embedded viewer. Seam polygon is applied to the image in which the 
first vertex is digitized, then the embedded viewer is updated and 
the input images are stitched along the seam polygon boundaries.

Mosaic Using 
Laguna Beach 
Images

In this section, you will mosaic laguna beach images.

Starting MosaicPro from 
LPS menu

MosaicPro dialog can be started from the LPS  or the DataPrep 

 on the ERDAS IMAGINE icon panel.

1. In the Erdas IMAGINE icon panel, click the LPS icon  .

The LPS Project Manager is displayed.

2. In the Project Manager, select File -> Open or click the Open icon 

 .
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The Block File Name dialog is displayed.

3. In the Block File Name dialog under Filename, select laguna.blk 
from the list.

4. Click OK in the Block File Name dialog.

The file laguna.blk is displayed in the LPS Project Manger.

Adding and Displaying 
Images in MosaicPro

1. Click the Mosaic icon  .

The Start Ortho Mosaicking dialog is displayed.
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2. Select MosaicPro from the dropdown list and click OK.

The MosaicPro Viewer and Elevation Source dialog is displayed.

3. In the Elevation Source dialog, click the DTM File button.

4. Click the Open icon  , and the DTM File dialog is displayed.

5. In the DTM File dialog under Filename, select 
laguna_reference_dem.img from the list.

6. Click OK in the DTM File dialog.

7. Click OK to dismiss the Elevation Source dialog.

The Add Images dialog is displayed.



Mosaic Using Laguna Beach Images / 356ERDAS IMAGINE Tour Guides

8. Click the Compute Active Area button.

9. Click OK to close the Add Images dialog and add images in the 
MosaicPro Viewer.

The MosaicPro Viewer is displayed.

The data for laguna_beach images displays in the MosaicPro Image 
List CellArray. 

If the Image List is not automatically displayed at the bottom of 
the MosaicPro viewer, go to Edit -> Show Image Lists, and 
select it.

10. Click the Vis box in the image list cellarray, then select View -> 
Show Rasters in the viewer menu or click the Display raster 

images icon  .
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The raster images are displayed.

Drawing and 
Editing Seam 
Polygons

MosaicPro allows you to draw a seam polygon through images or a 
single polygon in an individual image.

1. In the viewer, click the Seamlines Generation Options  icon .

The Seamline Generation Options dialog is displayed.

2. Select Most Nadir Seamline and click OK to accept this option.

Menu bar

Toolbar

Mosaicked
laguna_beach
images are 
displayed in
embedded
viewer

Image List
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3. Use the Zoom In icon  to look at the seamline area you want to 
digitize up close.

4. Select the Create Polygon icon  on the viewer.

Once in the viewer, the cursor becomes a crosshair.

5. Draw and edit the seam polygon.

The edited seam polygon is displayed.
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Correcting Color

1. Select Edit -> Color Corrections from the viewer menu or click the 

Color Corrections icon  to open the Color Balancing dialog.

The Color Corrections dialog is displayed.

2. Select Use Color Balancing and click Set.

The Set Color Balancing Method dialog is displayed.



Drawing and Editing Seam Polygons / 360ERDAS IMAGINE Tour Guides

3. Select Manual Color Manipulation and click Set.

The progress meter runs.

Mosaic Color Balancing dialog is displaced.

4. Select Global and Global balancing form the Color Balancing 
dialog.

5. Click Compute for All and Accept for All.

6. Click Close to accept these changes and close the Color Balancing 
dialog.

7. Click OK to close Color Balancing dialog Method dialog.

Image Dodging In this section, you use the Image Dodging option to correct light 
displacement in an image.

1. Choose Use Image Dodging in the Color Corrections dialog, and 
click the Set button.

The Image Dodging dialog is displayed.
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2. In the Image Dodging dialog, make sure under Display Setting, the 
band choices are Red-1, Green-2, and Blue-3.

It is obvious when looking at the image in the dodging viewer that 
there is a bright spot to correct.

3. Look under Statistics Collection at Grid Size, Skip Factor X, and 
Skip Factor Y. You can change these numbers to suit your 
purposes, but for this exercise leave them at the defaults of 10, 3, 
and 3.

4. Look under Options For All Images, make sure Band 
Independent is not selected (unchecked). This will yield Band 
Dependent results.

5. Click Compute Current.

6. Click Preview to view the image after applying Image Dodging.

The image appears in the Dodge Image Preview section of the dialog.

7. Click Accept to accept the dodged image, and click Close.
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8. Click OK to close Color Corrections dialog.

Previewing the Mosaic

1. Select the mosaic preview icon  .

2. Select the area to preview with this box.

3. Select Process -> Preview Mosaic for window.

The preview window is displayed in the image.

4. Click OK when the Job Status meter is done.

5. Use the Zoom In icon  to see the area previewed.

6. Select Process -> Delete the Preview Mosaic Window to delete 
the Preview window.

Setting Seamline 
Functions

1. Click the Function  icon in the viewer.

2. Click No Smoothing for the Smoothing Option.

3. Click Feathering for the Feathering Option.

4. Click OK to accept the changes and close the Set Seamline 
Function dialog.



ERDAS IMAGINE Tour Guides Drawing and Editing Seam Polygons / 363

Defining the Output 
Images

1. Click the Output Image  icon in the viewer. 

Output Image Options is displayed.

2. In the Output Image Options dialog under Define Output Map 
Area(s), make sure that Union of all Inputs is selected.

3. Click OK to close the Output Image Options dialog.

Running the Mosaic

1. In the viewer, select Process -> Run Mosaic.

2. In the Run Mosaic dialog under Output file Name, enter 
tour_laguna.img in the directory of your choice, then press Enter.

Displaying the Mosaic

1. Open a viewer in the ERDAS IMAGINE icon panel.

2. Click the open icon  in the new viewer.

3. In the Select Layer to Add dialog under Filename, select 
tour_laguna.img the file from the directory in which you saved it.
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4. Click the Raster Options tab and click Fit To Frame.

5. Click OK to display the file.

The mosaicked image, tour_laguna is displayed.
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Viewshed Analysis

Introduction One of the many tasks you can perform using IMAGINE Advantage 
is Viewshed Analysis. This tour guide describes how to use this 
analysis tool.

Viewshed Analysis allows you to position an observer on a DEM in a 
Viewer and determine the visible areas within the terrain. You can 
adjust the observer’s height either above ground level or above sea 
level and set the visible range. 

This tool is useful for planning the location and height of towers used 
for observation or communications. It might also be used to 
determine areas that lie within poor reception of standard broadcast 
towers and are thus potential cable markets.

In this tour guide, you can learn how to:

• start an Image Drape viewer

• start the Viewshed tool

• work with multiple observers

• query Viewshed data and layers

Approximate completion time for this tour guide is 15 minutes.

Create a Viewshed In this exercise, you create a viewshed, and analyze the terrain 
within it.

ERDAS IMAGINE must be running with a Viewer open.

1. Click the Open icon  in the Viewer (or select File -> Open -> 
Raster Layer).

2. In the Select Layer To Add dialog, navigate to the 
<IMAGINE_HOME>/examples directory.

3. Select the file eldodem.img, then click the Raster Options tab.

4. In the Raster Options tab, make sure that the Fit to Frame 
checkbox is active.

5. Click OK in the Select Layer To Add dialog.
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Add the Raster Image

1. Click the Open icon again, and navigate to the 
<IMAGINE_HOME>/examples directory.

2. Select the file eldoatm.img, then click the Raster Options tab.

3. In the Raster Options tab, make sure that the Clear Display 
checkbox is not active.

4. Click OK in the Select Layer to Add dialog.

Both files are displayed in the Viewer.

Start an Image Drape 
Viewer and Set the Level 
of Detail

1. From the menu bar of the Viewer displaying eldodem.img, select 
Utility -> Image Drape.

The Image Drape Viewer opens displaying eldodem.img, which 
supplies terrain relief, and eldoatm.img, which supplies the color. 
Position the Image Drape Viewer so that it does not cover the first 
Viewer you opened. Now, you can set the level of detail.

2. Select View -> LOD Control from the Image Drape viewer menu 
bar.

The Level Of Detail dialog opens.

3. In the field next to DEM LOD (%), enter 100, and press Enter on 
your keyboard.

4. Click Apply to increase the level of detail in the Image Drape viewer.

5. Click Close to dismiss the Level Of Detail dialog.

Your two Viewers now look like the following:

Change DEM
level of detail
in this field

You can also
change the 
level of detail
using these
meter controls

Change raster
level of detail
in this field
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Start the Viewshed 
Analysis Tool

1. Click the Interpreter icon  on the ERDAS IMAGINE icon bar.

The Image Interpreter menu opens.

2. From the Image Interpreter menu, select Topographic Analysis.

The Topographic Analysis menu opens.

Select Topographic 
Analysis
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3. From the Topographic Analysis menu, select Viewshed.

A Viewer Selection Instructions dialog opens.

 

4. Click in the Viewer containing eldodem.img and eldoatm.img.

The Viewshed dialog opens.

5. At this time, click Close on both the Image Interpreter menu and 
the Topographic Analysis menu to remove them from your 
display.

An observer marker is automatically placed in the center of the 
Viewer containing eldodem.img.

Click Viewshed

Click the Observers tab to add an observer Select Multiple Viewsheds
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6. In the Function tab of the Viewshed dialog, click the dropdown list 
next to Output Type to select Multiple Viewsheds.

Add First Observer

1. Click the Observers tab in the Viewshed dialog.

The Observers tab of the CellArray displays.

2. Click in the cell of the X column to enter 471950.88, then press 
Enter on your keyboard.

3. Click in the cell of the Y column to enter 4421011.47, then press 
Enter on your keyboard.

4. Click Apply in the Viewshed dialog.

The viewshed layer is generated and displays in the Viewer.

Specify the observer’s position in these columns

The area of the 
viewshed is marked 
by a circle
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Add Another Observer

1. Click Create in the Viewshed dialog.

A new observer is added to the CellArray.

2. Click in the cell of the second observer’s X column to enter 
472474.65, then press Enter on your keyboard.

3. Click in the cell of the second observer’s Y column to enter 
4419343.08, then press Enter on your keyboard.

4. Click Apply in the Viewshed dialog.

The second viewshed layer is generated and displays in the Viewer.

5. Click the Function tab in Viewshed dialog to view the legend.

The Function tab opens, displaying the legend of the viewshed.

Click createThe second observer is added to row 2

Portions of the 
two viewsheds 
intersect, 
evidenced by 
the overlap of 
the red circles
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There are two basic kinds of output. The Viewshed outputs 
provide a binary analysis of visibility within the specified range. 
In other words, the image is color-coded to show only visible or 
hidden areas. The Height outputs provide a color-coded map of 
the invisible areas indicating the amount of change in observer 
height required to see a given zone.

Link the Viewers and Set 
Eye and Target Positions

1. Using your mouse, move the Eye of the Positioning tool on top of 
Observer 1.

2. Move the Target on top of Observer 2 in the Viewer.

The legend displays here, in the Function tab

The Eye of the 
position tool is
placed on top
of Observer 1

The Target of the
position tool is 
placed on top 
of Observer 2
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As you move the Positioning tool, the 3D image in the Image Drape 
viewer is updated. Observer 1 is now looking at the location of 
Observer 2. The 3D image is positioned so that the target is 
centered in the Image Drape viewer.

3. Switch the Eye and Target of the Positioning tool in the Viewer. 

Observer 2 is now looking at the location of Observer 1.

Again, the 3D image rotates to match the Eye and Target positions 
of the Viewer.

Save the Viewshed What can we do with a saved viewshed? For example, the saved 
viewshed can be used to create a map composition.

1. In the Viewshed dialog, click Save Image.

The Save Viewshed Image dialog opens.



ERDAS IMAGINE Tour Guides Create a Viewshed / 373

2. In a directory where you have write permission, type vs_tour.img 
in the Viewshed File window.

3. Click OK to dismiss the Save Viewshed Image dialog. 

A Viewshed Analysis progress meter opens while the image is saved.

4. Click Close to dismiss the Viewshed dialog.

Query Viewshed Data In this section, use the Raster Attribute Editor to query the viewshed 
layer in the Viewer.

Create Class Names for Viewshed Regions

1. Select Raster -> Attributes from the Viewer menu bar.

The Raster Attribute Editor opens.

2. Select Edit -> Add Class Names from the Raster Attribute Editor 
menu bar.

A new column is added to the front of the Raster Attributes CellArray.

3. In Row 1 of the Class Names column, enter Perimeter, and press 
Enter on your keyboard.

4. In Row 2, enter Hidden Region, and press Enter on your keyboard.

Type the 
name of the 
viewshed 
image here in 
the directory 
of your choice

Add a 
column 
for class 
names
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5. In Row 3, enter Visible by One Observer, and press Enter on your 
keyboard.

6. In Row 4, enter Visible by Two Observers, and press Enter on 
your keyboard.

Add Area Column to the 
CellArray

1. Now select Edit -> Add Area Column from the Raster Attribute 
Editor menu bar.

The Add Area Column dialog opens.

2. Select acres from the Units dropdown list and click OK to dismiss 
the Add Area Column dialog.

The Area column is added to end of the Raster Attributes CellArray.

3. Select Edit -> Column Properties from the Raster Attribute Editor 
menu bar.

The Column Properties dialog opens.

Class Names identify 
each of the areas in 
the viewshed

Click OK to 
accept hectares



ERDAS IMAGINE Tour Guides Create a Viewshed / 375

4. In the Columns field, select Histogram, and click the Up button 
four times to move it below the Color column.

5. Now select Area, and click the Up button until it is between Color 
and Histogram.

6. Click OK to apply these changes to the CellArray. The Column 
Properties dialog closes.

7. Select File -> Save in the Raster Attribute Editor to save all edits to 
the CellArray.

You can now easily view the size and location of visible and hidden 
areas in the viewsheds.

Query the Viewshed 
Layer

1. Click an area inside the Viewer. The corresponding class is 
highlighted in the CellArray of the Raster Attribute Editor dialog.

2. When you complete your query of the data, select File -> Close in 
the Raster Attribute Editor to dismiss the dialog.

Finish

1. Click Close in the Viewshed dialog.

2. Select File -> Close in the Viewer.

Use the Up and 
Down buttons to 
rearrange 
columns

Columns are 
displayed in the 
new order
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3. Select File -> Close Image Drape in the Image Drape viewer.
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IMAGINE Professional™
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Spatial Modeler

Introduction In ERDAS IMAGINE, GIS analysis functions and algorithms are 
accessible through three main tools:

• script models created with the Spatial Modeler Language (SML)

• graphical models created with Model Maker

• pre-packaged functions in Image Interpreter

Spatial Modeler Language SML is the basis for all GIS functions in ERDAS IMAGINE, and it is the 
most powerful. It is a modeling language that allows you to create 
script (text) models for a variety of applications. Using models, you 
can create custom algorithms that best suit your data and 
objectives.

Model Maker Model Maker is essentially the SML with a graphical interface. This 
enables you to create graphical models using a palette of easy-to-
use tools. Graphical models can be run, edited, saved, or converted 
to script form and edited further using the SML.

This tour guide focuses on Model Maker.

Image Interpreter The Image Interpreter houses a set of common functions that are 
created using either Model Maker or the SML. They have been given 
a dialog interface to match the other processes in ERDAS IMAGINE. 
In most cases, you can run these processes from a single dialog. 
However, the actual models are also delivered with the software, so 
that you can edit them if you want more customized processing.

For more information on Image Interpreter functions, see  
“Image Interpreter” on page 257.

Approximate completion time for this tour guide is 3 hours.

Start Model Maker ERDAS IMAGINE should be running and a Viewer should be open.

1. Click the Modeler icon  on the ERDAS IMAGINE icon panel.

The Spatial Modeler menu displays.
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2. Click Model Maker in the Spatial Modeler menu to start Model 
Maker.

The Model Maker viewer and tool palette open.

ERDAS IMAGINE is delivered with several sample graphical models 
that you can use as templates to create your own models. Open 
these models in Model Maker by selecting File -> Open from the 
Model Maker viewer menu bar or clicking the Open icon on the 
toolbar.

3. Click Close in the Spatial Modeler menu to clear it from the screen.

Create Sensitivity 
Layer

When three input thematic layers are combined, the resulting file has 
meaningful class values. These values may also be easily color coded 
in the final output file so that they are visible over the SPOT 
panchromatic reference data. 

Therefore, you recode the data values of the input files so that the 
most environmentally sensitive areas have the highest class value 
and the least have the lowest value. You use class values 0-4, with 
4 being the most environmentally sensitive and 0 being the least. 
This recode also facilitates defining the conditional statement within 
the function. These recodes are done at the same time the files are 
defined in the Raster dialog.

You must have Model Maker running.

NOTE: Refer to the following model when going through the following 
steps.

1. Click the Raster icon  in the Model Maker tool palette.

2. Click the Lock icon  , which becomes  .

3. Click in the Model Maker viewer in four different places to place three 
input Raster graphics and one output Raster graphic.

4. Select the Function icon  in the Model Maker tool palette.

5. Click in the Model Maker viewer window to place a Function graphic 
on the page between the three inputs and the one output Raster 
graphic. 

6. Select the Connect icon  in the Model Maker tool palette. 
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7. Connect the three input Raster graphics to the Function and the 
Function to the output Raster by simply dragging from one graphic 
to another.

Your model should look similar to the following example: 

8. In the Model Maker tool palette, click the Lock icon to disable the lock 
tool.

9. Click the Select icon  .

10. In the Model Maker viewer menu bar, select Model -> Set Window 
to define the working window for the model.

The Set Window dialog opens.

You want the model to work on the intersection of the input files. The 
default setting is the union of these files.

11. In the Set Window dialog, click the Set Window To dropdown list 
and select Intersection.

12. Click OK in the Set Window dialog.

Click this dropdown 
list to select Intersection 
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Define Input Slope Layer

1. In the Model Maker viewer, double-click the first input Raster 
graphic.

The graphic is highlighted and the Raster dialog opens.

2. In the Raster dialog, click the Open icon  under File Name. 

The File Name dialog opens.

3. In the File Name dialog under Filename, click the file slope.img and 
then click OK.

This image has some noise around the edges that you want to 
eliminate, so you use a subset of this image in the model. To take a 
subset, you display the file in a Viewer and select the processing 
window with an inquire box.

Display Slope Layer

1. Click the Open icon  in a Viewer (or select File -> Open -> 
Raster Layer from the menu bar). 

The Select Layer To Add dialog opens.

Click here, then here,
to recode class values

First, click
the Open icon 
to select the 
slope file Click here to 

select 
processing 
window
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2. In the Select Layer To Add dialog under Filename, click the file 
slope.img.

3. Click the Raster Options tab at the top of the dialog, and then 
select the Fit to Frame option.

4. Click OK in the Select Layer To Add dialog to display the file in the 
Viewer.

Select Area to Use

1. With your cursor in the Viewer, right-hold Quick View -> Inquire 
Box.

A white inquire box opens near the center of the image displayed in 
the Viewer. The Inquire Box Coordinates dialog also opens. The title 
of this dialog is Viewer #1: slope.img. 

Click here to 
select slope.img 

Click here to 
select the 
Raster Options 

A preview of 

displays here 
the image 
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2. Hold inside the inquire box in the Viewer and drag the box to the 
desired image area. You use the entire image area you select, except 
for the edges.

You can reduce or enlarge the inquire box by dragging on the sides 
or corners.

NOTE: You may wish to select nearly the entire image area with the 
inquire box, as this is helpful when you compare your output image 
with the example output image at the end of this exercise.

3. In the Raster dialog, under Processing Window, click From 
Inquire Box.

The coordinates in the Raster dialog now match the coordinates in 
the Inquire Box Coordinates dialog.

4. Click Close in the Inquire Box Coordinates dialog.

Recode Classes Now that the processing window is defined, you can recode the 
values.

1. In the Raster dialog, click the Recode Data option. 

2. Click the Setup Recode button. 

The Recode dialog opens.

You recode this file so that the classes with a slope greater than 25% 
have a class value of 1 and all other classes are 0 (zero). This is easy 
to do using the Criteria option of the Row Selection menu.

3. With your cursor in the Value column of the Recode dialog, right-
hold Row Selection -> Criteria.

The Selection Criteria dialog opens.
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Next, you select all classes with a slope greater than 25%. By looking 
at the Recode dialog, you can see that all classes greater than Value 
4 have a slope greater than 25%. You can then invert your selection 
to recode all classes with values less than 25%.

4. In the Selection Criteria dialog, under Columns, click Value.

$ “Value” displays in the Criteria window at the bottom of the 
dialog.

5. Under Compares, click >.

6. In the calculator, click the number 4.

The Criteria window now shows $ “Value” > 4. 

7. In the Selection Criteria dialog, click Select to select all classes 
meeting that criteria in the Recode dialog.

All classes greater than 4 are highlighted in yellow in the Recode 
dialog.

8. Click Close in the Selection Criteria dialog.

9. In the Recode dialog, confirm that the New Value is set to 1.

10. In the Recode dialog, click Change Selected Rows to give the 
selected classes a new value of 1.

11. With your cursor in the Value column of the Recode dialog, right-
hold Row Selection -> Invert Selection to deselect all currently 
selected classes and select all nonselected classes.

12. Enter a New Value of 0 in the Recode dialog.

13. Click Change Selected Rows to give the selected classes a new 
value of 0.

14. Click OK in the Recode dialog.

The Recode dialog closes.

15. Click OK in the Raster dialog.

Click here
and it displays
here
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The Raster dialog closes. The Raster graphic in the Model Maker 
viewer now has n1_slope_RC written under it.

Define Input Flood Plain 
Layer

1. Double-click the second Raster graphic in the Model Maker viewer. 

The graphic is highlighted and the Raster dialog opens.

2. In the Raster dialog, click the Open icon  under File Name. 

The File Name dialog opens.

3. In the File Name dialog under Filename, select the file 
floodplain.img and then click OK. 

This file does not need to be subset or recoded.

4. Click OK in the Raster dialog.

The Raster dialog closes and n2_floodplain is written underneath 
the second Raster graphic.

Define Input Land Cover 
Layer

1. Double-click the third Raster graphic in the Model Maker viewer. 

The graphic is highlighted and the Raster dialog opens.

2. In the Raster dialog, click the Open icon  under File Name. 

The File Name dialog opens.

3. In the File Name dialog under Filename, select the file 
landcover.img and then click OK. 

You recode this file so that the most sensitive areas have the highest 
class value. 

4. In the Raster dialog, click the Recode Data option.

5. Click the Setup Recode button. 

The Recode dialog opens.

6. In the Value column of the Recode dialog, click 1 to select it.

7. In the New Value box, enter a New Value of 4.

8. Click Change Selected Rows to recode Riparian to 4.

Now both Riparian and Wetlands have a class value of 4.

9. With your cursor in the Value column, right-hold Row Selection -> 
Invert Selection.

Now all classes are selected except one (Riparian). 
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10. With your cursor in the Value column, Shift-click 4 to deselect 
Wetlands.

11. With your cursor in the Value column, Shift-click 0 to deselect the 
background.

Your Recode dialog looks like the following:

12. Enter a New Value of 1.

13. Click Change Selected Rows.

14. Click OK to close the Recode dialog.

15. In the Raster dialog, click OK.

n3_landcover_RC is written under the third Raster graphic in the 
Model Maker viewer.

Now, all of the files are set up so that the most sensitive areas have 
the higher class values: 

These values are used in the next step to create the sensitivity file.

Define Function

1. In the Model Maker viewer, double-click the Function graphic.

The graphic is highlighted and the Function Definition dialog opens.

Rows in yellow are 
recoded to a value of 1

Table 8: Class Values for n3_landcover_RC

Class Value

> 25 percent slope 1

flood plain 1

riparian & wetlands 4

undeveloped land 1
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Next, you use a conditional statement to create a new file that 
contains only the environmentally sensitive areas.

2. In the Function Definition dialog, click the Functions dropdown list 
and select Conditional. 

3. Click CONDITIONAL in the box below Functions. 

The CONDITIONAL function is placed in the function definition 
window at the bottom of the dialog.

4. Type the following statement in the definition box, replacing the 
previously created condition statement:

CONDITIONAL { ($n3_landcover_RC==0)0,
($n3_landcover_RC==4)4,
($n1_slope_RC==1)3,
($n2_floodplain==1)2,
($n3_landcover_RC==1)1 }

NOTE: The file names can be added to your function definition simply 
by clicking in the appropriate spot in the function definition, and then 
clicking on the file name in the list of Available Inputs.

This creates a new output file with the class values 0-4. Each class 
contains the following: 

Select the 
Click here
and it displays
here

Functions here 
Conditional 

Table 9: Conditional Statement Class Values

Class Contents

0 developed

1 undeveloped land

2 flood plain

3 > 25 percent slope

4 riparian & wetlands
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Areas with a class value of 4 are the most environmentally sensitive, 
and are therefore unsuitable for development. Classes 3-1 are also 
environmentally sensitive, but proportionally less so. Further 
analysis determines whether classes 3-1 are eligible for 
development.

5. Take a moment to check over the conditional statement you just 
entered to be sure it is 100% accurate. The model does not run if the 
information has not been entered accurately.

6. Click OK in the Function Definition dialog.

The Function Definition dialog closes and CONDITIONAL is written 
under the Function graphic.

Define Output Raster 
Layer

1. In the Model Maker viewer, double-click the output Raster graphic. 

The graphic is highlighted and the Raster dialog opens.

2. Under File Name, type the name sensitivity.img for the new 
output file.

NOTE: Be sure that you specify a directory in which you have write 
permission.

3. Click the Delete if Exists option so that the output file is 
automatically overwritten when the model is run again.

4. Click the File Type dropdown list and select Thematic. 

5. Click OK in the Raster dialog.

The Raster dialog closes and n4_sensitivity is written under the 
output Raster graphic in the Model Maker viewer. 

Your model should look similar to the following example:
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Save and Run the Model

1. In the Model Maker viewer toolbar, click the Save icon  (or select 
File -> Save As from the Model Maker viewer menu bar) to save the 
model.

The Save Model dialog opens.

2. Enter a name for the model. Be sure you are saving in a directory in 
which you have write permission.

3. Click OK in the Save Model dialog.

Run the Model You can now run this portion of the model to see if it works correctly.

1. In the Model Maker viewer toolbar, click the Run icon  (or select 
Process -> Run from the Model Maker viewer menu bar) to run the 
model.

Click OK

Enter the name of the 
model here
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While the model runs, a Job Status dialog opens, reporting the status 
of the model.

2. When the model is finished, click OK in the Job Status dialog.

Enhance SPOT 
Data

To enhance the detail in the SPOT data, you run a convolution kernel 
over it before it is combined with the sensitivity layer. This portion of 
the model includes a Raster input, a Matrix input, a Function, and a 
Raster output.

Follow the next series of steps to create this portion of the model in 
a new Model Maker viewer. After you have verified that this portion 
runs correctly, you paste it into the first Model Maker viewer. 

NOTE: Refer to the following model when going through the following 
steps.

1. Click the new Window icon  in the Model Maker viewer toolbar or 
select File -> New to create a new Model Maker viewer.

The new Model Maker viewer opens.

2. Click the Raster icon  in the Model Maker tool palette, then click 

the Lock icon  .

3. Click twice in the Model Maker viewer to place the input and output 
Raster graphics.

4. Click the Matrix icon  in the Model Maker tool palette.

5. Click in the Model Maker viewer to place the input Matrix graphic.

This is where you define the convolution kernel.

6. Click the Function icon  in the Model Maker tool palette.

7. Click the Model Maker viewer to place a Function graphic on the 
page.

Place the Function graphic between the two inputs and the output 
Raster graphic. 

8. Click the Connect icon  .

9. Connect the input Raster graphic to the Function, the input Matrix to 
the Function, and the Function to the output Raster.

This part of the model looks similar to the following example:
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10. In the Model Maker tool palette, click the Lock icon to disable the 
Lock tool.

11. Click the Select icon  .

Define Input SPOT Layer

1. Double-click the input Raster graphic in the Model Maker viewer. 

The graphic is highlighted and the Raster dialog opens.

2. In the Raster dialog, click the Open icon  under File Name. 

The File Name dialog opens.

3. In the File Name dialog under Filename, click the file spots.img 
and then click OK.

4. Click OK in the Raster dialog.

The Raster dialog closes, and n1_spots is written under the input 
Raster graphic.

Define Input Convolution 
Kernel

In Model Maker, you have access to built-in kernels or you can create 
your own. In this exercise, use the built-in 5 × 5 summary filter.

1. Double-click the input Matrix graphic.

The Matrix Definition and Matrix dialogs open. 
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2. In the Matrix Definition dialog, click the Kernel dropdown list and 
select Summary. 

3. Click the Size dropdown list and select 5x5. 

The kernel displays in the Matrix dialog. 

4. Click OK in the Matrix Definition dialog.

The Matrix Definition and Matrix dialogs close, and n3_Summary is 
written under the Matrix graphic in the Model Maker viewer.

Define Function

1. Double-click the Function graphic in the Model Maker viewer.

The Function Definition dialog opens.

Selected kernel shown here

Click here to 

Click here to 
select the size

select the 
kernel
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2. Click CONVOLVE from the list below Functions. 

The CONVOLVE statement displays in the function definition 
window. 

3. Click in the first prototype (<raster>), and then click $n1_spots 
under Available Inputs to define the raster input. 

4. Click in the second prototype (<kernel>), and then click 
$n3_Summary under Available Inputs to define the kernel. 

5. Click OK to close the Function Definition dialog.

The Function Definition dialog closes and CONVOLVE is written 
below the Function graphic in the Model Maker viewer.

Define Output Raster 
Layer

1. Double-click the output Raster graphic in the Model Maker viewer.

The Raster dialog opens.

2. In the Raster dialog under File Name, type the name 
spot_summary for the new output file. The .img extension is added 
automatically.

Be sure that you specify a directory in which you have write 
permission.

3. Click the Delete if Exists option.

4. Confirm that Continuous is selected for the File Type. 

5. Click OK in the Raster dialog.

The Raster dialog closes and n2_spot_summary is written under 
the Raster graphic in the Model Maker viewer.

Click here
and it opens
here

Click here and inputs automatically 
display in the designated prototype here 
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Save and Run the Model

1. In the Model Maker viewer toolbar, click the Save icon  (or select 
File -> Save As from the Model Maker viewer menu bar) to save the 
model.

The Save Model dialog opens.

2. Enter a name for the model, such as convolve.gmd, being sure that 
you specify a directory in which you have write permission.

3. Click OK in the Save Model dialog.

Run the Model You can now run this portion of the model to see if it works correctly.

1. In the Model Maker viewer toolbar, click the Run icon  (or select 
Process -> Run from the Model Maker viewer menu bar) to run the 
model. 

While the model runs, a Status box opens, reporting the status of the 
model.

2. When the model is finished running, click OK in the Status box.

Combine Models You now use the Copy and Paste commands to combine these two 
separate models into one. Make sure that both models you created 
are open.

1. In the menu bar of the second model you created, select Edit -> 
Select All.

You can also select objects by clicking and dragging in the Model 
Maker viewer. All objects contained within the selection box that 
you draw are selected.

2. Click the Copy icon  in the toolbar of the same model (or select 
Edit -> Copy from the menu bar) to copy the selected objects to the 
paste buffer.

3. Click the Paste icon  in the toolbar of the first model (or select 
Edit -> Paste from the menu bar) to paste the second model into 
the first Model Maker viewer.

The second model is pasted on top of the first model. 

4. Close the second Model Maker viewer by selecting File -> Close.

NOTE: Do not select File -> Close All, as this closes both of the 
models.

5. Drag the pasted model to the right in the Model Maker viewer, so 
that it does not overlap the first model. 
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You can resize the Model Maker viewer to see the entire model.

6. Click outside of the selection to deselect everything.

Combine 
Sensitivity Layer 
with SPOT Data

With both the thematic sensitivity layer (sensitivity.img) and the 
SPOT data (spot_summary.img) defined, you can use these two 
files as the input raster layers in a function that combines the two 
files into one final output. A Scalar is also used in the function to 
offset the data file values in the SPOT image by five, so that the 
sensitivity analysis does not overwrite any SPOT data.

NOTE: Refer to the following model when going through the next set 
of steps.

1. Click the Function icon  in the Model Maker tool palette.

2. Click in the Model Maker viewer below the output raster graphics 
(n4_sensitivity and n7_spot_summary) to place a Function 
graphic.

3. Click the Scalar icon  in the Model Maker tool palette.

4. Click in the Model Maker viewer to the left of the Function graphic 
you just positioned to place an input Scalar.

5. Click the Raster icon  in the Model Maker tool palette.

6. Click in the Model Maker viewer below the Function to place an 
output Raster graphic.

7. Click the Connect icon  and then on the Lock icon  .

8. Connect the input Raster graphics (n4_sensitivity and 
n7_spot_summary) to the Function, the input Scalar to the 
Function, and then the Function to the output Raster.

9. Click the Lock icon  to disable the lock tool.

10. Click the Select icon  .

Define Input Scalar

1. Double-click the Scalar graphic in the Model Maker viewer.

The Scalar dialog opens. 
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2. In the Scalar dialog, enter a Value of 5.

3. Click the Type dropdown list and select Integer.

4. Click OK in the Scalar dialog.

The Scalar dialog closes and n11_Integer displays under the Scalar 
graphic in the Model Maker viewer.

Define Function Next, you create a file that shows sensitivity data where they exist 
and allows the SPOT data to show in all other areas. Therefore, you 
use the conditional statement.

1. Double-click the untitled Function graphic in the Model Maker viewer.

The Function Definition dialog opens.

2. In the Function Definition dialog, click the Functions dropdown list 
and select Conditional.

3. In the list under Functions, click EITHER.

The EITHER statement and prototype arguments display in the 
function definition window. 

4. Click in the first prototype <arg1>, then click $n4_sensitivity 
under Available Inputs to automatically replace the prototype with 
an argument.

5. Click in the prototype <test>, then click $n4_sensitivity.

Change scalar
type here

Enter value
here

When you 
click here,
it displays
here
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The function definition now reads:

EITHER $n4_sensitivity IF ($n4_sensitivity) OR <arg2> 
OTHERWISE

6. Click the Functions dropdown list and select Analysis.

7. Click the remaining prototype, <arg2>, and then scroll down the list 
under
Functions and click the first STRETCH function to replace <arg2>.

The STRETCH function and its prototype arguments are inserted 
into the function definition.

8. Click <raster>, then click the file name $n7_spot_summary 
under Available Inputs. 

9. Click <stdcount>, then click the number 2 on the calculator. 

10. Using this same method, replace <min> with 0 and <max> with 
250.

The STRETCH function uses two standard deviations to stretch the 
data file values of spot_summary.img between 0 and 250. The 
scalar is added to ensure that there are no data file values between 
0 and 4, since these are the values in the sensitivity file.

11. Click in front of OTHERWISE to insert the cursor in the function 
definition.

12. Click + on the calculator, then $n11_Integer under Available 
Inputs, to add the scalar to the function.

The final function definition should look like the following:

13. Click OK in the Function Definition dialog.

The Function Definition dialog closes, and EITHER $n4_sensitivity 
IF is written under the Function graphic in the Model Maker viewer.
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Define Output Raster 
Layer

1. Double-click the untitled output Raster graphic. 

The Raster dialog opens.

2. In the Raster dialog, enter the file name sensitivity_spot for the 
new output file. 

Be sure that you specify a directory in which you have write 
permission.

3. Click the Delete if Exists option.

4. Click the File Type dropdown list and select Thematic. 

5. Click OK in the Raster dialog.

The Raster dialog closes, and n12_sensitivity_spot is written 
under the Raster graphic in the Model Maker viewer. 

Your final model should look like the following example: 
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Save and Run the Model

1. In the Model Maker viewer toolbar, click the Save icon  (or select 
File -> Save from the Model Maker viewer menu bar) to save the 
model.

Run the Model

You can now run the entire model.

2. In the Model Maker viewer toolbar, click the Run icon  (or select 
Process -> Run from the Model Maker viewer menu bar) to run the 
model. 

While the model runs, a Job Status dialog opens, reporting the status 
of the model.

3. When the model is finished running, click OK in the Job Status 
dialog.

Display New Layer Once your model has run, the new output file is created. You can 
display this file in a Viewer and modify the class colors and class 
names of the overlaid sensitivity analysis.

Prepare

You must have run the model and you must have a Viewer open.

1. In the Viewer toolbar, click the Open icon  (or select File -> 
Open -> Raster Layer from the Viewer menu bar).

The Select Layer To Add dialog opens.

2. Under Filename, click the file sensitivity_spot.img.

3. Click the Raster Options tab at the top of the dialog and confirm 
that the Fit to Frame option is selected, so that you can see the 
entire layer.

4. Click OK to display the file.
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Adjust Colors The sensitivity analysis displays with a grayscale color scheme.

1. In the Viewer menu bar, select Raster -> Attributes.

The Raster Attribute Editor opens. You add a Class Names column.

2. In the Raster Attribute Editor, select Edit -> Add Class Names.

A new Class_Names column is added to the CellArray.

Next, rearrange the columns so that the Color and Class Name 
columns come first. This makes it easier to change the colors of the 
overlaid sensitivity analysis.

3. In the Raster Attribute Editor, select Edit -> Column Properties.

The Column Properties dialog opens.
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4. Click Color under Columns, then click Top to make Color the first 
column in the Raster Attribute Editor.

5. Click OK in the Column Properties dialog to change the order of the 
columns.

The Raster Attribute Editor now looks similar to the following 
example:

Next, change the colors and class names.

6. To change the color of the class 1, with your pointer over the color 
patch for that class, right-hold Other.

The Color Chooser dialog opens. 

First, click
the column
name here,
then click
the action
here

Click here to change
the order of the columns

This is 
class 1, 
notice the 
Histogram 
value
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This dialog gives you several options for changing the class colors. 
You can move the black dot on the color wheel, use the slider bars, 
select colors from a library (under the Standard tab), or enter RGB 
values. 

7. Experiment with each of these methods to alter the class colors of 
classes 1 through 4. Change class 1 to Green, class 2 to Yellow, 
class 3 to Tan, and class 4 to Red.

When you have selected the desired color for a class, click Apply and 
then Close in the Color Selector dialog. Then redisplay the Color 
Chooser for the next class by moving your cursor to that color patch 
and right-holding a specific color or Other.

8. Click in the Class_Names column of class 1.

9. Type Undeveloped Land. Press Enter on your keyboard.

Your cursor is now in the class name field of class 2.

10. Type Floodplain for class 2. Press Enter.

11. Type >25 Percent Slope for class 3. Press Enter.

12. Type Riparian and Wetlands for class 4. Press Enter.

Enter RGB values 
here or move the 
slider bars 

A preview of the 
selected color 
displays here 

Drag this slider 
bar upward to 
enhance the 
RGB 

Drag this dot 
to select a color 
on the color 
wheel 

New 
class 
names 
go in this 
column
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Test the Output The following steps describe how to compare your output with the 
one delivered with ERDAS IMAGINE.

You must have completed the Spatial Modeler tour guide up to this 
point, creating sensitivity_spot.img in the process. The file 
sensitivity_spot.img should be displayed in a Viewer.

1. Display the file 
<IMAGINE_HOME>/examples/modeler_output.img in a 
second Viewer.

2. Select Session -> Tile Viewers from the ERDAS IMAGINE menu 
bar to position the two Viewers side by side, so that you can view 
both images at once.

3. In Viewer #1, select View -> Link/Unlink Viewers -> 
Geographical.

A Link/Unlink Instructions dialog opens, instructing you to click in 
Viewer #2 to link the two Viewers.

4. Click in Viewer #2 to link the two Viewers and close the Link/Unlink 
Instructions dialog.

If sensitivity_spot.img is a subset of modeler_output.img, 
a white bounding box displays in Viewer #2 
(modeler_output.img), marking the area of the image that is 
shown in Viewer #1 (sensitivity_spot.img).

5. Select Utility -> Inquire Cursor from either Viewer’s menu bar.

6. Compare the two images using the Inquire Cursor.
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7. When you are finished, click Close in the Inquire Cursor dialog.

8. Right-click in the Viewer displaying sensitivity_spot.img to access 
the Quick View menu.

9. Select Geo Link/Unlink.

10. Click in the Viewer containing modeler_output.img to break the 
link.

Add Annotation to 
a Model

You can add annotation to a model to make it more understandable 
to others, or to help you remember what the model does. It is also 
a helpful organizational tool if you create several models and need 
to keep track of them all. 

Next, add a title and an explanation of each function to the model 
you just created. 

You must have the model open.

NOTE: Refer to the following model when going through the next set 
of steps.

Add a Title

1. Select the Text icon  in the Model Maker tool palette.

2. Click near the center of the top of the model page to indicate where 
you want to place the text.

The Text String dialog opens.

3. Type these words in the Text String dialog: Sensitivity Analysis 
Model

4. Press Enter on your keyboard, and then click OK in the Text String 
dialog.

The text string you typed in step 3 displays on the page.

Format Text

1. Click the text string you just added to select it. The string is reversed 
out (white on black) when it is selected.

2. On the Model Maker viewer menu bar, select Text -> Size -> 24.

The text string is redisplayed at the new point size. If the text 
overwrites any of the graphics in the model, you can simply click it 
to select it and then drag it to a new location.
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3. In the Model Maker viewer menu bar, select Text -> Style -> Bold.

The text string is redisplayed in bold type.

NOTE: If you want to edit a line of text, simply double-click it to bring 
up the Text String dialog again. Correct your entry or type a new 
one.

Add Text to a Function 
Graphic

1. In the Model Maker tool palette, select the Text tool and then the 
Lock tool to add text to the first Function graphic.

2. Click the center of the CONDITIONAL Function graphic, toward the 
top of the graphic.

The Text String dialog opens.

3. Type the following words in the Text String dialog:

Create a sensitivity file by

4. Press Enter on your keyboard, and then click OK in the Text String 
dialog.

5. Click under the first line of text to add another line. 

6. In the Text String dialog, type:

combining Slope, Floodplain, and Landcover

7. Press Enter on your keyboard and then click OK in the Text String 
dialog.

8. Repeat step 5 to add a third line of text:

using a conditional statement.

9. Click OK.

All three text strings display over the Function graphic, but they are 
very large.

Format Text

1. In the Model Maker tool palette, click the Lock icon to disable the lock 
tool and then click the Select icon.

2. Click the first line on the Function graphic to select it.

3. Shift-click the second and third lines to add to the selection.

4. Using the same procedure you used to change the point size and 
style of the title, change these lines to 14 points, Normal.

You may also want to adjust the positioning (simply drag on the 
text).
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Add Text to Other 
Graphics

1. Add the following lines of text to the CONVOLVE function:

Enhance the SPOT image
using a summary filter.

2. Next, add these two lines to the final output raster 
(n12_sensitivity_spot):

Overlay of sensitivity analysis on
SPOT Panchromatic image.

Your annotated model should look like the following example. 

3. Save the model by selecting File -> Save from the menu bar.

Generate a Text 
Script

The graphical models created in Model Maker can be output to a 
script file (text) in SML. Select Tools -> Edit Text Files from the 
ERDAS IMAGINE menu bar, and then edit these scripts using the SML 
syntax. Re-run or save the edited scripts in the script library.

SML is designed for advanced modeling, and encompasses all of the 
functions available in Model Maker, as well as:

• conditional branching and looping
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• complex data types

• flexibility in using raster objects

To generate a script from a graphical model, follow these steps:

The graphical model must be open.

1. In the Model Maker viewer menu bar, select Process -> Generate 
Script.

The Generate Script dialog opens.

The Script Name defaults to the same root name as the graphical 
model. Scripts have the extension .mdl. 

2. If you do not want to use the default, enter a new file name under 
Script Name.

3. Click OK to generate the script.

The model is now accessible from the Model Librarian option of 
Spatial Modeler.

4. From the ERDAS IMAGINE icon panel, click the Modeler icon.

The Spatial Modeler menu displays.

5. Select the Model Librarian option in the Spatial Modeler menu.

The Model Librarian dialog opens. 

Enter a new 
file name here 

Click here to 
generate the script 



ERDAS IMAGINE Tour Guides Generate a Text Script / 409

From this dialog you can edit, delete, or run script models.

6. Under Model Library, select the name you used for your model in 
step 2.

7. Click Edit in the Model Librarian dialog.

The model displays in the Text Editor, as in the following example:

Click here 
to select 

Click here 
to edit 

the model 
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Annotation in scripts is located at the top of the file, in the order 
in which it was entered. If you want the annotation to be in the 
order of processing, annotate your graphical model from top to 
bottom.

8. Select File -> Close from the Text Editor menu bar.

9. Click Close in the Model Librarian dialog and the Spatial Modeler 
menu.

Print the Model You can output graphical models as ERDAS IMAGINE annotation files 
(.ovr extension) and as encapsulated PostScript files (.eps 
extension). You can also output directly to a PostScript printer.

You must have a graphical model open.

1. In the Model Maker viewer menu bar, select File -> Page Setup.

The Page Setup dialog opens. 

The default setting specifies a 8.5” × 11” page size. This is acceptable 
for most PostScript printers. 

2. In the Page Setup dialog, adjust the size of the Page Margins to suit 
your preferences.

3. Click OK.

4. In the Model Maker viewer menu bar, select File -> Show Page 
Breaks.

Dotted lines indicate page breaks according to the page size 
specified in the Page Setup dialog. You may have to use the scroll 
bars on the bottom and side of the Model Maker viewer to see these 
page breaks. 

5. If your model takes up more than one page, you may want to 
rearrange it so that it fits on a single sheet.

Enter printer
paper size here

Indicate margins
around the outside
edges of each page

Enter magnification 
or reduction to apply 
before printing here 

here 
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6. In the Model Maker viewer toolbar, click the Print icon  (or select 
File -> Print from the Model Maker viewer menu bar). 

The Print dialog opens.

7. In the Print dialog, select the page(s) to print in the Pages box, or 
select All to print the entire model.

8. Click Print to print the model.

Apply the Criteria 
Function

The Criteria function in Model Maker simplifies the process of 
creating a conditional statement. In this example, you use data from 
a thematic raster layer and a continuous raster layer to create a new 
output layer. The input layers include a Landsat TM file and a slope 
file. This model performs similar to a parallelepiped classifier, but 
uses slope and image statistics in the decision process. The output 
file contains four classes: chaparral in gentle slopes, chaparral in 
steep slopes, riparian in gentle slopes, and riparian in steep slopes.

For information on the parallelepiped classifier, see  “Advanced 
Classification” on page 479.

Evaluate Training 
Samples

Before beginning, the ERDAS IMAGINE Classification tools were used 
to gather training samples of chaparral and riparian land cover. This 
was done to determine the minimum and maximum data file values 
of each class in three of the seven TM bands (4, 5, 3). These values 
are listed in the following table:

Select to print 
the entire model 

Select to print
specific pages 

Table 10: Training Samples of Chaparral and Riparian Land 
Cover

Band

Chaparral Riparian

Min Max Min Max

4 31 67 55 92
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Slopes below class value 3 are less than 8 percent, and therefore are 
characterized as gentle. Slopes in class value 3 or above are greater 
than 8 percent, and are characterized as steep. These values are 
used in the criteria function.

You must have Model Maker running, with a new Model Maker viewer 
displayed.

1. Click the Raster icon  in the Model Maker tool palette, then click 

the Lock icon  .

2. Click three times in the Model Maker viewer to place the two input 
Raster graphics and the one output Raster graphic.

3. Click the Criteria icon  in the Model Maker tool palette.

4. Click in the Model Maker viewer to place the criteria graphic between 
the input and output Raster graphics.

5. Click the Connect icon  .

6. Connect the input Raster graphics to the criteria and the criteria to 
the output Raster graphic.

7. Click the Lock icon to disable the lock tool.

8. Click the Select icon  .

Define Input Raster 
Layers

1. Double-click the first Raster graphic in the Model Maker viewer.

The Raster dialog opens.

2. In the Raster dialog, click the Open icon  under File Name. 

The File Name dialog opens.

3. In the File Name dialog under Filename, select the file dmtm.img 
and click OK.

5 30 61 57 87

3 23 37 27 40

Table 10: Training Samples of Chaparral and Riparian Land 
Cover (Continued)

Band

Chaparral Riparian

Min Max Min Max
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4. Click OK in the Raster dialog.

The Raster dialog closes and n1_dmtm is written underneath the 
Raster graphic.

5. Double-click the second Raster graphic.

The Raster dialog opens.

6. In the Raster dialog, click the Open icon  under File Name. 

The File Name dialog opens.

7. In the File Name dialog, select the file slope.img and click OK.

8. Click OK in the Raster dialog.

The Raster dialog closes and n2_slope is written underneath the 
Raster graphic.

Define Criteria

1. Double-click the Criteria graphic in the Model Maker viewer.

The Criteria dialog opens.

2. In the Criteria dialog, click $n2_slope under Available Layers. 

The descriptor fields associated with that layer are now listed in the 
Descriptor dropdown list. 

3. Click the Descriptor dropdown list to select the Value descriptor. 

4. Click Add Column to add that descriptor to the Criteria Table.

5. Under Available Layers, click $n1_dmtm(4), then click Add 
Column to add a column for the minimum data file values in band 4. 

6. Click Add Column again to add a column for the maximum data file 
values in band 4. 

7. Repeat this procedure for $n1_dmtm(5) and $n1_dmtm(3). 

There are now eight columns in the Criteria Table.

Click here to add a column—columns display here 

Click here to 
select a file, 
then click here 
to select a 
descriptor 

Change the number
of rows here



Apply the Criteria Function / 414ERDAS IMAGINE Tour Guides

8. Change the number of Rows to 4, because the final output file has 
four classes. 

9. Click in the first row of the $n2_slope column and type <3. Press 
Enter on your keyboard.

10. Under $n2_slope, enter >=3 in row 2, <3 in row 3, and >=3 in 
row 4.

11. In the same manner, enter the minimum and maximum data file 
values for chaparral and riparian in the Criteria Table. 

Rows 1 and 2 correspond to chaparral, and rows 3 and 4 correspond 
to riparian (see Table 10, “Training Samples of Chaparral and 
Riparian Land Cover”).

The Criteria dialog should look like the one in the following diagram:

The complete Criteria Table should look similar to the following 
table: 

12. When all of the values are entered into the Criteria Table, click OK.

The Criteria dialog closes and All Criteria is written under the 
criteria graphic.

Table 11: Complete Criteria Table

Row $n2_slope. 
“Value”

$ncc1_dmtm
(4)

$n1_dmtm
(4)

$n1_dmtm
(5)

$n1_dmtm
(5)

$n1_dmtm
(3)

$n1_dmtm
(3)

1 <3 >31 <67 >30 <61 >23 <37

2 >=3 >31 <67 >30 <61 >23 <37

3 <3 >55 <92 >57 <87 >27 <40

4 >=3 >55 <92 >57 <87 >27 <40
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Define Output Raster 
Layer

1. Double-click the output Raster graphic in the Model Maker viewer.

The Raster dialog opens.

2. In the Raster dialog under File Name, enter the name 
slope_ppdclass, then Enter on your keyboard.

Be sure that you specify a directory in which you have write 
permission.

3. Click the Delete if Exists option.

4. Click the Data Type dropdown list and select Unsigned 4-bit. 

5. Confirm that Thematic is selected in the File Type dropdown list. 

6. Click OK in the Raster dialog.

The Raster dialog closes and n3_slope_ppdclass is written under 
the output Raster graphic.

The model you created looks like this:

7. In the Model Maker viewer menu bar, select Model -> Set Window 
to define the working window for the model.

The Set Window dialog opens.

Click this dropdown 
list to select Intersection 
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You want the model to work on the intersection of the input files. The 
default setting is the union of these files.

8. In the Set Window dialog, click the Set Window To dropdown list 
and select Intersection.

9. Click OK in the Set Window dialog.

Save the Model

1. Click the Save icon  or select File -> Save As from the Model 
Maker viewer toolbar to save your model.

The Save Model dialog opens.

2. In the Save Model dialog, enter a name for your model. 

Be sure you are saving the model in a directory in which you have 
write permission.

3. Click OK in the Save Model dialog.

4. In the Model Maker viewer toolbar, click the Run icon  (or select 
Process -> Run from the Model Maker viewer menu bar) to run the 
model.

While the model runs, a Job Status dialog opens, reporting the status 
of the model.

5. When the model is finished, click OK in the Job Status dialog.

6. If you like, display slope_ppdclass.img in a Viewer to view the 
output image of your model.



ERDAS IMAGINE Tour Guides Minimizing Temporary Disk Usage / 417

The image displays in grayscale. The class values are defined in the 
criteria function where: 1—chaparral in gentle slopes, 2—chaparral 
in steep slopes, 3—riparian in gentle slopes, and 4—riparian in steep 
slopes.

Minimizing 
Temporary Disk 
Usage 

The Spatial Modeler attempts to perform operations in memory 
where possible, but there are some common operations that produce 
temporary files. Any time a Global operation is performed on an 
intermediate result, a temporary file is produced. For example, if the 
Global Maximum pixel value is required for an image being 
calculated, nothing other than an estimate may be produced without 
actually generating the image.

If an intermediate image is going to be used in two or more 
additional functions in a model, a temporary file is created. Also if 
nonpoint functions like Spread and Clump are preformed on 
intermediate results, or if their results are used in further processes, 
temporary files are created.

There are two types of temporary files created by Spatial Modeler: 
temporary files, which are declared as such; and intermediate files, 
which get created due to the mix of operations. The amount of space 
required by temporary files can be controlled to some degree by user 
preferences. By default, Spatial Modeler is shipped to maintain the 
highest degree of precision at the expense of disk space. The default 
data type for both temporary and intermediate files is double 
precision floating point, which uses 8 bytes to store a pixel value. 
Depending on your needs, you can cut the size of your temporary 
files in half.

Set Preferences

1. Select Session -> Preferences from the ERDAS IMAGINE menu 
bar.

2. In the Preference Editor, select the Spatial Modeler category.

3. Set Float Temp Type to Single Precision Float. 

4. Set Float Intermediate Type to Single Precision Float.

Spatial Modeler, by default, also does not constrain the area your 
model processes, so temporary files extend to the union of all your 
input images. If, for example, you are doing an operation on two 
input images and your results are only valid in areas where both 
images exist, then setting the following preference may significantly 
reduce your temporary space requirements:

5. Set Window Rule to Intersection.

Also to ensure the temporary files get created on a disk drive where 
space is available, check the following preference:

6. In the Preference Editor, select the User Interface & Session 
category.
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7. Set the Temporary File Directory to a local disk with sufficient free 
space.

In some cases, you may be able to adequately predict the output 
data range of a calculation. For example, if you calculate NDVI within 
your model, you know that at most, it can range from -0.5 to 0.5. In 
this case, you could 

• store the result as floating point, taking at least 4 bytes per pixel, 
or

• scale the results to 0-255 in order to store the result as unsigned 
8-bit data, taking just 1 byte per pixel. In this case since you 
know the range, you can re-scale the data by simply adding 0.5 
then multiplying by 255, without the need for any temporary 
files.

For more extensive examples of how models may be written 
without the use of temporary disk space use Model Maker to 
open: 8bit_pca.gmd and 8bit_res_merge.gmd in the 
<IMAGINE_HOME>/etc/models directory, where 
<IMAGINE_HOME> is the location of ERDAS IMAGINE on your 
system.

Making Your 
Models Usable by 
Others 

Prompt User When you specify specific input rasters or vectors in your model, 
their complete path is stored in the model. The same is true when 
you specify output files. So, to give someone else your models, they 
need to redefine all the inputs and outputs. 

Starting with ERDAS IMAGINE 8.3, inputs and outputs can be set to 
Prompt User so that no absolute paths are contained in the model. 
The model, in turn, may easily be shared without the need to 
redefine any inputs or outputs. 

Providing a User 
Interface to Your Model 

Another method of producing a model that can not only be easily 
shared with others, but is also very easy to run, is to write an EML 
front-end to your model. 

You must have ERDAS IMAGINE running. 

1. Click the Modeler icon  on the ERDAS IMAGINE icon panel.

The Spatial Modeler menu opens.
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2. Click Model Maker on the Spatial Modeler menu.

A blank Spatial Modeler viewer opens along with the Model Maker 
tool palette.

Open an Existing Model

1. Select File -> Open or click the Open Existing Model icon  in the 
toolbar. 

The Load Model dialog opens.

2. Select 8bit_res_merge.gmd in the Load Model dialog, and click 
OK. 

The model opens in the Spatial Modeler viewer.

Select Model Maker

Select 
8bit_res_merge.gmd 
from the list
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3. Select Process -> Generate Script. 

The Generate Script dialog opens.

4. Click the Open icon  in the Generate Script dialog, and navigate 
to a directory where you have write permission.

5. Name the file 8bit_res_merge.mdl, then click OK in the dialog.

Remember where you saved the file. You use it again in “Edit the 
EML”. 

Save the .mdl file in a 
location where you have 
writer permission
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6. Click OK in the Generate Script dialog. 

Edit the Model

1. In the Spatial Modeler menu, click Model Librarian. 

2. Navigate to the directly in which you saved 8bit_res_merge.mdl, 
and select it.

3. Click the Edit button in the Model Librarian dialog. 

The following SML script displays in the Editor: 

Select the model 
from your writable 
directory

Click Edit to make 
changes to the 
model
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# Principal Components Resolution Merge 
# Input Multispectral (8-bit) 
# Principal Components 
# Replace PC1 with High Res Data 
# Inverse PC 
# Output Merged Image (8-bit) 
# Input High Resolution (8-bit) 
# Stretch to Approximate PC1 Data Range 
# 
# set cell size for the model 
# 
SET CELLSIZE MIN; 
# 
# set window for the model 
# 
SET WINDOW INTERSECTION; 
# 
# set area of interest for the model 
# 
SET AOI NONE; 
# 
# declarations 
# 
Float RASTER n1_dmtm FILE OLD NEAREST NEIGHBOR AOI NONE 

ì$IMAGINE_HOME/examples/dmtm.imgî; 
Integer RASTER n23_spots FILE OLD NEAREST NEIGHBOR AOI 
NONE 

ì$IMAGINE_HOME/examples/spots.imgî; 
Integer RASTER n29_merge_small FILE DELETE_IF_EXISTING 
IGNORE 

0 ATHEMATIC 8 BIT UNSIGNED INTEGER 
ìc:/temp/merge_small.imgî; 

FLOAT MATRIX n3_Output; 
FLOAT MATRIX n11_Output; 
FLOAT MATRIX n26_Output; 
FLOAT TABLE n16_Output; 
{ 
# 
# function definitions 
# 
#define n31_memory Float(STRETCH ($n23_spots(1) , 3 , 0 
, 255 )) 
n3_Output = COVARIANCE ( $n1_dmtm ); 
n11_Output = MATTRANS ( EIGENMATRIX ($n3_Output) ); 
n26_Output = MATINV ( $n11_Output ) ; 
#define n7_memory Float(LINEARCOMB ( $n1_dmtm - GLOBAL 
MEAN ( 

$n1_dmtm ) , $n11_Output )) 
n16_Output = EIGENVALUES ( $n3_Output ) ; 
#define n22_memory Float(FLOAT((($n31_memory - 127.5) * 
3 * 

(SQRT($n16_Output[0]))) / 127.5)) 
#define n38_memory Float(STACKLAYERS($n22_memory , 

$n7_memory(2: NUMLAYERS ($n7_memory)))) 
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n29_merge_small = LINEARCOMB ( $n38_memory , 
$n26_Output ) + 

GLOBAL MEAN ( $n1_dmtm ); 
} 
QUIT;

4. Locate “$IMAGINE_HOME/examples/dmtm.img” (in bold 
above) on line 24 and change it to arg1. 

5. Locate “$IMAGINE_HOME/examples/spots.img” (in bold 
above) on line 25 and change it to arg2. 

6. Locate “c:/temp/merge_small.img” (in bold above) on line 26 
and change it to arg3.

7. Select File -> Save, or click the Save Current Document icon  in 
the Editor. 

Edit the EML

1. Select File -> New, or click the New icon  in the Editor. 

2. Select File -> Open, or click the Open icon  .

3. In the Load File dialog, type *.eml for the File Name and change 
Files of type to All Files and press Enter on your keyboard.

This searches for EML scripts in the directory.

4. Browse to <IMAGINE_HOME>/scripts, where <IMAGINE_HOME> is 
the location of ERDAS IMAGINE on your system.

5. Select 8bit_res_merge.eml, and click OK in the Load File 
directory. 

The .eml file is located in <IMAGINE_HOME>/scripts, where 
<IMAGINE_HOME> is the location of ERDAS IMAGINE on your 
system.

The following EML script displays in the Editor: 
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component res_merge {

frame res_merge { 
title ìResolution Mergeî; 
geometry 140,120,250,230; 
statusbar;
filename hi_res_pan; 
filename outputname; 
button ok;
filename multi_spec {

title above center ìMultispectral File:î; 
info ìSelect the multispectral input 

file.î; 
shortform; 
geometry 0,10,245,49; 
select getpref (ìemlî 

ìdefault_data_pathî)+î/*.imgî;
filetypedef ìrasterî;
on input { 

if (($multi_spec != ìì) & ($hi_res_pan 
!= ìì) & 

($outputname != ìì)) { enable ok;
} 
else 
{ 
disable ok; 

}
}

}

filename hi_res_pan {
title above center ìHigh Resolution 

Pan File:î;
info ìSelect the high resolution pan 

input file.î;
shortform;
geometry 0,70,245,49;
select getpref (ìemlî 

ìdefault_data_pathî)+î/*.imgî;
filetypedef ìrasterî;
on input {
if (($multi_spec != ìì) & 

($hi_res_pan != ìì) & 
($outputname != ìì)) { enable ok;

}
else
{ 
disable ok;

} 
}

}

filename outputname {
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title above center ìOutput File:î;info 
ìSelect output file.î;

shortform;
geometry 0,130,245,49;
select getpref (ìemlî 

ìdefault_output_pathî)+î/*.imgî; 
filetypedef ìrasterî pseudotypes off 

creatable on;
newfile;
on input {

if (($multi_spec != ìì) & ($hi_res_pan 
!= ìì) & 

($outputname != ìì)) { enable ok;
}
else
{
disable ok;

}
}

}

button ok {
title ìOKî;
info ìAccept all info and issue the 

job.î;
geometry 35,190,82,25;
on mousedown {
disable ok;
job modeler -nq

"c:/program files/imagine 
8.7/etc/models/8bit_res_merge.mdl" 

-meter
-state 
quote($multi_spec)
quote($hi_res_pan)
quote($outputname)
;

unload;

} 

}

button cancel {
title ìCancelî;
info ìCancel this process, do not run 

the job.î;
geometry 140,190,82,25;
on mousedown { 
unload ; 

} 
}

on framedisplay { 
disable ok; 



Making Your Models Usable by Others /ERDAS IMAGINE Tour Guides

} 
}

on startup { 
display res_merge; 

} 
}

6. Locate “d:/erdas/models/8bit_res_merge.mdl” (in bold 
above) on line 74, and change it to the location and name of the 
script you generated.

7. Select File -> Save As. 

Change this section 
of the code to reflect 
the location of the 
.mdl file you edited 
with arg1, arg2, and 
arg3

Save the .eml file
with a new name
in a directory 
where you
have write 
permission
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8. In the Save As dialog, navigate to a directory where you have write 
permission.

9. Save the .eml file as 8bit_res_merge_TG.eml, then click OK in the 
Save As dialog.

Set Session Commands

1. On the ERDAS IMAGINE menu bar select Session -> Commands. 

The Session Command dialog opens.

2. In the Command field enter the following command (replacing the 
directory with the one you chose).

load ìc:/temp/8bit_res_merge.emlî 

3. Press Enter on your keyboard.

The following dialog displays:

Your most recent commands are listed here

Type the load command, plus the location 
of the .eml file here to execute the model

Select these files from 
the /examples 
directory

Save the Output File in 
a directory where you 
have write permission
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4. For the Multispectral File, select dmtm.img from the /examples 
directory. 

The file dmtm.img is located in the 
<IMAGINE_HOME>/examples directory, where 
<IMAGINE_HOME> is the location of ERDAS IMAGINE on your 
system.

5. For the High Resolution Pan File, select spots.img from the 
examples directory. 

6. For the Output File, select a directory in which you have write 
permission, and enter the name 8bit_res_merge_TG.img, then 
press Enter on your keyboard.

7. Click OK. 

A Job Status dialog opens, tracking the progress.

8. When the job is 100% complete, click OK in the dialog.

You can set the Keep Job Status Box in the User Interface & 
Session category of the Preference Editor so that the Job Status 
box is dismissed automatically after an operation is performed.

Check the Results

1. In the ERDAS IMAGINE icon panel, click the Viewer icon  .

2. Click the Open icon  , and navigate to the directory in which you 
saved the Output File you just created, 8bit_res_merge_TG.img.

3. Click OK in the Select Layer To Add dialog to add the file.

The image displays in the Viewer.
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4. Click the Open icon, and navigate to the /examples directory.

5. Select the file dmtm.img from the list, then click the Raster 
Options tab.

6. Deselect the Clear Display option.

7. Click OK in the Select Layer To Add dialog.

The multispectral file, dmtm.img, lends the color to the resulting 
file: 8bit_res_merge_TG.img. 

Use the Swipe Utility

1. From the Viewer menu bar, select Utility -> Swipe.

2. Move the slider bar back and forth to see how the two images 
compare.

3. When you are finished, close the Swipe utility.
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Check the spots.img 
image

The panchromatic image, spot.img, is the image that lends the 
detail to the image you created: 8bit_res_merge_TG.img.

1. Click the Viewer icon on the ERDAS IMAGINE icon panel to open a 
new Viewer.

2. Click the Open icon, and navigate to the /examples directory in the 
Select Layer To Add dialog.

3. Select the file spots.img, then click OK in the Select Layer To Add 
dialog.

The file spots.img displays in the Viewer. Note the detail in the 
image.
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4. When you are finished evaluating the images, select Session -> 
Close All Viewers from the ERDAS IMAGINE menu bar.

5. Close the editors.

6. Save changes to your .eml file, 8bit_res_merge_TG.eml.

7. Close the .gmd file, do not save changes.

Using Vector 
Layers in Your 
Model

Vector layers may be used in several different ways within models. 
All processing is done in raster format. However, converting the 
vector layers to raster is done on the fly at either a default resolution 
or one specified to meet the level of detail required by the 
application.

Vector Layers as a Mask One simple application of vector layers is to use polygonal 
boundaries to cookie-cut your imagery. Whether the polygons 
represent political boundaries, ownership boundaries, zoning, or 
study area boundaries, they may be used to limit your analysis to 
just the portions of the imagery of interest.

In the following example you use a vector coverage to not just 
cookie-cut an image but to generate an output image for visual 
presentation that highlights the study area. Inside the study area, 
you enhance the image, while outside the study area you blur the 
image to further distinguish the study area.

You must have ERDAS IMAGINE running. 

1. Click the Modeler icon  on the ERDAS IMAGINE icon panel.

The Spatial Modeler menu opens.

2. Click the Model Maker button in the Spatial Modeler menu.

A blank Model Maker viewer opens along with tools.

Set up the Model

1. Click the Raster icon  in the Model Maker tool palette.

2. Click near the top center of the Model Maker viewer.

3. Click the Matrix icon  in the Model Maker tool palette.

4. Click to the left of the Raster object in the Model Maker viewer.

Select Model Maker
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5. Click the Matrix icon again in the Model Maker tool palette.

6. Click to the right of the Raster object in the Model Maker viewer.

7. Click the Function icon  in the Model Maker tool palette.

8. Click below and to the left of the Raster object in the Model Maker 
viewer.

9. Click the Function icon again in the Model Maker tool palette.

10. Click below and to the right of the Raster object in the Model Maker 
viewer.

11. Click the Raster icon in the Model Maker tool palette.

12. Click below the first Function object in the Model Maker viewer.

13. Click the Raster icon again in the Model Maker tool palette.

14. Click below the second Function object in the Model Maker viewer.

15. Click the Function icon in the Model Maker tool palette.

16. Click below and between the Raster objects just placed in the Model 
Maker viewer.

17. Click the Vector icon  in the Model Maker tool palette.

18. Click to the left of the Function object just placed in the Model Maker 
viewer.

19. Click the Raster icon in the Model Maker tool palette.

20. Click to the right of the Function object just placed in the Model 
Maker viewer.

21. Using the Connection tool  , and optionally the Lock tool, connect 
the objects in the model as depicted in the following picture.

When you are finished, the model looks like the following:
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Add Matrix Properties

1. Make sure the Selector tool  is active.

2. Double-click the top left Matrix object in the Model Maker viewer.

The Matrix Definition and Matrix dialogs open.

Select the 5 × 5 
Summary Kernel
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3. Using the Kernel dropdown list select Summary.

4. Using the Size dropdown list select 5x5.

5. Click the OK button in the Matrix Definition dialog.

Add Raster Properties

1. Double-click the top Raster object in the Model Maker viewer.

2. Click the Open icon  to open the File Name dialog.

3. Select germtm.img from the examples directory, and click OK in 
the File Name dialog.

4. Click OK in the Raster dialog to accept the file germtm.img.

Add Matrix Properties

1. Double-click the top right Matrix object in the Model Maker viewer.

2. Verify that Low Pass is selected in the Kernel dropdown list.

3. Using the Size dropdown list select 7x7.

4. Click the OK button in the Matrix Definition dialog.

Add Function Properties

1. Double-click the left Function object.

The Function Definition dialog opens. 

Select the file 
here
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2. From the Analysis Functions select CONVOLVE ( <raster> , 
<kernel> ), this should be the third item on the list.

3. In the lower portion of the Function Definition dialog, click in the 
middle of <raster>.

4. Under Available Inputs, click $n1_germtm.

5. In the lower portion of the Function Definition dialog, click in the 
middle of <kernel>.

6. Under Available Inputs, click $n2_Summary.

7. Click OK in the Function Definition dialog.

Add Function Properties

1. Double-click the right Function object.

2. From the Analysis Functions select CONVOLVE ( <raster> , 
<kernel> ), this should be the third item on the list.

3. In the lower portion of the Function Definition dialog, click in the 
middle of <raster>.

4. Under Available Inputs, click $n1_germtm.

5. In the lower portion of the Function Definition dialog, click in the 
middle of <kernel>.

6. Under Available Inputs, click $n3_Low_Pass.

Your function string should look like the following:

CONVOLVE ( $n1_germtm , $n3_Low_Pass )

7. Click OK in the Function Definition dialog.

Add Raster Properties

1. Double-click the Raster object that is output from the Function on the 
left.

Define the Analysis 
Function using 
Inputs in this 
window
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2. In the lower-left corner of the dialog click the checkbox Temporary 
Raster Only.

3. Click OK in the Raster dialog.

Add Raster Properties

1. Double-click the Raster object that is output from the Function on the 
right.

2. In the lower left corner of the dialog click the checkbox Temporary 
Raster Only.

3. Click OK in the Raster dialog.

Add Vector Properties

1. Double-click the Vector object in the lower left corner of the model.

The Vector dialog opens.

Click this 
checkbox
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2. Click the Open icon  under Vector Layer Name.

3. In the Vector Layer Name dialog, navigate to the /examples 
directory, and select zone88.

4. Click OK in the Vector Layer Name dialog.

5. Click OK in the Vector dialog to accept the Vector Layer Name.

Add Function Properties

1. Double-click the final Function object.

The Function Definition dialog opens.

2. In the Functions dropdown list, select Conditional.

3. In the list of Functions, select EITHER <arg1> IF ( <test> ) OR 
<arg2> OTHERWISE, this should be the second item on the list.

Select zone88 in the 
/examples directory

Select the 
Conditional 
Function

Edit the 
Function here
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4. In the lower portion of the Function Definition dialog, click in the 
middle of <arg1>.

5. Under Available Inputs, click $n6_memory.

6. In the lower portion of the Function Definition dialog, click in the 
middle of <test>.

7. Under Available Inputs, click $n9_zone88.

8. In the lower portion of the Function Definition dialog, click in the 
middle of <arg2>.

9. Under Available Inputs, click $n7_ memory.

10. Click OK in the Function Definition dialog.

Add Raster Properties

1. Double-click the final output Raster object.

The Raster dialog opens.

2. Click the Open icon and navigate to a directory where you have write 
permission.

3. In the Filename section of the File Name dialog, type 
hilight_germtm.img for the output image name, then click OK in 
the File Name dialog.

4. Click Delete If Exists checkbox.

5. Click the OK button in the Raster dialog.

Your completed model should look like the following:

The output 
file name is 
listed here
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Execute the Model and Check Results

1. Select Process -> Run, or click the Execute the Model icon  in 
the toolbar.

A Job Status dialog opens tracking the progress of the function. 

2. Click OK in the Job Status dialog when it reaches 100% complete.

Next, use the Viewer to examine your output image and locate the 
highlighted area.

3. Click the Viewer icon  in the ERDAS IMAGINE icon bar.

4. Click the Open icon and navigate to the directory in which you saved 
the output file, hilight_germtm.img, then click OK in the dialog to 
display the file.
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5. Use the Zoom In tool  to view the highlighted area.

Notice that the area you emphasized with the model is sharp, while 
the area surrounding it is fuzzy.

6. When you are finished viewing the image select File -> Close from 
the Viewer menu bar.

Add Attributes to Vector 
Layers

Another application of using vector layers in models is to calculate 
summary information about your imagery for each polygon in a 
vector layer. This summary information can then be stored as an 
additional attribute of the vector layer.
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Copy Vector Layers

You must have ERDAS IMAGINE running. 

1. Click the Vector icon  on the ERDAS IMAGINE icon bar.

The Vector Utilities menu opens.

2. Click the Copy Vector Layer button on the Vector Utilities menu.

The Copy Vector Layer dialog opens.

3. In the Vector Layer to Copy section, navigate to the 
<IMAGINE_HOME>/examples directory, and select zone88.

4. In the Output Vector Layer section, navigate to a directory where 
you have write permission.

5. Type the name zone88, then press Enter on your keyboard.

Click Copy 
Vector Layer

Keep the name 
of the file the 
same

This is a directory 
in which you have 
write permission
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6. Click OK in the Copy Vector Layer dialog.

A Job Status dialog opens tracking the progress.

7. When the job is finished, click OK in the Job Status dialog.

8. Click Close in the Vector Utilities menu.

Set up the Model

1. Click the Modeler icon  on the ERDAS IMAGINE icon panel.

The Spatial Modeler menu opens.

2. Click the Model Maker button in the Spatial Modeler menu.

A blank Model Maker viewer opens along with the tools.

3. Click the Raster icon  in the Model Maker tool palette.

4. Click near the upper left corner of the Model Maker viewer.

5. Click the Vector icon  in the Model Maker tool palette.

6. Click to the right of the Raster object in the Model Maker viewer.

7. Click the Function icon  in the Model Maker tool palette.

8. Click below and between the Raster and the Vector objects in the 
Model Maker viewer.

9. Click the Table icon  in the Model Maker tool palette.

10. Click below the Function object in the Model Maker viewer.

11. Using the Connection tool  , and optionally the Lock tool, connect 
the Raster object and the Vector object to the Function object as 
inputs.

12. Using the Connection tool, connect the Function object to the output 
Table object.

When you are finished, the model looks like the following:

Select Model Maker



ERDAS IMAGINE Tour Guides Using Vector Layers in Your Model / 443

Add Raster Properties

1. Confirm the Selector tool  is active.

2. Double-click the Raster object.

3. In the Raster dialog, click the Open icon to open the File Name 
dialog.

4. Select germtm.img from the /examples directory and click OK in 
the File Name dialog.

5. Click OK in the Raster dialog to accept the file germtm.img.

Add Vector Properties

1. Double-click the Vector object.

The Vector dialog opens.
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2. Click the Open icon to open the Vector Layer Name dialog.

3. Select the copy of zone88 you made earlier, and click OK in the 
Vector Layer Name dialog.

4. Click OK in the Vector dialog.

Add Function Properties

1. Double-click the Function object.

The Function Definition dialog opens.

2. In the Functions dropdown list, select Zonal.

3. In the Functions dropdown list, select ZONAL.

4. In the list of Functions, select ZONAL MEAN ( <zone_raster> , 
<value_raster> ), this should be the sixteenth item on the list.

5. In the lower portion of the Function Definition dialog, click in the 
middle of <zone_raster>.

Select the file from the 
directory in which you 
copied it

Choose the Zonal 
Function
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6. Under Available Inputs, click $n2_zone88.

7. In the lower portion of the Function Definition dialog, click in the 
middle of <value_raster>.

8. Under Available Inputs, click $n1_germtm(4).

9. Click the OK button in the Function Definition dialog.

Add Table Properties

1. Double-click the Table object.

The Table Definition dialog opens.

2. Verify that Output is selected.

3. Under the Output Options, click the Output to Descriptor or 
Attribute checkbox.

4. For the Existing Layer Type dropdown list, select Vector Layer.

5. For File, select the copy of zone88 from the directory in which you 
saved it earlier.

6. Since we are computing a new attribute, for Attribute, type MEAN-
NIR.

7. The Data Type dropdown list should now be enabled, so select 
Float.

The Table Definition dialog should look as follows:

8. Click OK in the Table Definition dialog.

Your model should now look like the following:

Click Output to 
Descriptor or Attribute

Select zone88

Make sure Output 
is selected

Choose an existing 
vector layer

Name a new Attribute

Data type is Float
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Execute the Model and Check the Results

1. Select Process -> Run, or click the Execute the Model icon  in 
the toolbar.

2. When the Job Status dialog is 100% complete, click OK.

3. Click the Viewer icon  in the ERDAS IMAGINE icon bar.

4. In the Viewer, select Open -> Vector Layer from the File menu.

5. In the Select Layer To Add dialog, select the copy of zone88 you 
created and click OK.

6. From the Viewer’s Vector menu select Attributes.

7. In the Attribute CellArray, scroll to the right to see the newly created 
MEAN-NIR field.

The values in this column represents the mean pixel value from band 
4 (near infrared) of germtm.img for each of the polygons in 
zone88.

Debug Your Model Model Maker facilitates creating a model to accomplish your task, but 
it may still take some effort to get your model running successfully. 
Model Maker works hand in hand with Modeler. 
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Model Maker is used to create models graphically. To execute these 
models, Model Maker creates an SML script, which it hands off to 
Modeler for execution. Modeler does all of the syntax and error 
checking, so finding an error in your model is not a single step 
operation. The following exercises demonstrate some of the common 
errors encountered in building new models. 

Eliminate Incomplete 
Definition 

In building a model, Model Maker provides prototypes for function 
arguments to be replaced with actual arguments. In this exercise, 
you see what happens if you forget to replace a prototype.

You must have ERDAS IMAGINE running. 

1. Click the Modeler icon  on the ERDAS IMAGINE icon panel.

The Spatial Modeler menu opens.

2. Click Model Maker on the Spatial Modeler menu.

A blank Spatial Modeler viewer opens along with the Model Maker 
tool palette.

Create the Model

1. Click the Raster icon  in the Model Maker tool palette. 

2. Click to place a Raster object in the upper left corner of the Model 
Maker viewer. 

3. Click the Matrix icon  in the Model Maker tool palette.

4. Click to place the Matrix object to the right of the Raster object in the 
Model Maker viewer. 

5. Click the Function icon  in the Model Maker tool palette. 

6. Click to place the Function object below and centered between the 
Raster object and the Matrix object in the Model Maker viewer. 

7. Click the Raster icon in the Model Maker tool palette. 

8. Click to place the Raster object below the Function object in the 
Model Maker viewer. 

9. Click the Connection icon  in the Model Maker tool palette. 

Select Model Maker
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10. Click the Lock icon  in the Model Maker tool palette. It changes 

to reflect the locked state  .

11. Connect the first Raster object and the Matrix object to the Function 
object as inputs. 

12. Connect the Function object to the final Raster object as an output. 

13. Click the Selector icon  in the Model Maker tool palette. 

14. Click the Lock icon in the Model Maker tool palette to turn it off. 

Your model now looks like the following:

Add Raster Properties

1. Double-click the first Raster object. 

The Raster dialog opens.
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2. Click the Open icon  in the Raster dialog to open the File Name 
dialog.

3. In the File Name dialog, select the file dmtm.img from the 
/examples directory.

The file dmtm.img is located in <IMAGINE_HOME>/examples, 
where <IMAGINE_HOME> is the location of ERDAS IMAGINE on 
your system.

4. Click OK in the File Name dialog.

The Raster dialog updates with the appropriate File Name.

5. Click OK in the Raster dialog.

Add Matrix Properties

1. In the Model Maker viewer, double-click the Matrix object. 

The Matrix Definition dialog opens.

Select the file 
here
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2. From the Kernel list, select Summary.

3. From the Size list, select 5 × 5. 

4. Click OK in the Matrix Definition dialog. 

Add Function Properties

1. Double-click the Function object. 

The Function Definition dialog opens.

2. Confirm that the Functions dropdown list shows Analysis.

3. Under Functions, select CONVOLVE ( <raster> , <kernel> ).

Choose Summary and 5 × 5

Selections you 
make display 
here



ERDAS IMAGINE Tour Guides Debug Your Model / 451

4. In the lower portion of the Function Definition dialog, click in the 
middle of <raster>. 

5. Under Available Inputs, click $n1_dmtm. 

At this point you would normally replace the <kernel> prototype, 
but you are going to intentionally forget to do that.

6. Click the OK button. 

Add Raster Properties

1. Double-click the output Raster object. 

The Raster dialog opens.

2. Click the Open icon  , then navigate to a directory where you 
have write permission.

3. In the File Name dialog, enter sharp_dmtm.img for the output 
image name.

4. Click OK in the File Name dialog.

The new file, sharp_dmtm.img, is listed in the Raster dialog.

5. Click the Delete If Exists checkbox. 

This option allows you to run the model many times. You may have 
to run the model more than once to get it working. 

6. Click the OK button in the Raster dialog. 

At this point, your model should look similar to the following:
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7. Select Process -> Run or click the Execute the Model icon  in 
the toolbar. 

A Job Status dialog opens, which tracks the progress of the model 
execution. 

You receive an error similar to the following:

Correct the Model

The next step is to figure out what this error means. 

1. Click OK to dismiss the Error dialog. 

2. Click OK to dismiss the Job Status dialog. 

Note the line 
number on which
the error occurs
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You can set the Keep Job Status Box in the User Interface & 
Session category of the Preference Editor so that the Job Status 
box is dismissed automatically after an operation is performed.

3. In the Model Maker viewer, select Process -> Generate Script.

4. In the Generate Script dialog, click the Open icon, and navigate to a 
directory where you have write permission. 

5. Enter the name sharpen.mdl, and click OK. 

Start the Model Librarian

1. In the Spatial Modeler dialog, click the Model Librarian button.

The Model Librarian dialog opens.

2. Navigate to the correct directory, then select sharpen.mdl.

The name of the model 
displays here

Select Model Librarian

Select the model 
sharpen.mdl from the list
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3. Click the Edit button in the Model Librarian dialog. 

4. In the Editor window, select View -> Current Line Number.

The Current Line Number dialog opens.

5. In the Current Line Number dialog, enter 36 for the Line Number 
(the line number referred to in the Error dialog). 

6. Click the Go To button. 

This highlights the line containing the error as depicted in the 
following picture:

Select the Current 
Line Number option 
from this menu

Enter the Line Number 
you want to view
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If you examine the selected line, just to the right of the equal sign is 
a function, which also serves as a label to a Function object in the 
graphical model. Most syntax errors occur in Function definitions. In 
general, you generate a script so you can relate the line number 
given in the error message back to a particular Function object in the 
model.

Correct the Function

1. In the Model Maker viewer, double-click the Function object, 
CONVOLVE.

2. Examine the function definition to determine the error. 

In this case, you determine the function definition still has an 
argument prototype, <kernel>, that needs to be replaced with an 
actual argument. 

3. In the lower portion of the Function Definition dialog, click in the 
middle of <kernel>. 

4. Under Available Inputs, click $n2_Summary. 

Your Function Definition dialog now looks like the following:

The line, 36, 
is highlighted
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5. Click OK in the Function Definition dialog. 

Execute the Model

1. Select Process -> Run or click the Execute the Model icon  in 
the toolbar.

The model should run to completion without error this time. 

2. Click the OK button to dismiss the Job Status dialog. 

Check the Results

1. Click the Viewer icon  to open a new Viewer.

2. Click the Open icon  , then navigate to the directory where you 
saved the file sharp_dmtm.img.

3. Select the file sharp_dmtm.img, then click OK in the Select Layer 
To Add dialog to open it in the Viewer.

The input 
$n2_Summary 
replaces 
<kernel>
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4. When you are finished viewing the image, click File -> Close in the 
Viewer to close the image. 

Eliminate Object type 
Mismatch 

There are five basic object types that can be either inputs to or 
outputs from a model. These are: 

• Raster

• Vector (input only)

• Matrix

• Table

• Scalar

Depending on the arguments, each function produces a particular 
object type. 

For example, the GLOBAL MAX function produces a Scalar if the 
argument is either a Matrix or a Table. However, it produces a Table 
if the argument is a Raster. In other words, for either a Matrix or a 
Table, the maximum value may be represented by a single number 
(that is, Scalar). A Raster has a maximum value in each individual 
spectral band, so the result in this case is a Table of maximum 
values: one for each band. In order to be consistent, this is still true 
for a Raster with only one band. In this case a table is produced with 
a single entry. 

In the following exercise, you build a model that rescales an image 
based on the maximum pixel value that actually occurs in an image. 
You do this using the GLOBAL MAX function. Initially, you incorrectly 
treat the output of the GLOBAL MAX function as a Scalar so you can 
see the type of error generated. 
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You must have ERDAS IMAGINE running. 

1. Click the Modeler icon  on the ERDAS IMAGINE icon panel.

The Spatial Modeler menu opens.

2. Click Model Maker on the Spatial Modeler menu.

A blank Spatial Modeler viewer opens along with the Model Maker 
tool palette.

Create the Model

1. Click the Raster icon  in the Model Maker tool palette. 

2. Click to position the Raster object in the upper left corner of the 
Model Maker viewer. 

3. Click the Function icon  in the Model Maker tool palette. 

4. Click to position the Function object below and to the right of the 
Raster object in the Model Maker viewer. 

5. Click the Scalar icon  in the Model Maker tool palette. 

6. Click to position the Scalar object below and to the right of the 
Function object in the Model Maker viewer. 

7. Click the Function icon in the Model Maker tool palette. 

8. Click to position the Function object to the left of the Scalar object in 
the Model Maker viewer. 

9. Click the Raster icon in the Model Maker tool palette. 

10. Click to position the Raster object below the Scalar object in the 
Model Maker viewer. 

11. Click the Connection icon  in the Model Maker tool palette. 

12. Click the Lock icon  in the Model Maker tool palette. It changes 

to the locked state  .

13. Connect the first Raster to the first Function. 

Select Model Maker
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14. Also connect the first Raster to the second Function. 

15. Connect the first Function to the Scalar. 

16. Connect the Scalar to the second Function. 

17. Connect the second Function to the final output Raster. 

NOTE: You may want to refer to the following diagram of the model 
to verify your connections. Connections may be broken or deleted by 
using the Connection tool in the reverse direction of the existing 
connection. 

18. Click the Selector icon  in the Model Maker tool palette. 

19. Click the Lock icon in the Model Maker tool palette to turn it off. 

Your model should look like the following:

Add Raster Properties

1. Double-click the first Raster object. 

The Raster dialog opens.
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2. Click the Open icon  on the Raster dialog, and navigate to the 
/examples directory.

3. In the Open File dialog, select spots.img and click OK. 

Add Function Properties

1. Double-click the first Function object. 

The Function Definition dialog opens.

2. In the Functions dropdown list, select Global. 

3. In the list of Global functions, select GLOBAL MAX ( <arg1> ). 

4. In the lower portion of the Function Definition dialog, click in the 
middle of <arg1>. 

Select the file 
spots.img

Select Global 
from the 
Functions list
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5. Under Available Inputs, click $n1_spots. 

6. Click OK in the Function Definition dialog. 

Add Scalar Properties

1. Double-click the Scalar object. 

The Scalar dialog opens.

2. Verify that the Type is set to Float, and click OK. 

You select Float to insure the model uses floating point arithmetic 
instead of integer arithmetic. You do this because you are calculating 
a ratio between 255 and the GLOBAL MAX. In other words, you want 
to be able to multiply the pixel values by numbers such as 1.3, 2.1, 
or 3.4 and not just 1, 2, or 3. 

Add Function Properties

1. Double-click the second Function object. 

The Function dialog opens.

2. Using the calculator portion of the Function Definition dialog enter 
255 / .

3. Under Available Inputs click $n3_Float. 

Confirm that the Type 
is set to Float

The function 
definition 
appears here
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4. In the calculator portion of the Function Definition dialog click *. 

5. Under Available Inputs click $n1_spots. 

6. Click OK in the Function Definition dialog. 

Add Raster Properties

1. Double-click the output Raster object. 

The Raster dialog opens.

2. Click the Open icon  in the Raster dialog, then navigate to a 
directory where you have write permission.

3. Enter stretched.img for the output image name, then click OK in 
the File Name dialog. 

Make sure 
you click the 
Delete If 
Exists 
checkbox

Save the file in 
a directory 
where you 
have write 
permission
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4. In the Raster dialog, click the Delete If Exists checkbox. 

You may have to run the model more than once to get it working. 

5. Click the OK button. 

At this point, your model should look similar to the following:

Execute the Model

1. Select Process -> Run or click the Execute the Model icon  on 
the toolbar. 

A Job Status dialog opens.

You receive an error like the following:
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The next step is to figure out what this error means. 

2. Click OK to dismiss the Error dialog. 

3. Click OK to dismiss the Job Status dialog. 

Check the On-Line Help

When a model is executed, an Assignment statement is generated 
for each Function object in the model. The error is telling you that 
one of the Function objects in the model is generating a different 
object type than what you have it connected to. 

You know that in one of our Function objects we using the GLOBAL 
MAX function, and in the other you are just doing arithmetic. At this 
point, you can use the online documentation to help out. 

1. Click Help -> Help for Model Maker.

2. Click the hyperlink to the Spatial Modeler Language Reference 
Manual in the third paragraph. The on-line manual is in Adobe® 
portable document format (SML.pdf). It opens in a new browser 
window.

3. In the Navigation Pane, click the + beside Section II SML Function 
Syntax to view all topics included in that section.

4. Click the Arithmetic topic to open that page in the Acrobat viewer.
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5. After reading the topic, click the hyperlink to open the Standard 
Rules page. The Standard Rules for Combining Different Types 
topic displays.

6. Scroll down to the Object Types section. 

While this section contains some very useful information, it gives no 
indication that anything is wrong with the Function in which you are 
doing simple arithmetic. 

7. In the Navigation Pane, click the + beside Global to view all the 
pages under this topic.

8. Click GLOBAL MAX (Global Maximum) to display this topic.

9. Scroll down to the Object Types section. 

Note the on-line documentation states, “If <arg1> is a RASTER, the 
result is a TABLE with the same number of rows as <arg1> has 
layers”. In your model, you incorrectly connected the output of 
GLOBAL MAX of a Raster to a Scalar instead of a Table. 

10. Select File -> Exit from the On-Line Help dialog. 

Click here 
to expand
Section II

Click here
to display
the Arithmetic
page

Click here to link
to the Standard Rules page

You can use
the Zoom feature
to adjust the zoom
to a comfortable reading level
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Correct the Model

1. In the Model Maker viewer, click the Scalar object. 

2. Select Edit -> Clear, or press the Delete key on your keyboard.

3. Click the Table icon  in the Model Maker tool palette.

4. Click to position the Table object in the location where the Scalar 
object was in the Model Maker viewer. 

5. Using the Connection tool, connect the first Function to the Table, 
and the Table to the second Function. 

Add Table Properties 

1. Using the Selector tool, double-click the Table object in the Model 
Maker viewer. 

The Table Definition dialog opens.

The Table replaces the 
Scalar you originally 
placed in the model
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2. Click the Data Type dropdown list, and select Float. 

3. Click the OK button. 

Correct Function Properties

1. Double-click the second Function object. 

Notice Model Maker replaced the name of the deleted Scalar object 
with a <scalar> place holder. It did this to remind you what was 
there before. In this case, you replace <scalar> with a Table. 

2. In the lower portion of the Function Definition dialog, click in the 
middle of <scalar>. 

3. Under Available Inputs, click $n6_Output. 

Select the Float Data 
Type

Replace the 
<scalar> place 
holder
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4. Click the OK button in Function Definition dialog. 

Execute the Model

1. Select Process -> Run or click the Execute the Model icon  on 
the toolbar.

The model should run to completion without error this time. 

2. Click the OK button to dismiss the Job Status dialog. 

The other advantage our model has, by properly treating the output 
of the GLOBAL MAX function as a Table, is that it works whether the 
input image has only a single band or hundreds of bands. Remember 
that, with multispectral data, the Table generated by the GLOBAL 
MAX function has an entry for each band representing the maximum 
value in each band, respectively. When we multiply a Raster by a 
Table, each band in the Raster is multiplied by the corresponding 
entry in the Table. This allows our model to work on all bands at once 
without having to loop through each band.

View the Results

1. Click the Viewer icon  to open a new Viewer.

2. Click the Open icon  , then navigate to the directory where you 
saved the file sharp_dmtm.img.

3. Select the file stretched.img, then click OK in the Select Layer To 
Add dialog to open it in the Viewer.

The correct input, 
$n6_Output 
displays in the 
window
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4. When you are finished, click File -> Close in the Viewer to close the 
image.

Eliminate Division by 
Zero

NOTE: Now that you are familiar with the tools and interface of the 
Spatial Modeler, the following two examples,“Eliminate Division by 
Zero” and “Use AOIs in Processing” do not have detailed instructions, 
or as many screen captures to guide you through the process. 

Calculating band ratios with multispectral imagery is a very common 
image processing technique. Calculating a band ratio can be as 
simple as dividing one spectral band by another. Any time division is 
done, care should be taken to avoid division by zero, which is 
undefined. In the following model, you can see what errors division 
by zero can cause and how to correct these errors.

Create the Model

You must have Model Maker running.

1. Click the Raster icon in the Model Maker tool palette.

2. Click near the upper left corner of the Model Maker viewer.

3. Click the Function icon in the Model Maker tool palette.

4. Click below and to the right of the Raster object in the Model Maker 
viewer.

5. Click the Raster icon in the Model Maker tool palette.

6. Click below and to the right of the Function object in the Model Maker 
viewer.

7. Click the Connection icon in the Model Maker tool palette.



Debug Your Model / 470ERDAS IMAGINE Tour Guides

8. Click the Lock icon in the Model Maker tool palette.

9. Connect the first Raster object to the Function object as an input.

10. Connect the Function object to the final Raster object as an output.

11. Click the Selector icon in the Model Maker tool palette.

12. Click the Lock icon in the Model Maker tool palette to turn it off.

Add Raster Properties

1. Double-click the first Raster object.

2. Select ortho.img from the examples directory and click OK.

Add Function Properties

1. Double-click the Function object.

2. Under Available Inputs, click $n1_ortho(1).

3. In the Calculator portion of the Function Definition dialog, click the / 
key.

4. Under Available Inputs, click $n1_ortho(2).

5. Click the OK button.

Add Raster Properties

1. Double-click the output Raster object.

2. Navigate to a directory where you have write permission, and enter 
veg_index.img for the output image name.

3. Click the Delete If Exists (you are going to run the model more 
than once to get it working properly).

4. Click the OK button.

At this point, your model should look similar to the following:
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Execute the Model

1. Select Process -> Run or click the Execute the Model icon in the 
toolbar.

After your model appears to have run to completion you receive the 
following error:

Next, you attempt to avoid dividing by zero by setting the output 
pixel value to zero any place there would be a division by zero.

2. Click OK to dismiss the Error dialog.

3. Click OK to dismiss the Modeler status dialog.

Change Function Properties

1. In the Model Maker viewer, double-click the Function object.

2. Click the Clear button to start our function definition from scratch.

3. In the Functions dropdown list, select Conditional.

4. In the list of functions, select EITHER <arg1> IF ( <test> ) OR 
<arg2> OTHERWISE, this should be the second item on the list.

5. In the lower portion of the Function Definition dialog, click in the 
middle of <arg1>.
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6. In the Calculator portion of the Function Definition dialog, click the 0 
key.

7. In the lower portion of the Function Definition dialog, click in the 
middle of <test>.

8. Under Available Inputs, click $n1_ortho(2).

9. In the Functions dropdown list select Relational.

10. In the list of functions select ==, this should be the first item on the 
list.

11. In the Calculator portion of the Function Definition dialog click the 0 
key.

12. In the lower portion of the Function Definition dialog, click in the 
middle of <arg2>.

13. Under Available Inputs, click $n1_ortho(1).

14. In the Calculator portion of the Function Definition dialog, click the / 
key.

15. Under Available Inputs, click $n1_ortho(2).

Your Function Definition dialog should now contain the following:

16. Click the OK button.

Execute the Model

1. Select Process -> Run, or click the Execute the Model icon in the 
toolbar.

After all the careful checking for division by zero you get the same 
error.The reason you still get the same error is that Modeler 
evaluates the entire statement at once. As it turns out, the error is 
generated when you do an Integer division by zero. So in order to 
avoid the integer division and the resulting error, you can use 
floating point arithmetic to set the output pixel value. You can force 
the use of floating point arithmetic by simply declaring our input 
Raster to be of type Float.

2. Click OK to dismiss the Error dialog.

3. Click OK to dismiss the Modeler status dialog.

Change Raster Properties

1. In the Model Maker viewer, double-click the input Raster object.

2. In the lower central portion of the Raster dialog, in the Declare As 
dropdown list select Float.
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3. Click the OK button.

4. Select Process -> Run or click the Execute the Model icon in the 
toolbar.

The model now runs successfully to completion without any errors. 
However, if you view the resulting image, veg_index.img, you 
notice that it is relatively dark and does not contain much detail. 

This happens because, even though you are calculating a floating-
point ratio, you are still outputting an integer result. So, all resulting 
output pixel values are being truncated to integers. This includes all 
pixels where the pixel value in band two is larger than the pixel value 
in band one—these are all set to 0 instead of retaining values such 
as 0.25, 0.833, or 0.498. In order to maintain the information being 
calculated, all you have to do is change the type of output file being 
generated.

Change Raster Properties

1. In the Model Maker viewer, double-click the output Raster object.

2. In the Raster dialog in the Data Type dropdown list select Float 
Single.

3. Click the OK button.

4. Select Process -> Run or click the Execute the Model icon in the 
toolbar.

If you view the resulting output image now, you see the full detail 
from the computations, which are available for further analysis.
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Use AOIs in Processing Area Of Interest (AOI) processing can be used to restrict the area 
processed of individual images or of the model as a whole. AOIs can 
be used as masks to cookie cut the desired portions of images. When 
and how the mask is applied may not be of much interest in a model 
utilizing point operations. However, in models doing neighborhood 
operations, when the AOI is applied yields differing results. 

For example, if you cookie cut the input image with an AOI before 
doing an edge detection filter, the model produces artificial edges 
around the AOI. In this case, you want to do the edge detection on 
the original input image and cookie cut the results with the AOI. 
Besides using AOIs as processing masks, Vector layer inputs may 
also be used. In the following example, you generate and use an AOI 
to smooth out the appearance of the water in Mobile Bay.

Create AOI

You must have Model Maker running.

1. Click the Raster icon in the Model Maker tool palette.

2. Click near the upper left corner of the Model Maker viewer.

1. In a Viewer, open mobbay.img from the /examples directory.

2. In the Viewer, click the Show Tool Palette for Top Layer icon.

3. Select the Region Grow AOI tool from the palette.

4. Click a dark portion of the water near the southeast corner of the 
image.

5. From the AOI menu select Seed Properties.

6. Click the Area checkbox to turn it off.
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7. Enter 20.0 for the Spectral Euclidean Distance.

8. Click the Redo button.

Add Raster Properties

1. Double-click the first Raster object.

2. Select mobbay.img from the /examples directory.

3. Click the Choose AOI button on the right side of the Raster dialog.

4. Select Viewer as the AOI Source and click OK.

5. Click OK in the Raster dialog.

Add Raster Properties

1. Click the Raster icon in the Model Maker tool palette.

2. Click to the right of the existing Raster in the Model Maker viewer.

3. Double-click this newly placed Raster object.

4. Select mobbay.img from the /examples directory.

5. This time do not select an AOI, but rather just click OK in the Raster 
dialog.

Add Matrix Properties

1. Click the Matrix icon in the Model Maker tool palette.

2. Click just to the right of the two Raster objects in the Model Maker 
viewer.

3. Double-click this newly placed Matrix object.

4. In the Size dropdown list select 5 × 5.

5. Click OK.

Add Function Properties

1. Click the Function icon in the Model Maker tool palette.

2. Click below n3_Low_Pass in the Model Maker viewer.

3. Connect n2_mobbay and n3_Low_Pass to the newly placed 
Function object.

4. Double-click the Function object.

5. From the analysis Functions select CONVOLVE ( <raster> , 
<kernel> ), this should be the third item on the list.
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6. In the lower portion of the Function Definition dialog, click in the 
middle of <raster>.

7. Under Available Inputs, click $n2_mobbay.

8. In the lower portion of the Function Definition dialog, click in the 
middle of <kernel>.

9. Under Available Inputs, click $n3_Low_Pass.

10. Click OK.

Add Raster Properties

1. Click the Raster icon in the Model Maker tool palette.

2. Click below the Function object in the Model Maker viewer.

3. Connect the Function object to the new Raster object.

4. Double-click the new Raster object.

5. Click Temporary Raster Only.

6. Click OK.

Add Function Properties

1. Click the Function icon in the Model Maker tool palette.

2. Click to the left of n5_memory in the Model Maker viewer.

3. Connect n1_mobbay, n2_mobbay, and n5_memory to the 
Function object.

4. Double-click the Function object.

5. In the Functions dropdown list select Conditional.

6. In the list of functions select EITHER <arg1> IF ( <test> ) OR 
<arg2> OTHERWISE, this should be the second item on the list.

7. In the lower portion of the Function Definition dialog, click in the 
middle of <arg1>.

8. Under Available Inputs, click $n5_memory.

9. In the lower portion of the Function Definition dialog, click in the 
middle of <test>.

10. Under Available Inputs, click $n1_mobbay.

11. In the lower portion of the Function Definition dialog, click in the 
middle of <arg2>.

12. Under Available Inputs, click $n2_mobbay.
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Your Function Definition dialog should now contain the following:

$n5_memory is the filtered image, $n1_mobbay has the AOI 
mask, and $n2_mobbay is the original image.

13. Click OK.

Add Raster Properties

1. Click the Raster icon in the Model Maker tool palette.

2. Click below the new Function object in the Model Maker viewer.

3. Connect the Function object to the Raster object.

4. Double-click the output Raster object.

5. Navigate to a directory where you have write permission and enter 
smooth_water.img for the output image name.

6. Click the Delete If Exists, in case you need to run the model more 
than once to get it working properly.

7. Click the OK button.

Your model should look like the following:
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Execute the Model

1. Select Process -> Run or click the Execute the Model icon in the 
toolbar.

2. Use the Viewer and the Swipe tool to compare the original 
mobbay.img and the new smooth_water.img.

Compare the image on the left, above, with the image on the right. 
The image on the right has been visibly smoothed in the areas of 
water. You can see this more clearly if you use the Swipe utility in 
the Viewer (see below).

Using the Swipe Utility

1. Open one file in the Viewer.

2. Open the second file in the Viewer making sure to uncheck the Clear 
Display checkbox in the Raster Options tab of the file selector.

3. Select Swipe from the Viewer Utility menu. The Viewer Swipe 
dialog opens.

4. Grab the Swipe Position slider and drag it left and right while 
observing the Viewer. As you move the slider to the left, the top 
image is rolled back to reveal the underlying image. 

Drag this slider
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Advanced Classification

Introduction Classification is the process of sorting pixels into a finite number of 
individual classes, or categories of data based on their data file 
values. If a pixel satisfies a certain set of criteria, then the pixel is 
assigned to the class that corresponds to that criteria. 

There are two ways to classify pixels into different categories:

• supervised

• unsupervised

Supervised vs. 
Unsupervised 
Classification

Supervised classification is more closely controlled by you than 
unsupervised classification. In this process, you select pixels that 
represent patterns you recognize or that you can identify with help 
from other sources. Knowledge of the data, the classes desired, and 
the algorithm to be used is required before you begin selecting 
training samples.

By identifying patterns in the imagery, you can train the computer 
system to identify pixels with similar characteristics. By setting 
priorities to these classes, you supervise the classification of pixels 
as they are assigned to a class value. If the classification is accurate, 
then each resulting class corresponds to a pattern that you originally 
identified. 

Unsupervised classification is more computer-automated. It allows 
you to specify parameters that the computer uses as guidelines to 
uncover statistical patterns in the data. 

In this tour guide, you perform both a supervised and an 
unsupervised classification of the same image file. 

All of the data used in this tour guide are in the 
<IMAGINE_HOME>/examples directory. You should copy the 
germtm.img file to a different directory so that you can have 
write permission to this file. 

Approximate completion time for this tour guide is 2 hours.

Perform 
Supervised 
Classification

This section shows how the Supervised Classification tools allow you 
to control the classification process. 

You perform the following operations in this section:

• Define signatures.
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• Evaluate signatures.

• Process a supervised classification.

Define Signatures using 
Signature Editor

The ERDAS IMAGINE Signature Editor allows you to create, manage, 
evaluate and edit signatures (.sig extension). The following types of 
signatures can be defined:

• parametric (statistical)

• nonparametric (feature space)

In this section, you define the signatures using the following 
operations:

• Collect signatures from the image to be classified using the area 
of interest (AOI) tools.

• Collect signatures from the Feature Space image using the AOI 
tools and Feature Space tools.

Preparation

ERDAS IMAGINE must be running and a Viewer must be open.

1. Select File -> Open -> Raster Layer from the Viewer menu bar, or 

click the Open icon  on the Viewer toolbar to display the image 
file to be classified. 

The Select Layer To Add dialog opens.

2. In the Select Layer To Add dialog File name section, select 
germtm.img, which is located in the <IMAGINE_HOME>/examples 
directory. This is the image file that is going to be classified.

3. Click the Raster Options tab at the top of the dialog, and then set 
the Layers to Colors to 4, 5, and 3 (Red, Green, and Blue, 
respectively).

Click 

Set values to 
4, 5, 3

Fit to Frame

Click here to 
display the image 

Click here to select
the raster options
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4. Click the Fit to Frame option to enable it.

5. Click OK in the Select Layer To Add dialog.

The file germtm.img displays in the Viewer. If you would like to see 
only the image in the Viewer and not the surrounding black space, 
right-click in the Viewer and select Fit Window to Image.

Open Signature Editor

1. Click the Classifier icon on the ERDAS IMAGINE icon panel.

The Classification menu displays.

2. Select Signature Editor from the Classification menu to start the 
Signature Editor. 

The Signature Editor opens.

3. In the Classification menu, click Close to remove this menu from 
the screen.

Click here to start the
Signature Editor
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4. In the Signature Editor, select View -> Columns.

The View Signature Columns dialog opens.

5. In the View Signature Columns dialog, right-click in the first column, 
labeled Column, to access the Row Selection menu. Click Select 
All.

6. Shift-click Red, Green, and Blue in Column boxes 3, 4, and 5 to 
deselect these rows.

These are the CellArray columns in the Signature Editor that you 
remove to make it easier to use. These columns can be reinstated at 
any time.

7. In the View Signature Columns dialog, click Apply.

The Red, Green, and Blue columns are deleted from the Signature 
Editor.

8. Click Close in the View Signature Columns dialog.

Use AOI Tools to Collect Signatures

The AOI tools allow you to select the areas in an image to be used 
as signatures. These signatures are parametric because they have 
statistical information.

1. Select AOI -> Tools from the Viewer menu bar.

The AOI tool palette displays.

These rows 

be selected 
should not 
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2. Use the Zoom In tool  on the Viewer toolbar to zoom in on one 
of the light green areas in the germtm.img file in the Viewer.

3. In the AOI tool palette, click the Polygon icon  .

4. In the Viewer, draw a polygon around the green area you just 
magnified. Click to draw the vertices of the polygon. Middle-click or 
double-click to close the polygon (depending on what is set in 
Session -> Preferences).

After the AOI is created, a bounding box surrounds the polygon, 
indicating that it is currently selected. These areas are agricultural 
fields. 

Select tool 

Polygon tool 

Region growing 
(seed) tool 
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5. In the Signature Editor, click the Create New Signature(s) from AOI 

icon  or select Edit -> Add from the menu bar to add this AOI 
as a signature.

6. In the Signature Editor, click inside the Signature Name column for 
the signature you just added. Change the name to Agricultural 
Field_1, then press Enter on the keyboard.

7. In the Signature Editor, hold in the Color column next to 
Agricultural Field_1 and select Green.

8. Zoom in on one of the light blue/cyan areas in the germtm.img file 
in the Viewer.

9. Draw a polygon as you did in step 2 through step 4.

These areas are also agricultural fields. 

10. After you create the AOI, a bounding box surrounds the polygon, 
indicating that it is currently selected. In the Signature Editor, click 

the Create New Signature(s) from AOI icon  , or select Edit -> 
Add to add this AOI as a signature.

11. In the Signature Editor, click inside the Signature Name column for 
the signature you just added. Change the name to Agricultural 
Field_2, then press Enter on the keyboard.

12. In the Signature Editor, hold in the Color column next to 
Agricultural Field_2 and select Cyan.

Select Neighborhood Options

This option determines which pixels are considered contiguous (that 
is, they have similar values) to the seed pixel or any accepted pixels.

1. Select AOI -> Seed Properties from the Viewer menu bar.

The Region Growing Properties dialog opens.
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2. Click the Neighborhood icon  in the Region Growing Properties 
dialog. 

This option specifies that four pixels are to be searched. Only those 
pixels above, below, to the left, and to the right of the seed or any 
accepted pixels are considered contiguous.

3. Under Geographic Constraints, the Area checkbox should be 
turned on to constrain the region area in pixels. Enter 300 into the 
Area number field and press Enter on your keyboard. 

This is the maximum number of pixels that are in the AOI. 

4. Enter 10.00 in the Spectral Euclidean Distance number field. 

The pixels that are accepted in the AOI are within this spectral 
distance from the mean of the seed pixel.

5. Next, click Options in the Region Growing Properties dialog. 

The Region Grow Options dialog opens.

6. In the Region Grow Options dialog, make sure that the Include 
Island Polygons checkbox is turned on in order to include polygons 
in the growth region. 

7. Click Close in the Region Grow Options dialog.

Create an AOI

1. In the AOI tool palette, click the Region Grow icon  .

2. Click inside a bright red area in the germtm.img file in the Viewer. 

This is a forest area. A polygon opens and a bounding box surrounds 
the polygon, indicating that it is selected.

Enter 300 here

Enter 10 here

Click here to create 
an AOI at the 
Inquire Cursor 
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3. In the Region Growing Properties dialog, enter new numbers in the 
Area and Spectral Euclidean Distance number fields (for 
example, 500 for Area and 15 for Spectral Euclidean Distance) 
to see how this modifies the AOI polygon.

4. In the Region Growing Properties dialog, click Redo to modify the 
AOI polygon with the new parameters.
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Add a Signature

1. After the AOI is created, click the Create New Signature(s) from AOI 

icon  in the Signature Editor to add this AOI as a signature.

2. In the Signature Editor, click inside the Signature Name column for 
the signature you just added. Change the name to Forest_1, then 
press Enter on the keyboard.

3. In the Signature Editor, hold in the Color column next to Forest_1 
and select Yellow.

4. In the Region Growing Properties dialog, enter 300 in the Area 
number field. 

Add Another Signature

1. In the Viewer, select Utility -> Inquire Cursor.

The Inquire Cursor dialog opens and the inquire cursor (a white 
crosshair) is placed in the Viewer. The inquire cursor allows you to 
move to a specific pixel in the image and use it as the seed pixel. 

2. Drag the intersection of the inquire cursor to a dark red area in the 
germtm.img file in the Viewer. This is also a forest area.
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3. In the Region Growing Properties dialog, click Grow at Inquire. 
Wait for the polygon to display.

4. After the AOI is created, click the Create New Signature(s) from AOI 

icon  in the Signature Editor to add this AOI as a signature.

5. In the Signature Editor, click inside the Signature Name column for 
the signature you just added. Change the name to Forest_2, then 
press Enter on the keyboard.

6. In the Signature Editor, hold in the Color column next to Forest_2 
and select Pink. 

7. Click Close in the Inquire Cursor dialog and the Region Growing 
Properties dialog.

Arrange Layers

1. Now that you have the parametric signatures collected, you do not 
need the AOIs in the Viewer. Select View -> Arrange Layers from 
the Viewer menu bar. 

The Arrange Layers dialog opens. 
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2. In the Arrange Layers dialog, right-hold over the AOI Layer button 
and select Delete Layer from the AOI Options menu. 

3. Click Apply in the Arrange Layers dialog to delete the AOI layer.

4. You are asked if you want to save the changes before closing. Click 
No.

5. In the Arrange Layers dialog, click Close.

Create Feature Space Image

The ERDAS IMAGINE Feature Space tools allow you to interactively 
define areas of interest (polygons or rectangles) in the Feature 
Space image(s). A Feature Space signature (nonparametric) is based 
on the AOI(s) in the Feature Space image. Use this technique to 
extract a signature for water.

1. Select Feature -> Create -> Feature Space Layers from the 
Signature Editor menu bar. 

The Create Feature Space Images dialog opens.

Right-hold over this
button to delete the
AOI layer

Click here to apply
the changes you have
made to the Viewer
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2. In the Create Feature Space Images dialog under Input Raster 
Layer, enter germtm.img. This image is located in 
<IMAGINE_HOME>/examples, and is the image file from which the 
Feature Space image is generated.

Under Output Root Name, the default name is germtm. This is the 
root name for the Feature Space image files that are generated. 

Verify that the directory where the Feature Space image files are 
saved has write permission.

3. In the Create Feature Space Images dialog, click the Output to 
Viewer checkbox so that the Feature Space image displays in a 
Viewer.

4. Under Feature Space Layers, click the number 8 in the FS Image 
column in the CellArray to select the germtm_2_5.fsp.img row. 
(You may need to scroll down to get to FS Image number 8.)

The output Feature Space image is based on layers two and five of 
the germtm.img file. Layers two and five are selected since water 
is spectrally distinct in this band combination.

5. Click OK in the Create Feature Space Images dialog to create the 
Feature Space image for layers two and five of the germtm.img file.

The Create Feature Space Images dialog closes, then the Job Status 
dialog opens.

After the process is complete, a Viewer (Viewer #2) opens, 
displaying the Feature Space image.

Enter germtm.img

Click 

Click here to

Click here to 

output to a Viewer

create image

germtm_2_5.fsp.img

Click here 

this dialog 
to close
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6. Click OK in the Job Status dialog to close this dialog.

Link Cursors in Image/Feature Space

The Linked Cursors utility allows you to directly link a cursor in the 
image Viewer to the Feature Space viewer. This shows you where 
pixels in the image file are located in the Feature Space image. 

1. In the Signature Editor dialog, select Feature -> View -> Linked 
Cursors.

The Linked Cursors dialog opens.

2. Click Select in the Linked Cursors dialog to define the Feature Space 
viewer that you want to link to the Image Viewer.

3. Click in Viewer #2 (the Viewer displaying the Feature Space image).

The Viewer number field in the Linked Cursors dialog changes to 2. 
You could also enter a 2 in this number field without having to click 
the Select button.

4. In the Linked Cursors dialog, click Link to link the Viewers, then click 
in the Viewer displaying germtm.img.

Click to select 
the Feature Space
viewer

This is

Click to link
the Viewers

Click to 
unlink Viewers

Click to close
this dialog 

set to 2
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The linked inquire cursors (white crosshairs) open in the Viewers.

5. Drag the inquire cursor around in the germtm.img Viewer (Viewer 
#1) to see where these pixels are located in the Feature Space 
image. Notice where the water areas are located in the Feature 
Space image. These areas are black in the germtm.img file (Viewer 
#1). 

You may need to use the Zoom In By 2 and Zoom Out By 2 options 
(accessed with a right-click in the Viewer containing the file 
germtm.img) to locate areas of water.

Define Feature Space Signature 

Any Feature Space AOI can be defined as a nonparametric signature 
in your classification.

1. Right-click inside the Viewer containing the Feature Space image and 
select Zoom -> Zoom In By 2 until you can see the area beneath 
the inquire cursor clearly.

2. Use the polygon AOI tool to draw a polygon in the Feature Space 
image. Draw the polygon in the area that you identified as water.

The Feature Space signature is based on this polygon.

3. After the AOI is created, click the Create New Signature(s) from AOI 

icon  in the Signature Editor to add this AOI as a signature.

Draw a polygon 
in the area 

as water 
identified 
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4. The signature you have just added is a nonparametric signature. 
Select Feature -> Statistics from the Signature Editor menu bar to 
generate statistics for the Feature Space AOI.

A Job Status dialog displays, stating the progress of the function.

5. When the function is 100% complete, click OK in the Job Status 
dialog.

The Feature Space AOI now has parametric properties.

6. In the Signature Editor, click inside the Signature Name column for 
the signature you just added. Change the name to Water, then 
press the Enter key on the keyboard.

7. In the Signature Editor, hold in the Color column next to Water and 
select Blue.

8. In the Linked Cursors dialog, click Unlink to unlink the viewers.

The inquire cursors are removed from the viewers.

9. In the Linked Cursors dialog, click Close.

10. Now that you have the nonparametric signature collected, you do not 
need the AOI in the Feature Space viewer. Select View -> Arrange 
Layers from the Viewer #2 menu bar. 

The Arrange Layers dialog opens.

11. In the Arrange Layers dialog, right-hold over the AOI Layer button 
and select Delete Layer from the AOI Options dropdown list.

12. Click Apply in the Arrange Layers dialog to delete the AOI layer.

13. You are asked if you want to save the changes before closing. Click 
No.

14. In the Arrange Layers dialog, click Close.

15. Practice taking additional signatures using any of the signature-
generating techniques you have learned in the steps above. Extract 
at least five signatures.

16. After you have extracted all the signatures you wish, select File -> 
Save As from the Signature Editor menu bar. 

The Save Signature File As dialog opens. 

17. Use the Save Signature File As dialog to save the signature set in the 
Signature Editor (for example, germtm_siged.sig).

18. Click OK in the Save Signature File As dialog.

Use Tools to Evaluate 
Signatures

Once signatures are created, they can be evaluated, deleted, 
renamed, and merged with signatures from other files. Merging 
signatures allows you to perform complex classifications with 
signatures that are derived from more than one training method 
(supervised and/or unsupervised, parametric and nonparametric). 
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Next, the following tools for evaluating signatures are discussed:

• alarms

• contingency matrix

• feature space to image masking

• signature objects

• histograms

• signature separability

• statistics

When you use one of these tools, you need to select the 
appropriate signature(s) to be used in the evaluation. For 
example, you cannot use the signature separability tool with a 
nonparametric (Feature Space) signature.

Preparation

You should have at least ten signatures in the Signature Editor, 
similar to the following:

Set Alarms

The Signature Alarm utility highlights the pixels in the Viewer that 
belong to, or are estimated to belong to a class according to the 
parallelepiped decision rule. An alarm can be performed with one or 
more signatures. If you do not have any signatures selected, then 
the active signature, which is next to the >, is used.

1. In the Signature Editor, select Forest_1 by clicking in the > column 
for that signature. The alarm is performed with this signature. 

2. In the Signature Editor menu bar, select View -> Image Alarm.

The Signature Alarm dialog opens. 
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3. Click Edit Parallelepiped Limits in the Signature Alarm dialog to 
view the limits for the parallelepiped.

The Limits dialog opens.

4. In the Limits dialog, click Set to define the parallelepiped limits.

The Set Parallelepiped Limits dialog opens. 

The Signature Alarm utility allows you to define the parallelepiped 
limits by either:

• the minimum and maximum for each layer in the signature, or

• a specified number of standard deviations from the mean of the 
signature.

5. If you wish, you can set new parallelepiped limits and click OK in the 
Set Parallelepiped Limits dialog, or simply accept the default limits 
by clicking OK in the Set Parallelepiped Limits dialog. 

The new/default limits display in the Limits CellArray. 

6. Click Close in the Limits dialog.

7. In the Signature Alarm dialog, click OK.

The alarmed pixels display in the Viewer in yellow. You can use the 
toggle function (Utility -> Flicker) in the Viewer to see how the 
pixels are classified by the alarm.

Be sure that there are no AOI layers open on top of the Alarm 
Mask Layer. You can use View -> Arrange Layers to remove 
any AOI layers present in the Viewer.

Click to change the
parallelepiped limits
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8. In the Signature Alarm dialog, click Close.

9. In the Viewer #1 menu bar, select View -> Arrange Layers.

The Arrange Layers dialog opens.

10. In the Arrange Layers dialog, right-hold over the Alarm Mask 
button and select Delete Layer from the Layer Options menu.

11. Click Apply to delete the alarm layer from the Viewer.

12. You are asked if you want to save the changes before closing. Click 
No.

13. In the Arrange Layers dialog, click Close.
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Evaluate Contingency

1. In the Signature Editor, select all of the signatures by Shift-clicking 
in the first row of the Class column and then dragging down through 
the other classes. 

2. In the Signature Editor menu bar, select Evaluate -> Contingency.

The Contingency Matrix dialog opens. 

Contingency Matrix
The Contingency Matrix utility allows you to evaluate signatures 
that have been created from AOIs in the image. This utility 
classifies only the pixels in the image AOI training sample, based 
on the signatures. It is usually expected that the pixels of an AOI 
are classified to the class that they train. However, the pixels of 
the AOI training sample only weight the statistics of the signature. 
They are rarely so homogenous that every pixel actually becomes 
assigned to the expected class. The Contingency Matrix utility can 
be performed with multiple signatures. If you do not have any 
signatures selected, then all of the signatures are used.

The output of the Contingency Matrix utility is a matrix of 
percentages that allows you to see how many pixels in each AOI 
training sample were assigned to each class. In theory, each AOI 
training sample would be composed primarily of pixels that belong 
to its corresponding signature class. 

The AOI training samples are classified using one of the following 
classification algorithms:

• parallelepiped

• feature space

• maximum likelihood

• Mahalanobis distance

NOTE: The classification decision rule that is going to be used in 
the actual image classification should be determined so that it can 
also be used in the Contingency Matrix utility.
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3. In the Contingency Matrix dialog, click the Non-parametric Rule 
dropdown list and select Feature Space.

See the chapter "Classification" in the ERDAS Field Guide for 
more information on decision rules.

4. Click OK in the Contingency Matrix dialog to start the process. 

A Job Status dialog displays, stating the progress of the function.

5. When the process is 100% complete, click OK in the Job Status 
dialog.

The IMAGINE Text Editor opens (labelled Editor:, Dir), displaying 
the error matrix.

Click to select
Feature Space

Click to start 
the process
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6. After viewing the reference data in the Text Editor, select File -> 
Close from the menu bar.

7. Deselect the signatures that were selected by right-clicking in the 
Class column and choosing Select None from the Row Selection 
menu.

Generate a Mask from a Feature Space Signature

The Feature Space to Image Masking utility allows you to generate 
a mask from a Feature Space signature (that is, the AOI in the 
Feature Space image). Once the Feature Space signature is defined 
as a mask, the pixels under the mask are identified in the image file 
and highlighted in the Viewer. This allows you to view which pixels 
would be assigned to the Feature Space signature’s class. A mask 
can be generated from one or more Feature Space signatures. If you 
do not have any signatures selected, then the active signature, 
which is next to the >, is used.

The image displayed in Viewer #1 must be the image from which the 
Feature Space image was created. 

1. In the Signature Editor, select Feature -> Masking -> Feature 
Space to Image.
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The FS to Image Masking dialog opens. 

2. In the Signature Editor, click in the > row for Water to select that 
signature. 

The mask is generated from this Feature Space signature.

3. Disable the Indicate Overlap checkbox, and click Apply in the FS to 
Image Masking dialog to generate the mask in Viewer #1. 

A mask is placed in the Viewer.

4. In the FS to Image Masking dialog, click Close. 

5. Deselect the Water feature.

This checkbox should be 
turned off (disabled)

Click to create 
the mask
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View Signature Objects

The Signature Objects dialog allows you to view graphs of signature 
statistics so that you can compare signatures. The graphs display as 
sets of ellipses in a Feature Space image. Each ellipse is based on the 
mean and standard deviation of one signature. A graph can be 
generated for one or more signatures. If you do not have any 
signatures selected, then the active signature, which is next to the 
>, is used. This utility also allows you to show the mean for the 
signature for the two bands, a parallelepiped, and a label. 

1. In the Signature Editor menu bar, select Feature -> Objects.

The Signature Objects dialog opens. 

2. In the Signature Editor, select the signatures for Agricultural 
Field_1 and Forest_1 by clicking in the Class row for Agricultural 
Field_1 and Shift-clicking in the Class row for Forest_1. 

3. In the Signature Objects dialog, confirm that the Viewer number 
field is set for 2. 

4. Set the Std. Dev. number field to 4. 

5. Enable the Label checkbox by clicking on it.

6. Click OK in the Signature Objects dialog. 

The ellipses for the Agricultural Field_1 and Forest_1 signatures 
display in the Feature Space viewer. 

Enter 2 here

Enter 4 here

Click here to start 
the process
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7. In the Signature Objects dialog, click Close.

Compare Ellipses

By comparing the ellipses for different signatures for a one band 
pair, you can easily see if the signatures represent similar groups 
of pixels by seeing where the ellipses overlap on the Feature Space 
image.

• When ellipses do not overlap, the signatures represent a 
distinct set of pixels in the two bands being plotted, which is 
desirable for classification. However, some overlap is 
expected, because it is rare that all classes are totally distinct.

When the ellipses do overlap, then the signatures represent similar 
pixels, which is not desirable for classification.
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8. Deselect the signatures for Agricultural Field_1 and Forest_1.

Plot Histograms

The Histogram Plot Control Panel allows you to analyze the 
histograms for the layers to make your own evaluations and 
comparisons. A histogram can be created with one or more 
signatures. If you create a histogram for a single signature, then the 
active signature, which is next to the >, is used. If you create a 
histogram for multiple signatures, then the selected signatures are 
used.

1. In the Signature Editor, move the > prompt to the signature for 
Agricultural Field_1 by clicking under the > column.

2. In the Signature Editor menu bar, select View -> Histograms or 

click the Histogram icon  . 

The Histogram Plot Control Panel and the Histogram dialogs open. 

3. In the Histogram Plot Control Panel dialog, change the Band No 
number field to 5 in order to view the histogram for band 5 (that is, 
layer 5). 

4. Click Plot.

The Histogram dialog changes to display the histogram for band 5. 
You can change the different plot options and select different 
signatures to see the differences in histograms for various signatures 
and bands.

5. In the Histogram Plot Control Panel dialog, click Close. The two 
Histogram dialogs close. 

Enter 5 here

Click here to create 
histogram plot
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Compute Signature Separability

The Signature Separability utility computes the statistical distance 
between signatures. This distance can be used to determine how 
distinct your signatures are from one another. This utility can also be 
used to determine the best subset of layers to use in the 
classification. 

The distances are based on the following formulas:

• euclidean spectral distances between their means

• Jeffries-Matusita distance

• divergence

• transformed divergence

The Signature Separability utility can be performed with multiple 
signatures. If you do not have any signatures selected, then all of the 
parametric signatures are used. 

1. In the Signature Editor, select all of the parametric signatures. 

2. In the Signature Editor menu bar, select Evaluate -> Separability.

The Signature Separability dialog opens.

3. In the Signature Separability dialog, set the Layers Per 
Combination number field to 3, so that three layers are used for 
each combination.

4. Click Transformed Divergence under Distance Measure to use 
the divergence algorithm for calculating the separability. 

Set this number 

Click here

Click here to 
start process

field to 3
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5. Confirm that the Summary Report radio button is turned on under 
Report Type, in order to output a summary of the report. 

The summary lists the separability listings for only those band 
combinations with best average and best minimum separability.

6. In the Signature Separability dialog, click OK to begin the process. 

When the process is complete, the IMAGINE Text Editor opens, 
displaying the report.

This report shows that layers (that is, bands) 2, 4, and 5 are the best 
layers to use for identifying features.

7. In the Text Editor menu bar, select File -> Close to close the Editor.

8. In the Signature Separability dialog, click Close.

Check Statistics

The Statistics utility allows you to analyze the statistics for the layers 
to make your own evaluations and comparisons. Statistics can be 
generated for one signature at a time. The active signature, which is 
next to the >, is used. 
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1. In the Signature Editor, move the > prompt to the signature for 
Forest_1. 

2. In the Signature Editor menu bar, select View -> Statistics or click 

the Statistics icon . 

The Statistics dialog opens. 

3. After viewing the information in the Statistics dialog, click Close. 

Perform Supervised 
Classification

The decision rules for the supervised classification process are 
multilevel:

• nonparametric

• parametric

In this example, use both nonparametric and parametric decision 
rules.

See the chapter "Classification" in the ERDAS Field Guide for 
more information on decision rules.
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1. In the Signature Editor, select all of the signatures so that they are 
all used in the classification process (if none of the signatures are 
selected, then they are all used by default).

Nonparametric
If the signature is nonparametric (that is, Feature Space AOI), 
then the following decision rules are offered:

• feature space

• parallelepiped

With nonparametric signatures you must also decide the overlap 
rule and the unclassified rule.

NOTE: All signatures have a nonparametric definition, due to their 
parallelepiped boundaries. 

Parametric
For parametric signatures, the following decision rules are 
provided:

• maximum likelihood

• Mahalanobis distance

• minimum distance

In this tour guide, use the maximum likelihood decision rule.

Output File
The Supervised Classification utility outputs a thematic raster 
layer (.img extension) and/or a distance file (.img extension). The 
distance file can be used for post-classification thresholding. The 
thematic raster layer automatically contains the following data:

• class values

• class names

• color table

• statistics

• histogram

The image file also contains any signature attributes that were 
selected in the Supervised Classification utility.
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2. In the Signature Editor menu bar, select Classify -> Supervised to 
perform a supervised classification. 

NOTE: You may also access the Supervised Classification utility from 
the Classification dialog. 

The Supervised Classification dialog opens.

3. In the Supervised Classification dialog, under Output File, type in 
germtm_superclass.img. 

This is the name for the thematic raster layer. 

4. Click the Output Distance File checkbox to activate it. 

In this example, you are creating a distance file that can be used to 
threshold the classified image file.

5. Under Filename, enter germtm_distance.img in the directory of 
your choice. 

This is the name for the distance image file.

NOTE: Make sure you remember the directory in which the output 
file is saved. It is important when you are trying to display the output 
file in a Viewer.

Select Attribute Options

1. In the Output File section of the Supervised Classification dialog, 
click Attribute Options.

The Attribute Options dialog opens.

Click to select 

Click to start 
the process 

Click to define attributes 
for signatures

Enter Click to create 

Enter 

Maximum 
Likelihood

here

Click to select 
Feature Space 

germtm_distance.img 
here

germtm_superclass.img a distance file
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The Attribute Options dialog allows you to specify the statistical 
information for the signatures that you want to be in the output 
classified layer. The statistics are based on the data file values for 
each layer for the signatures, not the entire classified image file. This 
information is located in the Raster Attribute Editor. 

2. In the Attribute Options dialog, click Minimum, Maximum, Mean, 
and Std. Dev., so that the signatures in the output thematic raster 
layer have this statistical information. 

3. Confirm that the Layer checkbox is turned on, so that the 
information is presented in the Raster Attribute Editor by layer. 

4. In the Attribute Options dialog, click Close to remove this dialog.

Classify the Image

1. In the Supervised Classification dialog, click the Non-parametric 
Rule dropdown list to select Feature Space.

You do not need to use the Classify Zeros option here because 
there are no background zero data file values in the germtm.img 
file. 

2. Click OK in the Supervised Classification dialog to classify the 
germtm.img file using the signatures in the Signature Editor.

A Job Status dialog displays, indicating the progress of the function.

3. When the process is 100% complete, click OK in the Job Status 
dialog.

See the chapter “Classification” in the ERDAS Field Guide for 
information about how the pixels are classified. 

Click here

Click here to close 
this dialog 
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4. Select File -> Close from the Signature Editor menu bar. Click Yes 
when asked if you would like to save the changes to the Signature 
Editor. 

5. Select File -> Close to dismiss Viewer #2.

6. You do not need to save changes to the AOI in the Signature Editor, 
so click No on that message dialog.

7. Click Close in the AOI tool palette.

8. Select File -> Clear from the Viewer #1 menu bar.

9. Proceed to:

• “Perform Unsupervised Classification” to classify the same image 
using the ISODATA algorithm.

• “Evaluate Classification” to analyze the classes and test the 
accuracy of the classification, or 

The super classification image is pictured on the left, and the 
distance image is pictured on the right.
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Perform 
Unsupervised 
Classification

This section shows you how to create a thematic raster layer by 
letting the software identify statistical patterns in the data without 
using any ground truth data. 

ERDAS IMAGINE uses the ISODATA algorithm to perform an 
unsupervised classification. The ISODATA clustering method uses 
the minimum spectral distance formula to form clusters. It begins 
with either arbitrary cluster means or means of an existing signature 
set, and each time the clustering repeats, the means of these 
clusters are shifted. The new cluster means are used for the next 
iteration. 

The ISODATA utility repeats the clustering of the image until either 
a maximum number of iterations has been performed, or a 
maximum percentage of unchanged pixel assignments has been 
reached between two iterations.

Performing an unsupervised classification is simpler than a 
supervised classification, because the signatures are automatically 
generated by the ISODATA algorithm. 

In this example, you generate a thematic raster layer using the 
ISODATA algorithm. 

Preparation You must have ERDAS IMAGINE running.
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1. Click the Classifier icon in the ERDAS IMAGINE icon panel to start the 
Classification utility.

The Classification menu opens.

Generate Thematic 
Raster Layer

1. Select Unsupervised Classification from the Classification menu 
to perform an unsupervised classification using the ISODATA 
algorithm. 

The Unsupervised Classification dialog opens.

Click here to start 
the Unsupervised 
Classification utility
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2. Click Close in the Classification menu to clear it from the screen.

3. In the Unsupervised Classification dialog under Input Raster File, 
enter germtm.img. This is the image file that you are going to 
classify. 

4. Under Output Cluster Layer, enter germtm_isodata.img in the 
directory of your choice. 

This is the name for the output thematic raster layer. 

5. Click Output Signature Set to turn off the checkbox. 

For this example, do not create a signature set. The Output 
Signature Set file name part is disabled. 

Set Initial Cluster Options

The Clustering Options allow you to define how the initial clusters 
are generated. 

1. Confirm that the Initialize from Statistics radio button under 
Clustering Options is turned on. 

This generates arbitrary clusters from the file statistics for the image 
file.

2. Enter a 10 in the Number of Classes number field.

Set Processing Options

The Processing Options allow you to specify how the process is 
performed. 

Enter germtm.img here Click here to turn off 

Enter germtm_isodata.img 

Enter 10 here to generate 
10 classes (that is, signatures)

Enter 24 for the maximum 

process can run

This should be 

Click here to 

the Output Signature Set

here

file name part

set to .950

start the process

number of times the
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1. Enter 24 in the Maximum Iterations number field under 
Processing Options. 

This is the maximum number of times that the ISODATA utility 
reclusters the data. It prevents this utility from running too long, or 
from potentially getting stuck in a cycle without reaching the 
convergence threshold.

2. Confirm that the Convergence Threshold number field is set to 
.95. 

3. Click OK in the Unsupervised Classification dialog to start the 
classification process. The Unsupervised Classification dialog closes 
automatically.

A Job Status dialog displays, indicating the progress of the function.

4. Click OK in the Job Status dialog when the process is 100% 
complete.

5. Proceed to the Evaluate Classification section to analyze the classes 
so that you can identify and assign class names and colors.

Evaluate 
Classification

After a classification is performed, the following methods are 
available for evaluating and testing the accuracy of the classification:

• classification overlay

• thresholding

• recode classes

• accuracy assessment

See the chapter "Classification" in the ERDAS Field Guide for 
information on accuracy assessment. 

Convergence Threshold
The convergence threshold is the maximum percentage of pixels 
that has cluster assignments that can go unchanged between 
iterations. This threshold prevents the ISODATA utility from 
running indefinitely. 

By specifying a convergence threshold of .95, you are specifying 
that as soon as 95% or more of the pixels stay in the same cluster 
between one iteration and the next, the utility should stop 
processing. In other words, as soon as 5% or fewer of the pixels 
change clusters between iterations, the utility stops processing.
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Create Classification 
Overlay 

In this example, use the Raster Attribute Editor to compare the 
original image data with the individual classes of the thematic raster 
layer that was created from the unsupervised classification 
(germtm_isodata.img). This process helps identify the classes in 
the thematic raster layer. You may also use this process to evaluate 
the classes of a thematic layer that was generated from a supervised 
classification. 

Preparation ERDAS IMAGINE should be running and you should have a Viewer 
open.

1. Select File -> Open -> Raster Layer from the Viewer menu bar, or 

click the Open icon  in the toolbar to display the germtm.img 
continuous raster layer. 

The Select Layer To Add dialog opens.

2. In the Select Layer To Add dialog under File name, select 
germtm.img.

3. Click the Raster Options tab at the top of the Select Layer To Add 
dialog.

4. Set Layers to Colors at 4, 5, and 3.

5. Click OK in the Select Layer To Add dialog to display the image file. 

6. Click the Open icon again in the Viewer toolbar to display the 
thematic raster layer, germtm_isodata.img, over the 
germtm.img file. 

7. Under File name, open the directory in which you previously saved 
germtm_isodata.img by entering the directory path name in the 
text entry field and pressing the Enter key on your keyboard.

8. Click the Raster Options tab at the top of the Select Layer To Add 
dialog.

Click this file tab
to see the raster
options

Click here to select
germtm.img
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9. Click Clear Display to turn off this checkbox. 

10. Click OK in the Select Layer To Add dialog to display the image file.

Open Raster Attribute Editor

1. Select Raster -> Attributes from the Viewer menu bar.

The Raster Attribute Editor displays.

2. In the Raster Attribute Editor, select Edit -> Column Properties to 
rearrange the columns in the CellArray so that they are easier to 
view. 

The Column Properties dialog opens. 
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3. In the Column Properties dialog under Columns, select Opacity, 
then click Up to move Opacity so that it is under Histogram.

4. Select Class_Names, then click Up to move Class_Names so that 
it is under Color. 

5. Click OK in the Column Properties dialog to rearrange the columns 
in the Raster Attribute Editor. 

The Column Properties dialog closes.

The data in the Raster Attribute Editor CellArray should appear 
similar to the following example: 

Analyze Individual 
Classes

Before you can begin to analyze the classes individually, you need to 
set the opacity for all of the classes to zero.

1. In the Raster Attribute Editor, click the word Opacity at the top of 
the Opacity column to select all of the classes. The column turns 
cyan in color.

2. Right-hold on the word Opacity and select Formula from the 
Column Options menu. 

Click here to
move the 
selected column up

Click here to rearrange
the columns 

Click here to move
this column
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The Formula dialog opens.

3. In the Formula dialog, click 0 in the number pad. 

A 0 is placed in the Formula field.

4. In the Formula dialog, click Apply to change all of the values in the 
Opacity column to 0, and then click Close.

5. Right-click in the Opacity column heading and choose Select None 
from the Column Options menu.

6. In the Raster Attribute Editor, hold on the color patch under Color 
for Class 1 in the CellArray and change the color to Yellow. This 
provides better visibility in the Viewer. 

7. Change the Opacity for Class 1 in the CellArray to 1 and then press 
Enter on the keyboard. This class shows in the Viewer.

NOTE: If you cannot see any yellow areas within the Viewer extent, 
you can right-click and select Zoom -> Zoom Out By 2 from the 
Quick View menu until yellow areas display within the Viewer.

Click here to 

Click here to 

Click here to 
close this dialog 

the Formula 
enter a 0 in 

to the Opacity 
apply a 0 value 

column
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8. In the Viewer menu bar, select Utility -> Flicker to analyze which 
pixels have been assigned to this class. 

The Viewer Flicker dialog opens. 

9. Turn on the Auto Mode in the Viewer Flicker dialog.

The flashing yellow pixels in the germtm.img file are the pixels 
Class 1. These areas are water.

10. In the Raster Attribute Editor, click inside the Class_Names column 
for Class 1. Change this name to Water and then press the Enter 
key on the keyboard.

11. In the Raster Attribute Editor, hold on the Color patch for Water. 
Select Blue from the dropdown list. 

12. After you are finished analyzing this class, click Cancel in the Viewer 
Flicker dialog and set the Opacity for Water back to 0. Press the 
Enter key on the keyboard.
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13. Change the Color for Class 2 in the CellArray to Yellow for better 
visibility in the Viewer. 

14. Change the Opacity for Class 2 to 1 and press the Enter key on the 
keyboard. This class shows in the Viewer.

Use the Flicker Utility

1. In the Viewer menu bar, select Utility -> Flicker to analyze which 
pixels were assigned to this class.

The Viewer Flicker dialog opens.

2. Turn on the Auto Mode in the Viewer Flicker dialog.

The flashing pixels in the germtm.img file should be the pixels of 
Class 2. These are forest areas.

3. In the Raster Attribute Editor, click inside the Class_Names column 
for Class 2. (You may need to double-click in the column.) Change 
this name to Forest, then press the Enter key on the keyboard.

4. In the Raster Attribute Editor, hold on the Color patch for Forest 
and select Pink from the dropdown list. 

5. After you are finished analyzing this class, click Cancel in the Viewer 
Flicker dialog and set the Opacity for Forest back to 0. Press the 
Enter key on the keyboard.
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6. Repeat these steps with each class so that you can see how the 
pixels are assigned to each class. You may also try selecting more 
than one class at a time.

7. Continue assigning names and colors for the remaining classes in the 
Raster Attribute Editor CellArray.

8. In the Raster Attribute Editor, select File -> Save to save the data 
in the CellArray. 

9. Select File -> Close from the Raster Attribute Editor menu bar. 

10. Select File -> Clear from the Viewer menu bar.

Use Thresholding The Thresholding utility allows you to refine a classification that was 
performed using the Supervised Classification utility. The 
Thresholding utility determines which pixels in the new thematic 
raster layer are most likely to be incorrectly classified.

This utility allows you to set a distance threshold for each class in 
order to screen out the pixels that most likely do not belong to that 
class. For all pixels that have distance file values greater than a 
threshold you set, the class value in the thematic raster layer is set 
to another value.

The threshold can be set:

• with numeric input, using chi-square statistics, confidence level, 
or Euclidean spectral distance, or

• interactively, by viewing the histogram of one class in the 
distance file while using the mouse to specify the threshold on 
the histogram graph.

Since the chi-square table is built-in, you can enter the threshold 
value in the confidence level unit and the chi-square value is 
automatically computed.

In this example, you threshold the output thematic raster layer from 
the supervised classification (germtm_superclass.img).

Preparation

ERDAS IMAGINE must be running and you must have 
germtm_superclass.img displayed in a Viewer.

1. Click the Classifier icon in the ERDAS IMAGINE icon panel to start the 
Classification utility.

The Classification menu displays.

2. Select Threshold from the Classification menu to start the 
Threshold dialog.
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 The Threshold dialog opens.

3. Click Close in the Classification menu to clear it from the screen.

4. In the Threshold dialog, select File -> Open or click the Open icon 

 to define the classified image and distance image files. 

The Open Files dialog opens.

Select Classified and Distance Images

1. In the Open Files dialog under Classified Image, open the directory 
in which you previously saved germtm_superclass.img by 
entering the directory path name in the text window and pressing 
Enter on your keyboard. 

2. Select the file germtm_superclass.img from the list of files in the 
directory you just opened.

This is the classified image file that is going to be thresholded.

3. In the Open Files dialog, under Distance Image, open the directory 
in which you previously saved germtm_distance.img by entering 
the directory path name in the text entry field and pressing Enter on 
your keyboard.

4. Select the file germtm_distance.img from the list of files in the 
directory you just opened.

This is the distance image that was created when the 
germtm_superclass.img file was created. A distance image file for 
the classified image is necessary for thresholding.

5. Click OK in the Open Files dialog to load the files.

Click here to load files

Type in the correct 

then press Enter here
path name and
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6. In the Threshold dialog, select View -> Select Viewer and then 
click in the Viewer that is displaying the germtm_superclass.img 
file.

Compute and Evaluate Histograms

1. In the Threshold dialog, select Histograms -> Compute.

The histograms for the distance image file are computed. There is a 
separate histogram for each class in the classified image file. 

The Job Status dialog opens as the histograms are computed. This 
dialog automatically closes when the process is completed.

2. If desired, select Histograms -> Save to save this histogram file. 

3. In the CellArray of the Threshold dialog, move the > prompt to the 
Agricultural Field_2 class by clicking under the > column in the 
cell for Class 2. 

4. Select Histograms -> View. 

The Distance Histogram for Agricultural Field_2 displays.
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5. Select the arrow on the X axis of the histogram graph to move it to 
the position where you want to threshold the histogram. 

The Chi-Square value in the Threshold dialog is updated for the 
current class (Agricultural Field_2) as you move the arrow. 

6. In the Threshold dialog CellArray, move the > prompt to the next 
class. 

The histogram updates for this class. 

7. Repeat the steps, thresholding the histogram for each class in the 
Threshold dialog CellArray. 

See the chapter "Classification" in the ERDAS Field Guide for 
information on thresholding. 

8. After you have thresholded the histogram for each class, click Close 
in the Distance Histogram dialog. 

Apply Colors

1. In the Threshold dialog, select View -> View Colors -> Default 
Colors. 

Use the default setting so that the thresholded pixels appear black 
and those pixels remaining appear in their classified color in the 
thresholded image. 

2. In the Threshold dialog, select Process -> To Viewer. 

The thresholded image is placed in the Viewer over the 
germtm_superclass.img file. Yours likely looks different from the 
one pictured here.

Click here to 

Hold arrow under 
histogram and drag 
it to here 

close dialog 
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Use the Flicker Utility

1. In the Viewer menu bar, select Utility -> Flicker to see how the 
classes were thresholded. 

The Viewer Flicker dialog opens.

2. When you are finished observing the thresholding, click Cancel in 
the Viewer Flicker dialog.

3. In the Viewer, select View -> Arrange Layers.

The Arrange Layers dialog opens.

4. In the Arrange Layers dialog, right-hold over the thresholded layer 
(Threshold Mask) and select Delete Layer from the Layer 
Options menu. 

5. Click Apply and then Close in the Arrange Layers dialog. When 
asked if you would like to save your changes, click No.

6. In the Threshold dialog, select Process -> To File.

The Threshold to File dialog opens.
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Process Threshold

1. In the Threshold to File dialog under Output Image, enter the name 
germtm_thresh.img in the directory of your choice.

This is the file name for the thresholded image.

2. Click OK to output the thresholded image to a file.

The Threshold to File dialog closes.

3. Wait for the thresholding process to complete, and then select File -
> Close from the Threshold dialog menu bar.

4. Select File -> Clear from the Viewer menu bar.

NOTE: The output file that is generated by thresholding a classified 
image can be further analyzed and modified in various ERDAS 
IMAGINE utilities, including the Image Interpreter, Raster Attribute 
Editor, and Spatial Modeler.

Use Accuracy Assessment The Accuracy Assessment utility allows you to compare certain pixels 
in your thematic raster layer to reference pixels, for which the class 
is known. This is an organized way of comparing your classification 
with ground truth data, previously tested maps, aerial photos, or 
other data.

Recode Classes
After you analyze the pixels, you may want to recode the thematic 
raster layer to assign a new class value number to any or all 
classes, creating a new thematic raster layer using the new class 
numbers. You can also combine classes by recoding more than one 
class to the same new class number. Use the Recode function 
under Interpreter (icon) -> GIS Analysis to recode a thematic 
raster layer.

NOTE: See the chapter "Geographic Information Systems" in the 
ERDAS Field Guide for more information on recoding.
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In this example, you perform an accuracy assessment using the 
output thematic raster layer from the supervised classification 
(germtm_superclass.img). 

Preparation

ERDAS IMAGINE must be running and you must have germtm.img 
displayed in a Viewer.

1. Click the Classifier icon  in the ERDAS IMAGINE icon panel.

The Classification menu displays.

2. Select Accuracy Assessment from the Classification menu to 
start the Accuracy Assessment utility. 

The Accuracy Assessment dialog opens.

Click here to start the
Accuracy Assessment
Utility
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Check the Accuracy Assessment CellArray

The Accuracy Assessment CellArray contains a list of class values for 
the pixels in the classified image file and the class values for the 
corresponding reference pixels. The class values for the reference 
pixels are input by you. The CellArray data reside in the classified 
image file (for example, germtm_superclass.img). 

1. Click Close in the Classification menu to clear it from the screen.

2. In the Accuracy Assessment dialog, select File -> Open or click the 

Open icon .

The Classified Image dialog opens.

3. In the Classified Image dialog, under File name, open the directory 
in which you previously saved germtm_superclass.img by 
entering the directory path name in the text entry field and pressing 
Enter on your keyboard. 

4. Select the file germtm_superclass.img from the list of files in the 
directory you just opened.

This is the classified image file that is used in the accuracy 
assessment.

5. Click OK in the Classified Image dialog to load the file.

6. In the Accuracy Assessment dialog, select View -> Select Viewer 

or click the Select Viewer icon , then click in the Viewer that is 
displaying the germtm.img file. 

7. In the Accuracy Assessment dialog, select View -> Change Colors.

The Change colors dialog opens. 

Enter the correct
path name here

Select 

from this list 
the file
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In the Change colors dialog, the Points with no reference color 
patch should be set to White. These are the random points that have 
not been assigned a reference class value. 

The Points with reference color patch should be set to Yellow. 
These are the random points that have been assigned a reference 
class value. 

8. Click OK in the Change colors dialog to accept the default colors.

Generate Random Points

The Add Random Points utility generates random points throughout 
your classified image. After the points are generated, you must enter 
the class values for these points, which are the reference points. 
These reference values are compared to the class values of the 
classified image. 

1. In the Accuracy Assessment dialog, select Edit -> Create/Add 
Random Points.

The Add Random Points dialog opens. 

2. In the Add Random Points dialog, enter a 10 in the Number of 
Points number field and press Enter on your keyboard. 

In this example, you generate ten random points. However, to 
perform a proper accuracy assessment, you should generate 250 or 
more random points. 

3. Confirm that the Search Count is set to 1024. 

Click here

This color should

This color should
 be set to yellow

be set to white

Click here to start

The Distribution Parameters

Enter 10 here

the process

should be Random
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This means that a maximum of 1024 points are analyzed to see if 
they meet the defined requirements in the Add Random Points 
dialog. If you are generating a large number of points and they are 
not collected before 1024 pixels are analyzed, then you have the 
option to continue searching for more random points.

NOTE: If you are having problems generating a large number of 
points, you should increase the Search Count to a larger number.

The Distribution Parameters should be set to Random. 

4. Click OK to generate the random points. 

The Add Random Points dialog closes and the Job Status dialog 
opens. 

This dialog automatically closes when the process is completed. A list 
of the points is shown in the Accuracy Assessment CellArray.

5. In the Accuracy Assessment dialog, select View -> Show All. 

All of the random points display in the germtm.img file in the 
Viewer. These points are white.
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6. Analyze and evaluate the location of the reference points in the 
Viewer to determine their class value. In the Accuracy Assessment 
CellArray Reference column, enter your best guess of a reference 
relating to the perceived class value for the pixel below each 
reference point.

As you enter a value for a reference point, the color of the point in 
the Viewer changes to yellow.

If you were performing a proper accuracy assessment, you 
would be using ground truth data, previously tested maps, aerial 
photos, or other data.

7. In the Accuracy Assessment dialog, select Edit -> Show Class 
Values. 

The class values for the reference points appear in the Class column 
of the CellArray.

8. In the Accuracy Assessment dialog, select Report -> Options. The 
Error Matrix, Accuracy Totals, and Kappa Statistics checkboxes 
should be turned on. 

The accuracy assessment report includes all of this information. 



Using the Grouping Tool / 532ERDAS IMAGINE Tour Guides

See the chapter "Classification" in the ERDAS Field Guide for 
information on the error matrix, accuracy totals, and Kappa 
statistics.

9. In the Accuracy Assessment dialog, select Report -> Accuracy 
Report.

The accuracy assessment report displays in the IMAGINE Text Editor. 

10. In the Accuracy Assessment dialog, select Report -> Cell Report.

The accuracy assessment report displays in a second ERDAS 
IMAGINE Text Editor. The report lists the options and windows used 
in selecting the random points. 

11. If you like, you can save the cell report and accuracy assessment 
reports to text files. 

12. Select File -> Close from the menu bars of both ERDAS IMAGINE 
Text Editors.

13. In the Accuracy Assessment dialog, select File -> Save Table to 
save the data in the CellArray. 

The data are saved in the classified image file 
(germtm_superclass.img). 

14. Select File -> Close from the Accuracy Assessment dialog menu 
bar. 

15. If you are satisfied with the accuracy of the classification, select File 
-> Close from the Viewer menu bar.

If you are not satisfied with the accuracy of the classification, you 
can further analyze the signatures and classes using methods 
discussed in this tour guide. You can also use the thematic raster 
layer in various ERDAS IMAGINE utilities, including the Image 
Interpreter, Raster Editor, and Spatial Modeler to modify the file.

Using the 
Grouping Tool

This section shows you how to use the Class Grouping Tool to assign 
the classes associated with an Unsupervised Classification and group 
them into their appropriate target classes. This tour is intended to 
demonstrate several methods for collecting classes, not to provide a 
comprehensive guide to grouping an entire Landsat image.

Setting Up a Class 
Grouping Project

In this example, you take a Landsat image that has been classified 
into 235 classes using the ISODATA and the Maximum Likelihood 
classifications. These 235 classes are grouped into a more 
manageable number of Land Use categories.

Preparation

1. Start ERDAS IMAGINE.
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2. Copy the file loudoun_maxclass.img from the 
<IMAGINE_HOME>/examples directory into a directory in which you 
have write permission.

Starting the Class Grouping Tool

1. Click the Classifier icon on the ERDAS IMAGINE icon panel.

The Classification menu displays.

2. Select Grouping Tool from the Classification menu to start the 
Signature Editor.

The Select image to group dialog opens.

3. Navigate to the directory into which you copied the file 
loudoun_maxclass.img. Select it from the list of files and click OK.

The Class Grouping Tool and a Viewer displaying the selected image 
file open.

4. To view the entire image, right-click in the Viewer and select Fit 
Image to Window from the Quick View menu.

Click here to 

Grouping Tool
start the
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Set Up the Target Classes

1. Click the Setup Target Classes button above the Target Classes 
CellArray. The Edit Target Classes dialog opens.

Class Grouping Tool Terminology
Classes are individual clusters of pixels with similar spectral 
characteristics. These clusters are the result of the unsupervised 
classification.

Target Classes are the final landuse or landcover categories for 
which you are interpreting.

Class Groups are the saved groups of classes that represent a 
single target class.

Working Groups are composed of the currently selected classes 
which are highlighted in the Viewer.

Working Group
CellArray

Class Groups
CellArray

Target Classes
CellArray

Menu Bar

Toolbars

Click Here to Set up
the Target Classes
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2. Place the cursor in the Target Class Name field and type Water. 
Click the Add -> button.

Water now appears in the list of Target Classes. 

3. Add Agriculture, Forest, and Urban classes.

4. Once you have finished adding Target Classes, click the OK button 
on the Edit Target Classes dialog. 

You may return to this dialog and add more Target Classes at 
any point during the grouping process.

The Target Classes you have added display in the Target Classes 
CellArray.

Now that the Target Classes are set up, you can assign target colors.

5. Click in the color block next to the Water Target Class. Select Blue 
from the Color dropdown list. Continue assigning colors to the Target 
Classes until colors have been assigned to each of them.

Type the target
class name here

Click Add->

Displays the number 
of Class Groups 

Target Class
Names

Click here 
to change the 
Target Color

in the Target Class

The caret (>) indicates 
the currently selected 
Target Class
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Collecting Class Groups The main goal of a Class Grouping project is to gather classes of 
pixels which have common traits into the same Target Classes. To do 
this, you must select the classes and save them to Class Groups. 
Class Groups are, as the name suggests, groups of classes that share 
similar traits; usually these are classes that are in the same landuse 
category. The Class Groups are themselves members of the Target 
Classes into which the image is being stratified.

There are numerous ways to collect Class Groups. This tour guide 
demonstrates how to use the Cursor Point Mode, the AOI Tool, and 
the Ancillary Data Tool to collect Class Groups.

Using the Cursor Point Mode

1. In the Viewer, right-click and select Inquire Cursor from the Quick 
View menu. The Inquire Cursor dialog displays.

2. In the X field, enter 280135.655592. Enter 4321633.145953 into 
the Y field. Press Enter on your keyboard.

3. In the Viewer, click on the Zoom In icon  and zoom in on the lake 
identified by the Inquire Cursor.

4. Click Close on the Inquire Cursor dialog.

5. Select the Cursor Point Mode icon  on the Class Grouping Tool 
toolbar. The cursor changes to a crosshair when it is placed in the 
Viewer.

6. In the Viewer, place the crosshair cursor over the lake and click.
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The lake, and all pixels belonging to the same classification as the 
pixel you selected, are highlighted in the Viewer.

The selected class also highlights in the Working Group CellArray.

7. Click the X in the WG column to clear the currently highlighted class 
from both the CellArray and the Viewer.

8. Now place the crosshair cursor over the lake. Click and drag the 
cursor in a short line over the lake. All of the classes that the cursor 
passes over are selected in the Working Groups CellArray.

All pixels in 

class are 
the same

highlighted

The Row is highlighted,
and the WG (Working
Group) column has an X
indicating that this class
is a member of the current
Working Group.
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This provides a much better selection, but there is still some 
speckling in the selection.

9. Right-click inside the Viewer and select Zoom -> Zoom In By 2 to 
see even more detail. 

This will help you select nonhighlighted pixels more easily.

10. Hold down the Shift key on the keyboard, and then click one of the 
unselected pixels. 

Note this adds all of the pixels to the currently selected classes in the 
Working Group. As pixels representing classes are selected, the 
corresponding Class row highlights in the Working Group 
CellArray.

11. Now hold down the Ctrl key on the keyboard and click one of the 
highlighted pixels. All of the pixels that belong to the same class as 
this pixel are removed from the selection.

NOTE: The Shift and Ctrl keys may also be used to select and 
deselect classes directly in the Working Classes CellArray.

Start the 

Finish the 

All of the 

line here

line here

classes that 
the cursor 
passes over 
are highlighted

Filling in the Holes and Removing the Speckle
The initial step in any collection method can leave either holes—
unselected classes that are “islands” within the class—or 
speckles—selected classes that are “islands” outside of the 
majority of the selected classes. To increase the accuracy of your 
Class Groups, you need to fill the holes and remove the speckle.
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12. Continue to collect the water classes of this lake using the Shift and 
Ctrl keys. 

13. Use the Toggle Highlight icon  to turn off the highlighting and see 
the actual pixels you have selected.

Include the class if:

• adding the class fills the holes in the existing selection,

• adding the class supplements the edges of the existing selection,

• removing the class opens significant holes in the selection, or

• adding the class reduces the overall complexity of the selection.

Exclude the class if

• adding the class creates speckles in places where there were 
none before,

• removing the class removes speckles in the overall image, or

• removing the class reduces the overall complexity of the 
selection.

Your selections should look similar to this:

14. Save the Working Group as a Class Group by clicking the Save As 
New Group button above the Class Groups CellArray.

Note that all of the pixels
 that belong to these 
classes are selected
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Using the AOI Tools

1. In the Viewer, right-click and select Inquire Cursor from the Quick 
View menu. The Inquire Cursor dialog displays.

2. In the Inquire Cursor dialog, enter 261278.630592 in the X: field 
and 4334243.327665 in the Y: field.

3. Use the Zoom In icon  to zoom in on the lake identified by the 
Inquire Cursor.
,

4. Click Close on the Inquire Cursor dialog to dismiss it.

5. If the Class Group from the previous section is still highlighted in the 

Viewer, click the Clear Working Group contents icon  in the Class 
Grouping Tool dialog to clear the selections.

6. Select AOI -> Tools from the Viewer menu bar. 

The AOI tool palette displays.

Click here to save 
the Working Group 
as a new Class Group
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7. Digitize a polygon the encompasses the majority of the open water 
pixels in the largest lake.

8. In the Class Grouping Tool toolbar, click the Use Current AOI to 

Select Classes icon  .

All of the classes that are contained within the currently selected AOI 
are highlighted in the Working Group CellArray.

9. Using the techniques outlined in “Using the Cursor Point Mode” on 
page 536, fill in the holes in the selections for these lakes.

10. In the Class Groups CellArray, make sure that the caret > is in the 

row for the Water_1 class, then click the Union icon  .

This adds the classes saved in the water_1 Class Group to the 
classes that are currently selected in the Working Group CellArray.

Select the 
Polygon Tool
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11. Click the Save button above the Class Groups CellArray to save all 
of the selected classes in the Working Group CellArray.

12. In the Class Groups CellArray, click in the Water_1 cell. This group 
represents the open water land use category, so change the Group 
Name by typing Open. 

NOTE: The Target Class Name is already a stored part of the Class 
Group name, so there is no need to repeat it in the Class Group 
name.

13. In the Class Grouping Tool dialog, click the Clear Working Group 

contents icon  to clear the selections.

Next, remove the AOI you created.

14. Select View -> Arrange Layers from the Viewer menu bar. 

15. Right-click on the AOI layer and select Delete Layer from the AOI 
Options menu. 

16. Click Apply in the Arrange Layers dialog.

17. Click No in the Verify Save on Close dialog prompting you to save 
the AOI to a file.

18. Click Close in the Arrange Layers dialog.

19. Click Close on the AOI tool palette to remove it from your display.
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Using the Ancillary Data 
Tool

It would take a very long time to collect all of the classes in a large 
image using only the simple tools outlined above. To save time, you 
should quickly group all of the classes into Class Groups and then 
refine these initial groupings to more accurately define the study 
area.

Definitions of Boolean Operators
The Class Grouping Tools provides four boolean operators that 
allow you to refine the selections in your Class Groups.

 Intersection of Sets: The intersection of two sets is the set 
of elements that is common to both sets.

 Union of Sets: The union of two sets is the set obtained by 
combining the members of each set.

 Exclusive-Or (XOR) of Sets: The Exclusive-Or of two sets 
is the set of elements belonging to one but not both of the given 
sets.

 Subtraction of Sets: The subtraction of set B from set A 
yields a set that contains all data from A that is not contained in B.
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The Ancillary Data Tool provides a means of performing this quick 
initial grouping. By using previously collected data, such as ground 
truth data or a previous classification of the same area, you can 
quickly group your image, and then concentrate on evaluating and 
correcting the groups.

The thematic file used as the Ancillary Data file need not cover 
the entire area, but it must at least overlap with the area being 
grouped.

Setting Up the Ancillary Data Classes

1. In the Class Grouping Tool toolbar, click the Start Ancillary Data Tool 

icon  .

Two dialogs display, the Ancillary Data Tool dialog and the Ancillary 
Class Assignments dialog.

2. In the Ancillary Class Assignments dialog, select File -> Set 
Ancillary Data Layer. 

The File Chooser opens. 

3. Select loudoun_lc.img from the <IMAGINE_HOME>/examples 
directory, then click OK. 

A Performing Summary progress meter displays. 

4. When the summary is complete, click OK to dismiss the progress 
meter (if your Preferences are not set so that it closes 
automatically). 

The summary process does three things:

• populates the Ancillary Class Assignments CellArray with 
information from the ancillary data file,

• provides summary values relating the ancillary data file to the file 
being grouped in the Ancillary Data Tool CellArray, and

• adds three new columns (Diversity, Majority, and Target %) 
to the Working Group CellArray in the Class Grouping Tool.

For a more detailed explanation of each of these dialogs and 
their contents, please see the ERDAS IMAGINE On-Line Help.

In the Ancillary Class Assignments dialog CellArray, the rows 
represent the classes from the ancillary data file (loudoun_lc.img) 
and the columns represent the information from the file being 
grouped (loudoun_maxclass.img).
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5. In the Ancillary Class Assignments dialog CellArray, scroll down until 
you see Low Intensity Residential in the Class Name column of 
the CellArray. 

You may want to expand the size of the Class Names column in 
the Ancillary Class Assignments CellArray so that you can read 
the entire Class Name.

6. Click in the corresponding Urban column of the CellArray to assign 
this class to the Urban Target Class. 

The X moves from the Water column (the first column in the 
CellArray) to the Urban column. 

7. Repeat this step for the High Intensity Residential and 
Commercial/Industrial/Transportation classes to add them to 
the Urban class as well.

8. Continue arranging the Xs in the Ancillary Class Assignments dialog 
so that they properly relate the named classes from the ancillary 
data file to the remaining Target Classes, which are Agriculture and 
Forest. If the ancillary data classes do not have labels (Ancillary 
Classes/Class Names), leave the corresponding X in the Water 
column.

Collecting Groups Using the Majority Approach

In most cases, this approach would be the first step you took in 
the grouping process. As a first step, this process would result 
in a completely grouped image that had no Similarities and no 
Conflicts between Target Classes.

We have already begun collecting Class Groups, and this causes 
some conflicts between Target Classes.

Click here to relate
the Ancillary Data 
classes to the Target
Classes in the image
being grouped
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Once you have assigned the ancillary data classes to the Target 
Classes, you may minimize the Ancillary Data Tool and the Ancillary 
Class Assignments dialogs.

1. In the Working Group CellArray on the Class Grouping Tool, right-
click in the numbered row labels. Select Criteria... from the Row 
Selection menu. 

The Selection Criteria dialog displays.

2. In the Columns area, click Majority to set the selection criteria. 

3. In the Target Classes section of the Class Grouping Tool dialog, 
select the Water Target Class by placing the caret > in the Water 
row.

4. In the Selection Criteria dialog, click the Select button. 

All of the classes that best represent the selected Target Class are 
highlighted in the Working Group section of the Class Grouping 
tool.

5. In the Class Groups area of the Class Grouping Tool, click the Save 
As New Group button. 

The selected classes are added as a new class group.

Click Majority
to specify the 
selection criteria

Make sure that 
the caret > is 
in this row

Click here to save 
the classes as 
a new group

Change the name 
of the new group
to Majority
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6. Change the name of the new group by selecting the Water_2 text 
and typing Majority. 

This helps you keep track of how the Class Group was collected.

7. Repeat step 3 through step 6 for each of the Target Classes, moving 
the caret in the Target Classes CellArray to the next Target Class 
each time.

8. When you are finished, click the Close button on the Selection 
Criteria dialog.

9. Save the Grouping Process by selecting File -> Save Image... from 
the Class Grouping Tool menu bar.

This provides a broad grouping of all the classes in the image, and 
each Class Group must be closely examined to determine the 
accuracy of the Majority grouping. 

10. Click Close in the Ancillary Data Tool dialog.

11. Click Close in the Ancillary Class Assignments dialog.

12. Click the Clear Working Group Contents icon  in the Class 
Grouping Tool dialog to prepare for the next section.

Next, you can learn how to find the grouping conflicts and some 
strategies for resolving them.

Identifying and Resolving Similarities and Conflicts

The Class Grouping Tool allows there to be any number of Class 
Groups representing each Target Class, and there is no restriction on 
whether or not these groups overlap or conflict with each other. It is 
frequently the case that a single class may properly belong with 
more than one target class. These classes are termed conflicted 
classes, and they generally are a source of speckle in the resulting 
final classification.

Both Similarity and Conflict are measures of shared classes. Similar 
classes are shared by other groups within the same Target Class, 
while conflicted classes shared by groups under a different Target 
Class.

1. In the Target Classes section of the Class Grouping Tool dialog, 
select the Water Target Class by placing the caret > in the Water 
row. 

2. In the Class Groups section of the Class Grouping Tool dialog, select 
the Open Class Group by placing the caret > in the Open row.

3. In the Class Groups section of the Class Grouping Tool dialog, click 
the Load button.



Using the Grouping Tool / 548ERDAS IMAGINE Tour Guides

Notice the Similarity and Conflict numbers displayed just under 
the Working Group CellArray:

The Similarity statistics are calculated between the Working Groups 
and the selected Class Group. These are the same, so we would 
expect there to be the same number of Similarities and Classes 
Selected, and this is the case.

Place the 

...and then click 
Load to highlight
the classes in the
Working Groups
CellArray

carets >
here...

Number of similarities
between the Working 
Group and the selected
Class Group

Number of conflicts
between the Working
Group and the selected
Class Group

Number of selected 
classes in the Working
Group CellArray
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4. In the Class Grouping Tool toolbar, click the Toggle 

Similarity/Conflict icon  to highlight the other Target Classes that 
have classes in common with the Working Group (which is exactly 
the same as the Open Class Group).

5. Select the Agriculture Target Class by placing the caret > in the 
Agriculture row.

NOTE: The contents of the Working Group CellArray do not change 
when you change the selected Target Class, but the contents of the 
Similarity and Conflict statistics have reversed.

6. To identify the classes that these two Target Classes have in 
common, click the Intersect Working Group with Current Group icon 

 . 

For more information on Boolean operators, see “Definitions of 
Boolean Operators”.

The Target Classes
and Class Groups
that share classes
are highlighted
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This loads the intersection of the classes included in the Working 
Group (Water, Open) and the selected Class Group (Agriculture, 
Majority).

7. In the Viewer, zoom in on the classes that are currently selected. 
These classes are located in the Lakes you collected with the AOI 
Tool. 

8. Use the Toggle Highlighting icon  to view the pixels in question. 

These pixels belong in the Water Target Class and not in the 
Agriculture Target Class. Next, you remove these classes from the 
Agriculture Target Class

9. Make sure the caret > is still in the Agriculture Target Class and the 
Majority Class Group.

10. Click the XOR Working Group and Current Group icon  . 

This loads all of the classes in the selected Class Group 
(Agriculture, Majority) without any of the classes that were 
previously highlighted in the CellArray (the conflicted classes).

11. In the Class Groups area of the Class Grouping Tool dialog, click the 
Save button to save the Agriculture, Majority Class Group without 
the conflicted classes.

12. In the Class Grouping Tool toolbar, click the Save icon  to save 
the grouping process to the image file.

Coloring the Thematic 
Table

Sometimes it is helpful to judge your progress by seeing the entire 
picture. The Class Grouping Tool provides a mechanism for you to 
see how the grouping process is progressing.

1. In the Class Grouping Tool menu bar, select Colors -> Set to target 
colors.

The colors in the T column in the Working Groups CellArray change 
to reflect the colors of the associated Target Classes.

Classes that are conflicted
or are not included in any
Target Class are highlighted
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All of the classes that have not been grouped into Target Classes or 
are in conflict with other Target Classes are highlighted. These 
conflicted or unassigned classes must be resolved.

2. If a class is highlighted but has been assigned a target color, it is 
included in more than one target class. Use the techniques described 
in “Identifying and Resolving Similarities and Conflicts” to resolve 
the conflict.

After you have resolved some of the conflicts, you can refresh 
the classes that remain unresolved by clearing the current 
working group and then selecting Colors -> Set to target 
colors in the Class Grouping Tool menu bar.

3. If a class is highlighted but has not been assigned a target color (that 
is, the colors in the C and T column of the Working Group CellArray 
are the same), the class has not yet been collected in any group. Use 
the techniques described in “Using the Cursor Point Mode” to collect 
these classes into their groups.

4. To change back to the standard color table display in the Viewer, 

click the Standard Color Table icon  .

5. To view the thematic color table display in the Viewer, click the 

Thematic Color Table icon  .

6. When you have finished the grouping process, click the  icon to 
display the Thematic colors in the Viewer, then select File -> Save 
-> Top Layer As.... Save the image as loudoun_strata.img.

You can separately load that image in a Viewer to compare it to the 
original image, loudon_maxclass.img.
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Close and Exit

1. Select File -> Close from the Class Grouping Tool menu bar.

2. Select File -> Close from the Viewer menu bar.

3. Select Session -> EXIT IMAGINE if you want to end your session.
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Frame Sampling Tools

Introduction Let’s say that you needed to assess the amount a land that is 
covered by parking lots on a university campus. How would you go 
about accomplishing this? You could either go and start surveying 
parking lots, or you could get aerial photography of the campus and 
start digitizing them. But what if you wanted to analyze the amount 
of land covered by forests in an entire county, or the amount of 
arable land planted with grain in an entire state? The cost of 
collecting ground truth data from the entire county or of digitizing 
the entire state would be prohibitive to getting an accurate 
assessment.

The process of Frame Sampling provides an answer to these types of 
problems. Frame Sampling is a statistical methodology that enables 
the accurate survey of a Material of Interest (MOI) in the study area. 
As the name suggests, Frame Sampling uses a frame to define the 
study area and the analysis of representative samples from within 
that frame to estimate the proportion of the MOI in the frame. 
Although getting ground truth from an entire county or digitizing and 
entire state might not be feasible, it would certainly make sense to 
use ground truth and imagery interpretation to calculate the amount 
of the MOI in these representative samples.

Remote Sensing and 
Frame Sampling

The use of Frame Sampling and remote sensing can assist the 
surveyor in achieving the most accurate estimate for the least cost. 
Remote Sensing provides the analyst with a synoptic view of the 
entire Frame. 

The classification methods described in “Perform Unsupervised 
Classification” and the Class Grouping Tool described in “Using the 
Grouping Tool” provide two methods of “stratification”, or creating 
smaller homogenous units that represent the entire Frame. This 
stratification reduces the number of samples that are allocated to 
provide an accurate result.

High resolution aerial photography can be used in the labeling of the 
areas containing the MOI in the representative samples, thereby 
limiting the amount of ground truth data that needs to be collected.

Frame Sampling Tools The Frame Sampling Tools provide a framework guiding the Frame 
Sampling process, a means of managing the array of files generated 
by the process, links to the appropriate remote sensing tools, and 
the necessary computations for the final analysis of the MOI. 

Frame Sampling Tools Tour

This tour guide is intended to walk you through a landcover analysis 
Frame Sampling project. The frame for this project is defined by the 
political boundaries of Loudon County. The MOI for this project is 
forest cover.



Setting Up the Sampling Project / 554ERDAS IMAGINE Tour Guides

The Frame Sampling Project Manager provides the ability to track 
and perform the necessary steps for preparing a file for Frame 
Sampling. For the purposes of this tour guide, the following 
preparatory steps have already been performed for you:

• Obtain a large-scale synoptic image (or images) that covers the 
entire study area.

• Orthorectify that synoptic image. Orthorectification is explained 
in  “Orthorectification”.

• Classify the orthorectified image using a classification technique 
such as ISODATA classification described in “Perform 
Unsupervised Classification”.

• Group the classified image with the Class Grouping Tool. Tips and 
techniques for Grouping the Classified image are illustrated in 
“Using the Grouping Tool”.

Setting Up the 
Sampling Project

This section shows you how to set up a Sampling Project and how 
the Sampling Project Manager allows you to manage and track the 
files used in the Frame Sampling process.

You perform the following operations in this section:

• Create a Sampling Project

• Assign the Project Files

• Recode the Grouped File

• Create a Sampling Grid

• Select the Samples for Interpretation

• Use the Dot Grid Tool to Label the Samples

• Compute the Final Analysis and Fraction Files

Approximate completion time for this tour guide is 45 minutes.

ERDAS IMAGINE must be running.

Create a New Sampling 
Project

The first step in the Frame Sampling process is to create the 
sampling project.

1. Click the Classifier icon on the ERDAS IMAGINE icon panel.



ERDAS IMAGINE Tour Guides Setting Up the Sampling Project / 555

The Classification menu displays.

2. Click the Frame Sampling Tools button to open the Frame 
Sampling Tools menu.

3. Click the Project Manager button on the Frame Sampling Tools 
menu.

The Open/Create a Sampling Project dialog opens.

Click here to open
the Frame Sampling
Tools menu

Click here to open
the Project Manager
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4. Click the Create a new Sampling Project radio button.

5. If necessary, click the Open File icon  and browse to a directory 
in which you have write permission.

6. Enter county_forests.spf as the Project File.

7. Select the Enable Dot Grid Analysis checkbox.

8. Click OK.

The Sampling Project Manager opens displaying the contents of your 
new project.

Click here to create
a new Sampling Project Browse to a directory

in which you have
write permission

Enter the project name

Click here to enable
Dot Grid Analysis
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The Frame Sampling process is very long, and can take several 
days for large projects. You can save your progress on any 
project by selecting File -> Save from the Sampling Project 
Manager menu bar. You may then exit the project and return to 
it without losing any of your work.

Root Level 
Functions

The Single Sampling Wizard Palette is designed to walk you through 
the steps associated with the Frame Sampling process. 

1. Click the Use Sampling Project Wizard icon  to open the Single 
Sampling Wizard Palette.

The Tree View
is a hierarchical
list of all files
in the project

The Files CellArray
shows all the files
associated with
the item selected 
in the Tree View

These icons
affect the file
currently selected
in the CellArray

These icons
affect the 
selected node
in the Tree View 
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The general workflow in the Frame Sampling process moves from the 
top to the bottom of the Single Sampling Wizard Palette. Clicking on 
an icon in the palette jumps directly to that step in the Frame 
Sampling workflow wizard.

These steps affect
the Root Node level
files in the Project
Manager

These steps affect
the Tile Node level
files in the Project
Manager

These steps affect
the Sample level files
in the Project Manager

Single Sampling Project Nodes
Root Node Level steps affect the project as a whole. Root Node 
files display in the far left of the Tree View hierarchy.

Tile Node Level steps are performed on the Tiles. Image Tiles are 
the large-scale synoptic images that cover the study area. Each of 
these Tiles is stratified and then divided into representative 
samples. Tile Node files are dependent upon one of the Root Node 
files.

Sample Node Level steps are performed on the high-resolution 
representative samples of the Image Tiles. These Samples are 
interpreted for the MOI. Sample level files are dependent upon one 
of the Image Tiles.
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2. Click the Set up Root Node Files icon on the Single Sampling Wizard 
Palette to open the first step of the Single Sampling Wizard. 

The Single Sampling Wizard opens. Each step in the Wizard has text 
that explains the current step and either allows you to set up the file 
assignments, or click icons to launch the appropriate tools.

3. Click the Setup Files icon in the Root Node - Setup Files step of the 
Single Sampling Wizard. 

The Root Node - Define File Descriptors dialog displays.

This dialog allows you to manage the files in the Sampling Project. 
You can add and remove files from the process, as well as modify the 
relationship between a file and the process by clicking the Set 
Process Associations button.

4. Click Cancel without making any changes to the files. You are 
returned to the Single Sampling Wizard.

5. Click Next > on the Single Sampling Project Wizard. The Root Node 
- Add Image Tiles step displays.

Enter the Descriptor
for the new file

Select the type
of file to add

Select a descriptor
from the list 
of root level files

Modify the location
of the new file
in the project
hierarchy

Click to set
the relationship
between the selected
file and the other
files in the project

To Add a New File:

Click Add >>

To Edit an Existing File:

Modify the location
of the existing file
in the project
hierarchy
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6. Click the Add Image Tile icon on the Wizard. 

The Root Node - Manage Image Tiles dialog displays. This dialog 
allows you to add names for the tiles in the Sampling project. 

The image tiles must cover the entire area frame. You may need 
to add more than one tile if the frame cannot be covered by a 
single tile.

7. In the Name of Tile field, type Loudoun_TM.

8. Click Add >> to add the tile name to the List of Tiles.

9. Click Close to exit the Root Node - Manage Image Tiles dialog.

Enter the name
of the new tile

Click Add >

Click Close
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Note that the Tile Node has been added to the Tree View in the 
Sampling Project Manager.

10. Click Next > on the Wizard. 

The Tile Node - Setup Files step displays.

11. On the Tile Node - Set Up Files dialog, click Next >.

The Tile Node - Assign Files dialog displays in the Wizard.

Click here to expand
the Root Node

Click the new 

The arrow indicates
the node that is 
currently selected

Tile name to display
files associated with
Tile-level processes
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Tile Level 
Functions

The Tile level functions are processes that apply to the entire Image 
Tiles. 

Tile Node Files
Imported Tile: An Imported Tile is a native IMAGINE format 
image that provides the initial synoptic view of the study area. This 
file provides the initial starting point for all of the files below. The 
inclusion of an Imported Tile in the project is optional, as long as 
you can provide a Stratified Tile.

Rectified Tile: A Rectified Tile is an orthorectified version of the 
Imported Tile. The Rectified Tile must undergo Classification to 
provide the Classified Tile below. The inclusion of a Rectified Tile 
in the project is optional, as long as you can provide a Stratified 
Tile. 

NOTE: For more information on orthorectification, see  
“Orthorectification”.

Classified Tile: A Classified Tile is a thematic classification of the 
Rectified Tile. 

NOTE: For instructions on classifying an image, refer to  “Advanced 
Classification”.

Stratified Tile: The stratified tile is a refined grouping of the 
Classified Tile. This grouping is usually performed with the Class 
Grouping Tool. The Grouped image is then Recoded to include only 
those strata which contain the MOI. This file is required by the 
Frame Sampling process.

NOTE: For tips and techniques on stratifying images, see “Using 
the Grouping Tool”.

Sampling Grid: The Sampling Grid contains the vector polygons 
needed for Sample Selection. The Sampling Grid is usually created 
with the Grid Generation Tool, but it can be a previously created 
Shapefile. This file is required by the Frame Sampling process.

Prior Data: The Prior Data file is any standard IMAGINE .img file 
that contains information about previous locations of the particular 
feature class of interest or variation of the occurrence of the 
material of interest within the study area. This information helps 
you choose which portions of the image to sample with high-
resolution imagery. The inclusion of Prior Data in the project is 
optional.

Selected Samples: The Selected Samples file defines the 
Sampling Grid Cells that have been selected for analysis with high-
resolution imagery. This file is usually created with the Sample 
Selection Tool, and is required by the Frame Sampling process.

Fraction File: The Fraction File is created by the Final Analysis 
process. 



ERDAS IMAGINE Tour Guides Tile Level Functions / 563

The Assign Tile Node Files step allows you to select files that have 
already been prepared for the sampling process and assign them to 
their proper places in the project. 

1. Select Classified_Tile from the File Descriptor dropdown list.

2. In the File Chooser section, click the Open File icon  and browse 
to the IMAGINE_HOME/examples directory. Select 
loudoun_maxclass.img from the list of files, and click OK.

3. Click Next > on the Single Sampling Wizard. 

The Tile Node - Create/Assign Stratum Files step displays in the 
Wizard. 

NOTE: The Grouped File used in this tour guide was created during 
the section “Using the Grouping Tool”, which is in the Advanced 
Classification tour guide. 

This dropdown list has
all the Image Tiles
in the project

Select Classified Tile

Browse to the 
examples directory
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4. If you have not already created the Grouped File, you can click the 
Class Grouping Tool icon to launch the Grouping Tool. See the “Using 
the Grouping Tool” section of the Advanced Classification tour guide 
for more information. 

Recoding the Grouped File

Now that you have Grouped the Classified File into class groups, it is 
necessary to recode the Grouped file so that only those classes which 
contain the MOI are included in the file. This eliminates the possibility 
of MOI contribution from strata that have been designated as 
Non-MOI strata and reduces the noise in the estimate. It also 
increases the User Confidence in the Final Analysis.

1. From the IMAGINE icon panel, select the Image Interpreter icon.

The Image Interpreter menu displays.

2. Click the GIS Analysis button to open the GIS Analysis menu.

Click here to open
the GIS Analysis menu
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3. Click the Recode button to open the Recode dialog.

4. Select the input file to be recoded, loudoun_maxclass.img. This 
file was created in the “Using the Grouping Tool” tour guide. 

5. Click the Setup Recode button to open the Thematic Recode dialog.

Click here to open
the Recode utility

Enter the Grouped 

Click to Setup 

file here

the Recode

Right-click here
and select Criteria...



Tile Level Functions / 566ERDAS IMAGINE Tour Guides

Take a moment to look at the columns that appear in the Thematic 
Recode CellArray. Notice that the columns that were created with the 
Grouping Tool are all labeled with GT TargetName GroupName. A 0 
in this column means that the Class (Value column) is not included 
in this Group. A 1 indicates that Class is included in the Group.

6. Right-click in the Value column and select Criteria... from the 
dropdown list.

The Selection Criteria dialog opens.

7. Set each of the GT Forest columns == 1.

8. Click the Select button.

All of the columns that are grouped into the Forest Target Class 
should be selected in the Thematic Recode dialog.

9. Right-click in the Value column and select Invert Selection.

10. Enter 0 in the New Value field and click the Change Selected 
Rows button.

To select the forested classes,
set GT Forest columns == 1

Click Select

Click Close
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All of the Classes that are not members of the Forest Target Class 
have their pixel values set to 0. This excludes them from the Stratum 
File and eliminates them from the computations of the Final Analysis.

11. Right-click the Value column again and select Invert Selection 
from the dropdown list.

This selects only those classes that are members of the Forest Target 
Class.

12. Renumber the New Values for the members of the MOI Target class 
so that they are consecutively numbered. To renumber a class, left-
click in the New Value column and type the number.

13. Click OK to exit the Thematic Recode dialog and return to the Recode 
dialog.

Enter 0 here

Click Change
Selected Rows

Renumber the
selected Classes

Click OK
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14. In the Output Filename field, click the Browse icon  and browse 
to the project directory. Enter loudoun_strata.img as the File Name 
and click OK in the File Selector.

15. Click OK on the Recode dialog to start the Recode process. A 
Progress meter displays.

16. When the Progress meter reaches 100%, click OK to dismiss it.

NOTE: You may want to paste the color table from the grouped 
image to the Attribute Editor of the new stratum file. Use the same 
criteria selection method as described above to copy the MOI colors 
to the Stratum file.

Generate the Sampling Grid

1. In the Create/Assign Stratum File step, click the Browse icon  
and browse to the directory in which you created the stratum file. 
Select loudoun_strata.img from the list of files and click OK.

2. Click Next in the Wizard.

The Create/Assign Sampling Grid step displays.

3. In the Create/Assign Sampling Grid step, click the Create Sampling 
Grid icon to create a Sampling Grid file.

The Grid Generation Tool opens.

Using the Grid Generation Tool

The Grid Generation Tool is used to create a Shapefile grid that 
overlays the Stratum file. 

Enter loudoun_strata.img
here
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1. Make sure that the Reference Image is set as 
loudoun_strata.img.

2. Note that the Output Grid File is loudoun_tm_grid.shp. This is 
the default name, which has _grid.shp appended to the Tile Name. 
If you change the Output Grid File name, that change is reflected 
in the Sampling Project Manager.

3. Select the Use Mask Overlay checkbox.

The Mask file is used to limit the coverage of the Sampling Grid. 
Because the Sampling that can be performed in this tour is restricted 
by your ability to use only the two existing high resolution files, you 
use the mask file to mask out all of the portions of the Tile that do 
not have high resolution imagery coverage. 

4. Next to the Mask Filename part, click the Browse icon  and 
browse to the IMAGINE_HOME/examples directory. Select 
loudoun_mask.img from the list of files and click OK.

5. Enter 80 as the Inclusion Threshold.

Setting the Inclusion Threshold to 80 ensures that at least 80% of 
every Sample Cell created by the Grid Generation Tool falls within 
the bounds set by the Mask File.

6. Click OK to create the Sampling Grid and return to the Sampling 
Project Wizard. 

A Progress meter opens and tracks the progress of the Grid 
Generation Process.

7. When the Create/Assign Sampling Grid step redisplays, click Next 
>. 

The Select Samples step displays.

Note that the Sampling Project Manager is updated to include the 
Sampling Grid file you just created.

Select the
Use Mask Overlay
checkbox

Browse to 
loudoun_mask.img

Enter 80% as the
Inclusion Threshold

Click OK to generate
the Shapefile
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All of the Tile Node Level files are created in a Tile Level directory 
which bears the same name as the Tile itself.

Selecting the Samples The Statistical Sample Selection dialog allows you to choose which 
files you would like to open to aid you in the selection of the Sample 
Cells which are interpreted for the MOI.

1. In the Select Samples step of the Sampling Wizard, click the Select 
Samples icon.

The Statistical Sample Selection dialog displays.

2. Select the Selection with Strata radio button.

3. Make sure that the Sampling Grid file name part displays the 
loudoun_tm_grid.shp file.

The new sampling grid file
was placed in a directory
named loudoun_tm 

Select the
Selection with Strata
radio button

The Sampling Grid file
displays here

Browse to the Stratum File
created in the Recoding the 
Grouped File step

Click OK 
to open the Sample 
Selection Tool
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4. Make sure that the Stratum File file name part displays the 

loudoun_strata.img file. If it does not, click the Browse icon  
and browse to the file. Select loudoun_strata.img from the list of 
files and click OK.

5. Click OK in the Statistical Sample Selection dialog to open the 
Sample Selection Tool.

The Sample Selection Tool opens.

Manually Selecting Cells

1. Using the Manual Zoom icon  zoom in on the upper portion of the 
Sampling Grid.

The Sampling Grid
loudoun_tm_grid.shp

The Stratum File
loudoun_strata.img
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2. Click the Selector icon  in the Sample Selection toolbar.

3. Click the indicated Sample Cell to highlight it.

4. Select Utility -> Blend from the Sample Selection menu bar.

The Viewer Blend / Fade dialog opens.

5. Use the meter handle to adjust the amount of blending so that you 
can view the Stratum File through the Grid. This allows you to select 
Sample Cells that contain a representative amount to the MOI.

You must exercise caution when manually selecting Sample 
Cells for interpretation. No more than half of the Samples should 
be manually selected. Manually selecting more Cells introduces 
user bias into the calculations.

6. When you have finished viewing the Stratum file, click OK on the 
Viewer Blend/Fade dialog to dismiss it.

7. Click the Accept Manually Selected Cells icon  to select this cell 
for interpretation. 

Click here
to highlight
this Cell
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Automatically Selecting Sample Cells

The Sample Selection Tool provides a utility for randomly selecting 
Cells for interpretation. This utility automatically selects cells based 
on the size and expected proportion of the MOI in the stratum.

1. Click the Automatic Selection icon  in the Sample Selection 
toolbar.

The Required Samples dialog opens.

Note that the Current Samples number box displays the number 1. 
This is the cell that you manually selected.

2. In the Total Samples number box, type 15 and press Enter.

The New Samples number updates to 14, indicating the number of 
samples that the program needs to automatically identify.

3. Click OK on the Required Samples dialog to close it and 
automatically select 14 additional cells.

NOTE: Because the Automatic Selection process is random, the 
automatically selected samples may differ from those in this tour.

4. Select File -> Save Selected As... to save the selected cells as a 
new shapefile.

The Save Sampling Grid As dialog opens.

5. Navigate to the loudoun_tm directory that contains the 
loudoun_tm_grid.shp file.

6. Enter loudoun_selected.shp in the file name and click OK to save the 
shapefile.

7. Select File -> Close to dismiss the Sample Selection Tool and return 
to the Sampling Project Wizard.

A Progress meter displays as the Sample Selection Tool creates AOI 
bounding boxes for each of the selected samples.

Note that the Sampling Project Manager has been updated to include 
the 15 samples you have selected.

Enter 15 here

Click OK
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Sample Level 
Functions

You are now ready to perform the Sample Level functions.

1. Click Next > on the Select Samples step of the Sampling Wizard.

The Set Up Sample Node Level Files step displays.

2. Click Next > on the Setup Sample Node Files step of the Sampling 
Wizard.

The Assign Sample Node Files step displays.

This dialog is used to assign files that are associated with each of the 
Samples to their respective Sample Cell.

Click here to expand
the Tile level node 

This dropdown list contains
all of the samples
for the selected Tile

This list contains
all of the file descriptors
for the selected Sample
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Assigning the Rectified Samples

The first step in assigning the Rectified Samples is to find out which 
selected cells overlap which high resolution image.

1. On the ERDAS IMAGINE icon panel, click the Viewer icon to open a 
Viewer. 

2. Click the Open file icon  on the Viewer toolbar.

The File Chooser opens.

3. Browse to the IMAGINE_HOME/examples directory.

4. From the Files of Type dropdown list, select MrSID (*.sid).

5. Ctrl-click loudoun_highres1.sid and loudoun_highres2.sid.

6. Click OK to open the files in the Viewer.

7. Click the Open file icon  on the Viewer toolbar.

Sample Node Files
Sample Boundary: The Sample Boundary is a polygon AOI file that 
traces the boundary of the Selected Cell. This file is automatically 
created and by the Project Manager after Sample Selection. It is a 
required file.

Imported Sample: An Imported Sample is a native IMAGINE format 
image that provides high resolution view of the representative 
sample. The inclusion of an Imported Sample in the project is 
optional, as long as you can provide a Rectified Sample.

Rectified Sample: A Rectified Sample is an orthorectified version of 
the Imported Sample. The Rectified Sample is used to perform the 
high resolution interpretation of the Sample Cells. This file is 
required by the Sampling Process.

NOTE: The Rectified Sample files must be manually assigned to 
the appropriate samples.

Dot Grid Interpretation: The Dot Grid Interpretation is an annotation 
file (.ovr) that is the result of a Dot Grid Interpretation of the high 
resolution sample. This file created by the Dot Grid Tool. This file 
is required for this sample to be included Dot Grid Final Analysis.

Polygon Interpretation: The Polygon Interpretation is the output file 
of a Polygon Interpretation of the high resolution sample. This file 
is created by the Polygon Analysis Tool. This file is required for this 
sample to be included Polygon Final Analysis.
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The File Chooser opens.

8. Browse to the directory that contains your Sampling Project.

9. Select the loudoun_tm/sample_1 directory.

10. From the Files of Type dropdown list, select AOI (*.aoi).

11. Select sample_1_boundary.aoi and click OK.

The AOI that defines the boundary of Sample_1 opens in the Viewer.

12. In the Assign Files step of the Sampling Wizard, select Sample_1 from 
the Samples dropdown list.

13. Select Rectified_Sample from the File Descriptor dropdown list.

14. Click the Browse icon  and browse to the IMAGINE 
_HOME/examples directory.

15. In the Files of Type dropdown list, select MrSID (*.sid).

16. Select the high resolution file that overlaps Sample_1 
(loudoun_highres2.sid) and click OK. 

17. Repeat step 7 through step 16 for each of the Samples.

Dot Grid Interpretation Dot Grid Interpretation overlays a grid of dots on the portion of the 
high-resolution image contained within the Sample. You label these 
dots so that they correctly identify the underlying features. The 
labeled grid is used to calculate the percentage of the MOI occurring 
within that portion of the Stratum File.

loudoun_highres1.sid

loudoun_

Sample Boundary 

highres2.sid

AOIs
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Placing the Dot Grid

1. Click Next > on the Sampling Wizard.

The Interpret High Resolution Samples step opens.

2. In the Sample dropdown list, select Sample_1.

3. Click the Perform Dot Grid Interpretation icon to open the Dot Grid 
Tool.

The Create Dot Grid dialog opens.

4. In the Approach group, select the Manual Placement radio 
button. This has the program randomly place the Dot Grid within the 
Sample.

5. Select the Fixed Rotation radio button. Enter 30 in the Fixed 
Rotation number field.

6. Click OK.

The high resolution image displays in the Dot Grid Tool. An AOI is 
placed in the image to demarcate the boundary of the Sample. A 
square indicates the location of the Dot Grid.

Select Manual
Placement 

Select 

Enter 30 
here

Fixed
Rotation
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7. Drag the Dot Grid square until it covers the majority of the Sample.

8. Double-click inside the square to create the Dot Grid.

AOI marking the 
Sample Boundary 

Square indicating the
Dot Grid location
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Set Up the Grid Labels

The first step in the Interpretation of the Samples is to create a Label 
set used to label all of the Samples.

1. Determine the number of labels used to interpret the Sample. In this 
tour, use three labels: Forest, Not Forest, and Not Used.

2. Select the Append new row to Grid Label CellArray item from the 
Dot Grid menu. Repeat this for every label you add to the Label Set.

3. In the Grid Labels Group, click the Locked icon  to enable the 
editing of the Grid Labels. The icon changes to indicate that the 

labels have been unlocked  .

4. Click OK on the message that informs you that this label set is 
applied to all of the samples in the project.

5. Click in the Label column of row 2. Type Not Forest.

6. Click in the Label column of row 3. Type Forest.

7. Click in the Color column for Not Used. Select Gray from the list of 
colors.

Dot Grid

Main View

Overview

Zoom View

Grid Labels
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8. Click in the Color column for the Not Forest label. Select Red from 
the list of colors.

9. Click in the Color column for the Forest label. Select Dark Green from 
the list of colors.

The Grid Labels should look like this:

10. Click the Save icon to Save the current label set.

11. Read the Warning Message. Click Save Label Set on the Warning 
Message.

The File Chooser opens.

12. Browse to the Sampling Project directory.

It is generally a good idea to save the Label Set in the Tile level 
directory. This keeps the Labels in a logical place within the 
project files hierarchy.

13. Enter forest_moi_labels.lbs as the file name.

14. Click OK to save the Label Set. 

Manually Label the Grid

1. Use the Manual Zoom icon  to zoom in on the portion of the Dot 
grid that falls outside of the high resolution image.

2. Use the Manual Zoom icon  in the Zoom View to zoom in to a 
comfortable magnification.

3. Use the Manual Zoom icon  in the Overview so that it displays the 
extent of the Dot Grid.

4. Click the Select icon  on the Dot Grid Tool toolbar.

5. Select a dot on the edge of the image by clicking on it in the Main 
View.

Click here to Save
the Grid Labels

Click to Lock
the Grid Labels
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The Zoom View shows that over half of the dot is outside of the 
image.

6. Set the caret > in the Not Used row of the Grid Labels by clicking in 
the first column.

7. Label the selected dot by clicking the Label Selection icon  .

The dot is filled with the color of the current label (Not Used) to 
indicate that it has been labeled.

Automatically Apply Labels

1. Click the Manual Label icon  to toggle on the Automatic Label 

mode. The Automatic Label icon  indicates that Automatic Label 
Mode is active.

2. Make sure that the Not Used label is still set as the current label in 
the Labels CellArray.

3. Select another of the dots that lies outside of the high resolution 
image extent.

The Not Used label is automatically applied to the dot as it is selected.

4. Repeat this process to label the dots outside of the image extent.

Click this dot
to select it

The dot is also
selected in the
overview

The dot is centered
in the Zoom View

Click here to set
the Not Used label
as the current label
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Label Multiple Dots

1. Click the Automatic Label icon  to toggle on the Manual Label 

mode. The Manual Label icon  indicates that Manual Label Mode 
is active.

In the lower portion of the Main View, there is an area covered by 
trees. 

2. Click of the dots in this portion of the image to select it.

3. Shift-click the other dots that overlay this forested plot.

4. Place the caret > in the Forest label row to set it as the current label.

5. Label the selected dots by clicking the Label Selection icon  .

Use AOI to Label Multiple Dots

1. Use the Manual Zoom icon  to zoom in on the large forested plot 
in the upper-left portion of the Dot Grid.

2. Open the AOI Tools by clicking on the AOI Tools icon  on the Dot 
Grid toolbar.

The AOI Tool Palette opens.

3. Select the Create Polygon AOI icon  .

4. Digitize a polygon around the forested portion of the image.

Select all the dots that
lie over the forested plot 
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5. In the Label CellArray, place the caret > in the Forest label.

6. Click the Label AOI icon  to label all of the dots within the 
polygon.

7. Remove the AOI by selecting AOI -> Cut.

8. Select a dot that lies along the perimeter of the polygon.
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Use the Zoom View to analyze whether or not the selected dot is 
correctly labeled.

9. If it is incorrectly labeled, place the caret > in the Not Forest label 

row, and click the Label Selected Dot icon  .

10. Continue to analyze the dots that lie along the perimeter of the 
polygon, relabeling those that were erroneously included in the 
polygon.

Continue Interpretation

1. Continue labeling the Dot Grid until the entire Grid is correctly 
labeled.

2. Select File -> Save -> Save Dot Grid from the Dot Grid Tool menu 
bar.

3. Click File -> Quit to exit the Dot Grid Tool.

The Dot Grid Tool closes and you are returned to the Interpret 
Samples step of the Wizard.

The Sampling Project Manager updates to include the new 
Interpretation file.

Select this dot

The Zoom View
shows it is actually
Not Forest
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Although a Final Analysis can be run at this point, the accuracy 
of the analysis is affected by the limited number of samples that 
have been analyzed.

4. Continue to interpret the Samples until they have all been labeled. 
Experiment with the Size and Spacing of the Dot Grid, as well as the 
Automatic Placement and Rotation options.

The Sampling Project Manager indicates that all of the Samples have 
been interpreted, and Final Analysis may be performed by placing 
green check marks in the Tree View.

The green checks
indicate that sufficient
steps have been 
completed to perform
Final Analysis

The Dot Grid
file is added
to the Project 
Manger
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5. Click Next > in the Interpret Samples step of the Sampling Project 
Wizard. The Final Analysis step displays.

6. Click the Final Analysis icon to start the Final Analysis Wizard.

Final Analysis Wizard The Final Analysis Wizard lets you set the parameters which dictate 
how the Final Analysis process runs.

The Final Analysis Wizard opens with the Select Tiles for Analysis 
step displayed.
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NOTE: If you enabled both Dot Grid and Polygon Analysis when you 
created the Sampling Project, a preliminary step displays asking you 
to choose which sampling method to use in the calculations.

1. The current Sampling project only uses one Image Tile, so click Next 
> on the wizard.

The Select Samples To Be Used step displays. If any of the Samples 
did not represent a good sampling of the MOI (for example, it was 
centered over a lake or desert) you could exclude that sample from 
the Analysis.

2. Leave all of the Samples selected and click Next > on the wizard.

The Set Class Assignments For High Resolution Interpretation step 
displays.

3. Click in the Not Forest row, Not MOI column to set all of the dots 
in the Dot Grid that were labeled as Not Forest to be Not the Material 
of Interest in the Final Analysis.

An X indicates
the Tile is
included in the
Final Analysis

The number of
Samples that
have been 
interpreted and
are ready for
Final Analysis

The total number
of Samples for
the tile

Click here to set the dots
labeled as Not Forest
as Not MOI

Click here to set the dots
labeled as Forest as MOI
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4. Click in the Forest row, MOI column to set all of the dots that were 
labeled as Forest to be the Material of Interest for Final Analysis.

5. Leave the X in the Not Used row, Unused column to exclude these 
dots from the Final Analysis computations.

6. Click Next > in the Final Analysis Wizard.

The Check File Integrity step displays. 

7. Click Next > on the Wizard to perform with the project integrity 
check.

The Final Analysis process performs some preliminary checks to 
make sure that a Final Analysis can be performed.

8. Click the View Warnings button. The Warning Messages dialog 
displays.

9. Click Close to exit the Warning Messages dialog.

10. Click Next > in the Final Analysis Wizard.

The Single Sampling Parameters step displays.

11. Select Hectares from the Units dropdown list as the units in which to 
perform all the calculations.

a Final Analysis 
displays at the top
of this list of messages

Any problem that prohibits

Select Hectares
from this list

Enter _forest_fract
as the File Suffix

Click Next
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12. Enter _forest_fract as the suffix for the Fraction File. This identifies 
the MOI for this fraction file in the Project Manager.

13. Click Next > in the Final Analysis Wizard.

The View Analysis Results step displays in the Wizard. The Final 
Analysis Report opens in a Text Editor window.

The Final Analysis Report gives a wealth of information about the 
Sampling project up to this point. It can indicate which of the strata 
are undersampled and which of the strata lack stationarity. Both of 
these issues must be addressed to achieve an accurate estimation of 
the land covered by the MOI.

Project Files

Confidence
Values

Undersampled
Strata

Strata that
show poor
Stationarity
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Resolving these problems to achieve an acceptable Confidence 
Value may require numerous iterations of refining and recoding 
the Stratum File, adding and/or removing Samples, as well as 
finding and correcting labelling errors in the Interpretation files.

14. Once you are satisfied with the Analysis Results, click Next > on the 
Final Analysis Wizard to generate the Fraction File.

The Final Analysis process generates a Fraction File for each of the 
image tiles. 

Two Analysis Problems: Stationarity and Undersampling
The first few iterations of any Frame Sampling project serve 
mainly to reveal where the project breaks down. The Final Analysis 
Report reveals two of the biggest stumbling blocks for any project: 
stationarity and undersampling.

Stationarity
Stationarity, or Spatial Stationarity, is the measure of the MOI 
consistency in each stratum. A low Stationarity value means that 
the stratum reported relatively consistent MOI content 
percentages during the resampling iterations.

Undersampled strata
Not every stratum includes areas that are sampled with high-
resolution imagery, and some of those strata that are included 
only have a very small percentage of the actual area that is 
sampled—not enough to make an accurate estimate of the MOI. 
These areas are said to be Undersampled. 

Resolving the Problems

There are a number of ways to reduce the Undersampled strata 
and the Stationarity of the Strata; two of the most helpful methods 
are described below:

• Use the Dendrogram Tool (in the Class Grouping Tools) to 
revise your stratum file and group some of the problematic 
strata into spectrally similar groups that are adequately 
sampled. You also need to recode the stratum file again.

• Some of the Strata may include classes that are substantially 
different from each other. These classes need to be split apart 
into two separate strata. Use the Dendrogram Tool (in the 
Class Grouping Tools) to revise your stratum file and regroup 
these classes.

• Add additional Samples to the project to get a better 
estimation of the contents of the strata. 
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15. Click Close on the Final Analysis Wizard to exit the wizard and return 
to Sampling Project Manager. 

The Fraction File, which is generated during the Final Analysis 
process, is a floating point file; each pixel value represents the 
probability of that pixel containing the MOI.
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IMAGINE Expert Classifier™

Introduction This chapter is designed to introduce you to the IMAGINE Expert 
Classifier™. The IMAGINE Expert Classifier is composed of two 
modules: the Knowledge Engineer and the Knowledge Classifier. The 
Knowledge Engineer provides the interface for an expert with first-
hand knowledge of the data and the application to identify the 
variables, rules, and output classes of interest and create the 
hierarchical decision tree. The Knowledge Classifier provides an 
interface for a non-expert to apply the knowledge base and create 
the output classification. 

This set of exercises guides you through the basic process of creating 
a new knowledge base from scratch. The Knowledge Engineer tools 
and their uses are presented.

Create a 
Knowledge Base

In this tour guide you can learn how to:

• add hypotheses

• enter rules for hypotheses

• edit variables for the rules

• copy and edit existing rules

• test a knowledge base

Approximate completion time for this tour guide is 30 minutes.

Set Up the Output Classes For the purpose of this exercise, suppose that you are determining 
Residential and Commercial Services map classes from imagery and 
existing mapped data. (The example classes are a subset of the 
lanier.ckb provided in the examples directory.) 

This very simple two class example provides an opportunity to use 
and become familiar with the tools and processes of the Knowledge 
Engineer. The Knowledge Engineer aids in the process of designing 
a knowledge base by allowing you to set up a framework which can 
be easily be edited and rearranged during the design process.

Start the Knowledge Engineer

1. Click the Classifier icon and on the IMAGINE icon panel. 



Create a Knowledge Base / 594ERDAS IMAGINE Tour Guides

2. Select Knowledge Engineer from the Classification menu.

The Knowledge Engineer dialog starts with blank slates in the edit 
window, the decision tree overview section, and the Knowledge Base 
component list (Hypotheses, Rules, and Variables). 

Place Hypotheses into the Edit Window

1. Select Edit -> New Hypothesis to add the first hypothesis.

The Hypo Props (Hypothesis Properties) dialog opens with 
untitled.ckb in the title bar, a default hypothesis name: New 
Hypothesis, and the Color is set to Grayscale. 

Click here to start the
Knowledge Engineer

Decision tree 
overview 
section

Knowledge 
Base 
component list

Edit window



ERDAS IMAGINE Tour Guides Create a Knowledge Base / 595

2.  Change the default hypothesis Name to the first class name, 
Residential.

3. Since you want Residential to be an output class, the Create an 
Output Class checkbox is left checked.

You are going to give colors to each of the classes. 

4. Click the Specify radio button in the Color section. Then use the 
dropdown menu to select Orange as the color for this class.

5. Now click the Apply button in the Hypo Props dialog.

A green rectangle with the hypothesis name Residential and chip 
color displays in the edit window and an outline of the rectangle 
appears in the knowledge tree overview window. You probably 
noticed that there are diagonal lines through the hypothesis 
rectangle in the edit window. These lines remain until conditions 
have been added that can make the hypothesis true or false.

6. Select Edit -> New Hypothesis once again to set up the next class, 
Commercial Services. Enter the class Name and Specify Red as 
the color for the class.

7. Click Apply in the Hypo Props dialog to add the class.

8. Click Close on the Hypo Props dialog.

Type the new 
class name 
here

Specify the 
color Orange

Selecting Colors for Output Classes
If a color is not specified for an output class, it is automatically 
made grayscale. As additional grayscale output classes are added, 
grayscale values for each of the grayscale classes are 
automatically updated and stretched evenly across the range from 
white to black. This occurs even if some other classes are assigned 
specific colors.



Create a Knowledge Base / 596ERDAS IMAGINE Tour Guides

Enter Rules for the 
Hypothesis

1. Select the Create Rule Graphic Tool icon  from the Knowledge 
Engineer dialog icon bar.

2. Move the cursor, which changes to the shape of a rule, and click the 
green hypothesis rectangle for Residential.

A yellow rule rectangle, called New Rule, is attached to the 
hypothesis rectangle, Residential, by a line that is mirrored in the 
knowledge tree overview.

New classes 
display in the 
edit window, in 
the overview, 
and in the 
component list
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3. Double-click the yellow New Rule rectangle to open the Rule Props 
(Rule Properties) dialog.

4. Change the Name of the rule to Vegetated Within City and leave 
the Compute from Conditions radio button selected for Rule 
Confidence.

Enter Variables for the Rule

1. Click within the cell under Variable and select New Variable from 
the dropdown list.

The Variable Props dialog opens.

A new rule is 
added to the 
Residential 
class

Enter the name for 
the new rule here

Click here to create 
a new variable
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2. Change the Variable Name to Highway Map, and change the 
Variable Type to Raster.

Changing the type to Raster switches the bottom part of the dialog 
to the Raster Variable Options, providing a different set of choices 
than for the Scalar variable type.

3. Click the Select Image File icon  , then navigate to and select 
lnput.img from the <IMAGINE_HOME>/examples directory.

4. Click OK in the Select Image dialog to add the file to the Variable 
Props dialog.

5. Click the Apply button in the Variable Properties dialog to add 
Highway Map to the rule properties CellArray.

Type the name of 
the variable here

Select Raster as the 
Variable Type

Select lnput.img

A preview displays
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6. Click Close to dismiss the Variable Props dialog.

7. In the Rule Props dialog, click in the cell under Value and select 
Other.

8. Into the highlighted cell, type 7 and press Enter on your keyboard (7 
is the class number for urban areas in lnput.img).

9. Click Apply in the Rule Props dialog to enter the changes, then 
Close.

The new rule with its attached variable appears in the edit window. 
Notice that the diagonal lines in the hypothesis, Residential, and 
rule, Vegetated Within City, rectangles have disappeared for the 
hypothesis and rule you have edited. This is because at least one 
complete condition is now set.

Highway Map is the 
Variable

Change the Value 

The Value is now 
set to 7
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Add an Intermediate 
Hypothesis

In this section, you add an intermediate hypothesis as well as its 
conditions.

1. Select the Create Hypothesis icon  and click the rule, Vegetated 
Within City.

An intermediate hypothesis, New Hypothesis, is attached to the 
rule, linked by a New Hypothesis == TRUE variable.

2. Double-click the New Hypothesis rectangle to open the Hypo Props 
dialog.

3. In the Hypo Props dialog, change the name to Vegetation and 
deselect the Create an Output Class checkbox since you do not 
want this to be an output class.

4. Click Apply, then Close.

Create a New Rule

1. Using the Create Rule icon  , place a New Rule on the 
Vegetation hypothesis. 

2. Double-click the New Rule to open the Rule Props dialog, and 
change the rule Name to High IR and Low Visible.

3. Click in the cell below Variable and select New Variable.

4. Type the name TM Band 4 in the Variable Name field.

5. Change the Variable Type to Raster.

6. Click the Open icon to open the Select Image dialog, and select 
lanier.img from the <IMAGINE_HOME>/examples directory.

The Variable 
Highway Map 
has been added 
to the tree
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7. Click OK in the Select Image dialog to add lanier.img to the Variable 
Props dialog.

8. Click the Layer dropdown list and select (:Layer_4).

9. Click Apply, then Close in the Variable Props dialog.

The Rule Props dialog updates.

10. In the Rule Props dialog, click in the cell below Relation and select 
>=.

11. Click, then select Other from the Value cell, change the Value to 
21, then press Enter on your keyboard.

12. Now, using step 3 through step 11 above, add layer 2 of lanier.img 
as the second variable (row 2 under the AND column), name it TM 
Band 2, set Relation to < and set the value to 35.

Select lanier.img

A preview displays

Now that you have 
created the 
Variable, change its 
Relation and Value
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13. Click Apply, then Close in the Rule Props dialog.

Copy and Edit Since the hypothesis for the Commercial Services class has very 
similar rules and conditions to the Residential class, some of the 
conditions can be used directly, or copied and edited to save time. 

1. Begin editing the Commercial Services class by placing a new rule 
on the Commercial Services hypothesis rectangle, then double-
clicking the New Rule to open the Rule Props dialog.

Refer to “Enter Rules for the Hypothesis” if you forget how to 
create a new rule.

2. In the Rule Props dialog, change the Name of the rule to Bright 
Within City.

The first variable that is needed is Highway Map, which is now in 
the Variable list since it was entered previously.

3. Click in the cell below Variable and select Highway Map, confirm 
that the Relation is set to ==, and set the Value to 7. 

As before, this makes the variable equal to the urban area from 
lnput.img. 

4. Click Apply in the Rule Props dialog, then Close.

Two Variables, their 
Relations and 
Values have been 
added to the rule 
High IR and Low 
Visible

The Commercial 
Services class has 
the rule Bright Within 
City, which has the 
Variable Highway 
Map
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5. Now use the Create Hypothesis graphic tool to place a new 
hypothesis (which is an intermediate hypothesis) on the Bright 
Within City rule rectangle. 

See “Add an Intermediate Hypothesis” if you forgot how to 
create a hypothesis.

6. Double-click the New Hypothesis to open the Hypo Props dialog.

7. In the Hypo Props dialog, name the new hypothesis Bright and 
deselect the Create an Output Class checkbox. 

8. Click Apply, then Close in the Hypo Props dialog.

The Knowledge Engineer dialog updates accordingly.

Since the rule to be attached to the Bright hypothesis is very similar 
to the High IR and Low Visible rule that is attached to the 
Vegetation hypothesis, you can make a copy of it to paste and edit.

9. Click the High IR and Low Visible rule.

10. Right-click, and select Copy from the Options menu.

11. Click the Bright hypothesis, then right-click and select Paste from 
the Options menu.

A new rule is attached to the Bright hypothesis with a default name 
of High IR and Low Visible (1) (the (1) is added since it is a 
copy).

12. Double-click the High IR and Low Visible (1) rule to open the Rule 
Props dialog.

13. In Rule Props dialog for the new rule, change the Name to High IR 
and High Visible.

The Bright
Hypothesis 
has been
added 
using the
Create 
Hypothesis
icon
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The only change that needs to be made to the variables is the 
Relation for TM Band 2.

14. Change the Relation for TM Band 2 to >=.

15. Click Apply, then Close in the Rule Props dialog.

At this point, two hypotheses and their conditions have been 
entered. Now, the two classes can be tested to see what pixels are 
allocated to them.

Test the Knowledge Base

1. On the Knowledge Engineer dialog toolbar, select the Run Test 

Classification icon  (or select Evaluate -> Test Knowledge 
Base).

The Knowledge Classification dialog opens in Test Mode at the 
SELECT THE CLASSES OF INTEREST panel, along with a new 
Viewer where the test classification displays. All active enabled 
classes are selected by default.

The portion of 
the tree visible in 
the edit window 
is highlighted in 
the overview 
window

Rule properties 
have been 
changed for the 
High IR and High 
Visible rule
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2. Leave the two classes, Residential and Commercial Services, 
selected in the Selected Classes section of the Knowledge 
Classification dialog.

3. Click Next to go to the next panel of the Knowledge Classification 
dialog.

If the Prompt User option had been selected instead of 
entering file names for the variables, an intermediate panel, 
SELECT THE INPUT DATA FOR CLASSIFICATION, would display 
here to allow entry of file names.

The Select Classification Output Options panel allows you to set 
the number of best classes per pixel, set an output area and set 
an output cell size. The defaults are used here since you only 
have two classes and small images that are the same size and 
have the same cell size.

Also note the grayed-out options for Output Classified Image, 
Output Confidence Image, and Output Feedback Image. These 
images are made temporary files in Test Mode, but can be 
selected as output files when running Knowledge Classifier in 
regular (non-test) mode from the Classification menu.

The Selected 
Classes are 
Residential and 
Commercial 
Services
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4. Click OK in the Knowledge Classification dialog to start the test 
classification.

A status bar opens. When the classification has completed, the test 
classification image displays in the Viewer.

5. Click OK to dismiss the status bar when the classification is finished.

6. In the Knowledge Engineer dialog, click the Start Classification 

Pathway Feedback Mode icon  .

The Classification Path Information dialog opens along with a cursor 
in the Viewer.

Click OK to 
generate the 
test 
classification
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7. Move the cursor into the orange and red areas in the Viewer, which 
correspond to the orange Residential class and the red 
Commercial Services class.

Note that when the cursor is placed on a pixel for one of the classes, 
the path for the class is highlighted in the Knowledge Engineer dialog 
and in the overview window. In complex knowledge bases, this 
feature is useful for telling at a glance which hypothesis was used to 
classify the point of interest.

8. Click the Close button to dismiss the Classification Path Information 
dialog.

9. Select the gray Disable Node icon, then click the Commercial 

Services Hypothesis icon  to disable it.

The Commercial hypothesis path is grayed-out. This means the class 
is not considered when a test classification is run (or, in the regular 
Knowledge Classifier, if the knowledge base has been saved with the 
class disabled).

Details about the
class under the
cursor display here

The class 
currently under 
the cursor is 
highlighted in 
the Knowledge 
Engineer 
dialog
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10. To enable the Commercial Services class once again, click the 
Commercial Services hypothesis graphic with the yellow Enable 

Node icon  (or right-click the hypothesis graphic and select 
Enable).

11. Save the knowledge base by selecting File -> Save As.

12. Navigate to a directory in which you have write permission, and 
name the file ResComm_Class.ckb.

13. Click OK in the Save Classification Knowledge Base As dialog.

14. Select File -> Close from the Knowledge Engineer dialog, which is 
now entitled ResComm_Class.ckb, to finish.

Create a Portable 
Knowledge Base

This exercise is going to give you practice creating and using a 
portable knowledge base. In this example, you use a knowledge 
base to determine areas most suitable for cross-country travel.

Data Data available for the project includes the following:

• a landcover classification (supervised.img)

• a DEM (30meter.img)

• a map of minor and major roads (roads.img)

• a near-infrared degraded air photo with 30 m resolution 
(mason_ap.img)

Commercial 
Services is 
disabled
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The file supervised.img shows a typical landcover classification 
derived from Landsat TM data (a portion of the Landsat scene is 
provided as tm_860516.img along with the signature file 
tm_860516.sig, which was used to produce a maximum likelihood 
classification). The image shows the distribution of broad landcover 
categories such as different types of forestry, human-made features, 
water and open ground. However, it does not show the land use of 
each pixel, or how each pixel could be put to use.

Consider a scenario whereby someone wishes to traverse this area 
of ground with one or more vehicles. They need to use the landcover 
information, along with other ancillary data to help determine which 
areas can be traversed easily and which cannot.

Methodology Given these data sets, we can start to envisage expert rules that are 
based on these data (and data derived from them) to determine the 
ease of crossing a particular area. 

ERDAS IMAGINE must be running.

1. Click the Classifier icon in the ERDAS IMAGINE icon panel.

The Classification menu opens.

2. Click Knowledge Engineer in the Classification menu.

An empty Knowledge Engineer dialog opens. 

Click here to start the
Knowledge Engineer
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Open a Knowledge Base Next, you can open the mobility_factors.ckb knowledge base to 
examine what expert rules are used and how their components were 
created.

1. In the Knowledge Engineer dialog, click the Open icon  , or select 
File -> Open.

The Open Classification Knowledge Base dialog opens.

2. Navigate to the <IMAGINE_HOME>/examples directory, and select 
the file mobility_factors.ckb.

<IMAGINE_HOME> is the directory where ERDAS IMAGINE 
resides on your system.

3. Click OK in the Open Classification Knowledge Base dialog to load the 
file.

The knowledge base of mobility factors opens.
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Examine the Knowledge 
Base

This knowledge base was created by defining as many of the 
variables as would be needed as possible. For example, roads are 
going to be the easiest areas to traverse, so a variable was needed 
to define where roads are that can be used.

1. In the Knowledge Engineer dialog, click the Variables tab.

The variables for the mobility_factors.ckb knowledge base 
display.

2. In the Variables list, double-click the Roads variable.

The Variable Props dialog opens. 

Double-click the 
Roads variable 
to see its 
properties
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In the Variable Properties dialog, you can see that the Variable 
Type is Raster and the Imagery option is selected because the 
input is an image.

This knowledge base is transportable—you may want to pass it to a 
colleague in another office, or reuse it yourself to automate a 
production process. So, rather than selecting a specific image to be 
used, the Leave Undefined checkbox is selected and a prompt for 
the type of data that you want the end user to supply is typed in the 
Info window (that is, Select road coverage).

The same type of imagery variables have been defined for the 
landcover classification (Terrain Categorization), Digital Elevation 
Model (DEM) and air photo (Aerial Photo).

Some of the imagery variables are used directly in rules (such as the 
Terrain Categorization variable being used to identify open 
ground in the image). Others are used indirectly to calculate variable 
values.

For example, open ground (for example, grass, scrub) is also good 
for vehicles to cross, but not if the ground is steeply sloping. The fact 
that an area is open ground can be determined from the landcover 
classification (the Terrain Categorization variable), but you do not 
have an image that provides slope directly. However, you do have a 
digital elevation model (the DEM variable), which can be used to 
derive slope.

Derive Slope Values

1. In the Variables tab, double-click the variable called Slope from 
model.

The Variable Props dialog updates accordingly.

The Variable 
Type is Raster

Raster Variable 
Options are set to 
Imagery

The Leave 
Undefined (Prompt 
Analyst) checkbox 
is enabled
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Notice that the variable is again raster in nature, so the Variable 
Type is set to Raster. In this case, however the Graphic Model 
option of the Raster Variable Options has been selected. The 
graphic model associated with this variable is named slope.gmd.

2. In the Variable Props dialog, click the Edit Model button to view the 
graphic model.

A Spatial Modeler viewer opens, which contains the model that 
defines the Slope from model variable.

These are the 
properties for the 
Slope from model 
variable

The Slope from 
model variable uses 
a Graphic Model
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This is the model that the variable Slope from model uses to 
calculate the slope of any location.

To make the knowledge base transportable, you do not want to 
define actual image names in the slope.gmd model. Instead, the 
INPUT RASTER and the OUTPUT RASTER of the model have been 
set to PROMPT_USER. 

In the Variable Properties dialog, the PROMPT_USER Input Node 
that was the output in the model has been defined as the Output, 
and the following CellArray has been used to define which variables 
should be used to supply which Input Node. In this instance, 
clicking in the Variable Definition cell gave the list of defined 
variables from which DEM was selected.

Thus, a variable has been defined that calculates values on the fly as 
needed from another variable (in this case, slope is derived from a 
DEM).

3. Click the Close Model icon  , or select File -> Close from the 
Spatial Modeler viewer.

The Spatial Modeler viewer closes.

4. Click Close in the Variable Props dialog.

Build Hypotheses Since you have looked at how the two main types of input variable 
can be defined, now you can look at how each hypothesis is built in 
the knowledge base.

The knowledge base mobility_factors.ckb displays: 

Select the spatial model 
node that represents the 
calculated variable (Output)

Select variables as inputs to the 
spatial model in the CellArray 
here
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The first two hypotheses, Wide Road and Narrow Road, are fairly 
simple. The expert rule in these cases is that something identified as 
a road is going to be easily traversable by the vehicles, with major 
roads being better than minor roads.

Consequently, the Wide Road hypothesis has two rules (that is, 
they each have an OR statement so that either needs to be true for 
the hypothesis to be true). The first looks for major roads (DN value 
2) in the Roads variable (roads.img), and the second looks for pixels 
that are potentially identified as roads by the supervised 
classification.

1. Double-click the Highway category rule.

The Rule Props dialog opens.

conditionsruleshypotheses
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The Rule Props dialog shows how this particular rule depends on the 
Terrain Categorization (supervised.img) file. 

2. In the Rule Props dialog, click the horizontal scroll bar until you can 
see the Confidence value, 0.80.

3. In the Knowledge Engineer dialog, click the Major Road rule.

Its properties display in the Rule Props dialog.

4. Click the horizontal scroll bar until you can see the Confidence 
value, 0.98.

Note that the Confidence field for the Highway category rule has 
been set to a much lower value than the Confidence for the Major 
Road rule. This is because you are less certain of the results from a 
maximum likelihood classification than you would be from a road 
map.

The next four hypotheses work on the same basis. The expert rule is 
that open ground types are good for vehicle passage. As slopes get 
steeper, however, the open ground becomes less and less 
manageable until it becomes impassable at very steep angles.

5. Click Close in the Rule Props dialog.

Set ANDing Criteria These hypotheses also demonstrate the ANDing of criteria in a rule. 
The Flat solid open ground (go) hypothesis has only one rule, but 
that rule has two conditions. Both conditions must be true for a rule 
to be true.

Use the scroll bar 
to see the 
Confidence value 
in the CellArray

The Confidence for 
the Major Road rule 
is set higher than 
that for the Highway 
category rule
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1. Double-click the Slope from model <= 4 condition.

The Rule Props dialog opens.

In the List of Conditions CellArray, the slope calculated by the 
Slope from model variable must be less than or equal to 4 degrees, 
and (that is, AND, note the far left column of the CellArray) the 
Solid open ground variable must be true before this rule can be 
true.

2. Click Close in the Rule Props dialog.

The rule Flat solid open ground is defined by an intermediate 
hypothesis: Solid open ground.

3. In the Knowledge Engineer dialog, click the horizontal scroll bar and 
move it to the right until you can see the intermediate hypothesis 
Solid open ground.

The intermediate hypothesis Solid open ground uses the Terrain 
Categorization variable to identify various types of open ground 
cover.

hypothesis rule conditions

Value must be 
less than or 
equal to 4

intermediate 
hypothesis

rules conditions
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Check Other Hypotheses You can check the other hypotheses listed along the left side of the 
Knowledge Engineer dialog.

1. Position the horizontal scroll bar to the extreme left in the Knowledge 
Engineer dialog.

2. Move the vertical scroll bar down until you see the Water (no go) 
hypothesis.

The Water (no go) hypothesis is a simple expert rule that states 
that if the Terrain Categorization variable shows that a location is 
water, it is impassable.

3. Note the hypothesis below Water (no go): Soft Ground (no go).

Similarly, the Soft Ground (no go) hypothesis is a simple expert 
rule that states that if the Terrain Categorization variable shows 
that a location is a type of wetland, it is impassable.

Introduce Spatial Logic to 
the Knowledge Base

The three forest hypotheses are more complicated, and show how 
spatial operators can be used within the IMAGINE Expert Classifier 
to create a spatially aware classifier (rather than a traditional per-
pixel classifier). 

1. Use the vertical scroll bar to scroll down to the various forest 
hypotheses.
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The expert rule is that open forest canopies are easier to traverse 
than closed forest canopies because space between trunks is not as 
large with a closed canopy (that is, trees are older and have large 
trunks). However, it is difficult to determine canopy closure on a per-
pixel basis.

To a certain degree, canopy closure can be inferred from the type of 
tree cover. For instance, if the cover is coniferous, then it is more 
likely that you have a close canopy and close trunks. However, this 
is more difficult to state for mixed and other types of tree cover. 

Consequently, this particular hypothesis also looks at panchromatic 
aerial photography to try and determine crown closure. However, 
you cannot determine crown state on a per-pixel basis. Instead, the 
Tree Density model variable (using the Aerial Photo and Terrain 
Categorization variables as inputs) executes a graphical model 
(texture.gmd).

2. Click the Variables tab in the Knowledge Engineer dialog.

3. Double-click to select the Tree Density model variable.

The Variable Props dialog for the Tree Density model variable 
opens:

4. Note that the Raster Variable Options for the Tree Density 
model variable is set to Graphic Model.

Double-click Tree 
Density model

Graphic Model is 
selected for the
variable option
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The model that provides information for the Tree Density model 
variable is texture.gmd. 

5. Click the Edit Model button in the Variable Props dialog.

The Spatial Modeler viewer opens, which displays the model 
texture.gmd.

This model, texture.gmd, is a model that looks at every location 
that has been determined to be tree cover (from the Terrain 
Categorization variable), and analyzes both the air photo DN value 
at that location and the DN values in surrounding locations (using a 
3 × 3 moving window) to determine local texture. This spatial 
variable is then used in the Close Forest (no go), Medium 
Density forest (slow go), and Open Forestry (go) hypotheses to 
determine the relative density of the tree canopy, and thereby 
determine the relative ease of vehicular passage.

6. Select File -> Close from the Spatial Modeler viewer.

7. Click Close in the Variable Props dialog displaying properties for the 
Tree Density model variable.

Check Buildings 
Hypothesis

The Buildings (no go) hypothesis is a simple expert rule that states 
that if the Terrain Categorization shows that a location is a type 
of urban area, it is impassable.
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Confidences are kept low on these rules so that they do not override 
the Wide Road and Narrow Road hypotheses. That is, roads within 
urban areas are still traversable.

1. Double-click the Suburban rule attached to the Buildings (no go) 
hypothesis.

The Rule Props for the Suburban rule open.

2. In the Rule Props dialog, move the horizontal scroll bar all the way 
to the right.

3. Notice that the Confidence values are set to 0.75.

4. Click Close in the Rule Props dialog.

Identify Choke Points The final hypothesis is another good example of spatially enabling 
the IMAGINE Expert Classifier. This hypothesis identifies choke 
points in the road network—points where the road narrows 
considerably and traffic cannot circumnavigate, thereby 
representing a potential no go point. The main example of this is 
bridges.

Identification of bridges might sound like an easy proposition: find 
roads that are on water. However, the only information we have on 
location of water bodies is from the landcover classification (the 
Terrain Categorization variable), which cannot identify water that 
flows below other features. Consequently, a more complex approach 
is required.

1. Click the Variables tab in the Knowledge Engineer dialog.

This rule 
uses an 
AND 
statement 
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2. In the Variables tab, double-click Identify possible bridges 
model.

The Variable Props dialog for the variable Identify possible 
bridges model opens.

3. Click the Edit Model button in the Variable Props dialog.

The model used to identify potential bridges, 
identify_bridges.gmd, shows the expert rule.

Double-click the 
Identify possible 
bridges model 
variable

This 
variable 
also uses a 
Graphic 
Model
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Since you cannot immediately identify roads over water, you must 
instead look at roads in close proximity to water. This could be done 
by buffering (performing a Search function) on the roads and 
overlaying this with the location of water pixels. However, many 
roads simply run alongside lakes or rivers and do not necessarily 
therefore constitute a choke hazard. Instead, it is better to identify 
roads that occur in close proximity to at least two discrete water 
bodies (that is, one on either side of the bridge).

Therefore, identify_bridges.gmd first identifies all water pixels 
from the landcover classification. These locations are fed into two 
processes. The first finds all locations that are in close proximity to 
water by using a 5 × 5 circular moving window). These are then 
overlain with road locations (from Roads and Terrain 
Categorization variables) to identify roads in close proximity to 
water. At the same time, the water pixels are run through a Clump 
process to produce uniquely numbered, discrete water bodies. A 
Focal Diversity function is then used at each location determined to 
be a road in close proximity to water to determine how many of these 
discrete water bodies are close by. If more than two water bodies are 
identified, then that road is flagged as being a potential bridge or 
other choke point. This information is then used in the 
Bridges/landings (Choke Point) expert rule.

This provides a clear example of how the IMAGINE Expert Classifier 
can be used to integrate spatially aware rules. In this case, the 
values of neighboring pixels are analyzed to help determine the land 
use (bridge as opposed to road) of the target pixels. 
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4. Click the Close Model icon  , or select File -> Close from the 
Spatial Modeler viewer.

Also note that the Bridges/landings (Choke Point) hypothesis is 
always going to occur at pixel locations that have also met the 
requirements to be in the Wide Road or Narrow Road classes (it 
is extremely difficult to create expert rules that are always mutually 
exclusive). Consequently, the Confidence values on the 
Bridges/landings rule have been set higher than those for the 
normal road rules. In this way, the Bridges/landings (Choke 
Point) hypothesis always takes precedence in the classifications. 

5. In the Knowledge Engineer dialog, double-click the 
Bridges/landings rule.

The Rule Props dialog for Bridges/landings opens.

6. Move the horizontal scroll bar to the right see the Confidence value.

7. Note that the Confidence of the variable Identify possible 
bridges model is set to 0.99.

8. Click Close in the Rule Props dialog.

9. Click Close in the Variable Props dialog.

Run the Expert 
Classification

1. In the Knowledge Engineer dialog, click the Run icon  , or select 
Evaluate -> Test Knowledge Base.

The Knowledge Classification (Test Mode) dialog opens on the Select 
the Classes of Interest panel.

Check the 
Confidence 
value
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You want to see results for all of the classes; therefore, you can 
proceed to the next panel.

2. Click the Next button in the Knowledge Classification (Test Mode) 
dialog.

The Select the Input Data for Classification panel opens.

This panel enables you to identify the files to be used as variables, 
which were set to the Leave Undefined (Prompt Analyst) state.

3. Use the vertical scroll bar to see the variables and their 
corresponding files.

In this Knowledge Base, the Roads variable is associated with 
roads.img, the Terrain Categorization variable is associated with 
supervised.img, the DEM variable is associated with 
30meter.img, and the Aerial Photo variable is associated with 
mason_ap.img.

4. Click Next in the Knowledge Classification (Test Mode) dialog.

The Select Classification Output Options panel opens.

Use the scroll 
bar to see the 
values 
assigned to 
variables
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5. Change the Best Classes Per Pixel value to 2.

6. Confirm that the Cell Size is set to Minimum.

7. Click OK in the Select Classification Output Options panel of the 
Knowledge Classification (Test Mode) dialog.

Job Status dialogs open, tracking the progress of the expert 
classification.

8. When the job is complete, click OK in the Job Status dialogs.

You can set a preference to automatically close the Job Status 
dialog after computation is complete. It is located in the User 
Interface & Session category of the Preference Editor.

When the process is complete, the classification displays in a Viewer.

Change the 
Best Classes 
Per Pixel value 
to 2

Confirm that 
the Cell Size is 
set to Minimum
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Evaluate River Areas Now that the classification is complete, you should zoom in and see 
what the IMAGINE Expert Classifier designated as potential bridges.

1. In the Viewer toolbar, click the Zoom In icon  .

2. Move your mouse into the Viewer, and click an area of the river.

3. Click as many times as necessary in order to see the detail of the 
area.

Two 
bridges are 
located in 
this area of 
the image
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4. Zoom in further until you can see yellow pixels at bridge locations, 
which indicate the Bridges/landings (Choke Point) class.

If you refer back to the Knowledge Engineer dialog, you can see 
that the Bridges/landings (Choke Point) hypotheses has a 
yellow color square. Therefore, pixels in that class are also 
yellow.

Use Pathway Feedback You can use the pathway feedback cursor to analyze the 
classification in the Viewer.

1. Click the Classification Pathway Feedback Mode icon  in the 
Knowledge Engineer dialog.

The Classification Path Information dialog opens.

In the Classification Path Information dialog, the second row in the 
CellArray specifies the second most likely class (hypothesis) for this 
pixel (since you requested the 2 Best Classes Per Pixel).

An inquire cursor is placed in the Viewer containing the classification, 
and the pathway it corresponds to is highlighted in red in the 
Knowledge Engineer dialog.

2. Click the Select icon  from the Viewer toolbar.

3. Using your mouse click, hold, and drag the inquire cursor to a yellow 
pixel in the Viewer.

The Classification Path Information dialog and the Knowledge 
Engineer dialog update accordingly.

4. Continue to move the inquire cursor around in the Viewer, and 
analyze the results in the Classification Path Information dialog and 
the Knowledge Engineer dialog.

The class 
beneath the 
inquire cursor 
is identified 
here

The hypothesis, rule, and condition are outlined in red
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5. When you are finished, click Close in the Classification Path 
Information dialog.

A graphical model (clean_up_mobility.gmd) is supplied for 
removing the salt and pepper classification pixels from the final 
landuse map. This model uses a focal majority, but avoids 
altering the road and water classes.

6. Select File -> Close in the Viewer containing the classification.

7. Select File -> Close in the Knowledge Engineer dialog.

The knowledge base mobility_factors.ckb is an example of how a 
knowledge base can be built to take into account spatial rather than 
(or as well as) spectral per-pixel relationships to derive land use 
information. It also shows how commonly repeated tasks can be 
automated for repeating within an organization, or to repeat the 
same methodology at other organizations. instead of running several 
separate spatial models and trying to integrate the results, the entire 
process is captured in one knowledge base that can be easily applied 
to other data and other locations, with consistent results.
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IMAGINE AutoSync 

Introduction IMAGINE AutoSync provides both wizard-driven and workstation 
workflows for the automated rectification of imagery. The IMAGINE 
AutoSync wizards guide you through the geometric correction 
process or you can use the workstation for customizable control of 
your workflow. This tour guide explains the steps for edge matching 
two images using the Edge Matching Wizard and how to use the 
IMAGINE AutoSync Workstation to georeference a raw image. 

All of the data used in this tour guide are in the 
<IMAGINE_HOME>/examples directory. 

Approximate completion time for this tour guide is 1 hour.

For more information about using IMAGINE AutoSync, see the 
IMAGINE AutoSync white paper on the IMAGINE AutoSync 
product page at http://gi.leica-geosystems.com/products/.

Using the 
IMAGINE 
AutoSync Edge 
Matching Wizard

In this section of the tour guide, you use the IMAGINE AutoSync 
Edge Matching wizard to align two images so that features in the 
overlapping area match up.

The two files to be edge matched are air-photo-1.img and 
air-photo-2.img.

These data files are air photo images of the Oxford, Ohio area.

You must have ERDAS IMAGINE running.

1. Click the IMAGINE AutoSync icon on the ERDAS IMAGINE icon panel.

The IMAGINE AutoSync menu opens.

Click here to start
the Edge Matching Wizard



Using the IMAGINE AutoSync Edge Match-ERDAS IMAGINE Tour Guides

2. Select Edge Matching Wizard... from the IMAGINE AutoSync 
menu.

The IMAGINE AutoSync Edge Matching Wizard opens. 

Using the Input tab In the Input tab, you will add the images to be edge matched. 
IMAGINE AutoSync will edge match neighboring images, so input 
image order in the CellArray is important.

1. In the Input tab, click the Open File icon .

The Input Images dialog opens.

2. In the Input Images dialog under File name, select 
air-photo-1.img from the file list.

3. Click OK in the Input Images dialog.

Click here to 
select images

Click here 
to select
the file

Click here 
to display
the file

Preview 
window
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The file air-photo-1.img displays in the Input Images column in the 
Edge Matching Wizard dialog.

4. Repeat step 1 through step 3 for the second image, selecting 
air-photo-2.img this time.

5. Click Next> to continue to the APM Strategy tab in the Edge 
Matching Wizard.

Using the APM Strategy 
tab

In the APM Strategy tab, you can adjust the algorithm settings that 
control the placement of automatically generated tie points in your 
images. You can also select which input image layer to use to achieve 
a better point matching result. 

Input 
image



Using the IMAGINE AutoSync Edge Match-ERDAS IMAGINE Tour Guides

1. In this tour guide, accept the default settings in the APM Strategy 
tab. Make sure that Defined Pattern is selected.

2. Click Next> to continue to the Edge Match Strategy tab in the Edge 
Matching Wizard.

Using the Edge Match 
Strategy tab

In the Edge Match Strategy tab, you can select a refinement method 
and choose to apply the refinement to the overlapping area only or 
the whole image. 

1. In the Edge Match Strategy tab, click the Refinement Method list and 
select Linear Rubber Sheeting.

Make sure 
 
 
Defined Pattern
is selected

Click to select 
Linear Rubber 
Sheeting 

Make sure the 
 
 
buffer size is 180 
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2. Accept the Apply Refinement to default of Overlapping Area 
Only to apply refinement only to the overlapping area between the 
images. 

3. In the Edge Match Strategy tab, in the Buffer Around the 
Overlapping Area (pixels): field, keep the default of 180. 

4. Click Next> to continue to the Projection tab in the Edge Matching 
Wizard.

Using the Projection tab In the Projection tab, you can set a projection for your output 
images. You can set it to the same projection as the corresponding 
input image or to another specified projection.

NOTE: The Output Projection fields will be greyed out in the 
Projection tab until you select the Resample geocorrection method 
in the Output tab.

1. In the Projection tab, accept the default Output Projection of Same 
as Input Image.

2. Click Next> to continue to the Output tab in the Edge Matching 
Wizard.

Using the Output tab In the Output tab, you can specify the properties for your output 
images, including selecting the geocorrection method and specifying 
names for the output files and summary report.
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1. In the Output tab, select the Resample geocorrection method. 

2. Click Resample Settings... in the Output tab.

The Resample Settings dialog opens.

For more information on the geocorrection methods, see 
“Resampling vs. Calibration” on page 288.

3. In this tour guide, accept the default settings in the Resample 
Settings dialog. Make sure the Cubic Convolution resample 
method is selected.

4. Click OK in the Resample Settings dialog.

5. In the Output tab, click the Set Output File Names... button.

The Output File Names dialog opens.

Click here to select
the Resample method

Click here 
to open the
Resample 
Settings
dialog

Click here to open 
the Output File 
Names dialog

Enter a

 
summary 
report 
name here

Make sure Cubic
 
 
Convolution
is selected
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6. In the Output File Names dialog, click the File Selector icon  to 
select a default output directory of your choice.

7. In the Default Output File Name Suffix field, enter a default file 
name suffix of your choice, or use the default _output.

8. Click OK in the Output File Names dialog.

9. In the Output tab, make sure the Generate Summary Report 
checkbox is selected and enter a name of your choice for the HTML 

summary report. You can also click the File Selector icon  to 
select a directory of your choice.

10. In the Output tab, click Save to save the project. A File Selector 
opens, and you can save the project to a directory of your choice.

11. In the Output tab, click Finish to complete the edge matching 
process. 

The AutoSync Job status dialog appears, stating the progress of the 
edge match operation.

12. Click OK in the AutoSync Job status dialog when the operation is 
finished.

NOTE: Edge matching can take several minutes to run, based upon 
your hardware capabilities and the size of the image files.

Display Output Image

1. Click the Viewer icon in the ERDAS IMAGINE icon panel.

The Select Viewer Type dialog opens.

2. Select Classic Viewer.

3. Click OK in the Select Viewer Type dialog.

A new Viewer displays.

Click here to 
 
 
select a default 
output directory 

Enter a default 
file name suffix here
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4. Click the Open icon  in the Viewer you just created.

The Select Layer To Add: dialog opens.

5. Click the Raster Options tab at the top of the Select Layer To Add: 
dialog.

6. Select the Background Transparent option.

7. Click the File tab at the top of the Select Layer To Add: dialog.

8. In the Select Layer To Add: dialog under Filename, select the output 
images from the directory in which you saved them.

9. Click OK in the Select Layer To Add dialog.

The edge matched output images display in the viewer.

Use the Viewer Swipe Tool

1. To perform visual verification using the Viewer Swipe tool, select 
Utility -> Swipe... from the Viewer menu bar.

2. The Viewer Swipe dialog opens.
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3. Check Auto Mode in the Viewer Swipe dialog, and type 500 for the 
Speed. You can watch as the swipe tool slowly works its way over 
the images allowing you to evaluate the quality. Experiment with 
both Vertical and Horizontal direction and different speeds.

View Summary Report Once you have finished edge matching the images, you can view the 
HTML summary report to review information about the error, tie 
points, etc. 

1. In a Windows Explorer window, browse to the directory where you 
saved the HTML report (in the Output tab).

2. Click to open the HTML file.

The summary report opens in a browser window.

You can experiment with selecting different options in the Edge 
Matching wizard tabs to produce different results. For example, 
in the Edge Match Strategy tab, select to apply refinement to the 
Whole Image (instead of the Overlapping Area Only) or 
change the Buffer Around the Overlapping Area (pixels) 
number to see the differences in the resulting output images.

Using the 
IMAGINE 
AutoSync 
Workstation

In this tour guide, you use the georeference workflow in the 
IMAGINE AutoSync Workstation to georeference a raw Landsat TM 
image of Atlanta, Georgia, using a SPOT panchromatic image of the 
same area. The raw Landsat TM image does not have any map 
information and the SPOT image is rectified to the State Plane map 
projection.

Use the slide to swipe 
   over the images

Use Auto Mode and 
   Speed to watch the
images being swiped
at a rate you choose

Choose either 
   Vertical or Horizontal
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This tour guide explains the steps for using the georeference 
workflow in the workstation to georeference a raw image (an 
image without any map information). When georeferencing a 
rectified image, you do not need to manually collect tie points 
before running APM.

To georeference a raw image in the IMAGINE AutoSync Workstation, 
follow these basic steps:

• create a new IMAGINE AutoSync project

• add an input image

• add an image to reference against the input image

• collect manual tie points 

• run APM

• preview the output image

• improve output image results (if necessary)

• review the input and reference image map data information

• set the output image projection

• resample or calibrate the output image

• verify the rectification process 

• view the summary report

Create New IMAGINE 
AutoSync Project

First, create a new IMAGINE AutoSync project.

You must have ERDAS IMAGINE running.

1. Click the AutoSync icon on the ERDAS IMAGINE icon panel.

The AutoSync menu opens.

Click here to start
the IMAGINE AutoSync 
Workstation
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2. Select AutoSync Workstation... from the AutoSync menu.

The IMAGINE AutoSync Workstation Startup dialog opens.

3. On the IMAGINE AutoSync Workstation Startup dialog, select Create 
a new project.

4. Click OK.

The Create New Project dialog opens.

5. On the Create New Project dialog, select the Georeference 
workflow.

6. In the Project File (*.lap) field, click the File Selector icon  or 
enter a project file name of your choice.

7. On the Create New Project dialog, select the Resample 
geocorrection method.

8. Click the Resample Settings... button.

Click here to create
a new IMAGINE 
AutoSync project

Click here to select the
georeference workflow

Enter a project 
name here

Enter a summary report
name here

Click here to select the
Resample geocorrection
method

Click to open the
Resample
Settings dialog
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The Resample Settings dialog opens.

9. In this tour guide, accept the default settings in the Resample 
Settings dialog. Make sure the Cubic Convolution resample 
method is selected. 

IMAGINE AutoSync provides these widely-known resampling 
algorithms: Nearest Neighbor, Bilinear Interpolation, Cubic 
Convolution, and Bicubic Spline. In some cases you may want to 
change the Resample Method, but for this tour guide, leave it 
set to Cubic Convolution.

10. Click OK in the Resample Settings dialog.

11. In the Create New Project dialog, in the Default Output Directory: 

(*) field, click the File Selector icon  to select a default output 
directory of your choice.

12. In the Default Output File Name Suffix field, enter a default file 
name suffix of your choice, or keep the default _output.

13. In the Create New Project dialog, make sure the Generate 
Summary Report checkbox is selected. The name of the project in 
the Project File field defaults as the summary report name, but you 

can also click the File Selector icon  to select a different name 
and directory of your choice.

14. Click the OK button.

Make sure 
 
 
is selectedClick to accept 

the default
resample settings

Cubic
Convolution
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Add Input Image After you have created the IMAGINE AutoSync project, the next step 
is to add the input image you want to georeference.

1. To add an input image to the project, do one of the following:

• In the IMAGINE AutoSync toolbar, click the Open Input Images 

icon 

• Select File -> Add Images -> Input Images... from the menu 
bar

• Right-click on the Input Images folder in the Project Explorer 
Tree View and select Add Input Image... 

The Select Images To Open dialog opens. 

Status bar

CellArray

GCP toolbar

Viewer panes

Project Explorer

IMAGINE AutoSync 

Menu bar

toolbar
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2. In the Select Images To Open dialog under Filename, click the file 
tmAtlanta.img.

This file is a Landsat TM image of Atlanta that has not been rectified.

3. Click OK in the Select Images To Open dialog.

The input image tmAtlanta.img displays in the IMAGINE AutoSync 
Workstation.

Click here 
to select
the file

Click here 
to add the file

Preview 
window
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Add Reference Image After you have added an input image, the next step is to add an 
image to reference against the input image.

1. To add a reference image to the project, do one of the following:

• In the IMAGINE AutoSync toolbar, click the Open Reference 

Images icon 

• Select File -> Add Images -> Set Reference Image... from 
the menu bar

• Right-click on the Reference Image folder in the Project Explorer 
Tree View and select Set Reference Image... 

The Select Images To Open dialog opens.

The input file
displays in the 
Project Explorer
and left viewer
panes
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2. In the Select Images To Open dialog under Filename, click the file 
panAtlanta.img.

This file is a SPOT panchromatic image of Atlanta. This image has 
been georeferenced to the State Plane map projection.

3. Click OK in the Select Images To Open dialog.

The reference image panAtlanta.img displays in the IMAGINE 
AutoSync Workstation.

Click here 
to select
the file

Click here 
to add the file

Preview 
window
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Collect Manual Tie Points Once you have loaded the input and reference images in the 
IMAGINE AutoSync Workstation, you can manually collect tie points.

This step is necessary in this tour guide because the input image 
(tmAtlanta.img) is a raw image (without any map 
information). When using the IMAGINE AutoSync Workstation to 
georeference images with map information, you do not need to 
manually collect tie points before running APM and you can skip 
this step.

1. In the GCP toolbar, click the Create GCP icon  .

The reference 
file displays in the 
Project Explorer
and right viewer
panes
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2. In the GCP toolbar, click the Show Selected Points icon  .

3. To make the input image tie points easier to see in the viewer om 
the left, right-click in the Color column to the right of Point ID in 
the first row of the CellArray and select the color Yellow. Repeat this 
for each tie point in the CellArray.

4. To make the reference image tie points easier to see in the viewer 
on the right, right-click in the Color column to the right of Y Input 
in the first row of the CellArray and select the color Yellow. Repeat 
this for each tie point in the CellArray.

5. In the Main View pane of the input image, click a location to collect 
a tie point.

The point you have created is labeled as 1 in the Main View pane and 
its X and Y inputs are listed in the CellArray. Also notice that the input 
image icon in the Project Tree View now has a green border since it 
now has tie points.

6. In the Main View pane of the reference image, click the same location 
to collect a tie point.

Click to 
  collect tie points

Click to show tie points
  in the viewer panes

Click to change the 
  tie point color to yellow
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7. Collect at least three manual tie points in both the input and 
reference images.

You should choose points that are easily identifiable in both 
images, such as road intersections and landmarks, so that the 
images match properly. Also, make sure you scatter your tie 
points around the images so they are not all concentrated in one 
place. Try to collect tie points that are close to each of the four 
corners of the images.

Your project in the IMAGINE AutoSync Workstation should now look 
similar to the following:

Click to create
  tie points on both the
input and reference
images

These are the X and Y
  map coordinates for 
tie points in the input image
(tmAtlanta.img)

These are the X and Y
  map coordinates for 
tie points in the reference
image (panAtlanta.img)
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Run APM After collecting several tie points in the input and reference image, 
the next step is to run automatic point matching (APM) to 
automatically generate more control points for your images. 

1. In the IMAGINE AutoSync toolbar, do one of the following to run 
APM:

• In the IMAGINE AutoSync toolbar, click the Run APM icon  

• Select Process -> Run APM from the menu bar

• Right-click on the input image (tmAtlanta.img) in the Project 
Explorer Tree View and select Run APM 

The Status bar at the bottom of the workstation displays the RMSE 
and Error Standard Deviation results. The APM points generated 
populate the CellArray and display in the viewers for both the input 
and reference images.
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Preview Output Image After you run APM, you can preview the output image to make sure 
you are satisfied with the results before resampling or calibrating.

1. To preview the output image, right-click on the input image 
(tmAtlanta.img) in the Project Explorer Tree View and select 
Preview Output.

The output image displays in the viewer.

The APM points
  display in the viewers
and populate the 
CellArray

The Status bar displays
  
standard deviation
the RMSE and error

results
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Improve Output Image 
Results 

If you preview the output results and the image is warped, shows 
black images, or produces other unacceptable output, it is most 
likely the result of incorrect APM tie points or an inappropriate sensor 
model. In this tour guide, if you are dissatisfied with the results, 
there are most likely incorrect tie points that you should delete 
before resampling. If the Error Std. Dev. is higher than 2.0, you 
should also follow these steps to improve the tie points. If you delete 
incorrect APM points and the results are still poor, then you should 
try changing the sensor model in the IMAGINE AutoSync Project 
Properties dialog.

To learn more about improving APM results, see the IMAGINE 
AutoSync white paper on the IMAGINE AutoSync product page 
at http://gi.leica-geosystems.com/products/.

1. Right-click on the input image (tmAtlanta.img) in the Project 
Explorer Tree View and select Review Points.

The input and reference images display in the viewer panes, showing 
the tie points.
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2. In the GCP toolbar, enter or use the nudgers to the right of the field 
to select 2 in the error threshold text box. 

3. In the GCP toolbar, click the Select GCPs with Error Threshold icon 

 . 

The tie points with an error higher than 2 are highlighted in the 
CellArray.

Enter 2 for the error
  
 
threshold search
criteria

Click to select tie
  
 
points with an error 
threshold of 2 in the 
CellArray
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4. Click the Drive To icon  to click through the selected points in the 
CellArray.

As you click through the points, the points in the viewers will be 
highlighted with a box.

5. When you find a point with a high error, click the Delete GCP  
icon.

The selected point is deleted from the viewers and the CellArray.

6. After you delete all the points with a high error, right-click on the 
input image (tmAtlanta.img) in the Project Explorer Tree View and 
select Preview Output.

Review Image Map Data The next step is to review the image map data for the input and 
reference image. You can review the map data to learn about the 
map and projection information in order to determine if you want the 
output image to have the same projection as the reference image.

1. Click on the reference image in the Main View pane or in the Project 
Explorer Tree View to select it.

Click here to drive through
  
 
the selected points in 
the CellArray
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2. On the IMAGINE AutoSync toolbar, click the ImageInfo icon  . 

The ImageInfo dialog for panAtlanta.img opens.

Click to select 
 

Click to open the 
 ImageInfo dialog

panAtlanta.img
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Note the information in the Map Info section and that the 
Projection Info section shows that the map is georeferenced to 
State Plane.

3. When you are finished, select File -> Close in the ImageInfo dialog.

4. Click on the input image in the Main View pane or in the Project 
Explorer Tree View to select it.

Note map and 
 projection 
information
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5. On the IMAGINE AutoSync toolbar, click the ImageInfo icon  . 

6. The ImageInfo dialog for tmAtlanta.img opens.

Click to select 
 

Click to open the 
 ImageInfo dialog

tmAtlanta.img
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Note the information in the Map Info section and that the 
Projection Info section shows that this is a raw image with no 
projection information. Therefore, for this tour guide, use the input 
projection from the reference image (panAtlanta.img) for the 
output image.

Set Output Image 
Projection

Since the image to be georeferenced is a raw image with no 
projection information, you need to change the project properties to 
set the output projection before resampling or calibrating the image.

1. To change the output projection, do one of the following:

• Select Process -> Project Properties... from the menu bar

• In the IMAGINE AutoSync toolbar, click the Edit Project 

Properties icon  

The IMAGINE AutoSync Project Properties dialog opens.

2. Click the Projection tab.

The Projection tab opens in the IMAGINE AutoSync Project Properties 
dialog.

3. In the Output Projection section, select Same as Reference 
Image. 

The projection information from the reference image displays 
(greyed out).

Note map and 
 projection 
information
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4. Click the OK button to close the IMAGINE AutoSync Project 
Properties dialog.

Resample Output Image Resampling is the process of calculating the file values for the 
rectified image and creating the output file. All of the raster data 
layers in the source file are resampled. The output image will have 
as many layers as the input image.

1. To resample the output image, do one of the following:

• Select Process -> Calibrate/Resample from the menu bar 

• Right-click on the input image (tmAtlanta.img) in the Project 
Explorer Tree View and select Calibrate/Resample

You can change the resample settings in the Output tab in the 
IMAGINE AutoSync Project Properties dialog. You may want to 
experiment with changing the resample settings later, but this 
tour guide uses the default settings.

The resampled output image (tmAtlanta_output.img) displays in 
the workstation viewer and the output image name now displays in 
the Output Images folder in the Project Explorer. Your project in the 
IMAGINE AutoSync Workstation should now look similar to the 
following:

Click here to use the
  same projection
as the reference
image

The reference
  image projection
info displays here



Using the IMAGINE AutoSync WorkstationERDAS IMAGINE Tour Guides

Verify Output Image Once the output image is created, you can use the workstation to 
perform the output image verification. You can verify that the input 
image (tmAtlanta.img) has been correctly georeferenced to the 
reference image (panAtlanta.img) by visually checking that they 
conform to each other using the Viewer Blend/Fade, Viewer Swipe, 
or Viewer Flicker verification tools.

Use the Viewer Blend/Fade Tool

1. To perform visual verification using the Viewer Blend/Fade tool, click 

the Start Blend Tool icon  on the IMAGINE AutoSync toolbar.

The Viewer Blend/Fade dialog opens.

The resampled
   output image
displays in the viewer
and Project Tree View
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2. Select Auto Mode in the Viewer Blend/Fade dialog, and type 500 for 
the Speed. You can watch as the tool slowly blends the images, 
allowing you to evaluate the quality. Experiment with both different 
speeds or use the slide to blend and fade the images.

Use the Viewer Swipe Tool

1. To perform visual verification using the Viewer Swipe tool, click the 

Start Swipe Tool icon  on the IMAGINE AutoSync toolbar.

The Viewer Swipe dialog opens.

2. Check Auto Mode in the Viewer Swipe dialog, and type 500 for the 
Speed. You can watch as the swipe tool slowly works its way over 
the images allowing you to evaluate the quality. Experiment with 
both Vertical and Horizontal direction and different speeds.

Use the slide to blend 
   and fade the images

Use Auto Mode and 
   Speed to watch the
images being blended
together at a rate you 
choose

Use the slide to swipe 
   over the images

Use Auto Mode and 
   Speed to watch the
images being swiped
at a rate you choose

Choose either 
   Vertical or Horizontal
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Use the Viewer Flicker Tool

1. To perform visual verification using the Viewer Flicker tool, click the 

Start Flicker Tool icon  on the IMAGINE AutoSync toolbar.

The Viewer Flicker dialog opens.

2. Check Auto Mode in the Viewer Flicker dialog, and type 500 for the 
Speed. You can watch as the flicker tool switches between the top 
and bottom images, allowing you to evaluate the quality. You can 
also click Manual Flicker to quickly switch between the images. 
Experiment with different speeds.

View Summary Report You can view the summary HTML report for more information.review 
information about the error, tie points, etc. 

1. To view the summary report, do one of the following:

• In the GCP toolbar, click the Summary Report icon  

• Right-click on input image (tmAtlanta.img) in the Project 
Explorer Tree View and select Review Report.

• Open a Windows Explorer window, browse to the directory where 
you saved the HTML report (in the Create New Project dialog) and 
open the .html file

The summary report opens in a separate browser window.

Click to quickly switch
   between the images

Use Auto Mode and 
   Speed to watch the
images switch from 
top to bottom at a rate 
you choose



 / 665ERDAS IMAGINE Tour Guides

IMAGINE Radar Interpreter™
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IMAGINE Radar Interpreter™

Introduction Building a model, creating a map, or rectifying an image requires 
certain steps, regardless of the data you are using. However, 
processing radar data is application-driven, so there is no preset 
path to follow. Therefore, this tour guide shows you how the 
functions work, but you have to experiment on your own data files 
for your own applications. 

The default settings in the IMAGINE Radar Interpreter module 
dialogs provide acceptable results. However, we recommend that 
you experiment with the settings to obtain the best results.

NOTE: The data used in this tour guide are in the 
<IMAGINE_HOME>/examples directory. Replace <IMAGINE_HOME> 
with the name of the directory where ERDAS IMAGINE is installed on 
your system.

Although you can use the IMAGINE Radar Interpreter functions 
in any order, we recommend that you follow this tour guide in 
the order that it is presented. It is important to address speckle 
noise before any other processing.

See the chapter “Enhancement” in the ERDAS Field Guide for 
more theoretical information about using the Radar module.

You can find more information about radar applications in 
ERDAS IMAGINE in the IMAGINE Radar Mapping Suite User’s 
Guide.

The IMAGINE Radar Interpreter is part of the IMAGINE Radar 
Mapping Suite™, which also includes IMAGINE OrthoRadar™, 
IMAGINE StereoSAR DEM™, IMAGINE IFSAR DEM™, and the 
Generic SAR Node.

Approximate completion time for this tour guide is 45 minutes.
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Suppress Speckle 
Noise

In this section, you display two images—one that has been 
despeckled, and one raw radar image. The objective is to make the 
two images look alike by using the Speckle Suppression function. 

With all speckle suppression filters there is a trade-off between noise 
reduction and loss of resolution. Each data set and each application 
has a different acceptable balance between these two factors. The 
IMAGINE Radar Interpreter module Speckle Suppression filters have 
been designed to be versatile and gentle in reducing noise (and 
resolution). 

In this section, you also calculate the coefficient of variation for an 
image. This variable is required to fine-tune many Speckle 
Suppression filters. 

When processing radar imagery, it is very important to use the 
Speckle Suppression functions before other image processing 
functions to avoid incorporating speckle into the image.

Preparation

ERDAS IMAGINE should be running and a Viewer should be open.

1. In the Viewer menu bar, select File -> Open -> Raster Layer or 

click the Open icon  in the toolbar. 

The Select Layer To Add dialog opens.

2. In the Select Layer To Add dialog under File name, click 
loplakebed.img. 

3. Click OK in the Select Layer To Add dialog. 

The loplakebed.img file displays in the Viewer. 

Click here to 
select the file 

A preview of 
the image 
displays here 

Click here to 
display the file 

Click here to 
change the directory
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This image is a subset from imagery taken by the Shuttle Imaging 
Radar (SIR-A) experiment. It is L-band with 25 m pixels. This scene 
is the shore of Lop Nor Lake in the Xinjiang Province, Peoples’ 
Republic of China. This is an area of desiccated overflow basins 
surrounded by a series of parallel, wind-scoured, sedimentary 
ridges. The speckle in this image is obvious.

4. In the ERDAS IMAGINE icon panel, click the Viewer icon to open 
another Viewer.

5. From the ERDAS IMAGINE menu bar, select Session -> Tile 
Viewers to position and size the Viewers so that you can see the 
side-by-side Viewers on the screen. 

This helps you to view and evaluate the resultant image after each 
filter pass, and then decide if another pass is needed to obtain the 
desired results. 

6. Click the Radar icon  on the ERDAS IMAGINE icon panel.

The Radar menu opens.
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7. In the Radar menu, click Radar Interpreter.

The Radar Interpreter menu opens.

8. In the Radar Interpreter menu, select Speckle Suppression.

The Radar Speckle Suppression dialog opens.

9. In the Radar Speckle Suppression dialog under Input File, enter the 
file loplakebed.img.

Calculate Coefficient of 
Variation

Next, you calculate the coefficient of variation to be used in this 
function. 

Click Radar 
Interpreter

Select Speckle 
Suppression

Enter window
size here
(windows are
always square)

Click here 
to calculate the
Coefficient of
Variation

Enter the 
name of the 
input file here 
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1. In the Radar Speckle Suppression dialog, click the checkbox for 
Calculate Coefficient of Variation. 

All the other options in the dialog are disabled, except for the Subset 
Definition and Moving Window. If desired, you could specify a 
subset area of the image for which to calculate the coefficient of 
variation.

2. Under Moving Windows, confirm that the Window Size is set to 3. 

3. Click OK in the Radar Speckle Suppression dialog. 

The Radar Speckle Suppression dialog closes and a Job Status dialog 
displays, indicating the progress of the function. 

4. When the Job Status dialog indicates that the job is 100% complete, 
click OK (if the dialog does not close automatically).

Coefficient of Variation
The coefficient of variation, as a scene-derived parameter, is a 
necessary input parameter for many of the filters. (It is also useful 
in evaluating and modifying VIS/IR data for input to a 4-band 
composite image or in preparing a 3-band ratio color composite.) 

Speckle in imaging radar can be mathematically modeled as 
multiplicative noise with a mean of 1. The standard deviation of 
the noise can be mathematically defined as:

Standard Deviation of the noise =>  = Coefficient of 

Variation

It is assumed that imaging radar speckle noise follows a Rayleigh 
distribution. This yields a theoretical value for standard deviation 
(SD) of .52 for 1-look radar data and SD = .26 for 4-look radar 
data.

The following table gives theoretical coefficient of variation values 
for various look-averaged radar scenes.

Table 1: Coefficient of Variation Values for Look-averaged 
Radar Scenes

Number of 
Looks 

(scenes)

Coefficient of 
Variation 

Value

1 .52

2 .37

3 .30

4 .26

6 .21

8 .18

VARIANCE
MEAN

-------------------------------------
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Depending on your eml Preferences (under Session -> 
Preferences -> User Interface & Session -> Keep Job 
Status Box), when the Job Status bar shows 100 (indicating 
that the job is 100% done), you must either click OK to close 
the dialog or the dialog closes automatically.

5. If it is not already displayed, open the Session Log by selecting 
Session -> Session Log from the ERDAS IMAGINE menu bar. 

The calculated coefficient of variation is reported in the Session 
Log, as shown in the following example.

When using the filters in the Speckle Suppression function, you 
should calculate the coefficient of variation for the input image and 
use a number close to the calculated coefficient of variation for 
optimum results.

6. Click Close in the Session Log.

Run Speckle Suppression 
Function

1. In the Radar Interpreter menu, select Speckle Suppression.

The Radar Speckle Suppression dialog opens. 

2. Under Input File, enter the file name loplakebed.img.

3. Under Output File, enter despeckle1.img in the directory of your 
choice. 

NOTE: Be sure to remember the directory where you have saved the 
output file. This is important when you display the output file in a 
Viewer.

4. Under Coef. of Var. Multiplier (under Output Options), click 0.5. 

5. Under Output Options, confirm Lee-Sigma is selected from the 
dropdown list next to Filter.

6. Under Output Options, enter .275 for the Coef. of Variation 
(coefficient of variation), then press Enter on your keyboard.

This is the value (.275) that was reported in the Session Log when 
you calculated the coefficient of variation. 

7. Click OK in the Radar Speckle Suppression dialog. 

Calculated 
Coefficient of 
Variation is 
reported here
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The Radar Speckle Suppression dialog closes and a Job Status dialog 
displays, indicating the progress of the function.

8. When the Job Status dialog indicates that the job is 100% complete, 
click OK (if the dialog does not close automatically).

View Results

1. In the menu bar of Viewer #2, select File -> Open -> Raster 

Layer or click the Open icon  on the toolbar. 

The Select Layer To Add dialog opens.

2. In the Select Layer To Add dialog, select despeckle1.img as the file 
to open and click OK. 

3. Repeat step 1 through step 7 under “Run Speckle Suppression 
Function” to apply the Speckle Suppression function iteratively to the 
output images, using the following parameters for passes 2 and 3. 

You MUST enter a new output file name each time you run a 
speckle suppression filter. In this exercise, name each pass 
sequentially (for example, despeckle1.img, despeckle2.img, 
despeckle3.img, etc.). 

Table 2: Speckle Suppression Parameters

Pass Input file Output file Coef. 
of Var.

Coef. of 
Var. 

Multiplier

Window 
Size

1 loplakebed.img despeckle1.img 0.275 0.5 3 × 3

2 despeckle1.img despeckle2.img 0.195 1 5 × 5

3 despeckle2.img despeckle3.img 0.103 2 7 × 7
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Use Histograms to 
Evaluate Images

Next, the ImageInfo method of histogram display is explained.

1. Select Tools -> Image Information from the ERDAS IMAGINE 
menu bar.

The ImageInfo dialog opens.

2. Select File -> Open from the ImageInfo menu bar to select a file. 

You can also click the Open icon  in the ImageInfo toolbar to 
select a file.

3. In the Image Files dialog, click loplakebed.img to select it and then 
click OK.

The information for loplakebed.img displays in the ImageInfo 
dialog.

Speckle Suppression Filters
The Speckle Suppression filters can be used repeatedly in as many 
passes as needed.

Similarly, there is no reason why successive passes must be done 
with the same filter. 

The following filtering sequence might be useful prior to a 
classification. 

Table 3: Filtering Sequence

Filter Pass Sigma 
Value Sigma Multiplier Window

Lee 1 0.26 NA 3 × 3

Lee 2 0.22 NA 5 × 5

Local 
Region

3 NA NA 7 × 7 or 9 × 9

Histograms
Viewing the histograms of an image is often helpful in 
determining: the need for filtering, the type of filter to use, and the 
results of filtering.

You can see a histogram of an image through:

• Tools -> Image Information -> View -> Histogram from 
the ERDAS IMAGINE menu bar

• Utility -> Layer Info -> View -> Histogram from the 
Viewer menu bar 
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4. In the ImageInfo dialog, select View -> Histogram, or click the 

Histogram icon  .

The histogram for loplakebed.img displays. 

5. Select File -> New from the ImageInfo dialog menu bar to open 
another ImageInfo dialog.

A second ImageInfo dialog opens.

6. Click the Open icon  in the new ImageInfo dialog.

7. In the Open File dialog, select despeckle1.img from the directory 
in which you saved it and then click OK. 

Menu bar

Toolbar

Status bar

The presence of spikes
indicates the need for
speckle reduction
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The information for despeckle1.img displays in the ImageInfo 
dialog.

8. In the ImageInfo dialog, click the Histogram icon.

The histogram for despeckle1.img displays. 

9. Repeat step 5 through step 8 of “Use Histograms to Evaluate 
Images” to view the subsequent passes of speckle reduction 
performed (despeckle2.img, despeckle3.img).

10. When finished, click Close in the Histogram viewers.

11. Select File -> Close from the ImageInfo dialogs.

12. Select File -> Clear in both Viewers.

Enhance Edges In this exercise, you create two images—one that is processed from 
the original image with the Edge Enhancement function, and one 
that is processed from the final result of the Speckle Suppression 
exercise. The objective is to demonstrate the effectiveness of 
Speckle Suppression prior to Edge Enhancement. 

The Edge Enhancement functions in the IMAGINE Radar Interpreter 
module are similar to the Convolution and Neighborhood options in 
Image Interpreter. 

NOTE: You can use the Edge Enhancement functions on any type of 
image—not just radar data.

1. From the Radar Interpreter menu, select Edge Enhancement. 

The Edge Enhancement dialog opens.

After one pass, the 
spikes have been
reduced. Also note
the separation of two
distinct classes in
the data.
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2. In the Edge Enhancement dialog under Input File, enter 
loplakebed.img.

3. Under Output File, enter edgeuf.img in the directory of your 
choice.

4. Under Output Options, click the Filter dropdown list and select 
Prewitt Gradient.

5. Click OK in the Edge Enhancement dialog. 

The Edge Enhancement dialog closes and a Job Status dialog 
displays, indicating the progress of the function. 

6. Repeat step 1 through step 5, using despeckle3.img as the Input 
File and edgess.img as the Output File.

View Results

1. In Viewer #1, select File -> Open -> Raster Layer.

The Select Layer To Add dialog opens.

2. In the Select Layer To Add dialog, click the file edgeuf.img, then 
click OK.

This is the edge-filtered file derived from the unfiltered radar image 
file.

Select input and 
output files here 

Select filter here 
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3. If necessary, start another Viewer. In Viewer #2, select File -> 
Open -> Raster Layer.

4. In the Select Layer To Add dialog, click the file edgess.img, then 
click OK.

This is the edge filtered file derived from the speckle-suppressed file.
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5. In the ERDAS IMAGINE menu bar, select Session -> Tile Viewers 
to position and size the Viewers so that you can see both of them at 
once on the screen. 

The results should clearly show a more visible lake bed in the image 
that was speckle filtered (edgess.img). As an experiment, you may 
now want to take the unfiltered, edge-enhanced image 
(edgeuf.img) and pass it through the same Speckle Suppression 
process done previously. Comparing the result of this experiment 
with edgess.img should show whether it is better to perform 
speckle suppression before or after edge enhancement. 

You can experiment with other edge enhancement filters or proceed 
to the next section.

6. When you are finished comparing the images, select File -> Clear 
in Viewer #1 and Viewer #2.

Enhance Image The IMAGINE Radar Interpreter module provides three image 
enhancement categories:

• Wallis Adaptive Filter

• luminance modification
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• sensor merge

Wallis Adaptive Filter Make sure the IMAGINE Radar Interpreter module is running, and 
display the file radar_glacier.img in a Viewer.

Wallis Adaptive Filter

The Wallis adaptive filter is designed to adjust the contrast stretch 
of an image using only the values within a local region (defined by 
the window size), which makes it widely applicable. Three possible 
implementations of this technique are provided: Bandwise, IHS, 
and PC.

• In the Bandwise operation, the adaptive filter is passed over 
each band sequentially.

• In the IHS implementation, the input RGB image is 
transformed into IHS space. The adaptive filter is only passed 
over the intensity (I) component. The image is then 
transformed back into RGB.

• In the PC implementation, the input bands are transformed 
into principal components. The filter is only passed over PC-1. 
An inverse principal component transform is then performed.

In this section, you apply the Wallis adaptive filter function to an 
image and observe the results.
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1. In the Radar Interpreter menu, select Speckle Suppression.

The Radar Speckle Suppression dialog opens.

2. In the Radar Speckle Suppression dialog, enter radar_glacier.img 
as the Input File.

3. Type in despeckle4.img (in the directory of your choice) as the 
Output File.

4. Select Gamma-MAP from the Filter dropdown list.

5. Click OK in the Radar Speckle Suppression dialog to filter the image.

The Radar Speckle Suppression dialog closes and a Job Status dialog 
displays, indicating the progress of the function.

6. Click OK in the Job Status dialog when the process is complete.

7. Select Image Enhancement from the Radar Interpreter menu.

The Image Enhancement menu opens.
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8. Click Wallis Adaptive Filter in the Image Enhancement menu.

The Wallis Adaptive Filter dialog opens.

9. In the Wallis Adaptive Filter dialog under Input File, enter the file 
despeckle4.img. 

10. Under Output File, enter the name enhanced.img in the directory 
of your choice. 

11. Under Data Type, click Stretch to Unsigned 8 Bit.

12. Under Moving Window, confirm that the Window Size is set to 3. 

Rough images usually require smaller window sizes (3 × 3), whereas 
smooth, or cleaner, images can tolerate larger window sizes.

13. Set the Multiplier to 3.00.

14. Click OK in the Wallis Adaptive Filter dialog. 

The Wallis Adaptive Filter dialog closes and a Job Status dialog 
displays, indicating the progress of the function.

15. When the Job Status dialog indicates that the job is 100% complete, 
click OK (if the dialog does not close automatically).

Click Wallis 
Adaptive Filter

Enter the 
name of the 
input file here 

Click this 

Enter contrast 
multiplier here 

Enter the 
name of the 
output file here 

Set window 
size here 

checkbox
to activate
this option
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View Results

1. In the menu bar of Viewer #2, select File -> Open -> Raster 
Layer.

The Select Layer To Add dialog opens.

2. In the Select Layer To Add dialog, select the file enhanced.img and 
then click OK. 

3. Examine the differences between the two files.

4. When you are finished comparing the images, select File -> Clear 
in Viewer #1 and Viewer #2.

Apply Sensor Merge Next, you apply the Sensor Merge function to an image and 
observe the results.
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This package of algorithms enables you to combine imagery from 
different sensors. Examples of this would be radar with TM imagery 
or multifrequency radar with aeromagnetic data. Three different 
families of techniques are available: Principal Component, IHS, and 
Multiplicative (these are similar to those in the Wallis Adaptive Filter 
option).

1. If it is not already open, open the Image Enhancement menu by 
selecting Image Enhancement from the Radar Interpreter 
menu.

2. In the Image Enhancement menu, select Sensor Merge.

The Sensor Merge dialog opens.

Principal Component
In using the Principal Component techniques, you have the 
option to modify the grayscale image in any of the following ways.

• Remap—rescales the grayscale image to the range of PC-1.

• Hist. Match—matches the histogram of the grayscale image 
to PC-1.

• Multiply—rescales the grayscale image into the 0-1 range and 
then multiplies the grayscale by PC-1.

• None—replaces PC-1 with the input grayscale image.

IHS
Using the IHS family, two options exist.

• Intensity—rescales the grayscale image to the numerical 
range of the intensity (I) and then substitutes it for I.

• Saturation—rescales the grayscale image to the numerical 
range of saturation (S) and then substitutes it for S.

Multiplicative
The Multiplicative technique remaps the grayscale image to a 0-
1 range. Each band is then sequentially multiplied by the 
remapped grayscale image.
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3. In the Sensor Merge dialog under Gray Scale Image, select 
flood_tm147_radar.img from the <IMAGINE_HOME>\examples 
directory.

4. Click the Select Layer dropdown list and select 4 (the radar image 
layer).

5. Enter flood_tm147_radar.img under Multispectral Image.

6. Enter merge.img as the Output File (in the directory of your 
choice).

7. Under Method, click IHS.

8. Under Resampling Techniques, click Nearest Neighbor.

9. Make sure that Intensity is selected under IHS Substitution.

10. In the R, G, and B boxes, enter 1 for R, 2 for G, and 3 for B (the TM 
image layers).

11. Under Output Options, click Stretch to Unsigned 8 bit.

12. Click OK in the Sensor Merge dialog.

The Sensor Merge dialog closes and a Job Status dialog displays, 
indicating the progress of the function.

13. When the Job Status dialog indicates that the job is 100% complete, 
click OK (if the dialog does not close automatically).

View Results

1. In the menu bar of Viewer #1, select File -> Open -> Raster 
Layer.

Click this 
dropdown list to 
select the 
radar image 
layer 

Enter the 
name of the 
output file 
here 

Select IHS for 
the method 

Select Nearest 
Neighbor as 
the resampling 
technique 

Enter the 
appropriate 
layers to 
colors here 

Click this
checkbox 
to activate 
this option 



Enhance Image / 686ERDAS IMAGINE Tour Guides

The Select Layer To Add dialog opens.

2. In the Select Layer To Add dialog, click the file 
flood_tm147_radar.img.

3. Click the Raster Options tab at the top of the Select Layer To Add 
dialog.

4. Under Layers to Colors, select 1 for Red, 2 for Green, and 3 for 
Blue.

5. Click OK in the Select Layer To Add dialog.

6. In Viewer #2, select File -> Open -> Raster Layer.

The Select Layer To Add dialog opens.

7. In the Select Layer To Add dialog, click the file merge.img. 

8. Click the Raster Options tab at the top of the Select Layer To Add 
dialog.
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9. Under Layers to Colors, select 1 for Red, 2 for Green, and 3 for 
Blue.

10. Click OK.

11. Examine the difference between the two files.

12. When you are finished comparing the images, select File -> Clear 
in Viewer #1 and Viewer #2.

13. Click Close in the Image Enhancement menu.

Apply Texture Analysis Next, apply the Texture Analysis function to an image and observe 
the results.

The radar data’s sensitivity to texture is an advantage over other 
types of imagery where texture is not a quantitative characteristic. 

NOTE: Texture analysis has been shown to be useful for geologic 
discrimination and vegetation classification.
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1. From the Radar Interpreter menu, select Texture Analysis.

The Texture Analysis dialog opens.

2. In the Texture Analysis dialog, enter flevolandradar.img, which is 
located in the <IMAGINE_HOME>\examples directory, as the Input 
File.

3. Enter texture.img (in the directory of your choice) as the Output 
File.

4. Click the Operators dropdown list and select Skewness.

5. Under Moving Window, enter a Window Size of 5.

6. Click OK in the Texture Analysis dialog. 

The Texture Analysis dialog closes and a Job Status dialog displays, 
indicating the progress of the function. 

7. When the Job Status dialog indicates that the job is 100% complete, 
click OK (if the dialog does not close automatically).

View Results

1. In the menu bar of Viewer #1, select File -> Open -> Raster 
Layer.

2. In the Select Layer To Add dialog, click the file flevolandradar.img. 
This is an agricultural subscene from Flevoland, Holland. This image 
is from the ERS-1 satellite in C-band with 20-meter pixels.

3. Click OK in the Select Layer To Add dialog.

Enter window
size here

Enter the 
output file 
name here 

Enter the 
input file 
name here 

Select operator 
to use by 
clicking here
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4. In Viewer #2, select File -> Open -> Raster Layer.

5. In the Select Layer To Add dialog, click the file texture.img. then 
click OK.
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6. Examine the difference between the two files.

7. When you are finished comparing the images, select File -> Clear 
in Viewer #1 and Viewer #2.

Adjust Brightness The Brightness Adjustment function works by adjusting pixel DN 
values so that each line of constant range has the same average. In 
this way, the image is adjusted to have an overall, even brightness. 
Therefore, you must tell ERDAS IMAGINE whether the lines of 
constant range are stored in rows or columns. This depends on the 
flight path of the sensor and the output raster it produces.

1. Select Adjust Brightness from the Radar Interpreter menu. 

The Brightness Adjustment dialog opens.
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2. In the Adjust Brightness dialog under Input File, enter the name of 
the input file, flevolandradar.img, which is located in the 
<IMAGINE_HOME>\examples directory.

3. Under Output File, enter the name of the output file, bright.img, 
in the directory of your choice. 

4. Under Subset Definition, select a subset of the file if you want to 
apply the function to a portion of the image rather than the entire 
image.

5. Select the Data Type under Output file. The default is Float 
Single, which is recommended to save disk space.

6. Under Apply to in the Output Options, select Column.

You can often tell whether the data are stored in rows or columns by 
looking at the image header data or by consulting documentation 
supplied with the data.

Use the Data View option from the Import/Export dialog or 
Tools -> View Binary Data from the ERDAS IMAGINE menu 
bar to read the image header data.

7. Click OK in the Adjust Brightness dialog. 

The Adjust Brightness dialog closes and a Job Status dialog displays, 
indicating the progress of the function. 

8. When the Job Status dialog indicates that the job is 100% complete, 
click OK (if the dialog does not close automatically).

9. Select File -> Open -> Raster layer in the Viewer menu bar.

10. Navigate to the appropriate directory, then select bright.img.

Select column 

Enter input file
name here

Enter output file
name here

Select subset 

Click to select
output data type

area

here 
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11. After processing is complete, you must view and evaluate the 
resultant image and decide if another pass is needed to obtain the 
results you want. 

See the chapter “Enhancement” in the ERDAS Field Guide for 
theoretical information.

Adjust Slant 
Range

This section does not take you through an actual demonstration of 
the Slant Range Adjustment function, since the full image is 
required. However, when using this function, you follow the next 
series of steps.

The Slant Range Adjustment function applies only to radar data.

1. Select Adjust Slant Range from the Radar Interpreter menu. 

The Slant Range Adjustment dialog opens. 
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2. In the Slant Range Adjustment dialog under Input File, enter the 
name of the input file.

3. Under Output File, enter the name of the output file in the directory 
of your choice. 

4. Under Data Type, select the data type for the Output File by 
clicking on the dropdown list. The default is Float Single, which is 
recommended to save disk space but still retain precision.

5. Under Sensor Info, you must enter sensor-specific information that 
is obtained either from the data header information or from the data 
distributor.

Use the Data View option from the Import/Export dialog or 
Tools ->fio View Binary Data from the ERDAS IMAGINE menu 
bar to read the image header data.

6. Under Apply to, select Row or Column. See the previous section 
on “Adjust Brightness” for information about row and column 
selection.

7. Under the Surface Definition section:

• select Flat for shuttle or aircraft data, such as SIR-A or B, or 
AIRSAR, or

• select Spheroid for satellite data (ERS-1, Fuyo (JERS-1), 
RADARSAT, etc.)

8. Click OK in the Slant Range Adjustment dialog. 

A Job Status dialog displays, indicating the progress of the function.

Indicate Surface 
Definition here Click here 

for a list of
spheroid types 

Select row or 
column here

Enter sensor 
information here
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9. When the Job Status dialog indicates that the job is 100% complete, 
click OK (if the dialog does not close automatically).

10. After processing is completed, you must view and evaluate the 
resultant image and decide if another pass is needed to obtain the 
desired results. 
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IMAGINE Vector™
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IMAGINE Vector™

Introduction The IMAGINE Vector capabilities are designed to provide you with an 
integrated GIS package for raster and vector processing. The vector 
tools in ERDAS IMAGINE are based on the ESRI vector data model, 
therefore ArcInfo vector coverages, ESRI shapefiles, and ESRI SDE 
vectors can be used in ERDAS IMAGINE with no conversion. 

By integrating raster and vector data into one system, you can 
compile a complete database of your study area. You can overlay 
vectors onto current and accurate raster layers to update your vector 
information, including attributes. You can also use vectors to define 
an area of interest for an operation, such as classification or 
enhancement.

The IMAGINE Vector capabilities are divided into these levels:

• Native—vector capabilities that are native to ERDAS IMAGINE. 
These functions provide vector and attribute display and query 
using multiple selection tools, as well as vector creation and 
editing.

• IMAGINE Vector module—an add-on module for ERDAS 
IMAGINE that provides you with additional vector utility tools and 
importers/exporters of various vector formats. The utility tools 
include coverage clean, build, transform, create-label, raster to 
vector and vector to raster conversion, and a table tool for an 
INFO database. The importers/exporters handle the following 
data formats: DFAD, DGN, DLG, DXF, ETAK, IGES, SDTS, TIGER, 
and VPF.

This tour guide mainly discusses the IMAGINE Vector module. 
Depending on the package you are using, you may not be able 
to perform all of the steps. The Native capabilities are discussed 
in  “Vector Querying and Editing”.

This tour guide covers the following topics:

• copying vector data

• manipulating information attributes

• displaying vector layers

• changing vector symbology

• building and cleaning layers
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The data used in this tour guide are in the 
<IMAGINE_HOME>/examples directory. Replace 
<IMAGINE_HOME> with the directory where ERDAS IMAGINE is 
installed on your system (for example, /usr/imagine/880). 

A Digitizing Template is supplied in the information packet for 
ERDAS IMAGINE.

The vector data provided with ERDAS IMAGINE do not have write 
permission, therefore you need to copy them to another directory so 
that you can edit them. However, vector layers are not simple files. 
They are stored in directories called workspaces. Using the simple 
UNIX copy commands does not copy all of the necessary files. You 
must use the Copy utility provided with ERDAS IMAGINE.

NOTE: If you do not have the full IMAGINE Vector module, you do 
not need to move the data, since you cannot edit it.

Approximate completion time for this tour guide is 55 minutes.

Copy Vector Data Move to the directory where you want to create your workspace. 
Start ERDAS IMAGINE from this directory. Make sure this is a 
directory in which you have read/write permissions.

1. Click the Vector icon  from the ERDAS IMAGINE icon panel.

The Vector Utilities menu opens.
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Depending on the package you have, you may not see all of these 
utilities.

Click here to
copy sample 
vector layer
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2. Select Copy Vector Layer from the Vector Utilities menu.

The Copy Vector Layer dialog opens.

 IMAGINE Vector
This menu lists most of the tools of the IMAGINE Vector module. 
Through simple dialogs generated from this menu, you can:

• Clean a vector coverage 

• Build topology 

• Copy, Rename, Delete, and Externalize vector layers 
(native functions)

• Subset vector layers

• Mosaic polygon layers

• Transform vector coverages from digitizer units to real-world 
units

• Create polygon Labels

• Convert Raster to Vector layers and Vector to Raster layers

• Manipulate information tables using the Table Tool

• Generate polygon attributes from a background image (Zonal 
Attributes)

• Convert an ASCII File to a Point Layer

NOTE: Creating vector layers and vector editing tools are available 
through the Viewer. If you have the IMAGINE Vector module, you 
can also use the Import icon to access various external vector data 
types, such as DFAD, DGN, DLG, DXF, SDTS, TIGER, and VPF.

NOTE: The vector utilities in the Vector Utilities menu should not 
be run on open vector layers. Close the layer you are using before 
running the utility, and do not attempt to open the layer until the 
process is complete.
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3. In the Copy Vector Layer dialog under Vector Layer to Copy, enter 
the file name zone88.

4. Under Output Vector Layer, enter zone88 in the directory of your 
choice. 

5. Click OK in the Copy Vector Layer dialog.

A Job Status dialog displays to track the progress of the function. 
When copying is complete, you are ready to proceed with this tour 
guide.

6. Click OK in the Job Status dialog (if it does not dismiss 
automatically). 

The Copy Vector Layer dialog automatically closes.

7. Click Close in the Vector Utilities menu to dismiss it.

Manipulate Info 
Files

The Table Tool is a utility for managing INFO files. It allows you to 
view, edit, relate, import/export, copy, rename, delete, merge, and 
create INFO tables.

Prepare

ERDAS IMAGINE must be running and you must have completed the 
previous section, “Copy Vector Data”.

Start Table Tool

1. Click the Vector icon  on the ERDAS IMAGINE icon panel.

The Vector Utilities menu opens.

2. In the Vector Utilities menu, click Start Table Tool.

The Table Tool opens. 

Click here to
start copy

Enter new vector 
layer name here 

Enter vector layer
to copy here 
or simply click here 
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3. Click Close in the Vector Utilities menu to clear it from the screen.

Display an INFO File

4. In the Table Tool, click the Open icon  or select File -> Open 
from the menu bar. 

The Open Info Table dialog displays.

5. In the Open Info Table dialog, click the Open icon to select the info 
directory path.

The Enter the info directory path dialog opens.

6. Under Directory, check to be sure that the directory to which you 
copied ZONE88 is listed. If it is not, type that directory path in under 
Filename and press Enter on your keyboard.

7. In the file list under Filename, click info and then click OK.

Click here to select 
the info directory 
path 

Click here to open 
the selected info 
table 

Click here to select 
ZONE88.PAT 
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The directory path and table list for info display in the Open Info 
Table dialog.

NOTE: You can double-click any table name to browse the table 
contents before clicking OK to open that table.

8. In the Open Info Table dialog under Table List, click ZONE88.PAT 
and then click OK.

The information for ZONE88.PAT displays in the Table Tool 
CellArray. 

Create a New Table

1. In the Table Tool, click the New icon  . 

A second Table Tool displays. The new Table Tool CellArray is blank.

2. In the new Table Tool, select File -> New.

The Create New Table dialog opens. 



Manipulate Info Files / 704ERDAS IMAGINE Tour Guides

3. In the Create New Table dialog, enter the name of an Info 
Directory Path in which you have write permission, or click the 
Open icon to select the directory to put the new table in. 

The table list for the path you selected displays in the Create New 
Table dialog.

4. In the Create New Table dialog under New Table to Create, enter 
the name ZONE88_NEW.PAT, and then click Add.

The New Column dialog opens. 

5. In the New Column dialog next to Column Name enter ZONE88-
ID.

6. Next to Column Type click the dropdown list to select Integer.

7. Click OK in the New Column dialog.

8. Click OK in the Create New Table dialog.

The new table is entitled ZONE88_NEW.PAT and has a column 
entitled ZONE88-ID.

Enter the 
directory path 
name here 

Enter the new 
table name here Click here to add 

a new column 

Current columns 
are displayed 
here 

Click here to update 
the Table Tool 

Enter the new 
column name here 

Click here to select 
the column type 

Click here to add 
the new column to 
the column list in 
the Create New 
Table dialog 
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NOTE: If you create a new table by clicking File -> New in an 
existing table, the existing table is used as a template and the 
column definitions of the existing table are listed in the Create New 
Table dialog as the default columns of the new table.

Copy From One Table to Another

1. In the ZONE88.PAT Table Tool, click in the column title of ZONE88-
ID to select that column.

The column is highlighted in blue.

2. In the ZONE88.PAT Table Tool, right-hold in the column title 
ZONE88-ID to select Column Options -> Copy.

3. In the ZONE88_NEW.PAT Table Tool, click the column title 
ZONE88-ID to select it and then right-hold Column Options -> 
Paste.

The ID numbers for ZONE88-ID are entered into the new table, and 
the ZONE88-ID column is highlighted in blue.

Add a Column to the Table 

1. In the ZONE88_NEW.PAT Table Tool, select Edit -> Add A 
Column from the menu bar.

The Add Column dialog opens. This dialog is similar to the New 
Column dialog.

2. In the Add Column dialog next to Column Name enter 
NEW_ZONING.

3. Next to Column Type click the dropdown list to select Integer.

4. Click OK in the Add Column dialog.

The NEW_ZONING column is added to ZONE88_NEW.PAT.

Column associated 
with the new table

New table name
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Relate the Tables

Let’s say that you want to compare the Zoning information in 
ZONE88.PAT with some new zoning information that you have just 
received. First, you would need to enter the new zoning information 
in the NEW_ZONING column of the ZONE88_NEW.PAT Table 
Tool. 

1. Follow the example and enter imaginary numbers, which somewhat 
differ from the ZONING numbers, into the NEW_ZONING column. 
(Enter the numbers by clicking in each cell, typing the number, and 
pressing Enter on your keyboard.)

NOTE: For this example, it would suffice to only enter numbers for 
rows 1 through 13. To enter numbers, select Edit -> Enable 
Editing.

If you had an ASCII file with the new data in it, you could use 
the Column Options -> Import option.

2. In the ZONE88_NEW.PAT Table Tool, click the Save icon  to 
save your changes. 

3. In the ZONE88_NEW.PAT Table Tool, select File -> Close from the 
menu bar.

4. In the ZONE88.PAT Table Tool, select Relate -> Relate from the 
menu bar.

The Relate Manager dialog opens. 

5. In the Relate Manager dialog, click New.

The Creating New Relate dialog opens. 

Enter the new Zoning info in this column



ERDAS IMAGINE Tour Guides Manipulate Info Files / 707

6. In the Creating New Relate dialog under Relate Name, enter the 
name Comparison.

7. Under Source Column, click the dropdown list and select ZONE88-
ID.

8. Under Target Info Directory, enter the path in which you saved the 
ZONE88_NEW.PAT Table Tool (if it is not already listed).

9. Under Target Table, click the dropdown list and select 
ZONE88_NEW.PAT.

10. Click OK in the Creating New Relate dialog.

The Creating New Relate dialog closes and the information displays 
in the Relate Manager dialog. 

NOTE: At this point, you can click Save in the Relate Manager dialog 
to save the relates to a table for future use.

11. Click OK in the Relate Manager dialog.

ZONE88.PAT is now related to ZONE88_NEW.PAT. 

Click here to select 
the source column 

Enter the name of the 
directory path here or
click the icon to select 
a path 

Click here to select 
the target table 

Click here to 
update the Relate 
Manager dialog 

Enter a name for 
the Relate here 

Click OK in the 
Relate Manager
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This relationship makes it possible for you to compare the different 
zoning information.

NOTE: Selecting Utilities -> Table Merge enables you to 
permanently merge the two tables together.

12. Select Relate -> Drop in the related Table Tool to drop the related 
columns. 

Change Vector 
Symbology 

Display a Layer

ERDAS IMAGINE must be running and a Viewer open.

1. In the Viewer menu bar select File -> Open -> Vector Layer.

The Select Layer To Add dialog opens. 
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2. In the Select Layer To Add dialog, confirm that the File Type 
selected is Arc Coverage.

3. Under Filename, select zone88.

4. Click OK in the Select Layer To Add dialog to display the layer in the 
Viewer.

The zone88 polygon layer displays in the Viewer, similar to the 
following example.

5. In the Viewer menu bar, select Vector -> Symbology. 

The Symbology dialog opens. 

Click here to 
select the file 

Arc Coverage 
should be the 
file type 

Click here to 
display the 
vector layer 
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The Symbology dialog has a CellArray, but it does not yet contain 
any records.

6. In the Symbology dialog, select Automatic -> Unique Value.

The Unique Value dialog opens.

In this example, you want each zone to have a different symbology. 

7. In the Unique Value dialog, click the dropdown list and select 
ZONING.

8. Click the Generate New Styles checkbox to enable it.

9. Click OK in the Unique Value dialog.

The Unique Value dialog closes and the CellArray of the Symbology 
dialog fills with the newly generated styles.

Use these menu
bar options to
create, edit, 
and view
symbology

Symbology 
displays here

Select attribute 
to use for 
symbology here 

Click here to 
create new 
styles 
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10. Click Apply in the Symbology dialog to apply this new symbology to 
the displayed layer.

The vector layer is redrawn with the new symbology. As the 
Symbology CellArray indicates, red areas are zone 23, green are 
zone 15, dark blue are zone 4, etc.

Add Pattern Polygon Fill Now, change the style of zone 15 (green) from a plain solid to a 
pattern fill over a solid.

1. In the Symbology dialog, hold in the Symbol column for Zone 15 
(Row number 14) and select Other.

Every Class Name has 
its own unique symbol
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The Fill Style Chooser dialog opens.

2. In the Fill Style Chooser dialog, click the Custom tab at the top of 
the dialog.

3. Click the Use Pattern checkbox to activate it.

4. Hold on the Symbol dropdown list and select Other.

The Symbol Chooser dialog opens.

5. Click the dropdown list and select USGS to display the available 
USGS symbols.

6. Scroll through the symbol list under USGS and click the marsh 
symbol.

NOTE: This zone is not really marsh; this example is simply to show 
you how the pattern fill option works.

7. Change the symbol Size to 24.00 points.

The preview window in the Symbol Chooser dialog displays the 
symbol and the symbol size you have selected.

8. Click Apply and then Close in the Symbol Chooser dialog.

The preview window in the Fill Style Chooser dialog displays the 
symbol and the symbol size you selected in the Symbol Chooser 
dialog.

Click this tab to 
select custom 
style options 

Click this dropdown 
list to select USGS 

Use the scroll bar 
to scroll down the 
USGS symbol list 

Change the 
symbol size here 

A preview of 
the currently 
selected symbol 
displays here 
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9. In the Fill Style Chooser dialog, change both the X Separation and 
Y Separation to 10.00 points.

The new style displays in the preview window.

10. Click Apply and then Close in the Fill Style Chooser dialog.

The Fill Style Chooser dialog closes and the new style displays in the 
Symbology dialog.

11. Click Apply in the Symbology dialog to apply this new style to the 
vector layer in the Viewer.

The polygons in Zone 15 are redrawn with the pattern fill, as in the 
following example:

12. In the Symbology dialog, select File -> Save As.

The Save Symbology As dialog opens.

This is the 
new style

Pattern fill is
shown here
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13. In the Save Symbology As dialog, enter a name for the symbology 
file, such as zone88.evs, in the directory of your choice.

If you use the same root name as your coverage, then this is the 
default symbology file when you open this vector layer later.

14. Click OK to save the file.

15. Click Close in the Symbology dialog.

16. Select File -> Clear from the Viewer menu bar.

Build Topology After you have created or edited a vector layer, you must clean or 
build it to create or maintain the topology and reset the tabular 
information. If possible, it is always better to run Build instead of 
Clean. Clean is required only if lines intersect at locations other than 
nodes, or if there are dangling lines that you wish to automatically 
delete. This is not the case in this exercise, so you run Build on the 
new vector layer you just created.

The instructions for running Clean are included at the end of this tour 
guide for your reference.

Do not clean or build an open vector layer and do not attempt to 
open a layer that is being cleaned or built.

In order to complete this section, you must have already 
completed the exercises in  “Vector Querying and Editing”. A file 
you created there, zone88subset, is used in this example.

1. Click the Vector icon  on the ERDAS IMAGINE icon panel. 

The Vector Utilities menu opens.

Enter symbology
file name here
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2. Select Build Vector Layer Topology from the Vector Utilities 
menu.

The Build Vector Layer Topology dialog opens.

3. In the Build Vector Layer Topology dialog under Input Coverage, 
enter zone88subset (or the name you used for the subset in  
“Vector Querying and Editing”), making sure you are in the proper 
directory.

4. The Feature should be Polygon.

5. Click OK in the Build Vector Layer Topology dialog.

A Job Status dialog displays, indicating the progress of the function.

6. Click OK in the Job Status dialog when the build is complete (unless 
your Preferences are set to clear the Job Status dialog upon job 
completion).

If you get error messages when trying to display a vector layer 
in ERDAS IMAGINE, build or clean the layer, then try displaying 
it again. Do not build or clean an open vector layer and do not 
attempt to open a layer that is being cleaned or built.

7. Display the vector layer and attribute information to verify that the 
build ran successfully.

Clean Vector 
Layer 

1. In the Vector Utilities menu, click Clean Vector Layer.

The Clean Vector Layer dialog opens.

Enter vector
layer name to
build here

Click here to
start build
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2. In the Clean Vector Layer dialog under Input Coverage, enter the 
name of the layer to be cleaned (for example, zone88).

3. Click the Write to New Output checkbox and enter a name for the 
new file. This file name must not be longer than 13 characters.

NOTE: Although creating a new file is not necessary, we recommend 
that you do create a new file.

4. The Feature should be Polygon.

5. For this example, accept the default values for Fuzzy Tolerance and 
Dangle Length.

6. Click OK in the Clean Vector Layer dialog.

Enter the input 
coverage name here 

Click to write to a 
new output and then 
enter the output file 
name here 

Fuzzy Tolerance and Dangle Length
In general, fuzzy tolerance can be calculated using this formula:

For example, an input source map at a scale of 1:600 with 
coverage units in feet would have a fuzzy tolerance of .1:

The dangle length value is based on the length, in map units, of 
the longest overshoot that exists in the coverage. The value 
specified removes any dangling lines that are less than, or equal 
to, the value you specify. Any lines longer than the length specified 
remain in the coverage. To measure the dangle length needed for 
your coverage, you can use the Measurement Tool to measure 
lines in the coverage. 

scale
# of inches per coverage unit
-------------------------------------------------------( ) 0.002×

600
12
-------( ) 0.002× 0.1=
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A Job Status dialog displays, indicating the progress of the function. 

7. When the clean is completed, click OK in the Job Status dialog 
(unless your Preferences are set to clear the Job Status dialog upon 
job completion).
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Index
Symbols
.gen file (generic data) 199
.preview.img file (import preview) 187
.sig file (signature file) 480

Numerics
3D Surfacing dialog 306
3X3 Edge Detect 266
3X3 Edge Detect dialog 267

A
Accuracy assessment 526
Accuracy Assessment dialog 527
Add Image icon 66
Add Images for Mosaic dialog 316
Add intermediate hypothesis 600
Add Random Points dialog 529
Affine Model Properties dialog 163
Air photo images 311
AIRSAR 693
Animated Zoom 17
Annotation 79

borders 79
color 79
deselect 92
edit 103
grid lines 79, 89
group elements 89
legend 79
line style 79
lines 91
scale bar 79
style 91

change 91
symbol 79
text 79, 91

font 79
point size 91

tools
grid line 89
legend 94
map frame 83
scale bar 93
select map frame 88
symbol 99
tick mark 79, 89

Annotation Text dialog 96, 100
AOI 21, 480, 497

selecting signatures 482
AOI Cutline icon 321
AOI Styles dialog 23
AOI tool palette 21, 314, 320, 482
Archive dialog 75
ArcInfo

vector coverage 105, 697
Area Definition dialog 73
Area Fill dialog 34
Arrange Layers dialog 14, 21, 37, 88, 488,
493, 496
Attention dialog 116
Attribute Options dialog 508
Attributes viewer 111, 119, 121

B
Band Combinations dialog 47
Band-to-color gun assignment 3
Batch

add multiple files 214
create new variable 225
modify commands automatically 227
modify commands manually 209
multiple files/multiple commands 217
multiple files/single command 208, 212
process later 212
process now 208
save/load options 230
single file/single command 206
use commands as they are 206

Batch scheduler NT 204
Bicubic Spline 10, 161, 288, 644
Bilinear Interpolation 10, 161, 288, 644
Box Zoom 18
Breakpoint Editor 27
Brightness 26

adjust 25
Brightness Adjustment dialog 690
Brightness Inversion dialog 272
Build 714
Build Vector Layer Topology dialog 715

C
Camera Model 287
Catalog icon 65
Catalog Image dialog 66
CellArray 35, 111

add columns 121
column

adjust size 38
Column Options menu 38, 39
GCP Tool 156
report 41
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Row Selection menu 38, 111, 112, 384
select columns 38
select rows 38

using criteria 40
selection criteria 40
statistics 39

Change Colors 528
Change Colors dialog 528
Chart Options dialog 45
Chip extraction 16
Chip Extraction Viewer 153, 294, 300
Choose AOI dialog 317, 321
Circular Mask dialog 247
Class color

change 35
Class name

edit 403
Classification 135, 138, 479, 514, 697

decision rule 506
feature space 507
Mahalanobis distance 507
maximum likelihood 507
minimum distance 507
parallelepiped 507

distance file 507
output file 507
overlay 138, 515
supervised 479
unsupervised 135, 479, 511

Classification icon 594
Classification menu 481, 512, 533, 555, 594
Classification tools 411
Classified Image dialog 528
Classifier icon 481, 512, 521, 533, 554
Clean 714
Clean Vector Layer dialog 715
Clear Viewer icon 43
Coefficient of variation 672

calculating 671
color balancing

mosaic 337
Color Chooser dialog 36, 37, 402
Color printer 101
Colorwheel (see Color Selector dialog)
Column Attributes dialog 121
Column icon 39
Column Properties dialog 39, 140, 401, 516
Composer icon 80, 101, 103
Compositions dialog 101, 103
Conditions

copy 602
Constant value 34
Contingency matrix 497

Contingency Matrix dialog 497
Contrast 26

adjust 25, 44, 45, 46, 47, 48
shift/ bias 30

Contrast matching 333
Contrast stretch

linear 25
piecewise linear 26

Contrast Tool (piecewise) dialog 26
Contrast Tool dialog 25
Convolution dialog 265
Convolution kernel 391

define 392
summary 392

Copy icon 395
Copy rules and conditions 602
Copy Vector Layer dialog 106, 700
Create Feature Space Maps dialog 489
Create Frame Instructions dialog 84
Create GCP tool 156
Create New Signature icon 484
Create New Table dialog 703
Create Rule Graphic icon 596
Create Sensitivity Layer 380
Creating New Relate dialog 706
Crisp dialog 268
Criteria (see Selection Criteria dialog)
Criteria dialog 413
Cubic Convolution 10, 161, 288, 644
Cursor box 16, 84, 86

rotate 85
Cutline 319
Cutline Selection viewer icon 319

D
Dangle length 716
Data

ASCII 121
display 149

preference 3, 63
export (see Export)
flood plain 386
georeferenced 93
import (see Import)
land cover 386
Landsat MSS 3
Landsat TM 3, 6, 149
raster 697
sensitivity 401

combine with SPOT 396, 400
slope 382
SPOT 3
SPOT panchromatic 149, 380, 391, 397,
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641
enhance 391–395

subset 382
thematic 79
transparent 37
vector 79, 697

build 714
clean 714
copy 106, 121, 698, 700
create 118
edit 114

undo 118
select 110, 111
style 108
symbology 709

Data Preparation menu 136, 306
Data View 196, 691, 693
Data Viewer dialog 196
DataPrep icon 136, 330
Default symbol 99
Defined Areas dialog 73
DEM 32

edit 32
Dialog xxxi

3D Surfacing 306
3X3 Edge Detect 267
Accuracy Assessment 527
Add Images for Mosaic 316
Add Random Points 529
Affine Model Properties 163
Annotation Text 96, 100
AOI Styles 23
Archive 75
Area Definition 73
Area Fill 34
Arrange Layers 14, 21, 37, 88, 488, 493,

496
Attention 116
Attribute Options 508
Band Combinations 47
Brightness Adjustment 690
Brightness Inversion 272
Build Vector Layer Topology 715
Catalog Image 66
Chart Options 45
Choose AOI 317, 321
Circular Mask 247
Classified Image 528
Clean Vector Layer 715
Color Chooser 36, 37, 402
Column Attributes 121
Column Properties 39, 140, 401, 516

Compositions 101, 103
Contingency Matrix 497
Contrast Tool 25
Contrast Tool (piecewise) 26
Convolution 265
Copy Vector Layer 106, 700
Create Feature Space Maps 489
Create Frame Instructions 84
Create New Table 703
Creating New Relate 706
Crisp 268
Criteria 413
Data Viewer 196
Defined Areas 73
Edge Enhancement 676
Export Column Data 120
Export ERDAS 7.5 LAN Data 190
Eye/Target Edit 52
Feature Space to Image Masking 500
Fill Style Chooser 712
Filter Options 251
Form View 71
Formula 141, 518
Fourier Transform 237
Function Definition 387, 393, 397
GCP Matching 159
GCP Tool Reference Setup 299
Generate Script 408
Geo Correction Tools 151, 160, 292
Histogram 503
Histogram Plot Control 503
Hypo Props 595
IHS to RGB 279
Image Files 201
ImageInfo 72, 201, 303, 674
IMAGINE Radar Interpreter module 667
Import Column Data 122
Import Generic Binary Data 196
Import Options 187, 307
Import SPOT 184
Import/Export 184, 189, 691, 693
Indices 278
Inquire Box Coordinates 188, 383
Inquire Color 12
Inquire Cursor 11, 26, 162, 487
Inquire Shape 12
Interpolate 33
Inverse Fourier Transform 243
Job Status 186, 267, 324, 335, 346, 490,

701
Knowledge Base Editor 594
Legend Properties 95
Limits 495
Line Style Chooser 92, 109, 115
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Link/Unlink Instructions 19, 404
Linked Cursors 491
List of Recent Files 7
Low/High Pass Filter 240
Map Frame 84, 88
Map Frame Data Source 83
Matching Options 340
Matrix 392
Model Librarian 408
New Column 704
New Map Composition 80
New Vector Layer 118, 124
Open FFT Layer 238
Open Files 522
Open Info Table 702
Options 50, 111, 119
Output Image Options 323
Overlay True Color on Surface 49
Page Setup 410
Polynomial Model Properties 151, 158,

161
Position Parameters 53
Preview Options 185, 186
Print 13, 411
Print Map Composition 101
Projection Chooser 297
Properties 108, 115
Radar Speckle Suppression 670, 672, 681
Raster 380, 382, 384, 386, 389, 392,

412
Read Points 306
Recode 384, 386
Rectangular Mask 248
Red Mouse Linear Mapping 30
Reference GCC File 300
Region Grow Options 485
Region Growing Properties 23, 484
Relate Manager 706
Report Format Definition 41
Resample 161, 163, 301
RGB to IHS 279
Rule Props 597
Run Mosaic 335, 346
Save AOI As 24, 316
Save As 43
Save Layer As 242, 253
Save Model 390, 395, 416
Save Options File 199
Save Signature File As 493
Save Symbology As 713
Scalar 396
Scale Bar Instructions 93
Scale Bar Properties 93
Select A Directory 7

Select Layer To Add 4, 7, 14, 19, 44, 82,
102, 107, 114, 118, 123, 138,
150, 235, 267, 273, 310, 382,
400, 480, 515, 668, 677, 683,
686, 708

Select Profile Tool 44
Selection Criteria 40, 112, 384
Sensor Merge 684
Set Geometric Model 151, 163, 291
Set Grid/Tick Info 89
Set Overlap Function 322, 334, 345
Set Parallelepiped Limits 495
Set Window 381, 415
Shift/Bias Adjustment 29
Signature Alarm 494
Signature Objects 501
Signature Separability 504
Slant Range Adjustment 692
Spectral Statistics 46
Statistics 39, 506
Styles 91
Sun Positioning 51
Supervised Classification 508
Surfacing 309
Symbol Chooser 99, 115, 116, 712
Symbol Properties 100
Symbology 709
Tasseled Cap 275
Tasseled Cap Coefficients 276
Text Properties 97
Text String 405, 406
Text Style Chooser 92
Texture Analysis 688
Threshold 522
Threshold to File 525
Unique Value 710
Unsupervised Classification 512
Unsupervised Classification (Isodata) 136
View Extent 9
View Signature Columns 482
Viewer Flicker 141, 519, 525
Wallis Adaptive Filter 682
Wedge Mask 249

Digitize Points icon 33
Display options 8
Display Single icon 70
Display thematic data 14
Divergence 504
Dot Grid Interpretation 576

E
Edge Enhancement dialog 676
Electrostatic plotter 101
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Ellipse icon 33
Ellipse measurement 12
Enhancement 697

in graphical models 391
radiometric 271
spatial 265
spectral 275

Enterprise Geodatabase 132
ERDAS Field Guide 304, 667, 692
ERDAS IMAGINE

start 105, 698
ERDAS IMAGINE icon panel xxi, 80, 103,
136, 183, 379, 481, 512, 521, 533, 554
ERDAS IMAGINE Viewer 82, 84, 400
ERS-1 693
Evaluate 138, 514
Export

LAN data 189
statistics 190

Export Column Data dialog 120
Export ERDAS 7.5 LAN Data dialog 190
Eye/Target Edit dialog 52

F
Feature space 480

to image masking 499
Feature Space image 489

display image 490
Feature Space to Image Masking dialog 500
Feature Space viewer 491
Field of View (FOV) 53
Fill Style Chooser dialog 712
Filter 266

Prewitt Gradient 677
Filter Options dialog 251
Final Analysis Report 589
Final Analysis Wizard 586
Form View dialog 71
Formula dialog 141, 518
Fourier Analysis menu 237
Fourier Editor 238
Fourier Transform

create 235
Editor 235

start 238
using toolbar icons 251

Fourier Transform dialog 237
Fraction File 591
Frame area 83
Frame Sampling Tools 553
FS to Image Masking 499
Function Definition dialog 387, 393, 397
Function icon 322

Fuyo 693
Fuzzy tolerance 716

G
.gen file (generic data) 199
GCP 16

calculating 158
delete 157
number required 158
placement 156
select 157

GCP Matching dialog 159
GCP Tool 300

CellArray 156
GCP Tool Reference Setup dialog 299
Generate Script dialog 408
Geo Correction Tools dialog 151, 160, 292
Geologic discrimination 687
Geometric correction 151, 291
Geometric Correction Tool

starting 151
Georeferencing 149, 287
Global value 35
gotolink project_properties 654
Graphical model 269

adjust class colors 401
annotation

add 405
edit 405
select 406
style 405

define function 387, 393, 397
define input 382, 392, 396
define output 389, 394, 399
display output 400
edit 270
generate text script from 407
print 410
run 390, 395
save 395
title 405
using scalars in 396
view 269

Graphical Query viewer 67
Graphics

presentation 79
Grid Generation Tool 568
Grid Labels 579

H
High-Pass Filter icon 252
Histogram 674
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Histogram dialog 503
Histogram graphic 28
Histogram icon 503
Histogram manipulation 27
Histogram Plot Control dialog 503
Hypothesis

add intermediate 600
rules for 596

Hypothesis properties dialog 595

I
Icons

Add Image 66
AOI Cutline 321
Catalog 65
Classification 594
Classifier 481, 512, 521, 533, 554
Clear Viewer 43
Column 39
Composer 80, 101, 103
Copy 395
Create New Signature 484
Create Rule Graphic 596
Cutline Selection viewer 319
DataPrep 330
Digitize Points 33
Display Single 70
Ellipse 33
Function 322
High-Pass Filter 252
Histogram 503
Image Interpreter 237, 259, 265
Import 183, 700
Input 319
Line Selection 112
Lock 33
Low-Pass Filter 252
Marquee 112
Measurement 12
Modeler 379, 408
Mouse Linear Mapping 30
Open 7, 14, 82, 114, 150, 151, 273,

325, 347, 380, 382, 640, 674,
675

Output 323
Output Image 323
Paste 395
Polyline 13, 47
Print 411
Query 68
Radar 669
Region Grow 485
Roam 20

Run 31, 243, 390, 395
Save 101, 390, 395
Select Area for Zooming 68
Shift/Bias 29
Statistics 506
Text 96
Tools 21, 110, 124
Vector 105, 698, 714
Viewer 118, 123, 149, 267, 312, 324,

346, 639, 669
Visual Query 67
Window 391
Zoom In 15

IHS 36
IHS to RGB 279
IHS to RGB dialog 279
Image

invert 272
reverse 272

Image Catalog 65
add information 66
create 63

Image Commands tool 143
Image Drape viewer 50
Image Enhancement menu 681
Image Files dialog 201
Image Interpreter 9, 257, 379, 526

functions
Convolution 676
Neighborhood 676

Image Interpreter icon 237, 259, 265
Image Interpreter menu 237, 259, 265
Image matching 333
Image resampling 10
Image Stacking 333
Image Tiles 558
ImageInfo dialog 72, 201, 303, 674
ImageInfo utility 200

edit 201
IMAGINE AutoSync

IMAGINE AutoSync menu 633
IMAGINE AutoSync Edge Matching Wizard 633

APM Strategy tab 635
Edge Match Strategy tab 636
Input tab 634
Output File Names dialog 638
Output tab 637
Projection tab 637
Refinement method list 636
Resample settings dialog 638

IMAGINE AutoSync Workstation 641
Create New Project dialog 643
GCP toolbar 649
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Georeference workflow steps 642
IMAGINE AutoSync Project Properties dia-

log 660
IMAGINE AutoSync Workstation Startup

dialog 643
Resample Settings dialog 644
Viewer Blend/Fade tool 662
Viewer Flicker tool 664
Viewer Swipe tool 663

IMAGINE Radar Interpreter module
using the IMAGINE Radar Interpreter

module 667
IMAGINE Radar Interpreter module dialogs
667
IMAGINE Radar Interpreter module functions

Brightness Adjustment 690
Edge Enhancement 676
Luminance Modification 680
Sensor Merge 680
Slant Range Adjustment 692
Speckle Suppression 668
Wallis Adaptive Filter 680

Import
binary data 195
column data 122
decimated image 186
generic data 195
Landsat TM 186
SPOT data 183
subset 188

Import Column Data dialog 122
Import Generic Binary Data dialog 196
Import icon 183, 700
Import Options dialog 187, 307
Import SPOT dialog 184
Import/Export dialog 184, 189, 691, 693
Index 278
Indices dialog 278
Input icon 319
Input Slope Layer 382
Inquire Box Coordinates dialog 188, 383
Inquire Color dialog 12
Inquire Cursor 162

style 11
Inquire Cursor dialog 11, 26, 162, 487
Inquire Shape dialog 12
Interpolate dialog 33
Inverse Fourier Transform dialog 243
ISODATA 135, 511

J
Jeffries-Matusita 504
JERS-1 693

Job Status dialog 186, 267, 324, 335, 346,
490, 701

K
Kernel 266

CellArray 267
library 266

Keyboard shortcut 7
Knowledge Base

test 604
Knowledge Base Editor dialog 594
Knowledge engineer 593

add hypothesis 594
add intermediate hypothesis 600
ANDing criteria 616
copy and edit rules/conditions 602
enter rules for hypothesis 596
enter variable for rule 597
graphic model option 613
pathway feedback 628
prompt analyst 625
set up output classes 593
test knowledge base 604
use with spatial logic 618

L
Label point 110
Landsat 641
LANDSAT images 328
Legend 94

columns 96
position 95, 96
specify contents 95

Legend Properties dialog 95
Level of Detail 366
Limits dialog 495
Line

join 117
reshape 117
split 117

Line measurement 12
Line of constant range 690
Line Selection icon 112
Line Style Chooser dialog 92, 109, 115
Link box tool 153
Link symbol 19
Link/Unlink Instructions dialog 19, 404
Linked Cursors dialog 491
List of Recent Files dialog 7
Lock icon 33
Lookup table (LUT) graph

rotate 31
shift 31
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Lookup table (LUT) values
change 25
modify 27
reset 27

Low/High Pass Filter dialog 240
Low-Pass Filter icon 252

M
Magnifier window 16
Magnify image (see Zoom)
Map

area 83
create 80

prepare data layers 82
steps 79

edit 102
file (.map) 103
name 80
outside margin 90
print 101

to file 102
save 101
scale 81
size 81
title 96
units 81, 83

page 83
Map Composer

icon 80, 103
start 80
viewer 81

Map Composer menu 80, 103
Map frame 83

adjust size 85
create 82
delete 88
dimensions 83
edit 87
position 84, 86
reference to image in Viewer 86
scale 84, 86
select 88
size 84

Map Frame Data Source dialog 83
Map Frame dialog 84, 88
Map Path Editor 103
Map projection 11, 149, 184, 190, 287

State Plane 149, 641
Marquee icon 112
Mask 499
Matching Options dialog 340
Material of Interest 553
Matrix dialog 392

Measurement icon 12
Measurement Tool viewer 12
Menu

Classification 481, 512, 533, 555, 594
Data Preparation 136
Fourier Analysis 237
Image Enhancement 681
Image Interpreter 237, 259, 265
Map Composer 80, 103
Radar 669
Radar Interpreter 670
Radiometric Enhance 271
Session xxii
Spatial Enhancement 265
Spatial Modeler 379, 408
Spectral Enhancement 275
Tools xxv
Utilities xxvi
Vector Utilities 106, 698, 701, 714

Mineral ratio 278
Model

using conditional statements 388
working window 381, 415

Model Librarian dialog 408
Model Maker 257, 269, 379

functions 397
Analysis 398
Conditional 397
CONVOLVE 394
Criteria 411
EITHER 397
STRETCH 398

start 380
Modeler icon 379, 408
Modify commands automatically 227
Modify commands manually 209
Modify variables 221
MOI 553
Mosaic 311

color balancing 337
cutline 319
display 324
input 314
intersection 319
output 323
run 323, 335

Mosaic Image List 318
Mosaic Tool

viewer 314, 330
Mouse linear mapping 30
Mouse Linear Mapping icon 30
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N
Nearest Neighbor 10, 161, 288, 644
Neatline 89, 90
New Column dialog 704
New Map Composition dialog 80
New variable 225
New Vector Layer dialog 118, 124
No Link symbol 20
North arrow 98

O
Observer 53
On-Line Help xxvii
Opacity 38
Open FFT Layer dialog 238
Open Files dialog 522
Open icon 7, 14, 82, 114, 150, 151, 273,
325, 347, 380, 382, 640, 674, 675
Open Info Table dialog 702
Options dialog 50, 111, 119
Orthorectification 287
Output icon 323
Output Image icon 323
Output Image Options dialog 323
Overlay thematic data 49
Overlay True Color on Surface dialog 49

P
.preview.img file (import preview) 187
Page Setup dialog 410
Paragraph styles 554
Paste icon 395
Pattern Polygon Fill 711
Personal Geodatabase 129
Point measurement 12
Polygon Interpretation 575
Polygon measurement 12
Polyline icon 13, 47
Polynomial Model Properties dialog 151, 158,
161
Position Parameters dialog 53
PostScript 410
PostScript device 101
Preference Editor 3, 261

eml 3
saving changes 6
viewer 4

Preview Options dialog 185, 186
Preview window xxxi, 32, 36, 97, 99, 712
Prewitt Gradient filter 677
Print dialog 13, 411
Print icon 411
Print Map Composition dialog 101

Prior Data 562
Projection Chooser dialog 297
Properties dialog 108, 115

Q
Query

coordinates 11
pixel information 11

Query icon 68
Quick View menu 15, 26, 162, 273

R
Radar icon 669
Radar Interpreter menu 670
Radar menu 669
Radar Speckle Suppression dialog 670, 672,
681
RADARSAT 693
Radiometric Enhance menu 271
Raster Attribute Editor 32, 35, 37, 38, 138,
140, 401, 509, 515, 516, 526
Raster dialog 380, 382, 384, 386, 389, 392,
412
Raster options 311
Rayleigh distribution 671
Read Points dialog 306
Real Time Zoom 18
Recode 380, 384, 386, 526

using Criteria 384
Recode dialog 384, 386
Rectangle measurement 12
Rectangular Mask dialog 248
Rectification 16

image to image 149, 287
steps 149, 287
verifying 162

Red Mouse Linear Mapping dialog 30
Reference GCC File dialog 300
Region Grow icon 485
Region Grow Options dialog 485
Region Growing Properties dialog 23, 484
Relate Manager dialog 706
Report Format Definition dialog 41
Resample 10, 161, 288

Bicubic Spline 10, 161, 288, 644
Bilinear Interpolation 10, 161, 288, 644
Cubic Convolution 10, 161, 288, 644
Nearest Neighbor 10, 161, 288, 644

Resample dialog 161, 163, 301
RGB 36
RGB to IHS 279
RGB to IHS dialog 279
RMS error 158
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Roam 19
Roam icon 20
Rotate/Magnify Instructions box 114, 123
Rotation box (rot box) 114, 117, 123
Rule Properties dialog 597
Rules

copy 602
Rules for hypothesis 596
Run icon 31, 243, 390, 395
Run Mosaic dialog 335, 346

S
.sig file (signature file) 480
Sample Node 575
Sample Selection Tool 571
Sampling Grid 562, 568
Sampling Project 554
Save AOI As dialog 24, 316
Save As dialog 43
Save icon 101, 390, 395
Save Layer As dialog 242, 253
Save Model dialog 390, 395, 416
Save Options File dialog 199
Save Signature File As dialog 493
Save Symbology As dialog 713
Scalar dialog 396
Scale 83
Scale bar 93
Scale Bar Instructions dialog 93
Scale Bar Properties dialog 93
Script model

annotation in 410
delete 409
edit 409
run 409

Select A Directory dialog 7
Select Area for Zooming icon 68
Select Layer To Add dialog 4, 7, 14, 19, 44,
82, 102, 107, 114, 118, 123, 138, 150, 235,
267, 273, 310, 382, 400, 480, 515, 668,
677, 683, 686, 708
Select Profile Tool dialog 44
Selected Samples 562
Selection Criteria dialog 40, 112, 384
Sensor Merge 683

IHS 684
Multiplicative 684
Principal Component 684

Sensor Merge dialog 684
Session Log 183, 672
Session menu xxii, 3
Set Geometric Model dialog 151, 163, 291
Set Grid/Tick Info dialog 89

Set Overlap Function dialog 322, 334, 345
Set Parallelepiped Limits dialog 495
Set up scheduler 204
Set Window dialog 381, 415
Shadow

enhance 26
Shift/Bias Adjustment dialog 29
Shift/Bias icon 29
Signature

alarm 494
contingency matrix 497
ellipse 502
evaluate 493
feature space to image masking 499
histogram 503
merge 493
non-parametric 480, 507
parametric 480, 507
separability 504
statistics 501

Signature Alarm dialog 494
Signature Editor 480, 481
Signature Objects dialog 501
Signature Separability dialog 504
Single Sampling Project Nodes 558
Single Sampling wizard 557
SIR-A 669, 693
SIR-B 693
Slant Range Adjustment dialog 692
Space resection 287
Spatial Enhancement menu 265
Spatial Modeler 257, 526

Library 408
Spatial Modeler Language 257, 379, 407
Spatial Modeler menu 379, 408
Spatial Profile viewer 47
Speckle noise 667, 668
Spectral Enhancement menu 275
Spectral Profile viewer 44
Spectral Statistics dialog 46
Stacking 333
Stationarity 590
Statistics dialog 39, 506
Statistics icon 506
Stratified Tile 562
Styles dialog 91
Subset 258
Sun Positioning dialog 51
Supervised Classification dialog 508
Surface Profile viewer 48
Surfacing dialog 309
Symbol Chooser dialog 99, 115, 116, 712
Symbol Properties dialog 100
Symbology dialog 709
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Symbols 98

T
Tab 236, 480
Table Tool 701

CellArray 703
Tasseled Cap Coefficients dialog 276
Tasseled Cap dialog 275
Tasseled Cap transformation 275
Test Knowledge Base 604
Text 100

align 97
default style 100
deselect 98
edit 97
fonts 97
position 97
style 97

Text Editor 42, 498, 505
ERDAS IMAGINE 409
menu bar 43

Text entry fields 104
Text icon 96
Text Properties dialog 97
Text String dialog 405, 406
Text Style Chooser dialog 92
Texture 687
Texture Analysis dialog 688
Threshold 508, 521
Threshold dialog 522
Threshold to File dialog 525
Tick label 91
Tick mark 79, 89

length 90
select 91
spacing 90

Tool palette
AOI 314, 320, 482
Vector 110, 116, 124

Tools icon 21, 110, 124
Tools menu xxv, 691, 693
Transformation

changing the order of 158
coefficients 158

Transformation matrix
compute 158

Transformed divergence 504

U
Undersampled strata 590
Unique Value dialog 710
Unlink cursor 20
Unsupervised Classification (Isodata) dialog

136
Unsupervised Classification dialog 512
Utilities menu xxvi
Utility menu 196

V
Variable 225
Vector icon 105, 698, 714
Vector tool palette 110, 116, 124
Vector Utilities menu 106, 698, 701, 714
Vegetation classification 687
View Extent dialog 9
View Signature Columns dialog 482
Viewer 3

Attributes 111, 119, 121
Chip Extraction 294, 300
Feature Space 491
Image Drape 50
Measurement Tool 12
Mosaic Tool 314, 330

Viewer (ERDAS IMAGINE) 82, 84, 311, 400
AOI menu 21
arrange layers in 14
close 16, 20
link 19, 162
menu bar 7, 382
open new 19
Quick View menu 162
resize 16, 313
split 273
title bar 10
toolbar 110, 124
unlink 20

Viewer Flicker dialog 141, 519, 525
Viewer icon 118, 123, 149, 267, 312, 324,
346, 639, 669
viewer swipe tool 640
Viewshed Analysis 365
Viewshed dialog 368, 370
viewshed layer 369, 370
Visual Query icon 67

W
Wallis Adaptive Filter 680
Wallis Adaptive Filter dialog 682
Warning box 302
Wedge Mask dialog 249
Window icon 391

Z
Zoom 15
Zoom In icon 15
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